(Topic ID: 155578)

Hobbit Owners Thread


By Eryeal

3 years ago



Topic Stats

  • 7,893 posts
  • 518 Pinsiders participating
  • Latest reply 4 hours ago by Mr_Outlane
  • Topic is favorited by 193 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,152 images uploaded to this topic. (View topic image gallery).

0EBF61C9-860A-4237-84E3-A4810907060F (resized).jpeg
95937948-C10C-4118-BF50-2D83A8119265 (resized).jpeg
AC977F7C-F4EB-4A21-B065-77BD8B30E6E4 (resized).jpeg
61188774-F72B-48E1-B400-8118BD7D7A90 (resized).jpeg
3E1B9990-8695-4EF7-9CF7-334A53871163 (resized).jpeg
96A279BA-D769-4927-A255-614370D13582 (resized).jpeg
D42E605B-56D9-49C5-A6C0-0C8B2251718A (resized).jpeg
Castle (resized).png
IMG_20191027_094800 (resized).jpg
IMG-20191027-WA0016 (resized).jpg
IMG_20191027_092217 (resized).jpg
IMG_20191027_090807 (resized).jpg
IMG_20191027_091030 (resized).jpg
IMG_20191027_091023 (resized).jpg
IMG-20191027-WA0016 (resized).jpg
IMG-20191027-WA0012 (resized).jpg

Topic index (key posts)

16 key posts have been marked in this topic

Post #14 First impressions by new owner. Posted by Eryeal (3 years ago)

Post #45 The source of the voice call-outs Posted by Troz (3 years ago)

Post #71 Detailed game review Posted by Vyzer2 (3 years ago)

Post #128 Cosmetic issues from factory and customer service response. Posted by RichieWrench (3 years ago)

Post #214 review with detail and good set of pictures. Posted by Pimp77 (3 years ago)

Post #402 Backglass LED diffuser (tones cold white to a more neutral amber color) Posted by PanzerFreak (3 years ago)

Post #714 Another BackBox light filter Posted by Damonator (3 years ago)

Post #769 Rulesheet Posted by tiesmasc (3 years ago)

Post #1064 Owner fixes and tweaks after 150 games. Posted by pinballinreno (3 years ago)

Post #1113 Noteworthy new owner issues and photos Posted by VolunteerPin (3 years ago)

Post #1358 JJP video on fix kit. Posted by tatapolus (3 years ago)

Post #1706 example of time marks order through delivery Posted by meSz (3 years ago)

Post #2007 Here's the code download link Posted by LTG (3 years ago)

Post #2220 How to install Hobbit Cliffy protectors Posted by mbelofsky (3 years ago)

Post #3613 Nice tip on locktite product for wood or metal screws. Posted by pinballinreno (2 years ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider drenden.
Click here to go back to viewing the entire thread.

#533 3 years ago
Quoted from kpg:

Ok guys!!! I have perfectly dialed in my Hobbit LE. Today, the changes I made turned this game into a blazing fast pin. I had to actually turn the flipper power down 3-4 notches because of the airballs this caused.
I did the following:
1) Waxed playfield with a different wax this time, Mill Wax playfield wax & cleaner- let it dry and then buffed it out
2) Pinball Life Oh Shiny balls
3) Super band rubbers
4) Flippers at 24 left, 27 right power
I cannot believe the difference after those 3 things. Everything moves so quickly, theres little to no floatiness, and power must be turned down on flippers! This should be a mandatory thing to do after pulling it out of the box.
This, with 7* pitch - wireform post on left side, and bending loop on left wireform upwards to prevent hop overs, has made this thing awesome. Anyone with speed complaints must try this pin with those fixes/changes/upgrades because its a world of a difference.
Also, for the plunger- I did use some silicone spray on the shaft and its much smoother and plunges the ball way better- no spring change necessary.

Whatever you do don't ever use millwax on any game ever again. It's an abrasive. It is not to be used on newer cleared playfield. Used a proper petroleum free automotive wax.

1 month later
#1199 3 years ago

Rob,

Try taping the flap back and see if it helps. Sometimes it hits that floating flap. My game is pitched at 7.2 and I don't have the issue at all

2 weeks later
#1442 3 years ago
Quoted from ikrananka:

Just set up my Hobbit and am finding a minor issue with the left VUK under Smaug. When it fires the ball reaches the end of the VUK wireform, hits the end of the horizontal section and then bounces back the way it came and down to only be fired back up again. This may happen 2 or 3 times before the ball is successfully deposited in the main left wireform.
Has anyone else experienced this? I'm thinking that reducing the power of the VUK may be the solution and will post back here if it is.

Either lower or raise the power on the Vuk.

#1483 3 years ago

You don't need any additional leg protectors at all.

1 week later
#1674 3 years ago
Quoted from WackyBrakke:

Doh! Just realized I am running v1.21.....Updating to 1.31 now

Start button saves.

1 week later
#1775 3 years ago
Quoted from meSz:

Sorry for delay, out of town!
Still no idea as to what the screw is for. Victor at JJP couldnt determine either. He said he "walked out to the assembly line and couldn't find that size screw anywhere". Must be something that JJP buys pre assembled!!!

That looks like the screw they holds the power cable cover on. Certainly long enough.

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
7,000
Machine - For Sale
Flagstaff, AZ
$ 50.00
$ 49.95
Lighting - Led
Pin Stadium Pinball LEDs
From: $ 42.00
Playfield - Toys/Add-ons
ModFather Pinball Mods

You're currently viewing posts by Pinsider drenden.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside