(Topic ID: 155578)

Hobbit Owners Thread


By Eryeal

3 years ago



Topic Stats

  • 8,091 posts
  • 527 Pinsiders participating
  • Latest reply 14 hours ago by wesman
  • Topic is favorited by 191 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,179 images uploaded to this topic. (View topic image gallery).

B6DEFB70-D32A-474A-A4DE-FE7EB6B909F1 (resized).jpeg
EA74C334-0179-4521-928B-A73E8EB74357 (resized).jpeg
46F6C0B3-5EA5-402F-9C0F-C6604D2A4293 (resized).jpeg
DSC05213 (resized).JPG
DSC05212 (resized).JPG
DSC05203 (resized).JPG
DSC05190 (resized).JPG
DSC05191 (resized).JPG
20191231_020309 (resized).jpg
20191231_020316 (resized).jpg
20191231_020311 (resized).jpg
20191231_020334 (resized).jpg
20180720_165623 (resized).jpg
20191227_200249 (resized).jpg
4633C49D-49D3-4DF0-960A-1C04CA53D131 (resized).jpeg
874435AB-97D5-4D74-8375-09F6D2EC1E2F (resized).jpeg

Topic index (key posts)

16 key posts have been marked in this topic (Show topic index)

There are 8091 posts in this topic. You are on page 12 of 162.
#551 3 years ago
Quoted from kpg:

Anyone else having reset issues? If so, let's post the error messages here- here's mine from today
Also, I had emailed JJP technical
Support about the issue last week, about 4 days ago, and no response. My history with WOZ support has been that email and opening tickets is worthless, but phone support is good so I'll try that avenue next.

Last message I had from Lloyd was it was software related. None of the "fixes" I have seen out there have worked for me.

#552 3 years ago
Quoted from bemmett:

Last message I had from Lloyd was it was software related. None of the "fixes" I have seen out there have worked for me.

Decided to buy that Crucial Ballistix memory that Lloyd/LTG recommended, in hopes of solving the reset issue.

First game with new memory and it reset, and about 5-6 after with no issues.

So, if anyone is planning on buying that memory, save your cash. It's definitely software related, and hopefully JJP will chime in on here and let us know they are working on a code fix. I was heading for a new GC score and the reset killed the game for me.. Not happy about it as you can imagine.. Hope they're working on it...

#553 3 years ago
Quoted from statsdoc:

So, for those of us wanting to preorder "alternatives" for our hobbit, what should we consider. I am hearing ...
Shooter spring
Leaf switch tool
Flipper bands
Post (for left side return)
What am I missing?
Also, what is the current level of spring? Panzer mentioned upgading to purple, but I see that purple seems to have high tension according to Pinball life. Is that the right upgrade? I dont mind ordering a few colors to get it right.
What post should be ordered? Anyone with a new delivery see a "fix" for this issue in their Hobbit from the factory?
It is getting close. i should have mine within a few weeks. I appreciate all the advice from you "beta" testers.

Pinnovators.com up and down volume plate, allows you to adjust volume with out losing ball in play ?

#554 3 years ago

Since I've solved my resets and air balls I solved another annoyance this weekend. My left habitrail that goes to the outlane wasn't 100% consistent on catching and holding the ball. I added a 1/4" tall spacer under the bottom screw and it made it 100% reliable (so far) with a pretty good amount of plays on it today. No traps, no bounce outs. Perfect.

Now I have just one more minor annoyance to figure out and it will be perfect. One in maybe 100 right habitrail returns will drop the ball and spin it up and out the right outlane. It is FRUSTRATING when it happens and screws us enough to need to find a way to fix it. Anybody else experience this one?

image_(resized).jpeg

image_(resized).jpeg

#555 3 years ago

I have been keeping abreast of all "The Hobbit" threads on "Pinside" as I await delivery of my LE. Needless to say the reset issue has me concerned. I really question as to whether this is solely a software problem. If it is code-related then why wouldn't everyone who has installed Version 1.10 have the same problem? Someone mentioned their reset occurred when the ball hit a pop bumper. Couldn't the problem lie with a voltage spike? Spurious voltages have been known to affect the running of software. And maybe the condition could be enhanced by the quality of the cable connections, etc. Just questioning the obvious.

#556 3 years ago

this solution works perfect for me

1122_(resized).jpg

#557 3 years ago

Dear Hobbit owners, DON'T let this happen to you!

I got a nice 2 foot long scratch on my invisiglass. HOW?

Because of the metal bracket that is below the ring button under the lock down bar!

The metal piece that sits just above the switch for the ring button is placed very high...too high on mine...pulled the glass off and SCCRAAATTCHH! @#!@@@!$# Boy am I upset about that one.

SO WHAT IS THE FIX? Bend that metal tab down a bit and keep a bit of upwards pressure when removing the glass.

Now, does anybody know what I can do about this nearly 2 foot long scratch on my invisiglass (apart from buying a new one)?

I'll try to send a few pics when I get the chance...

#558 3 years ago

Sammy that really sucks call your distributor and see if they can warranty or at least get wholesale on a new sheet. i get my glass polishing stuff from these guys http://www.granquartz.ca/ but its close to 600.00 by the time you get all the hand sanding pads, polishing pads , and tinoxide .

#559 3 years ago

Thanks Chris

#560 3 years ago
Quoted from fordtudoor:

I have been keeping abreast of all "The Hobbit" threads on "Pinside" as I await delivery of my LE. Needless to say the reset issue has me concerned. I really question as to whether this is solely a software problem. If it is code-related then why wouldn't everyone who has installed Version 1.10 have the same problem? Someone mentioned their reset occurred when the ball hit a pop bumper. Couldn't the problem lie with a voltage spike? Spurious voltages have been known to affect the running of software. And maybe the condition could be enhanced by the quality of the cable connections, etc. Just questioning the obvious.

It sounds software related since it didn't occur before 1.10. I bet we see a fix with the next software release.

I know a couple owners have said that they think the reset issue has been related to inconsistent voltage to the game / its devices. I got my game last week, running 1.10 and have not had a reset. My game is plugged into an APC surge protector which is then plugged into an APC voltage regulator (as are all my games).

#561 3 years ago
Quoted from ls1chris:

Sammy that really sucks call your distributor and see if they can warranty or at least get wholesale on a new sheet. i get my glass polishing stuff from these guys http://www.granquartz.ca/ but its close to 600.00 by the time you get all the hand sanding pads, polishing pads , and tinoxide .

Yes, I would think JJP would warranty the glass as its their fault the tab is not down lower.

#562 3 years ago
Quoted from PanzerFreak:

Yes, I would think JJP would warranty the glass as its their fault the tab is not down lower.

Absolutely agree! This should be on JJP if this is a result of faulty installation or construction.

#563 3 years ago
Quoted from PanzerFreak:

It sounds software related since it didn't occur before 1.10. I bet we see a fix with the next software release.
I know a couple owners have said that they think the reset issue has been related to inconsistent voltage to the game / its devices. I got my game last week, running 1.10 and have not had a reset. My game is plugged into an APC surge protector which is then plugged into an APC voltage regulator (as are all my games).

Interesting theory there. My pins are connected to a line conditioner.

#564 3 years ago

So I've manged to eliminate 90% of pop outs from the far left habit rail. Someone else posted this either here or on the JJP Google group.

Bending the end of the far left habit rail up (the circular ball exit area) helps to elimate pop outs. I covered the metal on the rail (to prevent scratches) and then used a pair of needle nose pliers to bend the end of the rail slighlty upwards. I may try bending it a little more.

I did remove the screw on the end of the rail before I attempted to bend the bracket. On my game I also bent it up and slightly to the right as the rail seemed to lean left a little bit.

#565 3 years ago

I have a big scratch on my Invisiglass too! That must have been how it happened- I'll look, because it seems it lines right up with that ring button thing too. Man that's BS. Gonna have to figure something out about that..

Also, my reset yesterday happened right when the ball entered the pops. In fact, each reset (3 total out of 120 games) has happened when the ball was in the poppers.

For power issues, I have my pins hooked up to an APC surge protector that is hooked into an APC AVR line conditioner, and have never had any problems with resets or voltage issues to any other pin I've owned so it's not that.

#566 3 years ago
Quoted from PanzerFreak:

So I've manged to eliminate 90% of pop outs from the far left habit rail. Someone else posted this either here or on the JJP Google group.
Bending the end of the far left habit rail up (the circular ball exit area) helps to elimate pop outs. I covered the metal on the rail (to prevent scratches) and then used a pair of needle nose pliers to bend the end of the rail slighlty upwards. I may try bending it a little more.
I did remove the screw on the end of the rail before I attempted to bend the bracket. On my game I also bent it up and slightly to the right as the rail seemed to lean left a little bit.

Glad that worked for you! That's exactly what I did and I no longer have bounce outs. I also lowered the pitch to 6.8* and the game still plays great but it's a lot less wild.

#567 3 years ago
Quoted from Pimp77:

Since I've solved my resets and air balls I solved another annoyance this weekend. My left habitrail that goes to the outlane wasn't 100% consistent on catching and holding the ball. I added a 1/4" tall spacer under the bottom screw and it made it 100% reliable (so far) with a pretty good amount of plays on it today. No traps, no bounce outs. Perfect.
Now I have just one more minor annoyance to figure out and it will be perfect. One in maybe 100 right habitrail returns will drop the ball and spin it up and out the right outlane. It is FRUSTRATING when it happens and screws us enough to need to find a way to fix it. Anybody else experience this one?

I had this annoying issue as well, right ramp the ball would drop then pop up and over into the right outlane drain! Such BS.

I took a small post rubber, cut it, and put it on the metal inlane wire guide. It has not happened since. But it does work. Also, I removed the washer from the post that the ramp bolts to in order to lower it some more, so it doesn't drop as hard to the playfield and bounce out. Doing both of those things worked for me.

Here's a pic

2016-05-31_09.50.39_(resized).jpg

#568 3 years ago

Hi there - I did a search but could not find what JJP is charging for direct shipping. Can someone post that cost? thanks

#569 3 years ago
Quoted from Hjbondar:

Hi there - I did a search but could not find what JJP is charging for direct shipping. Can someone post that cost? thanks

It's going to be around $400-450. I suggest calling Automated/Pinballs.com as they might still have them in stock, and offer free shipping.

#570 3 years ago

Thanks KPG. I am looking for what someone was actually charged as I was quoted $500 by JJP - and it seemed high - Harvey

#571 3 years ago
Quoted from Hjbondar:

Thanks KPG. I am looking for what someone was actually charged as I was quoted $500 by JJP - and it seemed high - Harvey

From JJP to CA...about $500-$550.

#572 3 years ago
Quoted from Hjbondar:

Thanks KPG. I am looking for what someone was actually charged as I was quoted $500 by JJP - and it seemed high - Harvey

I was originally going to buy my TH LE from JJP directly, and just looked back in my email and was quoted from JJP to me here in SoCal, it was $466.

#573 3 years ago
Quoted from Hjbondar:

Thanks KPG. I am looking for what someone was actually charged as I was quoted $500 by JJP - and it seemed high - Harvey

436.88 shipped to San Jose with me picking up at terminal. I thought it was expensive too. Forgot all about the cost once I started playing it.

#574 3 years ago

Just got off the phone w/ Frank @ JJP regarding the reset issue. He said it is software related, and that the developers may have already solved it, and are working on a patch to fix it.

Those who have not had reset issues simply have not hit the required combination of things that must start/end at the right time to cause a reset in the bumpers. It may take dozens of games, maybe a hundred or more to finally hit that criteria of things that lead to the glitch/reset- but alas, JJP is fixing it!

#575 3 years ago
Quoted from kpg:

Just got off the phone w/ Frank @ JJP regarding the reset issue. He said it is software related, and that the developers may have already solved it, and are working on a patch to fix it.
Those who have not had reset issues simply have not hit the required combination of things that must start/end at the right time to cause a reset in the bumpers. It may take dozens of games, maybe a hundred or more to finally hit that criteria of things that lead to the glitch/reset- but alas, JJP is fixing it!

Thats good news that they are on it, thanks for finding out. Keith and the guys have been averaging one good sized update a month (just like WOZ initially) so we may see another software update in the middle of June. 1.10 was released on 5/12, 1.01 on 4/6.

#576 3 years ago
Quoted from PanzerFreak:

Thats good news that they are on it, thanks for finding out. Keith and the guys have been averaging one good sized update a month (just like WOZ initially) so we may see another software update in the middle of June. 1.10 was released on 5/12, 1.01 on 4/6.

I love the coding support from JJP, not only with WOZ, but with TH. That actually was a big deciding factor on purchasing TH for me.

I know there is much more to come, a lot of modes do not have special lighting effects or even music and sound effects when playing them. I know they are unfinished, along with the wizard modes. So watching the game mature and worked towards being finished is going to be awesome, and I am confident any bugs that pop up will be quickly handled.

#577 3 years ago

I'm planning on purchasing TH and I am curious how much wider is a wide-body? I've never owned one. Is the backbox wider too or just the playfield?

#578 3 years ago
Quoted from netman63129:

I'm planning on purchasing TH and I am curious how much wider is a wide-body? I've never owned one. Is the backbox wider too or just the playfield?

No only the cab/playfield is wider, the backbox width is the same.
Like the WPC Super Pins like Twilight Zone, STTNG

10
#579 3 years ago

Installed green "Perfect Play" flipper bands and rubber posts on my game. Maybe its just me but the game seems to play even better (possibly quicker too) with the new bands. I noticed that the stock flipper bands are slightly shorter then traditional bands, not sure why JJP went with those. Also, having a Perfect Play post rubber on the post between the flippers versus the stock one seems to provide more bounce.

I also adjusted the shooter housing and the ball can now make a plunge to the lower 3 top drop targets (couldn't hit any before). As others have said a stronger plunger spring wasn't needed and a purple rated spring provided too much tension.

Some pics of my game with the new bands / post rubbers.

20160601_073137_(resized).jpg20160601_071313_(resized).jpg

#580 3 years ago

250 play update:

Lower PF was waxed with P21S.
Hard to reach areas washed with Mist & Shine and buffed off with dry MF cloth.
All armoured surfaces waxed with P21S along with wireforms. Metal ramps lightly waxed with P21S.
Plastics and ramps cleaned with novus 1, ramps finished with mist and shine.
Inner drop targets cleaned with sparkle and novus 1.
All other stuff cleaned with a dampened microfiber cloth.

Everything seems like brand new again (which it is essentially).

The inner dwarf targets are getting bent back especially the f.
I bent them back but bent targets are the source of tons of air-balls. I'm hoping for a longer term solution for the "bent drop target" problem like maybe tilting the whole mech down slightly.

I switched the flipper rubber to green Pinball life super-bands™ on all 3 flippers. It seems to play better, more accurate. I can make the hole shots more frequently now.

I had to drop the flipper power a couple nothches after waxing and was getting air-balls stuck on the right side behind the spotlight. The cause was the wire to the spotlight on the hex post, needed to be re-routed to the front of the light and the wire ties moved up to the top.
Now the ball will move past the post without getting hung there.

All in all the game plays better than new after settling a bit.
My scores are getting above a million frequently.

I have also settled on the right flipper being set I notch higher than the left at 26 and 27 respectively.

#581 3 years ago

Has anyone else noticed that the magnet at the drop off for Smaug ball locks doesnt always activate? At times instead of a ball stopping at the magnet and then slowly dropping into the subway it will just go straight through.

I'm concerned that over time that this could cause wear on the playfield around the area where the ball drops into. Maybe one of the balls is magnetized?

#582 3 years ago
Quoted from PanzerFreak:

Has anyone else noticed that the magnet at the drop off for Smaug ball locks doesnt always activate? At times instead of a ball stopping at the magnet and then slowly dropping into the subway it will just go straight through.
I'm concerned that over time that this could cause wear on the playfield around the area where the ball drops into. Maybe one of the balls is magnetized?

Just wondering if the behavior above is normal? After waxing the playfield and putting Perfect Play bands on my game I ended up dropping flipper power down to 18 for the left, right and upper right flippers. Game still plays quick but there are less air balls.

#583 3 years ago
Quoted from PanzerFreak:

Has anyone else noticed that the magnet at the drop off for Smaug ball locks doesnt always activate? At times instead of a ball stopping at the magnet and then slowly dropping into the subway it will just go straight through.
I'm concerned that over time that this could cause wear on the playfield around the area where the ball drops into. Maybe one of the balls is magnetized?

I had the same behavior - sometimes magnet would catch it, other times it would roll through.

#584 3 years ago
Quoted from PanzerFreak:

Has anyone else noticed that the magnet at the drop off for Smaug ball locks doesnt always activate? At times instead of a ball stopping at the magnet and then slowly dropping into the subway it will just go straight through.
I'm concerned that over time that this could cause wear on the playfield around the area where the ball drops into. Maybe one of the balls is magnetized?

Yes this is normal - mine does it too, I don't think it's supposed to activate each time, or maybe the ball does so fast it doesn't have a chance to capture it sometimes.

I keep my flipper power up very high though, as I like to hit the ramps from any flipper. I think my settings are 25 for left flipper, 28 right flipper- this way I can hit left ramp w/ left flipper and right ramp w/ right flipper no problem. But I do get air balls, hoping the game will settle down because I love the flippers cranked up on this game

#585 3 years ago
Quoted from kpg:

Yes this is normal - mine does it too, I don't think it's supposed to activate each time, or maybe the ball does so fast it doesn't have a chance to capture it sometimes.
I keep my flipper power up very high though, as I like to hit the ramps from any flipper. I think my settings are 25 for left flipper, 28 right flipper- this way I can hit left ramp w/ left flipper and right ramp w/ right flipper no problem. But I do get air balls, hoping the game will settle down because I love the flippers cranked up on this game

My game catches the ball every single time it goes there for a lock.

Has anyone with this behavior recorded it in a video? I am curious to see this happen and what else is going on at the time.

#586 3 years ago
Quoted from metahugh:

My game catches the ball every single time it goes there for a lock.
Has anyone with this behavior recorded it in a video? I am curious to see this happen and what else is going on at the time.

Mine is hit or miss. I think the ball just goes too fast sometimes. It's doesn't effect anything.

#587 3 years ago
Quoted from Pimp77:

Mine is hit or miss. I think the ball just goes too fast sometimes. It's doesn't effect anything.

I think it may be by design- maybe it depends on which call out/saying Smaug will say- it could need to hold the ball a little longer to complete the call out, and if its a short one the magnet doesn't hold the ball. I've noticed the magnet not holding the ball as often in the 1st lock, but more on the 2nd lock and also into multiball - just an idea.

#588 3 years ago

Thanks for the feedback guys, good to know its normal behavior. During the times that the ball is not held I just hope nothing gets damaged over time. I did see a half circle metal guard around the Smaug drop off hole so I assume the ball hits that and then goes into the hole.

Also, we may be due for another code update in the next week or two. Keith released the last two about a month apart (1.10 was out May 12th, 1.01 April 8th) so maybe the next release will come in the next week or the following.

#589 3 years ago

Where do I find the back box key? It's not on the coin mechs like I would expect?

#590 3 years ago
Quoted from Gizmata:

Where do I find the back box key? It's not on the coin mechs like I would expect?

It is...look again.

#591 3 years ago
Quoted from Gizmata:

Where do I find the back box key? It's not on the coin mechs like I would expect?

It should be on the side of the right coin mech.

LTG : )

DSC00048_(resized).JPG

#592 3 years ago

That is exactly where I looked many times and it is not there. I also checked the coin box and bottom of the cabinet without luck. I will contact my distributor.

Thanks

#593 3 years ago
Quoted from Gizmata:

That is exactly where I looked many times and it is not there. I also checked the coin box and bottom of the cabinet without luck.

Do you have an empty hook there ? If not please check the side of the left coin chute.

If empty hook - did you check under the huge metal box that holds the boards ? And through all the wires in the rear of the bottom of the cabinet ?

Thank you.
LTG : )

#594 3 years ago
Quoted from Pimp77:

Mine is hit or miss. I think the ball just goes too fast sometimes. It's doesn't effect anything.

I can confirm this is true. Here is some video evidence:

Of course once I start posting it's not happening to my game it starts happening. This is the first game I fired up tonight and it missed 50% of the time.

I do think the ball is going too fast for the magnet to catch the ball as it is currently programmed. I would imagine there is a set delay when the ramp entrance opto is tripped when the magnet is fired and it is calibrated for a slower moving ball. I also imagine the pulse is short to avoid leaving the magnet on for too long. The length of time the magnet is engaged could be changed. I agree it isn't causing a real problem. Actually, I think it may be better to go straight in versus the magnet catching it, at least until I can get some mylar installed in the drop area

I think the reason why I haven't noticed it much is because I prefer hitting the right ramp with a backhand when trying to lock a ball. I feel that I am more accurate with a backhand than a shot from the left flipper. I bet if I go back into the numerous videos I have posted on YouTube I will find more than a few times this has happened in the past and I just didn't notice it.

#595 3 years ago
Quoted from metahugh:

I can confirm this is true. Here is some video evidence:
» YouTube video
Of course once I start posting it's not happening to my game it starts happening. This is the first game I fired up tonight and it missed 50% of the time.
I do think the ball is going too fast for the magnet to catch the ball as it is currently programmed. I would imagine there is a set delay when the ramp entrance opto is tripped when the magnet is fired and it is calibrated for a slower moving ball. I also imagine the pulse is short to avoid leaving the magnet on for too long. The length of time the magnet is engaged could be changed. I agree it isn't causing a real problem. Actually, I think it may be better to go straight in versus the magnet catching it, at least until I can get some mylar installed in the drop area
I think the reason why I haven't noticed it much is because I prefer hitting the right ramp with a backhand when trying to lock a ball. I feel that I am more accurate with a backhand than a shot from the left flipper. I bet if I go back into the numerous videos I have posted on YouTube I will find more than a few times this has happened in the past and I just didn't notice it.

Seems to happen more often in the first lock then the 2nd and 3rd on my machine ive noticed. I truly think it is a software issue of the timing between the opto trigger and firing of the magnet - i'm sure it will be resolved at some point. I hope they are adding more things Smaug says though! The ones now get old quick

#596 3 years ago

I was getting some audio clipping, most notably on the Smaug lock grumbles and sighs. Played with the cabling and it made no difference. Remembered the sound clipping issue on WOZ and lowered all the audio settings. It fixed it! No more clipping. Then I decided to up the sfx and fanfare and tweak the voices and music a bit. I got it sounding much better than out of the box (IMO).

#597 3 years ago
Quoted from Pimp77:

I was getting some audio clipping, most notably on the Smaug lock grumbles and sighs. Played with the cabling and it made no difference. Remembered the sound clipping issue on WOZ and lowered all the audio settings. It fixed it! No more clipping. Then I decided to up the sfx and fanfare and tweak the voices and music a bit. I got it sounding much better than out of the box (IMO).

Nice, I think I've noticed some minor audio clipping as well at times. Can you please share your games audio settings?

#598 3 years ago
Quoted from LTG:

Do you have an empty hook there ? If not please check the side of the left coin chute.
If empty hook - did you check under the huge metal box that holds the boards ? And through all the wires in the rear of the bottom of the cabinet ?
Thank you.
LTG : )

Yes, the hooks are empty. I searched the bottom of the cabinet, lifted the cpu box, looked in the cables, checked the speaker magnet, and playfield wiring without luck.

Thanks for confirming where the key was supposed to be.

#599 3 years ago
Quoted from PanzerFreak:

Has anyone else noticed that the magnet at the drop off for Smaug ball locks doesnt always activate? At times instead of a ball stopping at the magnet and then slowly dropping into the subway it will just go straight through.
I'm concerned that over time that this could cause wear on the playfield around the area where the ball drops into. Maybe one of the balls is magnetized?

Hit or miss with mine as well.

The magnet is small compared to the ones under the playfield... I'm thinking it just doesn't have enough power to stop the faster moving balls. Is there a setting to increase the magnet power? I did not find one...

#600 3 years ago
Quoted from PanzerFreak:

Has anyone else noticed that the magnet at the drop off for Smaug ball locks doesnt always activate? At times instead of a ball stopping at the magnet and then slowly dropping into the subway it will just go straight through.

Mine consistently holds ball 2 and lets ball 1 and 3 fall into the hole. Even slow moving seems to get by for ball 1 and 3. I figured that was how it was coded for some reason (perhaps something upcoming in a code update would have it make sense). I'll pull the glass off and try different speeds and ball lock number to see if there really is a repeatable pattern. Was wondering about this myself.

Promoted items from the Pinside Marketplace
7,000
Sale Pending!
Evansville, IN
$ 59.00
Playfield - Toys/Add-ons
Pixels Arcade Games
7,000 (OBO)
Machine - For Sale
Leesburg, VA
$ 29.95
Gameroom - Decorations
Pinball Photos
$ 49.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
There are 8091 posts in this topic. You are on page 12 of 162.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside