(Topic ID: 69131)

High Speed Club ~ Dispatch, this is 504. We have a Club now, over.


By lordloss

6 years ago



Topic Stats

  • 3,733 posts
  • 338 Pinsiders participating
  • Latest reply 1 day ago by Pin-Pilot
  • Topic is favorited by 165 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,107 images uploaded to this topic. (View topic image gallery).

highspeed (resized).jpg
IMG_20200705_152053 (resized).jpg
IMG_20200705_152047 (resized).jpg
IMG_0539 (resized).jpg
6E5642D9-01F9-4B6B-AAE2-52CD1DFE0C96 (resized).jpeg
20200629_154344 (resized).jpg
20200629_154448 (resized).jpg
20200629_154815 (resized).jpg
20200629_154340 (resized).jpg
20200629_154257 (resized).jpg
20200629_154304 (resized).jpg
20200629_154752 (resized).jpg
20200629_154454 (resized).jpg
20200629_154803 (resized).jpg
DDC771B7-AA7D-4F51-9A8D-BAD961818BEA (resized).jpeg
AE1F2E09-CAB4-480F-9C8B-AA1A4F80AD90 (resized).jpeg

You're currently viewing posts by Pinsider medioil.
Click here to go back to viewing the entire thread.

#1535 4 years ago

Hi HS fans.
My 5" rubber broke (the one that runs right at the top of playfield) and needs replacing . It looks tricky to get at , any tips how to do it with the least amount of fuss? Do I need to remove anything?
Thanks for your help.

Medioil

#1538 4 years ago

Thanks for the fast responses . Ill have a go this weekend ! - as I get edgy when I can't play , I miss that siren !

1 year later
#1786 2 years ago

Hi Speeders.
I need some advice as ALL my playfield lamps have stopped working.
Everything else works fine (Flippers, Sounds, Score Display)

I checked every fuse with a meter - all ok
I wriggled the connections IJ4 IJ5 IJ6 IJ7 on the CPU board in case of bad connection.

What else can I do?? before the kids rediscover their electronic games !!

Medioil - Australia

#1791 2 years ago

Hi ,
Thanks for advice !!
Back Box lights and general illumination on playfield are ok.

"Did you check for the +18 volts?
Did you check the connectors in the neck?
Did you check the +18 volt bridge?"

Not sure what this means Vec-tor . I found a component next to J4 connector labelled +18V is this what you mean, and how do you check?

I have the manual from ipdb if this helps to indentify/describe parts.

#1795 2 years ago

Grumpy. Measured voltage across 1 to 3 (Purple to Black ) . Reads 0.1V only .
attached photo , cause the wire colors are faded .
Thanks, medioil

HS (resized).JPG

#1796 2 years ago

Grumpy , u r genius.
Play field lights are up and running !!!!

I viewed this vid

- How to test a bridge rectifier.
After doing this switched machine on - hey presto its' good.

Voltage across is now 17.5V

I now noticed a few minor lights appear to be out - but a project for another day.

Just in time for weekend - so family will be pleased too.
Pinballs aren't much fun when the lights are out.

Thank You. Thank You. Thank You.

Medioil

Promoted items from the Pinside Marketplace
$ 11.95
$ 27.99
Lighting - Interactive
Lee's Parts

You're currently viewing posts by Pinsider medioil.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside