(Topic ID: 69131)

High Speed Club ~ Dispatch, this is 504. We have a Club now, over.


By lordloss

6 years ago



Topic Stats

  • 3,736 posts
  • 338 Pinsiders participating
  • Latest reply 19 hours ago by eyeamred2u
  • Topic is favorited by 164 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,107 images uploaded to this topic. (View topic image gallery).

highspeed (resized).jpg
IMG_20200705_152053 (resized).jpg
IMG_20200705_152047 (resized).jpg
IMG_0539 (resized).jpg
6E5642D9-01F9-4B6B-AAE2-52CD1DFE0C96 (resized).jpeg
20200629_154344 (resized).jpg
20200629_154448 (resized).jpg
20200629_154815 (resized).jpg
20200629_154340 (resized).jpg
20200629_154257 (resized).jpg
20200629_154304 (resized).jpg
20200629_154752 (resized).jpg
20200629_154454 (resized).jpg
20200629_154803 (resized).jpg
DDC771B7-AA7D-4F51-9A8D-BAD961818BEA (resized).jpeg
AE1F2E09-CAB4-480F-9C8B-AA1A4F80AD90 (resized).jpeg

There are 3736 posts in this topic. You are on page 32 of 75.
#1551 3 years ago

Does that mean the lug on the right is wired wrong and one of the two green wires (that both go to the eos) should be on the left lug? Can you take a pic of your configuration?

#1552 3 years ago

By the way this is the lower right flipper

#1553 3 years ago
Quoted from V_piscopo:

Does that mean the lug on the right is wired wrong and one of the two green wires (that both go to the eos) should be on the left lug? Can you take a pic of your configuration?

Never mind. The two green is correct, your center and left lug need to be switched. My left has the yellow marked wire.
image_(resized).jpeg

#1554 3 years ago

Sweet thx. Should play much smoother now. Lol

#1555 3 years ago

not an expert on pinballs yet but am familiar with electricity and it looks like you EOS switch is connected to the same lug, meaning its not switching anything from the low and high power sides. If both leads of the EOS go to the same tab, its not doing anything.

#1556 3 years ago
Quoted from Langless28:

not an expert on pinballs yet but am familiar with electricity and it looks like you EOS switch is connected to the same lug, meaning its not switching anything from the low and high power sides. If both leads of the EOS go to the same tab, its not doing anything.

You are right, I did not catch that. V_piscopo, ignore my previous recommendation.

Your blue and purple goes on the right lug.

The green wire on the right side of the eos goes to the right lug.

The green wire on the left side of the eos goes to the center lug.

The blue and yellow goes on the left lug.

#1557 3 years ago

There we go! Got her all patched up. Playing like a champ again. Maybe next time I will wait to start drinking untill repairs are done.........or take a pic first......or.....no none of that will happen.

#1558 3 years ago

Ok. Just finished the shop job on mine. Here's a pic as promised.

20160720_204540_(resized).jpg

#1559 3 years ago

Looks good. Nice score cards BTW. Where did you score them? Like the green on your flips, and the yellow stop light looks good.

#1560 3 years ago

Thanks. The cards are from the custom cards thread here on pinside

#1561 3 years ago

Fresh from the 3D printer. Needs to be cleaned up some still and painted. Can't really see the face detail but it's matched to the traffic lights on the game.

I can also email the .STL file to anybody who would like to make one.

image_(resized).jpeg

#1563 3 years ago

Sweet. Show us a pic after she's cleaned up, painted, and installed. Looks good.

#1564 3 years ago

Getting ready to finally install those helicopters that have been in my drawer for several years. I am going to install one in the shooter lane, and unsure if I want to install one or two more.

Looking for ideas for the other ones. Please post pictures of your helicopter installations, and please include information on mounting hardware, spacers, standoffs, posts, plastic, metal, aluminum, size and length, screws etc. You get the idea.

In the shooter lane, I am planning to use the left facing helicopter on a 1" tall metal spacer, and a 1 1/2" to 1 3/4" #6 phillips screw (if I go with the 1" spacer linked below).

http://www.marcospecialties.com/pinball-parts/254-5001-00

I am trying to match the prototype flyer picture.

https://images.pinside.com/b/26/5c/b265c83fcbef04925a7f9f996dbf440baa6854f0.jpg

#1565 3 years ago

OK, I'm joining the club. I have F2K, HGT, Count-Down, Space Shuttle, and now my newest edition, High Speed. HS is by far, my favorite, and I've owned JD, TAF, BSD, and STTNG. I just finished a CPR play field swap and added Jeff's nice clear ramp. Also, mod for stop light. I have one issue that someone might know. When I go into test mode, the sling shot coils fire rapidly. I sent MPU for repair and only one transistor was bad for upper left pop bumper. Will put back into machine later this week, but hoping to see if anyone else has had this problem. Thanks for any help.

IMG_3755_(resized).JPG

IMG_3757_(resized).JPG

IMG_3782_(resized).JPG

IMG_3786_(resized).JPG

IMG_3783_(resized).JPG

IMG_3788_(resized).JPG

IMG_3816_(resized).JPG

IMG_3756_(resized).JPG

#1566 3 years ago
Quoted from Navystan:

OK, I'm joining the club. I have F2K, HGT, Count-Down, Space Shuttle, and now my newest edition, High Speed. HS is by far, my favorite, and I've owned JD, TAF, BSD, and STTNG. I just finished a CPR play field swap and added Jeff's nice clear ramp. Also, mod for stop light. I have one issue that someone might know. When I go into test mode, the sling shot coils fire rapidly. I sent MPU for repair and only one transistor was bad for upper left pop bumper. Will put back into machine later this week, but hoping to see if anyone else has had this problem. Thanks for any help.

Oh, I also have a nice Black Knight!

#1567 3 years ago

That playfield is beautiful!

#1568 3 years ago

Damn that's sharp. Jelious.

#1569 3 years ago

Wow i wish mine looked that nice!

1 week later
#1570 3 years ago

Thanks for help from Kevin D., Chris H., Mike B., and Tom H., I have a fully working HS. Yes, I needed a lot of help. Play field swap complete. Here's a video. Notice the clear ramp and clear pop caps with matching yellow, green,and red skirts and lights. Also, moved light to back and with stop-light mod.

Watch the HD version:

#1571 3 years ago

What type of Led's are in the GI and clear inserts? Cool white?

#1572 3 years ago
Quoted from Langless28:

What type of Led's are in the GI and clear inserts? Cool white?

They are from Cointaker and are Super cool whites.

#1573 3 years ago

I just got one last weekend. It's a project for sure, but I want to make sure it's running well and play it before it gets restored. With the ROMs I have, will there be anything major missing or wrong?

image_(resized).jpeg

image_(resized).jpeg

image_(resized).jpeg

#1574 3 years ago

Everything seems to be there. Are you going to paint and clear that playfield or sand and overlay? Super fun game, welcome to the club. Will be looking forward to seeing your progress.

#1575 3 years ago

Has anybody here used and replaced there insert decals with the ones sold on Marco?

#1576 3 years ago
Quoted from desertT1:

I just got one last weekend. It's a project for sure, but I want to make sure it's running well and play it before it gets restored. With the ROMs I have, will there be anything major missing or wrong?

I believe there should be 2 rubbers along the back.

#1577 3 years ago
Quoted from V_piscopo:

Everything seems to be there. Are you going to paint and clear that playfield or sand and overlay? Super fun game, welcome to the club. Will be looking forward to seeing your progress.

Sand and overlay. I already have the overlay and will practice that method soon on my 69 Joust that is finished aside from the PF overlay/clear and cabinet decals.

Quoted from rwarren28806:

I believe there should be 2 rubbers along the back.

All of the rubbers will have to be replaced. I rolled the ball around, hit a yellow post and half of it chunked off. :p

Are there cabinet decals for HS? I'm just seeing stencils and I'm not sure which way I want to go with this. Just looking for a very nice player restore, not a CQ one because I intend to play this a lot.

#1578 3 years ago

I belive there's only stencils.

#1579 3 years ago

Checked as much as I know to do on my newest project, so it was time to put everything together and see what happens. Here's the list:

Cabinet/playfield... Already knew that part
The transistor that I replaced that was split into 3 pieces had an overheating coil, but it wasn't locked on. This is mystery priority #1.
Plunger spring is not proper, and weak.
Music, sound FX work, but zero voice callouts. Lots of buzz. Noticable at all times, but in attract mode, buzz is synced with insert lighting moving around.
Upper ramp diverters didn't divert when light was red.

The thing about that transistor is the coil was getting hot, but never locked on. I wiggled the transistor until it broke off and then tested it (since I assumed it was dead) and it was giving .5xx V, so not dead after all. Hovered over the coil that was very hot after 2 games earlier today, room temp without the transistor. This is a new one for me, any guesses?

#1580 3 years ago

Hi Group, just picked up a HS. I am in need of some pics. The coin door wiring is a mess, especially the 3-button service switch. I have broken wires and need pics to see where wires go. If anyone can help, I would appreciate it.

Thanks,

Ken

#1581 3 years ago

Hope it helps

image (resized).jpeg

#1582 3 years ago

Just in case someone wants to join the club... I'm bringing a decent one to the CLEPIN show for sale.

https://pinside.com/pinball/market/classifieds/ad/38278

#1583 3 years ago

Thank you for that awesome pic of the 3-button service switch. now I can repair mine.

Ken

#1584 3 years ago
Quoted from snyper2099:

Just in case someone wants to join the club... I'm bringing a decent one to the CLEPIN show for sale.
https://pinside.com/pinball/market/classifieds/ad/38278

Nice game and price is spot on. If I had the room I would take on a second HS.

#1585 3 years ago

Anybody ever have intermittent problems with there displays? Sometimes they will work perfect for weeks sometimes my 1st and 4th player are out sometimes my top line is out on second player sometimes there all out for a minute or two.

#1586 3 years ago
Quoted from V_piscopo:

Anybody ever have intermittent problems with there displays? Sometimes they will work perfect for weeks sometimes my 1st and 4th player are out sometimes my top line is out on second player sometimes there all out for a minute or two.

Could be your ribbon cable. Check that and reseat it. Could also be your power supply isn't putting out good +100V/-100V and may need new caps.

http://techniek.flipperwinkel.nl/wms11/index3.htm#display

#1587 3 years ago

Everything is in spec. It's only player 1 and 4 that are out. They were working fine yesterday. I've reseated everything but no go. I'll get a better look tonight.

#1588 3 years ago

I put in an old alphanumeric display I had laying around for kicks into P1. Of corce it worked. It has the top segment across out. I'll reflow tonight and see if I can get it back. What could cause P1 and 4 to go at the exact same time? Anybody have a spare p3 or 4 display laying around they want to sell?

#1589 3 years ago
Quoted from snyper2099:

Just in case someone wants to join the club... I'm bringing a decent one to the CLEPIN show for sale.
https://pinside.com/pinball/market/classifieds/ad/38278

I wish I had the cash right now or I'd be all over it! Don't let anyone cart it out before Friday though, I've been itching to play one in person for forever! Last year there was supposed to be one at the show but I couldn't make it until Saturday and it was already gone

#1590 3 years ago

I am in need of a pic of the coin door screws that attach to the coin door frame. Need size and head style info.

Thanks,

Ken

#1591 3 years ago

I'd like to submit for membership! Picked up High Speed on Saturday. It been well loved, but plays right and is a lot of fun. It's my first machine.

Everything was great at the seller's place, but once it got to my shop the playfield lights didn't work anymore. Nothing in the tach, the inlanes, the arrows, and nothing in the stoplight either. Play and scoring is still all good. All the fuses look fine on quick inspection. I tried to make sure the connectors were all nice and well seated. I found one transistor that looked a little fried, Q43, but that didn't seem to have much to do with the lamps in the schematic. Any thoughts? I was gonna wait until after the holiday to contact the seller and see if he had any ideas.

Also I need a little wire guide that is near the upper right flipper. With this guide missing, the ball bounces off the post on the way down after leaving the eject hole and messes up the shot for the ramp. Where does find find one? Or I could make one pretty easily too.

I have more questions, but I'll work my way through the old posts first. Thanks!

IMG_0533 (resized).JPG

#1592 3 years ago

If the fuses are good, I recommend pulling the connectors that are midway in the harnesses and reseat them. Check the connector on the top rh board in the backbox - the one on a pigtail.

#1593 3 years ago

I joined the club late last month! Here's my High Speed: I put new rubbers, LED's, cleaned/polished the mylar, changed up the pop bumper caps added partial new plastics (mounted another helicopter on the ramp and a Lamborghini plastic on the kick back lane), new stop light plastic, subwoofer, gold colored cabinet protectors, and touched up the cabinet...Now I just need to set a high score!

FullSizeRender (resized).jpg

image1 (resized).JPG

FullSizeRender 2 (resized).jpg

image2 (resized).JPG

#1594 3 years ago
Quoted from cad-kid:

If the fuses are good, I recommend pulling the connectors that are midway in the harnesses and reseat them. Check the connector on the top rh board in the backbox - the one on a pigtail.

All the connectors seem good. Is there a simple way to check if current is running out the pins to the lights? I measured only very small currents coming from the IJ6 and IJ7 pins which I think are the ones with the issues.

#1595 3 years ago

Question, don't have my high speed at home right now. Is there a hurry up in the game? What about the ramp loops? Are those just do 6 on a ball or do they fade away like on ramps on cyclone or whirlwind
Mof

#1596 3 years ago
Quoted from mof:

Question, don't have my high speed at home right now. Is there a hurry up in the game? What about the ramp loops? Are those just do 6 on a ball or do they fade away like on ramps on cyclone or whirlwind
Mof

The ramp value increases every time you hit a flashing 1-6 target, starting at 50,000. After it's scored, it goes back to 50,000.

The orbits/Freeways have a hurry up after the ball goes through the opposite inlane. I think it lights the spinner and increases the Freeway value if you hit a lit spinner. I think you can also adjust how many seconds the hurry up is.

1 week later
#1597 3 years ago

Got my rebuild kits in and did all 3 flippers last night. Would have gone a lot faster if coil sleeves were better toleranced. Some are smooth as silk coming out and others get to be ripped apart with pliers. I can say that having rev 1 and 2 roms (pictured in here somewhere) makes this game buggy as all getup. Multiball is possible, but it is very goofy trying to get it to admit that I can try to getaway. I had the red lights lit for a while and was looping the ramp a few times in a row, nothing. Goes into the kickback lane, boom, does the mulitball queue when it sends the ball back.

Oh, and the voice callouts that I thought weren't there, are there. Took a really long game to get one to happen, but I think it's just the old code. Will have some new ROMs coming at some point, but I want to record this game with the current ROMS to show the difference when I get the new ones.

This game is so fun.

#1598 3 years ago

Hi Guys, I would like to join your club.

I played HS when it first came out in a local bar. (1986)

I looked for one for almost a year.
I bought the one I have 9/10/16.

Pop cap is broken, wire ramps are missing the attachment arms, the traffic light keeps falling off and the display driver has battery damage.
OTHERWISE, it is an awesome game and I can't stop playing it.

#1599 3 years ago

Can someone please post some pics of HS Flipper Mech wiring.

Got band new Mechs from PBL and need a reference pics especially for the lane change switches and diodes!

Thanks heaps
Scotto

scottokong@gmail.com

#1600 3 years ago

Anybody know where I can get a traffic light cover. Marcos, Action pinball, Bay Area and Planetary pinball are all out of stock

Mike V

Promoted items from the Pinside Marketplace
From: $ 27.00
Boards
KAHR.US Circuits
There are 3736 posts in this topic. You are on page 32 of 75.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside