(Topic ID: 69131)

High Speed Club ~ Dispatch, this is 504. We have a Club now, over.


By lordloss

6 years ago



Topic Stats

  • 3,326 posts
  • 326 Pinsiders participating
  • Latest reply 1 day ago by KSUWildcatFan
  • Topic is favorited by 158 Pinsiders

You

Linked Games

Topic Gallery

There have been 906 images uploaded to this topic. (View topic image gallery).

IMG_20200326_144029 (resized).jpg
IMG_20200326_144046 (resized).jpg
HSPost.pdf (PDF preview)
IMG_20200325_164828 (resized).jpg
IMG_20200325_144954 (resized).jpg
IMG_20200325_142600 (resized).jpg
1 (resized).jpg
IMG_20200325_124337 (resized).jpg
IMG_20200325_124332 (resized).jpg
IMG_20200322_233220 (resized).jpg
IMG_20200322_233149 (resized).jpg
hs i (resized).PNG
PFB_Playfield_hinge (resized).JPG
PFB_Hing-R (resized).JPG
IMG_4891 (resized).JPG
IMG_20200321_040252 (resized).jpg

There are 3326 posts in this topic. You are on page 26 of 67.
#1251 4 years ago
Quoted from MikeS:

I would post a WTB ad in the marketplace. I'm sure there are lots of nice condition black ramps available from people that have upgraded to the new clear ramp that Freeplay made. If you do decide to buy new I would go for the clear ramp vs. a black.

What is the link for Freeplay?

#1253 4 years ago
Quoted from rwarren28806:

What is the link for Freeplay?

Here is the thread with the info. Best thing would be to PM him for details.

https://pinside.com/pinball/forum/topic/high-speed-clear-ramp

#1254 4 years ago

That clear ramp from Mark (FreePlay) is a thing of beauty. Highly recommended and the seller is a great guy.

He sent back my old black one which you are welcome to. It had a crack that I had never noticed while it was installed. If you want a stopgap measure, send me a pm and I'll root around for it. Have to say that even though I've not been in the hobby long, the clear ramp mod is the nicest I've seen, bar none.

#1255 4 years ago

Plus he moves all the hardware over for you which most of us aren't equipped to do, and you'd be stuck doing with a new black ramp for $100. Clear ramp is a huge NO-brainer!

#1256 4 years ago

Who needs marketing when I have friends and supporters like this!

#1257 4 years ago
Quoted from Freeplay40:

Who needs marketing when I have friends and supporters like this!

True. I haven't started dismantling it yet but from what I can see, the ramp I currently have will probably crumble when I remove it. I see glue in several spots and cracks in others. Can I assume that you have ramps available?

#1258 4 years ago
Quoted from Freeplay40:

Who needs marketing when I have friends and supporters like this!

If you are ever in Sacramento, I'd be glad to thank you in person.

#1259 4 years ago
Quoted from rwarren28806:

True. I haven't started dismantling it yet but from what I can see, the ramp I currently have will probably crumble when I remove it. I see glue in several spots and cracks in others. Can I assume that you have ramps available?

Yes I have ramps available...although I will be tied up for the next week with the NW Pinball show. I can generally turn them in just one day. Actually forming a bunch of them today.

#1260 4 years ago

I picked a High Speed up on Saturday so I'm in the club. Really enjoying this pin.

I have a tech question. When my slingshot is first hit, it fires and stay on for an odd amount of time (maybe 1 second) but after the first hit, it seems to fire normal. Could this be the capacitor across one of the sling switches? I have read that these go back and can cause odd firing of the slings or pops.

#1261 4 years ago
Quoted from foxct:

I picked a High Speed up on Saturday so I'm in the club. Really enjoying this pin.
I have a tech question. When my slingshot is first hit, it fires and stay on for an odd amount of time (maybe 1 second) but after the first hit, it seems to fire normal. Could this be the capacitor across one of the sling switches? I have read that these go back and can cause odd firing of the slings or pops.

That is sometimes due to the ring being too tight in the front. Pull it a bit so it is looser on the firing side.

#1262 4 years ago
Quoted from foxct:

I picked a High Speed up on Saturday so I'm in the club. Really enjoying this pin.
I have a tech question. When my slingshot is first hit, it fires and stay on for an odd amount of time (maybe 1 second) but after the first hit, it seems to fire normal. Could this be the capacitor across one of the sling switches? I have read that these go back and can cause odd firing of the slings or pops.

Check the leaf switches that rest up against the ring. I am guessing one is a little too closely adjusted, so when the ring hits it stays closed too long. HS is one of the Sys11 games that if the switch stays closed, the coil will remain pulled in, which can burn up the transistors, coil, etc...

#1263 4 years ago
Quoted from dsuperbee:

Check the leaf switches that rest up against the ring. I am guessing one is a little too closely adjusted, so when the ring hits it stays closed too long. HS is one of the Sys11 games that if the switch stays closed, the coil will remain pulled in, which can burn up the transistors, coil, etc...

Thanks rwarren and superbee, I will tinker around with the rubber and switches. It may actually be a hair small, I need to compare the two sling rubbers.

#1264 4 years ago

I repaired a ramp with this method, it works wonderfully if you take your time, and still want your old ramp to work and look good on the top side...
http://www.jeff-z.com/pinball/spacestation/repair/repair.html

with that being said, I have bought 2 ramps from freeplay40, and Im about to buy 2 more, they're that good!

#1265 4 years ago

I know you can sometimes get these new from BAA/PPS and others, but I saw this today, in case someone needed the wiring assembly side as well. (not mine)
-mof
ebay.com link » Williams High Speed Pinball Stop Light Assembly Plastic

#1266 4 years ago
Quoted from mof:

I know you can sometimes get these new from BAA/PPS and others, but I saw this today, in case someone needed the wiring assembly side as well. (not mine)
-mof
ebay.com link ยป Williams High Speed Pinball Stop Light Assembly Plastic

WOW that's cheap.

#1267 4 years ago

Stop light Red Targets. Can A-14691-4 be substituted for A-11022?

#1268 4 years ago

Hey guys, I have question about the flashers in HS. I've been going through a HS that I picked up a while back. One thing I did was to replace all flasher bulbs with fresh ones (incandescent 63s). In solenoid test I see that everything works except for the "Top" flashers don't go off. What kinds of things should I look for to get those flashers working?

#1269 4 years ago

test the bulbs in different sockets. If the bulbs are good then check the sockets and the wiring. Some flashers are in series and must all be good for any of them to work.

#1270 4 years ago

Having trouble with my high speed on boot up. The left, right, and shooter eos Check comes on. I read a thread on it possibly being q43 transistor, so I'm going to swap that tomorrow, but I'm not by it to double check, does anyone know what diode goes to those 3 switches? Also the left hideout switch doesn't register but that's a separate issue and I'm going to try swapping the switch before I really get into that issue. Any help on what diode it is would be great. Thanks!

#1271 4 years ago

Found and replaced diodes for 36,37,38 and didn't fix the issue. Gunna keep looking

#1272 4 years ago
Quoted from amkoepfer:

Having trouble with my High Speed on boot up. The left, right, and shooter eos Check comes on. I read a thread on it possibly being q43 transistor, so I'm going to swap that tomorrow, but I'm not by it to double check, does anyone know what diode goes to those 3 switches? Also the left hideout switch doesn't register but that's a separate issue and I'm going to try swapping the switch before I really get into that issue. Any help on what diode it is would be great. Thanks!

Where do these items fall on the switch matrix? Are they in the same row/column?

#1273 4 years ago

Same column, could it be one of the other switches in that column even though it only says those 3? All eos seem to be adjusted correctly. I did notice with it plugged in but not on, I touched the side rail of that game and the one next to it and felt a shock. Doubt that's the same issue though. The left hideout switch doesn't register and I think that may be on the same column as well, maybe that's causing it? That's just a little micro switch though. Sorry for being long winded, just have a lot of issues I'm trying to solve! Also the beacon doesn't work.

#1274 4 years ago

Same column: you have a wire disconnected somewhere.

Grab your manual and confirm they are all in the same column, and that the other switches in the column are indeed working.

The shock = bad ground.

#1275 4 years ago

Still having issues with the ball not getting diverted from the ramp about 1 out of 5 times. Both switches on the ramp respond immediately when pressed during switch test. Ran a coil test on the diverters and both popped without missing a beat 30 times in a row. Have no idea what is causing this.

#1276 4 years ago
Quoted from amkoepfer:

I did notice with it plugged in but not on, I touched the side rail of that game and the one next to it and felt a shock.

Check both of the games for a missing ground prong on the power plug.

#1277 4 years ago
Quoted from playboywillis:

Still having issues with the ball not getting diverted from the ramp about 1 out of 5 times. Both switches on the ramp respond immediately when pressed during switch test. Ran a coil test on the diverters and both popped without missing a beat 30 times in a row. Have no idea what is causing this.

Did you test the switches by rolling a ball over them, or pressing with your finger? If you used a finger, re-test with a ball and see what happens.

#1278 4 years ago

Ya power cord ground broke off. Replaced diodes on all other switches just in case and didn't fix, so I'm gunna have to search down a broken wire. Could the transistor on the mpu at q43 cause it but still have the 3 switches work? I am guessing it has to be in the left hideout since those aren't working, but want to cover all my bases.

#1279 4 years ago
Quoted from dsuperbee:

Did you test the switches by rolling a ball over them, or pressing with your finger? If you used a finger, re-test with a ball and see what happens.

With a finger. Thanks, I'll try a ball tonight.

#1280 4 years ago
Quoted from playboywillis:

With a finger. Thanks, I'll try a ball tonight.

Always test switches by rolling a ball over them. Always. It makes sense to test the switch with what will actually be touching it

1 week later
#1281 4 years ago

Ok so I have all issues fixed but one. I can't get the beacon motor or light to come on. Fuse is good, and I don't have schematics to track it down, but where is that controlled on the CPU? Anyone have any ideas?

#1283 4 years ago

I have it downloaded, its just hard to zoom in and be able to read it. Thanks though

#1284 4 years ago

Yeah, the quality can vary on those. My manual is at home.

Does it work at all? Test mode? Mine used to stick sometimes, and it I wapped on the dome it would start working.

#1285 4 years ago

when I repaired my dome it wouldn't turn (although it would light). I swapped the relay with the one under the playfield for the kickback and they both worked after. You can try this to rule out the relay.

#1286 4 years ago

Test mode doesn't work on the game. Light and motor does not come on. I'll try swapping relays and see if that's the issue. They should sell those at car parts stores right?

#1287 4 years ago

Put a DMM on the leads to the relay and see if it is getting voltage during self test. You don't even have to do that if the relay is clicking of course. On mine it would stop working after a while. It was blowing the 1A slow blow fuse. In the end I used a 2A slow blow since there is nothing else on that circuit and I think the motor was just getting older and drawing more current.

#1288 4 years ago

The fuse is good, I changed the relay and its still not working. I'll check the voltage next.

#1289 4 years ago

It's reading in MV when I test it, bouncing around, so I don't think it's really getting power. Any idea where power is supplied on the power board? It's a new relay and fuse so those two aren't the issue

1 week later
#1290 4 years ago

Recently picked this up. Great game. image.jpg

2 weeks later
#1291 4 years ago

So I'm starting to put the machine back together. I purchased one of the clear ramps as a replacement for the beat up and broken black one. Since there aren't any holes in the top of the new ramp to screw things into (and I would prefer not to), what is the purpose of the long rail that screws into the old ramp and goes behind? See post #436 to see the rail I'm referring to. I haven't seen the purpose of it as there are already 2 smaller rails there. I'm 1/2 thinking it is to support the ramp and the traffic light but that is just a guess.

#1292 4 years ago
Quoted from rwarren28806:

So I'm starting to put the machine back together. I purchased one of the clear ramps as a replacement for the beat up and broken black one. Since there aren't any holes in the top of the new ramp to screw things into (and I would prefer not to), what is the purpose of the long rail that screws into the old ramp and goes behind? See post #436 to see the rail I'm referring to. I haven't seen the purpose of it as there are already 2 smaller rails there. I'm 1/2 thinking it is to support the ramp and the traffic light but that is just a guess.

You don't need that piece. I think it was primarily to prevent the ball getting under the ramp. Not an issue with mine.

2 weeks later
#1293 4 years ago
Quoted from rwarren28806:

So I'm starting to put the machine back together. I purchased one of the clear ramps as a replacement for the beat up and broken black one. Since there aren't any holes in the top of the new ramp to screw things into (and I would prefer not to), what is the purpose of the long rail that screws into the old ramp and goes behind? See post #436 to see the rail I'm referring to. I haven't seen the purpose of it as there are already 2 smaller rails there. I'm 1/2 thinking it is to support the ramp and the traffic light but that is just a guess.

I don't think that's there for ball prevention. Looks like a brace/shock absorber to me.

#1294 4 years ago
Quoted from playboywillis:

I don't think that's there for ball prevention. Looks like a brace/shock absorber to me.

Regardless, it is not needed with the clear ramp.

2 weeks later
#1295 4 years ago

New question. I replaced the header on 3J8 and the connector as they had previously been burned and making bad connection. Whatever torched them has already been fixed.

I checked across the pins on the header (connector removed) to see if there is connectivity. There is over all of the pins. I meter pin 9 and pin 1, 9 and 2 etc.. and I have a circuit. It's like that over all of the pins. I'm thinking that as this is the connector for the GI lighting that it is OK for this to happen. But before I turn it on and smoke everything, I thought I'd put this out there and ask to be sure.

#1296 4 years ago

NOS motor on eBay. This is almost half of what I normally see. Note this is not mine.ebay.com link

#1297 4 years ago
Quoted from Cheddar:

NOS motor on eBay. This is almost half of what I normally see. Note this is not mine.
ebay.com link

Link takes me to eBay, nothing else.

#1299 4 years ago

Picked up a High Speed as my first pin 2 days ago. Like most people buying their first pin, I think I slightly overpaid for the condition, but oh well, I'm happy with it. With little free time this week, now the dilemma is do I test/clean/fix the small things, or do I play it until my fingers bleed? Obviously I'm choosing the latter

#1300 4 years ago
Quoted from lopazopy:

Picked up a High Speed as my first pin 2 days ago. Like most people buying their first pin, I think I slightly overpaid for the condition, but oh well, I'm happy with it. With little free time this week, now the dilemma is do I test/clean/fix the small things, or do I play it until my fingers bleed? Obviously I'm choosing the latter

First pin?
Read this:
https://pinside.com/pinball/forum/topic/post-purchase-checklist

Promoted items from the Pinside Marketplace
2,850
Machine - For Sale
Blaine, TN
There are 3326 posts in this topic. You are on page 26 of 67.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside