(Topic ID: 237515)

High Speed 2 : Getaway Supercharger and Topper


By Malenko

53 days ago



Topic Stats

  • 7 posts
  • 6 Pinsiders participating
  • Latest reply 52 days ago by yellowghost
  • No one calls this topic a favorite

You

Linked Games

#1 53 days ago

Picked this game up yesterday, everything seems to work pretty well except the supercharger doesnt fire the balls around the track. The ball either stays behind the gate, or rolls back down the ramp, bounces off the left post then ricochets perfectly down the right drain. Game passes all the switch tests , I just dont know when to begin looking to fix it. I couldnt find a thread that had a fix, so I decided to post.

The other lesser issue is the topper light comes on, but the light doesnt "spin" . I'd prefer to keep the original but if its an expensive or complex repair Ill just replace the beacon with an amazon one like I did one LW3 (which was missing when I got LW3)

#2 53 days ago

If I'm not mistaken there is a belt that makes the light spin .. Good luck with repair ....

#3 53 days ago
Quoted from transprtr4u:

If I'm not mistaken there is a belt that makes the light spin .. Good luck with repair ....

On f14 there is... hs2 uses a small motor

#4 53 days ago

On the supercharger, there are 3 optos under the cover that trigger each magnet. They are controlled by a separate board under the playfield. I’d check there first if you haven’t already.
Jeff

#5 53 days ago

All the switches tested fine but the magnets werent activating. Lower board was ok, but the fuse was indeed blown, well kinda.

It tested good, then it didnt, then it did, then it didnt lol. I replaced it and we were back to green flag racing!

The light up top still wont spin. Mechanically it spins one way, but not the other. I was considering switching the polarity of the wiring going to the motor thinking maybe its wired backwards and wont spin. Like I said, worst case, I'll get the red version of the one I put on LW3

#6 52 days ago
Quoted from Malenko:

The light up top still wont spin. Mechanically it spins one way, but not the other. I was considering switching the polarity of the wiring going to the motor thinking maybe its wired backwards and wont spin.

This is an AC motor, reversing the leads wont make any difference. Most likely the motor is bad.

#7 52 days ago

Probably seized. Tap it when its supposed to spin. I opened the transfer case on mine, cleaned it out and re-oiled it and it worked ok for a little while.

Promoted items from the Pinside Marketplace
$ 27.99
Lighting - Interactive
Lee's Parts
$ 16.00
$ 8.50
Lighting - Led
Bright Lights Pinball
$ 129.00
Lighting - Led
LED OCD
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 16.95
Wanted
Machine - Wanted
Hackettstown, NJ
$ 17.99
Playfield - Decals
Lermods
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 19.00
Boards
Tilted Pinball
$ 109.99
From: $ 11.95
Playfield - Toys/Add-ons
ULEKstore
$ 175.00
Lighting - Interactive
Professor Pinball
$ 16.50
Lighting - Led
Lermods
From: $ 369.95
Boards
PinSound
From: $ 29.00
Boards
KAHR.US Circuits
$ 40.00
Lighting - Other
Rock Custom Pinball
$ 239.99
Lighting - Led
PinballBulbs
$ 229.99
Lighting - Other
Lighted Pinball Mods
Wanted
Machine - Wanted
San Diego, CA
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
€ 95.00
Lighting - Led
FlipperLED
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
Hey modders!
Your shop name here

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside