(Topic ID: 43134)

Help: WTHeck??? (SOLVED)


By dbpbandit

7 years ago



Topic Stats

  • 12 posts
  • 4 Pinsiders participating
  • Latest reply 7 years ago by dbpbandit
  • No one calls this topic a favorite

You

Linked Games

You're currently viewing posts by Pinsider dbpbandit.
Click here to go back to viewing the entire thread.

#1 7 years ago

I'm working on a Bally Midway's Black Pyramid and it's doing something very strange.

When I finally get the game to boot up and start a game, the ball eject will not kick the ball into the shooter lane, the left pop-bumper works fine, the right slingshot works fine, the right pop up-bumper triggers the left slingshot, the saucer (kick out) triggers the knocker and the left slingshot switches also fire the knocker????

I've re-flowed all off the connections and I'm waiting on parts to rebuild the Power board but this thing has me really stumped. I've checked all of my cables and connections (they seem correct) When I do the test on the coils they all fire in correct order as stated on the list in the manual. I've also replaced the driver transistor for the knocker because it stuck on and almost fried that coil.

Any suggestions???

Thanks

#4 7 years ago

I'll check for a stuck switch, thanks.

#5 7 years ago

UPDATE: (finally got time to work on it again)

I rebuilt the power board and that took care of the issue I was having with the game booting up. I also re-capped the audio board and now the audio is working fine.

However, I'm still having an issue with switches and coils firing.

The switch test shows all switches are working. The coil test fires the right slingshot twice, the right pop-bumper twice and the drop targets twice but that's it, none of the others fire. Also, every time a coil fires the knocker fires as well??? If I use a ground wire and manually fire all of the coils from the driver board they all fire as they should.

I have checked the cables and they all seem fine.

I do have one burnt wire on the lamp driver board at J4 that I will fix next chance I get.

Any suggestions?

Thanks...

Post edited by dbpbandit : wrong board

#7 7 years ago

Yes, the game worked on and off before it was moved with the exception of the booting issue. (head was removed for the move) Since then Ive fixed all the minor issues and the booting issue, this is the last one. And yes, I've checked and rechecked all of the connections to and from the head.

Yes, if I manually fire the coils with a ground wire they all fire and all correspond to the correct transistor.

-Dave

#11 7 years ago

Thanks for the doc, this is great!

I'll get that connector replaced ASAP, I just figured since it was on the lamp side it wouldn't make any difference on the coil side of things.

I'm starting to think that since the kicker fires with the other coils that I must have a short somewhere. Just nothing obvious, of course....

I'll update more later, thanks.

#12 7 years ago

UPDATE: (SOLVED)

I finally got this issue figured out last night and now the game is working great.

After I replaced the connector pins on the lamp driver board I found a spot where a little too much solder had flowed between to pins on the back of the board. I cleaned that up and then decided to go back and recheck all of my other re-flow work. Turns out I needed to use a magnifying glass because there was just the smallest amount of solder shorting out between two pins. I didn't see it on my first or even my second and third pass, it actually took the magnifying glass to spot it. Once I cleaned it up the game came on and played like a champ. From now on I'll swallow some pride and use the magnifier when I re-flow these small pins. Thanks for the help.

Promoted items from the Pinside Marketplace
From: $ 10.00
Electronics
Third Coast Pinball
From: $ 155.00
$ 15.45
Gameroom - Decorations
KAHR.US Circuits
€ 3.95
Flipper Parts
Multigame
$ 149.95
Boards
Allteksystems
$ 9.00
Electronics
Yorktown Arcade Supply
$ 44.99
Electronics
PinballElectronics.com
From: $ 45.00
Displays
PinballSolutions.eu

You're currently viewing posts by Pinsider dbpbandit.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside