(Topic ID: 108357)

Help with Speakeasy Please


By dbpbandit

5 years ago



Topic Stats

  • 2 posts
  • 2 Pinsiders participating
  • Latest reply 5 years ago by CNKay
  • No one calls this topic a favorite

You

Linked Games

#1 5 years ago

I have a Bally Speakeasy that I've been working on for a while and I'm hoping I can get some advise here please.

Game boots, goes into attract, starts a game and plays fine but no sound. Every time the ball hits a switch (when there should be a sound) the coils "twitch" for lack of a better word. This same behavior exists weather the sound board is connected or disconnected.

Any suggestions?

Thank you.

-Dave

#2 5 years ago

If you lift up your pf is there a solenoid expander board? If so is there a light on all the time close by? if so remove the bulb and then trigger a switch. the correct coil should fire. The "twich" is likely the memory drop target solenoids.

The no sound is a totally different issue. Maybe speaker disconnected, bad sound board??? Do you have the coin door connector plugged in as on the coin door is the main volume control. who knows.

Just a guess too on my part but something for you to try.

Promoted items from the Pinside Marketplace
€ 3.95
Flipper Parts
Multigame
From: $ 18.00
Apparel - Men
Pinside Shop
$ 44.99
Electronics
PinballElectronics.com
$ 119.95
Boards
Allteksystems
$ 9.00
Electronics
Yorktown Arcade Supply
From: $ 155.00
From: $ 140.00
$ 149.00
From: $ 5,899.95
Pinball Machine
Pinball Pro
$ 5.00
Playfield - Decals
Doc's Pinball Shop
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside