(Topic ID: 53154)

Help with 'Speakeasy' (updated)


By dbpbandit

6 years ago



Topic Stats

  • 53 posts
  • 11 Pinsiders participating
  • Latest reply 6 years ago by dbpbandit
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

se3.jpg
se4.jpg
expboard1.jpg

You're currently viewing posts by Pinsider dbpbandit.
Click here to go back to viewing the entire thread.

#1 6 years ago

The game boots up and plays, sort of. So far I've rebuilt the voltage regulator/driver board, re-flowed all of the connections and fixed several little issues. All of the GI's are working but none of the playfield lights are working, all of the inserts are dark. I have figured out the the 1A fuse under the playfield blows as soon as you turn the game on. I have a dead short somewhere in that circuit but if I unplug the solenoid expander board under the playfield the short goes away. The game no longer plays but the short is gone. I ordered one of the newly re-designed Solenoid Expander boards from Marco thinking that would fix it but when I install that new unit I have the same issue, no lights, no spinning roulette wheel and a blown fuse. I don't see any obvious shorts anywhere and now I'm not certain that I got the right solenoid expander board. It lists this game but on the instructions it states that if your original has the jumper than you need to get the B version, my old one does have this jumper. (see the pic) However, since I got the game non-working I have no idea if this is the right one or not.

Can someone please let me know if I'm missing something? Thanks.

expboard1.jpg

#3 6 years ago

Thanks. I appreciate it.

#6 6 years ago

"(Edit: for future reference searches please chance the title of this thread from Sleepeasy to SpeakEasy All tough i understand it's a sleey one for you )"

Thanks, and DOH!!!

#7 6 years ago
Quoted from Patofnaud:

No jumper on the expander on my PF. Assuming that there was only one expander.

Thanks, for checking. I wonder if I just remove this jumper on mine if that will fix the issue? Maybe someone just out in the wrong one?

#11 6 years ago
Quoted from Hellfire:

The SW illumination check to be sure the bridge rectifier is putting out voltage on the rectifier board if it is check pf ground wire then if not the problem check the top left light driver board connector for burned pins.
Also on this machine it is common to have a added second bridge rectifier and/or hack mod for the SW illumination added to this machine to conform with the 555 service bullitin to drop the voltage to prolong the life of the 555 bulbs in the inserts just remove the second bridge and re jumper the cut trace on the rectifier board.

Thanks for the information but can you elaborate a bit more? I'm not sure what "SW" means?

Thanks

#13 6 years ago

"sw = switched lamps " that makes more sense now. Thanks, I'll check it out.

-Dave

3 weeks later
#14 6 years ago

UPDATE: Good news, I was able to get the game working, sort of....

Turns out that expander board I purchased will not work on this game, it blows that fuse as soon as I turn the game on. I was able to fix my original expander by replacing that relay with a new one (thanks for the suggestion and the link Thor-NL)

So after replacing the relay and the fuse everything came up and worked. All the lamps work as well as the roulette wheel. However I still have a connection issue somewhere in the head. If I leave the front open the game seems to play fine but when I close it up and put the back-glass on the displays go funky and the game lights/wheel do not work. OR, the game will come on and work, for a while and then locks up. I originally re flowed all of my connections but something may have come lose so I'm going to check them again. I'll also check for a lose connector/crimp, it's got to be something simple at this point.

-Dave

1 month later
#18 6 years ago

Hey guys, I finally got some time to get back to working on this. Previously, I explained how when closing the back box they game would have issues with the dis[lays and then stop working. Well, not I have no displays and the game will not start a game. All of the GL's and other lights work, just no game play and or displays. I'm not sure but when I turn it on the LED on the MPU comes on, then goes out and then blinks two or three more times, then goes out> I think it should blink six or seven times? I'm thinking maybe my MPU might be dying. I tried re-flowing all of the pins at the connectors and I still get the same results. My next step will be replacing the original connectors with new ones but as far as I can tell the original ones look fine. Any suggestions?

Thanks.

1 week later
#20 6 years ago

OK, Thanks for the tip. I cleaned up the socket and reseated U8 and now I get all seven flashes on the MPU LED. However, after the seven flashes the LED stays on, the score displays flash and flicker and the game will not take a credit or start a game. Suggestions?

Thanks,

-Dave

#22 6 years ago

Yes, with all connectors disconnected (except J4) the LED stays on after the seven flashes.

#24 6 years ago

When I measure voltage at TP7 I get 3.88VDC (not sure what this should be.

Also, I swapped U10/U11 and I get the same results.

#25 6 years ago

AAARG! I found the info on TP voltages and checked all of them. A couple of them seemed high, but I can only adjust the 5v, so I did and that's dead on now. I also checked all of the socketed chips, cleaned the sockets and the legs of the chips. Now, after all of that, when I power it on I get 8 flashes and the last one stays on. The displays are still acting strange and I'm still not able to start a game.

I'm open to suggestions, thanks.

1 week later
#29 6 years ago

This thing is quickly becoming a real pain....

In my first, second and third pass on this board, I found a ton of clipped resistors. Yes, someone actually clipped at least twenty+ resistors and diodes on the MPU. I have no idea why someone would do this to a board, makes no sense unless they were just trying to screw it up.

I have cleaned up the previous repair/clean up of battery damage (I used the typical vinegar method) Checked/replaced sockets, cleaned chips, etc, still wont work and it very inconstant. Sometimes I only get three blinks on the LED, sometimes 8, sometimes nothing at all. The only consistent thing is the game still isn't working....

Any chance someone has one of these boards (working) they'd be willing to sell, cheap? I know I can get one of those "ULTIMATE Bally & Stern MPU boards" for about $200 but I'm not sure I really want to put that much into it.

Thanks....

1 month later
#32 6 years ago

Hey guys, I've hit a wall on this one and I could really use some help please.

I got the new CPU (thanks barakandl) and it's working great, however...

I'm having issues with some of the play-field lamps and now I'm stuck. I tested the lamp driver board (thanks for the tester Half_Life) I had to replace a few of the transistors but even after all of that some of them will not light. Take a look at the pick, I have circled the ones that aren't working. They all appear to be on the same circuit with the same ground. I've checked the connectors, wires and sockets (and the lamps themselves) There were a couple of lose or broken wires at the sockets (fixed now) but I still cant get anything from them.

Am I looking in the wrong place? Is there another circuit somewhere I'm not checking? Any help is appreciated.

Other than this the game looks and plays great. I'm not at all clear on how the extra button on the left is supposed to work or the rules for it. Maybe if the other play-filed lights were working it would make more sense.

Thanks...

se4.jpg se3.jpg
#35 6 years ago

Yes, I checked the Aux driver and it seems to be fine too.

Yes, the lamp driver tester board shows that all of them are good.

Not sure if I understand this: " If so check for 6vdc on the lamp socket side connected to bare wire under the playfield"

Can you please clarify?

Thanks.

#38 6 years ago

OK, I get what your suggesting now. I'll give that a try tonight when I get home. Thanks for the detailed explanation.

As for the sacrifice button rules, thanks, I'll give that a try tonight too.

Thanks.

#39 6 years ago

OK, so I got the lights working, it's a little embarrassing but the problem ended up being a 10A fuse under the playfield. I had previously tested this fuse and it checked good but apparently that wasn't good enough. I worked my way back through the circuit, looking for the missing voltage and it lead me to this fuse. As soon as I replaced it with a fresh fuse the problem went away.

The game is working at 100% now. Thanks for all of the help along the way.

One thing I've noticed, since I've been playing it, is that the ball hits those swinging targets really hard across the bar. It seem to hit the bar and bounce back a lot more that it actually goes under and swings the targets up. Has anyone else noticed this? It seems to me like the bar is a little to low? Has anyone figured a way to remedy this?

Thanks again.

#43 6 years ago

Thanks. It's been kind-of a low priority project but it's nice to finally have it working. It looks really nice too. I still need to check off a few items but for the most part it is done. Thanks again to everyone here who helped me with it,

#44 6 years ago

Thanks for the tip on the air ball issue (Thor-NL) I pulled the spinning wheel glass, added some new padding and levelled it. No more air balls!

So now I'm down to (i hope) my last issue. The "10" lamp, in that lower section isn't working. Everything on the lamp driver board tests good (checked with the lamp driver board tester) lamp is good, traced the wire all the way back to the back box and checked for connection to the lamp driver board (J1 connector) so it should work. However, there is something not right, with the game on if I use my meeter on the line going to the lamp (at the lamp socket) it shows voltage but it's constant, not cycling on and off like the others (but the lamp isn't lighting) I rigged up a test lamp with a LED (44 lamp). If I connect it to the others the LED flashes on when the other lamp flashes, however on the "10" it stays lit all the time???? Anyone have a suggestion on where I should look next? Thanks.

#45 6 years ago

bump

#47 6 years ago

Even thought it tests good?

OK, so now I need to figure out which one drives that particular lamp. What's the best way to do that?

Schematic?

Thanks

#48 6 years ago

OK, so I'm studying the schematic and according to this the lamp in question is the "10k bonus" but it's on the J2 connector of the "auxiliary" lamp driver. No wonder, I'm looking in the wrong place... Also, my wire tracking skills are way off... I will pull that board out tonight and replace the Q10 and see what happens.

Thanks.

#49 6 years ago

I was able to fix the lamp issue so now the game working 100% ! Thanks again for all the help.

All I have left to do is re-cap the sound board, put on the new leg levellers, touch-up the paint on the cab and install the coin door lock and sticker.

I've learned a lot working on this game and it's a really neat and fun game. However, once I'm done it's going up for sale.

Now I just need to figure out a starting price for it.

Thanks again for all the help, Pinside ROCKS!

#50 6 years ago

Is there a way to set this game to free play?

#53 6 years ago

That's a good idea, I'll give that a try, thanks.

Promoted items from the Pinside Marketplace
$ 149.95
Boards
Allteksystems
From: $ 155.00
$ 119.95
Boards
Allteksystems
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 45.00
Displays
PinballSolutions.eu
$ 44.99
Electronics
PinballElectronics.com
€ 3.95
Flipper Parts
Multigame
$ 149.00
$ 9.00
Electronics
Yorktown Arcade Supply
$ 40.00
Gameroom - Decorations
Arcade Arts
€ 40.00
Playfield - Toys/Add-ons
YOYOKOPTER MODS
$ 28.75
Playfield - Toys/Add-ons
The MOD Couple
$ 35.00
Cabinet - Other
Filament Printing

You're currently viewing posts by Pinsider dbpbandit.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside