(Topic ID: 206409)

Help with DE G&R


By robertg130

1 year ago



Topic Stats

  • 5 posts
  • 2 Pinsiders participating
  • Latest reply 1 year ago by MagicSmoke
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

Hi,happy new year folks
Working in a g&r machine taken from a garage(last 8 years),when turning on cpu won’t boot,pia is on the center led also,but the blinking one no.This is my first DE machine,so I I’m need of help
Thanks

#2 1 year ago

The center led is only a 5v led. It just shows if there is 5v going to the board. Have you checked for corrosion? DE is not really different than any other system when it comes to booting. it is actually a copy of system 11.
Here is some good info

http://techniek.flipperwinkel.nl/desega/index2.htm#poweron

#3 1 year ago

No corrosion, batteries taken out

#4 1 year ago

When DE boards dont boot the two most likely culprits are corrosion and the 6808 processor. Since it isnt the corrosion next step is to check the processor, or just replace it with a 6802. The link i posted has a ton of info on fixing DE boards. If you have never done board work and diagnostics before it may save your sanity to buy a rottendog replacement.

#5 1 year ago

Also reseat your eprom make sure there is no bent legs on it.

Promoted items from the Pinside Marketplace
$ 14.50
Electronics
PinballElectronics.com
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 259.99
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
€ 95.00
Lighting - Led
FlipperLED

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside