(Topic ID: 173026)

help special force not working buttons not reading

By V8haha

5 years ago



Topic Stats

  • 7 posts
  • 2 Pinsiders participating
  • Latest reply 5 years ago by V8haha
  • No one calls this topic a favorite

You

Linked Games

#1 5 years ago

hello

so i just picked up a special force pinball machine

game powers on lights kick on some sound but the only things not working are the flippers

start button and flipper button i have tested it all in the test modes and their not working and not getting registered.

i have tested all fuses that i can see 2 under the play field and a few in the back box.

what could cause this? where to look next?

#2 5 years ago

PS i checked the leaf switches inside the game to make sure they had contact all looks good

also everything looks wired correctly

#3 5 years ago

Slam switch stuck?

#4 5 years ago

not that i can tell

update so i got the start button to work just by messing with it and now the left flipper works but not the right. the right flipper switch i can see a light spark when i push it in but doesn't move the coil i can hear a very faint hum coming from the coil when i use my hand to move the flipper it moves and if i hold the botton in it will lock the flipper in the up position and hold it until i release the button but it doesn't have enough streangh to move the coil.

any ideas

#5 5 years ago

bump

#6 5 years ago

Check for cold/cracked solder joint on that coil circuit.

#7 5 years ago

it was a mixture of things one being the end of stroke switch stuck on the right coil game is playing now.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside