(Topic ID: 297166)

Help repairing Whitestar power driver board for my Starship Troopers?

By offworldon

8 days ago


Topic Heartbeat

Topic Stats

  • 15 posts
  • 3 Pinsiders participating
  • Latest reply 3 days ago by phishrace
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

Screen Shot 2021-07-22 at 9.28.57 AM (resized).png
pasted_image (resized).png
PXL_20210721_235717183 (resized).jpg
PXL_20210721_215407520 (resized).jpg
PXL_20210721_203003842 (resized).jpg

#1 8 days ago

Hello! I have a partially functioning whitestar power driver board in my sst pin that keeps blowing fuse F7 - this is causing the flashers to not work and some other problems. I tried trouble shooting it myself but no luck. Hoping someone on here can repair the board properly for me. Thanks in advance!

Don

#2 8 days ago

If you're sure it's the board (not playfield), Rob Anthony can likely fix it for you.

http://lockwhenlit.com/contactus.htm

#3 8 days ago

Oh! Good call - For some reason just automatically assumed it was the board - I have a ID4 I can test it out in tomorrow. Thank you!

#4 7 days ago

Shouldn't need to remove the board to narrow it down.

Power off, remove connectors J6 and J7 on driver board, replace F7, power up with coin door closed. If the fuse blows, it's likely a board issue. If it doesn't blow, power off and reconnect J6 and J7 one at a time and see if the fuse blows.

#5 7 days ago

Oh wow its not the board!!! Short isolated it to J7! Never ran into anything like this before - any tips on how to troubleshoot this?

PXL_20210721_203003842 (resized).jpg
#6 7 days ago

Could still be a bad transistor on driver board.

Power off, J7 disconnected, meter set to diode (tone) mode, negative lead to ground (any driver board screw will work), then touch each of the wires in J7 with positive lead.

If any beep, that's your short. If no beeps, it's likely a shorted transistor on driver board.

#7 7 days ago

Well I have discovered 4 shorts in the wires. Looking at the manual to verify but have a hunch that these go to stepper motors 1-4. No idea what those are yet but at least making some progress here...

PXL_20210721_215407520 (resized).jpg
#8 7 days ago

Not likely the stepper motor as that's a 12 volt motor.

Power off, remove J6 and J7 connectors, test all pins on J6 for continuity to ground and pin 9 on connector J7.

#9 7 days ago

Getting continuity between these two pins and thats it. I do have a stuck switch in the stepper motor section as well. its the front one. it still will trigger but the service menu says its stuck on. wonder if that might have burned out the diodes for stepper motors 1-4 still learning about what they actually do...

PXL_20210721_235717183 (resized).jpg
#10 7 days ago

This may help...

Anything not connected to 20V (yellow highlights) simply isn't going to blow F7. Essentially if you disconnect J7 and it stops F7 from blowing all you have is the Brain Bug flasher circuit

pasted_image (resized).png

#11 7 days ago
Quoted from offworldon:

Getting continuity between these two pins and thats it.

You need to check continuity between each pin and ground, like you did with the female connector. Not pin to pin.

#12 7 days ago

No shorts to ground on the pins except the last one on J7 and the first one on J6 - think those are grounds though. Took a quick look at the brain bug flashers this morning before work and nothing out of the ordinary there. no metal touching metal - no loose wires etc. The manual says the for pins on the female connector that have continuity to ground are in fact the stepper motors 1-4 - still need to do more research on what those actually do.

Screen Shot 2021-07-22 at 9.28.57 AM (resized).png
#13 6 days ago

At this point, I would suggest pulling the board and testing all the transistors for shorts. Q23 and Q25 - Q32 are going to be your suspects.

#14 4 days ago

Well I replaced Q22 (by accident) and Q25 and Q23 and NO MORE BLOWING F7!!! I still don't have all my flashers but many of them came back! THANK YOU phishrace for the help!

I'm feeling more confident in repairing the boards now.

Still some q's - I replaced Q23 which was brain bug and those flashers still don't work - need to verify working bulbs in those - also need to find out what the hell stepper motors 1-4 do - i only see one motor for the warrior bug - maybe those are like WB sequences or something? Anyway WB moves around during gameplay now and one of its flashers is working too, but I can't run any of the stepper motors from the test menu.

Last but not least I accidentally lifted a pad on the board with my desolder gun on one of my first tries - the leg of the transistor doesn't go anywhere though at least from what i can tell - I tried to make a new one out of copper tape and it seems to be working/holding but Should I be soldering a trace to ground for something like that?

#15 3 days ago

Nice work. Motor tests may not work unless coin door high power interlock switch is pulled out (or pushed in). On the pulled pad, post a good pic. A stitch will likely get you going again.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside