(Topic ID: 278572)

Help my Aerosmith topper died!

By action76

1 year ago



Topic Stats

  • 5 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by titanpenguin
  • Topic is favorited by 1 Pinsider

You

Linked Games

You're currently viewing posts by Pinsider action76.
Click here to go back to viewing the entire thread.

#1 1 year ago

I currently have an Aerosmith Pro with the official Stern topper. It just stopped working the other day and I cannot figure out why. I have very little experience working on Spike machines so I am sure I am probably overlooking something. I checked the voltage at the power board and it is 48 volts like it should be. I assume there are no fuses in this machine because cannot find any other than the main line fuse? I'm not sure if the topper would be controlled by a node board but it only has two connections - the power, and a cat 5 going into CN12 on the MPU. Any help would be awesome. Thanks.

#2 1 year ago

Anybody got any ideas?

#3 1 year ago

In the node board test, this is what is showing up Node 0 - 0.2.0, node 1 - 0.25.0, node 8 - 0.25.0, node 9 - 0.25.0
I have no idea if that is correct or if something is missing or wrong.

Is there any connectors inside the topper itself that might have come loose?

Any help would be greatly appreciated.

You're currently viewing posts by Pinsider action76.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside