(Topic ID: 204099)

Help! JD won't boot


By tjprice222

1 year ago



Topic Stats

  • 8 posts
  • 6 Pinsiders participating
  • Latest reply 1 year ago by Rob_G
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 1 year ago

Hey all! Just got JD all put back together and everything was working great except the center scoop wasn't registering. I turned the game off, raised the playfield and realized I left the connector to the switches disconnected. I re-connected the connectors, lowered the playfield, powered the game on and went into coil test to eject a ball to manually test the scoop. As soon as I closed the coin door, the machine shut off like it was going to reset but no lights came on and the launch coil locked on and the planet and crane arm continued to run. I powered the game off immediately and checked over things. I smelled a faint burning smell but couldn't track it down. I checked over things below the playfield and in the backbox. All looked good so I turned the game back on. Nothing appeared to lock on but now the planet and the crane continuously run but no lights come on, DMD is off and the game never starts.

I'm not sure where to go from here to start troubleshooting and I certainly don't want to do any damage. Anyone kind souls care to guide me in the right direction?

#2 1 year ago

Unplug what ever you plugged in. Then pull fuses off of driver board and check with a meter. Any bad fuses ? Replace, leave thing unplugged, try again.

LTG : )

#3 1 year ago

Do you have any reference photos from before the connectors were unplugged? There's a couple of them that can sometimes get mixed up.

#4 1 year ago

Did you unplug any ribbon cables? If so, you may have one end plugged in one row off.

#5 1 year ago

ltg forceflow pinballmaniac40 Thank you all so much for the help! I tested all fuses on the driver board and none of them were bad. (I did pull each one prior to testing).

I also left the recently connected connector disconnected but I am sure it is correct by my pre-teardown photos and I labeled each side of the connector.

Ribbon cables were seated properly and game worked fine for about a week prior to this occurrence. I played the game for a while before realizing the scoop/jackpot shot was not registering. To rule them out, I went ahead and re-seated all ribbon cables.

I tried firing up the game and nothing happens now. No lights, no bong from the sound board, no spinning deadworld or moving crane arm. All the LED lights on the driver board light up except LED 3 which is normal and LED 5 which is not normal.

On the CPU board, D19 and D21 are lit solid and D20 appears to repeatedly flash one time. According to the manual, it says U6 is bad. I did remove and re-seat U6 but it did not help. I do have another U6 chip running later software but I didn't change it out because I don't want to risk damage to a second ROM.

Should I go ahead and replace U6 or are there some other troubleshooting steps I should take first? Thanks!

#6 1 year ago

Try giving the ASIC and the CPU [6809] a good press down in the socket and any other chips that are socketed on the CPU board.
I would unplug all switches on the CPU board and everything on the driver board except where the power comes in on the right and where it goes out to the CPU board on the left. you should be able to get it to boot with nothing else plugged in.
If you have a computer power supply, you can test it on the bench with 5v, 12v and ground. would help you rule out if it's a power issue or a CPU board issue.

#7 1 year ago

Also, looks like you have drac and fish tales. could try those CPU boards in it. Or test your rom in one of those. won't hurt anything just to see if it boots up.
You just have to start ruling things out.
good luck!

#8 1 year ago
Quoted from tjprice222:

As soon as I closed the coin door, the machine shut off like it was going to reset but no lights came on and the launch coil locked on and the planet and crane arm continued to run

As soon as you close the door, the high voltage is enabled. It sounds like you maybe have a short so I would check all the coils where a lug may be shorted to something else.

Rob

Promoted items from the Pinside Marketplace
$ 129.00
Lighting - Led
LED OCD
2,900
Sale Pending!
Lacey Township, NJ
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 47.00
$ 159.99
Lighting - Other
Lighted Pinball Mods
From: $ 369.95
Boards
PinSound
$ 9.99
Eproms
Matt's Basement Arcade
$ 8.50
Lighting - Led
Bright Lights Pinball
Wanted
Machine - Wanted
Killeen, TX
Trade
Machine - For Trade
Louisville, KY
$ 40.00
Lighting - Other
Rock Custom Pinball
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 19.95
Playfield - Toys/Add-ons
ULEKstore
$ 65.00
Cabinet - (Alt) Translites
Bright Lights Pinball
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 50.00
From: $ 29.00
Boards
KAHR.US Circuits
4,000 (Firm)
Machine - For Sale
Miami, FL
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 259.99
Lighting - Led
PinballBulbs
$ 25.00
Playfield - Plastics
Bright Lights Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside