(Topic ID: 279717)

HELP!! Game of Thrones LE flippers quit intermittantly during play

By Bluepilot

3 years ago



Topic Stats

You

Linked Games

#1 3 years ago

Although I've read past posts, I still haven't found a solution to a problem that arose a few weeks ago regarding flipper actuation on my GOT LE. --- The flippers will quit (sometimes one side, sometimes both sides {both upper and lower playfields}) while a multiball is in play. Usually and almost every time this happens is during multiball but sometimes (rarely) it will do it with just one ball in play. I've checked the flasher bulbs (555 LEDs) in the forward spotlights and replaced. I've flasher tested all the others with no problems seen. I've removed and reinstalled the 2 leads to the trough opto board as well.

And then, just last night, (not sure this is related, the speaker lights quit.

This game has an auxiliary power supply and the fuses look good. Can anything else be checked?

#2 3 years ago

Lift the playfield and check the connectors on the node board underneath. When my GOT pro flippers started behaving as you describe I found one of the connectors had worked it’s way nearly off of the prongs. Reseated it, never had that problem again.

Promoted items from the Pinside Marketplace
From: $ 6.00
7,999
Machine - For Sale
San Diego, CA

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from https://pinside.com/pinball/forum/topic/help-game-of-thrones-le-flippers-quit-intermittantly-during-play and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.