(Topic ID: 246421)

Help: Alltek MPU Over Voltage (Memory Lane)


By westofrome

1 year ago



Topic Stats

  • 9 posts
  • 5 Pinsiders participating
  • Latest reply 1 year ago by Quench
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

5B2FC392-FE23-49FE-A641-87C3C6F56EFF (resized).jpeg
pasted_image (resized).png

You're currently viewing posts by Pinsider westofrome.
Click here to go back to viewing the entire thread.

#1 1 year ago

I picked up a non-working Memory Lane and am trying to get it up and running, but have run into a road block.

I started at the rectifier board. All fuses are correct values and buzz continuity. Then I plugged in J2 and turned the game on, and tested all five test points for proper voltage - they all checked out properly.

Next I turned the game off, plugged in J1 and J3 to the rectifier board, and turned it back on. All I get are GI lights, and a solid red light on the original Stern MPU.

Then I take out the power driver board with the intent of recapping it and performing standard mods. While I have it out, I decide to put in a working Alltek driver board from another game, to see if that solves the issue, but I still get the solid red light on the MPU. The Alltek has green LEDS indicating the proper power, including the cyclone LEDs.

Then I tried putting in an Alltek MPU set to Memory Clear (was in another machine) which is when I get the Over Voltage light on the MPU. So it seems like the trouble is in the power the MPU is getting.

All connectors to the MPU appear to be seated properly and with keys that line up. As I'm reading the schematic, it looks like J4 provides the power from the driver board? I could repin but I figure if that was the issue it would only reduce voltage, not increase it?

I'd appreciate help with next steps in terms of troubleshooting. Thanks!

pasted_image (resized).png
#6 1 year ago

Thanks guys. I am only getting ~3VDC on the Altek MPU TP1 and TP4, so that is likely the source of the voltage differential. I was thrown by the "over voltage", thinking this must mean a specific voltage point was high, which didn't make sense in light of the new driver board and rectifier with proper test points.

In any case, I'm going to begin repinning. I know I should do it all, but to get things running I should begin with the MPU J4 and the driver board J3, correct?

#8 1 year ago

Driver board output tested ok. But the pins for the J4 MPU connector were only pushing out 3vdc when tested so I pulled them from the connector and one look told me they were the likely culprit. A nice shade of green.

Replaced J4 16 and 17 and it boots right up.

Gonna get to repinning everything but it’s nice to know where the issue is.

Thanks for the help guys.
5B2FC392-FE23-49FE-A641-87C3C6F56EFF (resized).jpeg

Promoted items from the Pinside Marketplace
From: $ 150.00
$ 149.00
From: $ 170.00
$ 6.00
Cabinet - Other
Siegecraft Electronics
From: $ 25.00
Boards
nvram.weebly.com
From: $ 45.00
Displays
PinballSolutions.eu
From: $ 12.00
From: $ 18.00
Apparel - Men
Pinside Shop
$ 149.95
Boards
Allteksystems
$ 119.95
Boards
Allteksystems
$ 63.29
Cabinet - Other
Pinball-Mods.com
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 400.00
Boards
Great American Pinball
$ 3.49
Playfield - Other
Pin Monk
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 159.00
Cabinet - Other
Pinball Pimp
$ 125.00
Cabinet - Toppers
Sparky Pinball

You're currently viewing posts by Pinsider westofrome.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside