(Topic ID: 158622)

Haunted House - Sys 80 ground mods - What have I done?

By wizzardz

3 years ago

Topic Stats

  • 13 posts
  • 4 Pinsiders participating
  • Latest reply 3 years ago by marmar
  • Topic is favorited by 2 Pinsiders


Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).


You're currently viewing posts by Pinsider wizzardz.
Click here to go back to viewing the entire thread.

#1 3 years ago

I picked up a nice Haunted House not long ago. It worked fine and is in nice shape, so I was hesitant to do anything with it. However, it needed a new power cord and didn't have any of the ground mods done. After each set of steps I tested the game to make sure all was working.

I started out replacing the power cord and adding a ground wire from the transformer base (where the power/filter ground is attached) to both the copper ground strap in the cabinet and to the metal base of the voltage regulator board in the head.

Next I ran a ground from the neg side of the voltage regulator cap to metal base after sanding the black from the contact areas.

Next I soldered a ground wire from the MPU cap to the voltage regulator base.


As with the voltage regulator board, I had to remove the MPU to do the solder work. I got the MPU ground wire in place and the board reinstalled. Once I powered up the game, the player 1 least significant digit was out. Thinking it was a connector problem I reseated the MPU connectors and fired up the machine again. Now I only get the below on the displays. Any ideas of where/what to check?


#3 3 years ago

After swapping my MGoW MPU (swapping ROMs) board and then replacing the original HH board, this is where it stands

What I do have:
Normal 5 sec delay on power-up
Attract lights are working.
Full displays are back (though player 1 & 3 least sig digit disappears sometimes)
Can start a game - though displays blink between 0 and high-score (don't recall if this is normal before plunge)

What I don't have:
That thunk at power on
regular cabinet relay click - i forget which lights this controls.
Sound - either attract or when starting a game
ball eject on starting a game
Ability to start multi-player
Active flippers after starting a game

The MGoW MPU gave me about the same results as when I put the original HH board back in so I'm thinking its probably not an MPU board issue.

#4 3 years ago
Quoted from ChrisHibler:

1. Are the attract mode lights working?
2. Does the display of "every other zero" alternate with HSTD?
3. When powering on, does the game still take normal 5 seconds then click the cabinet relays or do the displays immediately show the "every other zero"?

As of now:
1. Yes and did before recent improvements
2. no. Seemed to at first blink of one char (all segments lit), then only 0
3. Normal 5 sec startup. Minus the regular click of the cabinet/PF relay

#6 3 years ago

Thanks Chris. I'm leaning toward connectors as well...just not sure why so many problems occur at the same time. I suppose they could all be related to one.

I changed out the power driver just to make sure it wasn't anything there, but have the same results.

Do you know where the thunk originates (e.g., pwr thru MPU, direct only from MPU) and the connector on which the signal travels? MPU J6 looks good as do the others, but casual inspection might not be enough.

#8 3 years ago

Agreed the thunk itself isn't an issue, but it isn't happening anymore. The connector involved in that process is obviously a problem. Eventually all will have to be repinned, but if I can isolate the one or two connectors that might be the cause of my immediate problem it'll save time in getting it running again.

#10 3 years ago

Actually both boards resulted in the same results:

No thunk at power on
No regular cabinet relay click - i forget which lights this controls.
No Sound - either attract or when starting a game
No ball eject on starting a game
can't start multi-player
No active flippers after starting a game

It was the displays that improved during/after the swap, but that's it.

#12 3 years ago
Quoted from Drewscruis:

dumb question, but did you check the fuses?

^^^^^^^^^ give this guy a cigar.

No such thing as a dumb question, and the last thing you worked on is not always the cause of the problem.

Replaced an obviously toast 8a fuse and its up and running. Not sure why it'd fry. Normally I replace all the fuses on a new machine...but hadn't gotten around to it since it was an up and running machine. Looks like replacing the rest is the next step.

Promoted items from the Pinside Marketplace
€ 8.40
Machine - For Sale
Blaine, TN
$ 14.99
Machine - Wanted
Bristol, TN
Machine - For Trade
Sturgeon Bay, WI
$ 1,099.00
Flipper Parts
Machine - Wanted
Brownsburg, IN
$ 50.00
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 229.99
Lighting - Other
Lighted Pinball Mods
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 50.00
$ 42.00
Playfield - Toys/Add-ons
The MOD Couple

You're currently viewing posts by Pinsider wizzardz.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside