(Topic ID: 39477)

Haunted House Help Please

By mkemp

8 years ago



Topic Stats

  • 4 posts
  • 3 Pinsiders participating
  • Latest reply 8 years ago by Jesterfunhouse
  • No one calls this topic a favorite

You

Linked Games

#1 8 years ago

Various inserts lamp are flickering and a relay under main playfield is continuously opening and closing. Everything else works fine. Thanks in advance

#2 8 years ago

Mostly lightly its a bit of corrosion on one of your connectors in the backboard.

Common issue with Gottlieb System 80's. I'd open the head, re-seat all cable connectors first. Once you get that done, make a big cup of coffee and read;

http://www.pinwiki.com/wiki/index.php?title=Gottlieb_System_80

#3 8 years ago

And before you go too crazy,,, when you say relay opening and closing, is it random or about every 3-4 seconds? If its cyclic, that is normal for that game. What it does when idle is turn the general illumination off and on cycling between lower and main playfield.

The flickering on the lamps is not normal. If its all GI doing it, reset the connectors, if its one or two, wiggle the bulbs.

1 week later
#4 8 years ago

I agree with PATOFNAUD. I just had a similar issue with my Haunted House where it would cut power to the displays in the middle of the game and the Relays would turn on and off every couple of minutes resetting the game. I took off all the connectors to the driver board. Cleaned the contacts and reattached the connectors and did not have any problems after that with this issue.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside