Haunted House Club: The Beautiful Beast

(Topic ID: 143518)

Haunted House Club: The Beautiful Beast


By davebart5

3 years ago



Topic Stats

  • 629 posts
  • 105 Pinsiders participating
  • Latest reply 3 days ago by Bam_Man
  • Topic is favorited by 52 Pinsiders

You

Linked Games

Topic Gallery

There have been 244 images uploaded to this topic. (View topic image gallery).

20181205_185024 (resized).jpg
20181124_140731 (resized).jpg
20181124_134507 (resized).jpg
20181124_140259 (resized).jpg
20181124_134411 (resized).jpg
20181124_134503 (resized).jpg
20181124_134454 (resized).jpg
20181124_134500 (resized).jpg
20181124_134507 (resized).jpg
01EC666F-A8C9-4C35-9011-D04214968E07 (resized).jpeg
6DF1342E-EC03-476B-9593-91D2218083DE (resized).jpeg
83ED2612-4E01-4D69-A34A-1D67653B360F (resized).jpeg
20181014_162835 (resized).jpg
C9677133-A93C-40BE-92F3-435ABDF747C6 (resized).jpeg
20171006_174438 (resized).jpg
spiderweb (resized).png

There are 629 posts in this topic. You are on page 13 of 13.
#601 25 days ago

Gottlieb: It's Not Just A Job, It's An Adventure.

#602 25 days ago

Congrats. Also, check if the big capacitors in the bottom are orange and/or light blue. If so they should be changed out.

#603 25 days ago
Quoted from Zablon:

Congrats. Also, check if the big capacitors in the bottom are orange and/or light blue. If so they should be changed out.

Looks like they are originals. I set it up tonight and got a better look inside. MPU is original, its the driver board that had been replaced. Definetly needs some connector attention. I tugged on a couple suspect wires and they came right out of the housing. Not exactly shiny either so i think its the best place to start.

Found an unnecessary credit button added to the front - rather than the jumper on the diode board. But somthing was done to the power switch wiring which i havent looked into yet. Baby steps lol

83ED2612-4E01-4D69-A34A-1D67653B360F (resized).jpeg6DF1342E-EC03-476B-9593-91D2218083DE (resized).jpeg01EC666F-A8C9-4C35-9011-D04214968E07 (resized).jpeg
#604 23 days ago

Pulled the mpu and used a pink pencil eraser on the edge connectors and voila. Game is alive and plays. Lots of small issues to correct like some switches not scoring and an upkicker thats not upkicking.

Are there replacement edge connector housings that people use? And are there molex equivalents that use crimp contacts or are they just IDC’s?

#605 19 days ago

If you have an original coin box for your Haunted House can you post a picture of it? I've looked at a ton of Haunted House pictures online but none seem to show the coin box. I'd eventually like to find one for mine and would like to get the correct one. Dimensions would help.

Thank you

#606 15 days ago

I am currently working on my haunted house and I am not sure what to do next. Just finished up ground mods and wanted to make sure jumping them all to this ground terminal block is ok. When I power it up all I'm getting is the displays alternating from 000,000 to 770,000 and nothing else. The first time I powered it up after getting it the lower playfield up kick coil burnt up and I haven't replaced it yet. Just not %100 sure what to look at next. Any help would be great.

20181124_140259 (resized).jpg20181124_134500 (resized).jpg20181124_134503 (resized).jpg20181124_134507 (resized).jpg20181124_134411 (resized).jpg20181124_134454 (resized).jpg20181124_134507 (resized).jpg
#607 15 days ago
Quoted from Robotworkshop:

If you have an original coin box for your Haunted House can you post a picture of it? I've looked at a ton of Haunted House pictures online but none seem to show the coin box. I'd eventually like to find one for mine and would like to get the correct one. Dimensions would help.
Thank you

20181124_140731 (resized).jpg
#608 15 days ago
Quoted from Bam_Man:

I am currently working on my haunted house and I am not sure what to do next. Just finished up ground mods and wanted to make sure jumping them all to this ground terminal block is ok. When I power it up all I'm getting is the displays alternating from 000,000 to 770,000 and nothing else. The first time I powered it up after getting it the lower playfield up kick coil burnt up and I haven't replaced it yet. Just not %100 sure what to look at next. Any help would be great.
[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

Alternating sounds normal operation, no?

#609 15 days ago

770,000 to 000,000 is normal until you get higher than 770,000. When you say 'nothing else' do you mean if you have credits and hit start nothing happens?

If you have a coil burnt/stuck it may not do anything until you remove it/replace it.

#610 15 days ago
Quoted from shacklersrevenge:

Alternating sounds normal operation, no?

No sound

#611 15 days ago

Yea i can credit it up but nothing happens after. I will replace the coil (just waiting on part) and we will see what happens.

#612 15 days ago
Quoted from Zablon:

770,000 to 000,000 is normal until you get higher than 770,000. When you say 'nothing else' do you mean if you have credits and hit start nothing happens?
If you have a coil burnt/stuck it may not do anything until you remove it/replace it.

Yea i can credit it up but nothing happens after. I will replace the coil (just waiting on part) and we will see what happens.

#613 15 days ago
Quoted from shacklersrevenge:

Alternating sounds normal operation, no?

Ahh this is my first encounter with HH so if that's normal its news to me haha. I can credit it up but nothing happens when I hit start.

#614 15 days ago

There are 3 relays way at the back right of the main playfield. They control the game basically. If these got bumped or stuck the game won't do anything. Do you get a big 'thunk' when you turn it on? Do any of the solenoids/switches work? Do the basement lights go on and off every 10-15 seconds? (They should under normal attraction mode). There is also music that will go every 20-30 seconds or so...but that might be a setting.

#615 15 days ago
Quoted from Zablon:

There are 3 relays way at the back right of the main playfield. They control the game basically. If these got bumped or stuck the game won't do anything. Do you get a big 'thunk' when you turn it on? Do any of the solenoids/switches work? Do the basement lights go on and off every 10-15 seconds? (They should under normal attraction mode). There is also music that will go every 20-30 seconds or so...but that might be a setting.

No thunk, no solenoids/switches, no basement lights no music. I'll check relays

#616 15 days ago
Quoted from Bam_Man:

No thunk, no solenoids/switches, no basement lights no music. I'll check relays

Just throwing out things, but since you recently had them out, recheck your cables on the boards, and make sure you didn't accidentally pop the roms out.

#617 15 days ago
Quoted from Bam_Man:

I am currently working on my haunted house and I am not sure what to do next. Just finished up ground mods and wanted to make sure jumping them all to this ground terminal block is ok. When I power it up all I'm getting is the displays alternating from 000,000 to 770,000 and nothing else. The first time I powered it up after getting it the lower playfield up kick coil burnt up and I haven't replaced it yet. Just not %100 sure what to look at next. Any help would be great.
[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

I’d be cutting that battery off of there if I was you.

#618 15 days ago
Quoted from radium:

I’d be cutting that battery off of there if I was you.

Will do

#619 13 days ago

I remember when I got my first Gottlieb machine. In 1975. Loved Gottliebs ever since. Never a dull moment with the System 80/80A/80B era.

#620 8 days ago

I just had a lamp go out under one of the inserts under the small attic playfield. Is there an easy way to get to them or do you have to remove and lift off that upper attic playfield to get to them? I've never had to remove that yet. Is there anything to watch out for or any tricks to make it easier and safer to remove?

#622 8 days ago
Quoted from Robotworkshop:

I just had a lamp go out under one of the inserts under the small attic playfield. Is there an easy way to get to them or do you have to remove and lift off that upper attic playfield to get to them? I've never had to remove that yet. Is there anything to watch out for or any tricks to make it easier and safer to remove?

You do but it is easy.

On the front left and right sides of the metal frame you will see a divots in the metal, and there is a screw on each side. This holds the upper pf in place. You just have to loosen those (not take them all the way out). To get to the right one you will need to prop the main pf up a bit so it clears the cabinet.

You also have to unscrew the bottom of the metal ramp that is attached to the main pf. Then it should just swivel up. Note that there are some short cables attaching it in the back of it - so you won't be able to completely lift it all the way up unless you disconnect those. In the back of the pf there are slots where the whole piece slides into as well.

#623 6 days ago
Quoted from Bam_Man:

I am currently working on my haunted house and I am not sure what to do next. Just finished up ground mods and wanted to make sure jumping them all to this ground terminal block is ok. When I power it up all I'm getting is the displays alternating from 000,000 to 770,000 and nothing else. The first time I powered it up after getting it the lower playfield up kick coil burnt up and I haven't replaced it yet. Just not %100 sure what to look at next. Any help would be great.
[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

So I replaced the lower up kick coil, and found a blown fuse (F 14) on the underside of the playfield and still not getting anything. Same symptoms no thunk, no sounds, no basement lights, no solenoids/switches. My displays all work and gi and insert lights are working. I can credit it up but nothing happens when I hit the start button.

#624 5 days ago
Quoted from Bam_Man:

So I replaced the lower up kick coil, and found a blown fuse (F 14) on the underside of the playfield and still not getting anything. Same symptoms no thunk, no sounds, no basement lights, no solenoids/switches. My displays all work and gi and insert lights are working. I can credit it up but nothing happens when I hit the start button.

Turns out F4 was blown as well! Got a thunk and it's up and running. Now I just have to figure out why the lower and upper pop bumpers aren't working and the lower pf up kicker still isn't firing consistently. Basement lights (pointing down from main pf) don't turn on either. There's always something!

#625 5 days ago
Quoted from Bam_Man:

Turns out F4 was blown as well! Got a thunk and it's up and running. Now I just have to figure out why the lower and upper pop bumpers aren't working and the lower pf up kicker still isn't firing consistently. Basement lights (pointing down from main pf) don't turn on either. There's always something!

On these games, the pop bumpers each have a small, usually white-ish, board underneath. Find one of the boards associated with one of the working pop bumpers. Then with the power off, take the board from the working pop bumper and plug it in where one of the non working pop bumper's board. Fire er up and see if the one that wasn't working is working now. If it is, then you know that its something on that board. Most people just replace those with new ones because they aren't that expensive but you can definitely fix the old ones. The basement lights are a very special bulb even though they look like all the rest. Its entirely possible that they are all burnt out, take them out and double check by looking at the filament. They are #313 bulbs.

#626 4 days ago
Quoted from Ronnie1114:

On these games, the pop bumpers each have a small, usually white-ish, board underneath. Find one of the boards associated with one of the working pop bumpers. Then with the power off, take the board from the working pop bumper and plug it in where one of the non working pop bumper's board. Fire er up and see if the one that wasn't working is working now. If it is, then you know that its something on that board. Most people just replace those with new ones because they aren't that expensive but you can definitely fix the old ones. The basement lights are a very special bulb even though they look like all the rest. Its entirely possible that they are all burnt out, take them out and double check by looking at the filament. They are #313 bulbs.

Thank you! I'll try that out tomorrow. Didn't know that about the basement bulbs either.

#627 4 days ago

The basement lights are not 5v or 12v they are 24v I think (i can look them up to validate, for some reason 23v comes to mind but that can't be right). It is possible someone put 47's in and they blew them.

#628 4 days ago

How does this K gate relay system work? I can't get the lower pf up kick to work, the #31 switch (up kick switch) is reading in switch test and I can manually get it to fire if I press the relay switch together but nothing happens in normal play.

20181205_185024 (resized).jpg

#629 3 days ago
Quoted from Bam_Man:

How does this K gate relay system work? I can't get the lower pf up kick to work, the #31 switch (up kick switch) is reading in switch test and I can manually get it to fire if I press the relay switch together but nothing happens in normal play.
[quoted image]

It seems like the switch needed to be set on the other side of the relay. Working now

Promoted items from the Pinside Marketplace
From: $ 15.95
€ 55.00
$ 329.00
€ 8.40
€ 50.00
Boards
FLIPPROJETS
2,300 (OBO)
Machine - For Sale
Melrose, FL
$ 1,099.00
Flipper Parts
Mircoplayfields
750 (Firm)
Sale Pending!
Shandon, CA
€ 15.00
Boards
FLIPPROJETS
$ 22.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
$ 125.00
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 9.99
Eproms
Matt's Basement Arcade
$ 110.00
Lighting - Under Cabinet
Rock Custom Pinball
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
From: $ 11.95
Playfield - Toys/Add-ons
ULEKstore
There are 629 posts in this topic. You are on page 13 of 13.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside