(Topic ID: 287461)

Harlem Globetrotters MPU issue

By Woodingfleece

1 year ago



Topic Stats

  • 9 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by Woodingfleece
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 1 year ago

This is my very first table and it was working great for the first week but all of a sudden the game stopped working.
I notice on the MPU the green LED flashes Once and then stops and all the lights come on but the game wont complete its boot up sequence.
I have ordered new fuses to swap those out to see if that helps.

Any one out there have any advice?

Thank you in advance

#2 1 year ago

You’re in the right place, and that’s a great machine. Welcome!

Could you post a picture of the mpu? Does it have the original battery on it?

Perhaps, with the machine off, you could disconnect and carefully re-seat the connectors.

#3 1 year ago

It does not have the original battery
The person I bought it from installed a vRam chip I believe is what he called it

I did carefully do that with all the connectors and still no luck

I also looked under the play field to see if anything was burnt out. I do not see any burn outs on any boards or any solenoids underneath

#4 1 year ago

>>I did carefully do that with all the connectors and still no luck

Original MPU? Maybe try disconnecting the Top Left Connector (J1?) and then powering up. Any difference? I can sometimes get an MPU to fire up that way after a ghost reset I am chasing.

Another spot you might want to check for shorts that can cause an MPU reset are the light leads for your pop bumbers. Have had more than a few where the staple works out and the lead flops around and shorts...long shot. But I have had it happen on a Skateball, Paragon and Flash Gordon.

#5 1 year ago

If you do not have any corrosion related issues on the board, then probably your 6810 Ram at U7 is bad. You could try to reseat it. If that doesn't help, then replace it.

#6 1 year ago

Power it up while J1 is disconnected?

#7 1 year ago

I read that about the U7 somewhere else
Is it easy to take that Ram off of U7?

I have never done this before?

#8 1 year ago
Quoted from Woodingfleece:

Is it easy to take that Ram off of U7?

You can carefully pry it out of the socket with a small screwdriver. Pry it out evenly to avoid bending the pins on the chip. Replace it carefully as well, to avoid bending the pins when you push it into the socket. Also, there is a notch at one end of the chip. Should also be a corresponding notch on the socket or circuit board so to orient the chip correctly.

#9 1 year ago

Ok I will try that as well

Forgot to mention that when it happened exactly

It happened like this

Turned on the machine, it booted up properly
Was able to put in 3players to play the game
I started to explain the games rules to my friends when I was done is when it died out on me. With the scores blank and then I tried turning off and on and it turned on but only had the 1 blink on the green led from this point on

Idk if this info will help anyone pinpoint things easier

Thank you all so much for your advice

Promoted items from the Pinside Marketplace
$ 119.95
Boards
Allteksystems
From: $ 10.00
Cabinet Parts
Wire-Bot
1,700 (OBO)
Sale Pending! Machine - For Sale
Tulsa, OK
6,000 (Firm)
Machine - For Sale
Santa Ana, CA
$ 18.95
Eproms
Pinballrom
$ 9.00
Cabinet Parts
Third Coast Pinball
From: $ 170.00
From: $ 150.00
From: $ 18.00
Apparel - Men
Pinside Shop
Wanted
Machine - Wanted
Greenfield, WI

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!