(Topic ID: 279715)

Guns n Roses troubleshooting

By thePLAyNone

1 year ago


Topic Heartbeat

Topic Stats

  • 226 posts
  • 70 Pinsiders participating
  • Latest reply 10 hours ago by Pinballomatic
  • Topic is favorited by 64 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

1D8F6AE8-06A3-4B47-95B6-C478535C7840 (resized).jpeg
A82EC7A2-F075-428D-995D-C306B187CD1F (resized).jpeg
8CA5B9A9-2F73-4938-95DD-844176F21BFA (resized).png
PXL_20211011_004031927 (resized).jpg
PXL_20211011_004049007 (resized).jpg
PXL_20211011_004144480~2 (resized).jpg
PXL_20211011_004038987~2 (resized).jpg
PXL_20211017_184817382 (resized).jpg
35D0BEBC-B735-4B1E-87A4-B4ED5D6811B0 (resized).jpeg
1C98F149-BC45-475D-92AD-CCEE9D57E741 (resized).jpeg
coindoor (resized).JPG
Unknown screw (resized).jpg
20211001_174111 (resized).jpg
34B98ABC-73E0-4244-9248-E1B37551AA69 (resized).jpeg
loose screws (resized).jpg
8D07B1AB-2F25-4B87-84FF-7617E098F2D3 (resized).jpeg

There are 226 posts in this topic. You are on page 1 of 5.
#1 1 year ago

Please post problems and solutions here for Guns n Roses. Had a few switches to adjust and the upper flipper....now our main concern is the spinning record keeps falling apart. Any one else experiencing this or have solutions?

#2 1 year ago
Quoted from thePLAyNone:

Please post problems and solutions here for Guns n Roses. Had a few switches to adjust and the upper flipper....now our main concern is the spinning record keeps falling apart. Any one else experiencing this or have solutions?

My LE has had a number of relatively minor issues to address. I love the game!

- Upper playfield rightside guide rail will cut in to the upper flipper rubber over a short amount of time(2 days in my case). I've noticed at least one other LE owner with the problem. It will cut a groove into the rubber and then cause it to stick and get hung up on the rail. The easy fix is to bend the end of the rail out slightly to prevent it from contacting the rubber. Also check alignment of the flipper to the hole below it. May need adjustment.

- seems like common record disc issues that are simple to fix. I'm hearing lock tight and an easy adjustment of the nut to raise/lower the disc to proper flush with the playfield

- This may not be a problem on later machines on the assembly line from mine, but lots of stuff not screwed in under the playfield properly. check underneath the playfield and maybe tighten/use lock tight where necessary. Last night while playing the game the coil, coil stop, coil sleeve, and screws for the lower right flipper completely fell into the bottom of the cabinet, lol. Seems easy to fix.

- Be careful when lowering the playfield back in to the cabinet bc it's easy to slice the rubber tip of your shooter rod right off. Happened to from the factory. It came unboxed with a sliced shooter rod tip.

- There are multiple hangups throughout the playfield that need a little slight bending of rails, etc. On mine the ball gets stuck a lot on the right orbit underneath that metal piece of the right drumstick ramp underneath the P.A. speakers that say "not in this lifetime". There's also a spot on the right pop bumper(the ride cymbal bumper) where the ball can rest and get stuck between the buyer plastic and a post. Not sure of how to solve that one but it's not something that happens too often.

- Pretty sure the preamp for my headphone 3.5mm jack is blown. No volume and distorted. I'll get it fixed eventually. I don't use the headphones too often.

The game is so great and I'm pretty chill about these issues as it's early in the release and I have one of the first batch of LE's. A slight bummer but all fixable. What can you do, it's pinball.

#3 1 year ago
Quoted from thePLAyNone:

.now our main concern is the spinning record keeps falling apart. Any one else experiencing this or have solutions?

Put screw back in with blue Locktite. Be sure you have the washer too before inserting the screw.

Won't effect most games. Not a major issue.

LTG : )

#4 1 year ago
Quoted from BeeGee6533:

- Pretty sure the preamp for my headphone 3.5mm jack is blown. No volume and distorted. I'll get it fixed eventually. I don't use the headphones too often.

If it's anything like previous games ( I don't have a GNR to check ) see if the connector to the small board right inside the cabinet where the headphone would plug in. It might be on backwards. If it fits, unplug it and turn 180 degrees and plug back in and try. Be sure connector in the backbox is on the board tight.

LTG : )

#5 1 year ago

Is the washer the bronze piece? I seem to have up and down play with the record now and some wobble to it, I will check the cabinet for any missing pieces.

#6 1 year ago
Quoted from thePLAyNone:

Is the washer the bronze piece?

You can see the parts in this picture.

LTG : )

G&Rspiningtable (resized).jpg
#7 1 year ago

Thanks Lloyd, looks like just the disc, the screw, and the bronze piece.

#8 1 year ago

Okay, found it , there is a top collar also. So a bronze piece on the bottom and the top! Now where's my loctite!

#9 1 year ago
Quoted from LTG:

If it's anything like previous games ( I don't have a GNR to check ) see if the connector to the small board right inside the cabinet where the headphone would plug in. It might be on backwards. If it fits, unplug it and turn 180 degrees and plug back in and try. Be sure connector in the backbox is on the board tight.
LTG : )

Thx for the tip, Lloyd! I'll check it out and give it a try.

#10 1 year ago

My record kept falling off as well after about an hour of play, it doesn't seem like you can tighten it completely because the nut under the sticker seems to be spinning. I reattached with lock-tight (blue) and it hasn't fallen off in the last hour anyway.

Does anybody know where this grommet goes? I was lowering the playfield by the apron and all the sudden it was stuck to my shirt.

Grommet (resized).jpg
#11 1 year ago
Quoted from Xier:

My record kept falling off as well after about an hour of play, it doesn't seem like you can tighten it completely because the nut under the sticker seems to be spinning. I reattached with lock-tight (blue) and it hasn't fallen off in the last hour anyway.
Does anybody know where this grommet goes? I was lowering the playfield by the apron and all the sudden it was stuck to my shirt.
[quoted image]

I found one of those loose rolling around the playfield during one of my first games. I kept it but have no idea where it goes.

#12 1 year ago
Quoted from BeeGee6533:

I found one of those loose rolling around the playfield during one of my first games. I kept it but have no idea where it goes.

Looks like the grommet from the apron to protect the glass...

#13 1 year ago
Quoted from fastchef:

Looks like the grommet from the apron to protect the glass...

That was it, thanks!

grommet2 (resized).jpg
1 month later
#14 10 months ago

I got a report of a bad switch (#47, left ramp made). What am I supposed to do about that? I am not sure what the fix is . . . Any help would be appreciated. Thanks!

#15 10 months ago
Quoted from lpgnr:

I got a report of a bad switch (#47, left ramp made). What am I supposed to do about that? I am not sure what the fix is . . . Any help would be appreciated. Thanks!

Tests - switch tests - matrix switch tests then roll a ball through or check the switch by hand and see if it works

#16 10 months ago
Quoted from Pinballomatic:

Tests - switch tests - matrix switch tests then roll a ball through or check the switch by hand and see if it works

Thank you very much! I’m sorry for asking such novice questions. This is my first machine of this caliber. That worked!

#17 10 months ago
Quoted from lpgnr:

Thank you very much! I’m sorry for asking such novice questions. This is my first machine of this caliber. That worked!

machine will flag a switch red even if it just hasn't seen it in awhile.

#19 10 months ago
Thetestreport1of2 (resized).pngthetestreport2of2 (resized).png
#20 10 months ago

That is good to know. Thanks!

#21 10 months ago
Quoted from LTG:

You can see the parts in this picture.
LTG : )
[quoted image]

Is it normal to have some back/forth play on the record after all tightened? I am level and tight with the playfield, but notice the record has some up/down movement on the edge, sometimes catching the ball at the post.

#22 10 months ago
Quoted from Pinballomatic:

machine will flag a switch red even if it just hasn't seen it in awhile.

This switch came back up in a test report (#47). It seems that the diverter on the left ramp that blocks the ball from the upper play field which sends it back down the catwalk ramp is always down. Does anyone else have this problem?

#23 10 months ago

On the first day of owning the machine, the ball got stuck. During the ball-check, I heard something medal fall inside the machine itself. After opening it up, I found this piece of metal and these 3 screws. I looked around for something obvious, but couldn't find anything. Machine seems to play fine, but I'd like to know where this stuff fell from.

GnR (resized).png
#24 10 months ago
Quoted from legionsoup:

On the first day of owning the machine, the ball got stuck. During the ball-check, I heard something medal fall inside the machine itself. After opening it up, I found this piece of metal and these 3 screws. I looked around for something obvious, but couldn't find anything. Machine seems to play fine, but I'd like to know where this stuff fell from.
[quoted image]

Left ramp diverter on the front of the assembly

#25 10 months ago

Yes! The same thing happened to me with the same parts!

#26 10 months ago

Hopefully an easy fix. My ball gets stuck in the shooter lane, just to the side of the auto plunge. During multiball, a couple of balls will pile up in that shooter lane.

9975946C-1D2F-47EB-816C-F67776412F56 (resized).jpeg
#27 10 months ago

Slightly bend the wire switch arm lower and center it. Also make sure your game is properly leveled side to side And pitched correctly. Simply fix.

#28 10 months ago
Quoted from Yelobird:

Slightly bend the wire switch arm lower and center it. Also make sure your game is properly leveled side to side And pitched correctly. Simply fix.

Thx my friend. It was the shooter lane switch which was sitting up too high. Bent it down a little and I am in business. Thx!!

1 week later
#29 10 months ago

Hi I had it working on my le but that’s about the only thing that works this pin is a pc of shit junk junk junk broken flipper spring broken flipper button they sent wrong plug back box goes on and off when playing game resets in middle of play leg levelers were in coin box you put the legs on before you get to coin box if ball goes straight down the middle game does not register so you must turn off and back on 10000 with shipping this is junk I got 5 sterns to Chicago gaming one 1979 Bally and no issues ever

46BBD3CF-AF8E-42A0-916F-D943A08720E1 (resized).pngBD90AF84-E841-464A-A5F1-AC95146ECA84 (resized).jpegD1BEFEDA-3884-4C96-B2F7-D2B9C74B7937 (resized).jpeg
#30 10 months ago

Oh and skill shot just stopped working JUNK JUNK JUNK

#31 10 months ago
Quoted from klum11:

Oh and skill shot just stopped working JUNK JUNK JUNK

Keys on door for BB. And what’s wrong with skill shot. Looks like you had a few minor issues though “Shit” is not what I would call these minor things personally. Temporarily any pc plug will work to play the game till they get a replacement.

#32 10 months ago

Now this is broken too

F7A693EC-6BC7-48EA-A145-91D86C80DE5A (resized).jpeg
#33 10 months ago

No keys on door yes any pc plug will work do you speed 9500 to supply your own cord

#34 10 months ago
Quoted from klum11:

Now this is broken too
[quoted image]

Not sure what the error is on that picture but to guess if the ball isn’t releasing you need to calibrate the sensors via software.

#35 10 months ago
Quoted from klum11:

No keys on door yes any pc plug will work do you speed 9500 to supply your own cord

No you shouldn’t have to but it’s a simple mistake. Just wanted to help you Try to enjoy your game.

#36 10 months ago

Send me your info and I'll get you a USA cord and a flipper return spring and whatever else you might need.

1 week later
#37 9 months ago

Hi pinballomatic well I have a case number with Ken h at jjp he said he would ship out the parts they used the usps and sent on December 29 still nothing tracking info shows nothing after January 2 another weekend of great football on January 9/10 and all the guys will be over and will be playing the sterns and Chicago gaming pins not the fancy new gnr that was ten k to get it shipped to me just bought a hot wheels to see how American pinball machine does against jjp quality it’s on order so don’t have yet

#38 9 months ago
Quoted from klum11:

Hi pinballomatic well I have a case number with Ken h at jjp he said he would ship out the parts they used the usps and sent on December 29 still nothing tracking info shows nothing after January 2 another weekend of great football on January 9/10 and all the guys will be over and will be playing the sterns and Chicago gaming pins not the fancy new gnr that was ten k to get it shipped to me just bought a hot wheels to see how American pinball machine does against jjp quality it’s on order so don’t have yet

Hi - I think I follow you. USPS is having big time problems at the moment. If your order is delayed by them it would hardly be JJP's fault. But I'll check in with Ken on this anyway.

#39 9 months ago

So, this guy is doing very little to help himself, but JJP should not be using USPS. USPS is a disaster everywhere.

Send parts UPS or fedex.

Quoted from Pinballomatic:

If your order is delayed by them it would hardly be JJP's fault.

#40 9 months ago
Quoted from klum11:

Hi pinballomatic well I have a case number with Ken h at jjp he said he would ship out the parts they used the usps and sent on December 29 still nothing tracking info shows nothing after January 2 another weekend of great football on January 9/10 and all the guys will be over and will be playing the sterns and Chicago gaming pins not the fancy new gnr that was ten k to get it shipped to me just bought a hot wheels to see how American pinball machine does against jjp quality it’s on order so don’t have yet

A Christmas gift for my sister went out Dec 14 she got it this week your parts will get there it just may not be as fast as you like

#41 9 months ago

I had a question about how the playfield is supposed to rest in the steel channel. I've attached a few pictures here.

My first question is, which rubber feet am I supposed to be using to rest the playfield? There are three sets... two with metal around it, and one without.

But regardless of which one I am supposed to be using, the rubber feet don't rest on the flat part of the steel channel. This is because the notches in the channel don't line up with the metal bars that you pull. Are the notches supposed to line up? Right now, no matter how I place the playfield down, it's metal on metal.

IMG_0488 (resized).jpgIMG_0489 (resized).jpgIMG_0490 (resized).jpg
#42 9 months ago
Quoted from reflex33:

I had a question about how the playfield is supposed to rest in the steel channel. I've attached a few pictures here.
My first question is, which rubber feet am I supposed to be using to rest the playfield? There are three sets... two with metal around it, and one without.
But regardless of which one I am supposed to be using, the rubber feet don't rest on the flat part of the steel channel. This is because the notches in the channel don't line up with the metal bars that you pull. Are the notches supposed to line up? Right now, no matter how I place the playfield down, it's metal on metal.
[quoted image][quoted image][quoted image]

It doesn't matter. Use the pair that fits your service need at the time. They are primarily there to keep the playfield from sliding back into the cabinet.

#43 9 months ago

Anyone have any insights on connecting to Wifi? I logged a ticket with JJP, very responsive but still unresolved. Ken in support was great to work with. It sees my network, USB dongle was plugged into appropriate spot. Can't connect and password is correct. Agreed to the terms etc. Have tried about 30 times to connect but it won't. Signal strength not an issue either. Not a huge deal as I can always update via USB but just wondering if something is disconnected somewhere? Network tries to connect and then disconnects. Reseated dongle as well.

#44 9 months ago
Quoted from Bmanpin:

Anyone have any insights on connecting to Wifi? I logged a ticket with JJP, very responsive but still unresolved. Ken in support was great to work with. It sees my network, USB dongle was plugged into appropriate spot. Can't connect and password is correct. Agreed to the terms etc. Have tried about 30 times to connect but it won't. Signal strength not an issue either. Not a huge deal as I can always update via USB but just wondering if something is disconnected somewhere? Network tries to connect and then disconnects. Reseated dongle as well.

We had a very similar issue with ours (early release). May not be the same but they had us reset our router 1-2 times then oddly it just started working. Not sure if the Ghtz speed matters.

Call #LTG he is a computer mastermind!! lol

#45 9 months ago
Quoted from Yelobird:

Call #LTG he is a computer mastermind!!

I wouldn't say that.

Only thing I've seen so far is getting password right. Numbers, lower case letters, capitals. Then reboot router.

LTG : )

#46 9 months ago
Quoted from LTG:

I wouldn't say that.
Only thing I've seen so far is getting password right. Numbers, lower case letters, capitals. Then reboot router.
LTG : )

You have a New job title. JJP, IT support networks specialist! I am working on your shirt now! lol

Or JJP IT Support Specialist. JISS Networker for short lolol.

#47 9 months ago
Quoted from Yelobird:

You have a New job title.

Actually I do. Jersey Jack Pinball Ambassador.

LTG : )

#48 9 months ago
Quoted from Bmanpin:

Anyone have any insights on connecting to Wifi? I logged a ticket with JJP, very responsive but still unresolved. Ken in support was great to work with. It sees my network, USB dongle was plugged into appropriate spot. Can't connect and password is correct. Agreed to the terms etc. Have tried about 30 times to connect but it won't. Signal strength not an issue either. Not a huge deal as I can always update via USB but just wondering if something is disconnected somewhere? Network tries to connect and then disconnects. Reseated dongle as well.

Make sure your SSID and password has no funky characters and that the router is close to the machine. I use WPA2 and the access point is in the same room. It works great. Also try moving the USB WiFi dongle to another port.

#49 9 months ago

can you connect a GnR via ethernet cable or is it only WiFi?

#50 9 months ago
Quoted from fnosm:

can you connect a GnR via ethernet cable or is it only WiFi?

WiFi or ethernet

LTG : )

There are 226 posts in this topic. You are on page 1 of 5.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside