(Topic ID: 201799)

Guardians of the Galaxy owner's thread


By Blacksun

1 year ago



Topic Stats

  • 4,178 posts
  • 404 Pinsiders participating
  • Latest reply 14 hours ago by Green-Machine
  • Topic is favorited by 152 Pinsiders

You

Topic Gallery

There have been 959 images uploaded to this topic. (View topic image gallery).

AA3006F7-6DED-401E-817B-7C44E25AFE53 (resized).jpeg
76AB6888-DB54-42A4-8935-5ADD9A30CA40 (resized).jpeg
Screenshot_20190911-081957_Chrome (resized).jpg
B217B177-C291-4333-9E4B-3D81C13C24B3 (resized).jpeg
2304FEA8-BE8E-4F03-A583-7A1CBCDFFFB3 (resized).jpeg
79948E97-2DA9-4502-8C57-899B01BC3B82 (resized).jpeg
B2624B95-916A-4FBC-B935-57E4A2F08CA6 (resized).jpeg
43C14BD0-327E-452E-8022-22BC5B7A318D (resized).jpeg
F449AB78-A9E4-48EF-8283-397A980EF7F9 (resized).jpeg
Guardians-of-the-Galaxy-PRO-playfield-detail1 (resized).jpg
IMG_20190908_080553 (resized).jpg
IMG_20190908_075841 (resized).jpg
D64F76F0-2817-4E2F-B55C-817AFD18D463 (resized).jpeg
1CE63F52-4F4F-43C7-95C7-ED4BDBE6CF43 (resized).jpeg
4D9A698A-4BE6-4769-BE01-E941A7E4F95E (resized).jpeg
90EB0523-396B-4FA7-AB26-749903A2D81E (resized).jpeg

Topic index (key posts)

2 key posts have been marked in this topic (Show topic index)

There are 4178 posts in this topic. You are on page 84 of 84.
#4151 12 days ago
Quoted from PeterG:

Isn't that just Convolux in europe? Led4pin has these in the netherlands and Freddy in Germany.

Convolux is only in 1 color per set. I want 4 different colors for mine. (And yeah, I can hear the haters barfing up a colored rainbow and unicorn right now).

#4152 12 days ago

it is your machine....do what you want with it. It is always reversable.

#4153 12 days ago

Freddys convolux did have the exact same size then the plastics. The ulek ones are a little bit larger. In my opinion the wow effect is better with them.

#4154 11 days ago
Quoted from sirlonzelot:

Freddys convolux did have the exact same size then the plastics. The ulek ones are a little bit larger. In my opinion the wow effect is better with them.

You're from Germany, where can i find those Ulek's?

#4156 7 days ago

Hey guys, need some maintenance help on my Pro. So my left orb enclosure post screw flew off during a game last night Didn't realize it until a metal bracket appeared next to the drop target. In pics on the web, I can't see where the metal bracket goes, and don't really see the plastic piece attached to the right post either. I found the screw under the playfield in the cabinet. Question is, how does this thing go back together, and where does this metal bracket go? The picture with the orb is from the internet, the other 2 are mine. Thanks.
Guardians-of-the-Galaxy-PRO-playfield-detail1 (resized).jpgIMG_20190908_075841 (resized).jpgIMG_20190908_080553 (resized).jpg

#4157 7 days ago

This photo should show where the metal bracket goes. I’m guessing your clear plastic is an airball limiter maybe? Will the screen hole reach the left sleeve post if you swivel it around?

43C14BD0-327E-452E-8022-22BC5B7A318D (resized).jpegF449AB78-A9E4-48EF-8283-397A980EF7F9 (resized).jpeg
#4158 7 days ago
Quoted from jlatko:

Hey guys, need some maintenance help on my Pro. So my left orb enclosure post screw flew off during a game last night Didn't realize it until a metal bracket appeared next to the drop target. In pics on the web, I can't see where the metal bracket goes, and don't really see the plastic piece attached to the right post either. I found the screw under the playfield in the cabinet. Question is, how does this thing go back together, and where does this metal bracket go? The picture with the orb is from the internet, the other 2 are my mine. Thanks.[quoted image][quoted image][quoted image]

Get rid of both metal and small plastic protector - install this - much cleaner (& helps thin back left corner).

https://pinside.com/pinball/forum/topic/sale-gotg-orb-airball-plastic-protector-1
2304FEA8-BE8E-4F03-A583-7A1CBCDFFFB3 (resized).jpeg79948E97-2DA9-4502-8C57-899B01BC3B82 (resized).jpegB2624B95-916A-4FBC-B935-57E4A2F08CA6 (resized).jpeg

B217B177-C291-4333-9E4B-3D81C13C24B3 (resized).jpeg
#4159 7 days ago
Quoted from Kronlar:

This photo should show where the metal bracket goes. I’m guessing your clear plastic is an airball limiter maybe? Will the screen hole reach the left sleeve post if you swivel it around?[quoted image][quoted image]

Yes the apparent protector on the right post does attach to the left post just by swiveling it to the left. Thanks for showing me where the bracket goes. That is where I thought it went when I was looking at mine, but wasn't sure. Funny the pictures on the web I looked at don't have the bracket. Must have added it later in the run.

#4160 6 days ago

http://mezelmods.com/ Ordered a couple times from them. Prices very reasonable

Quoted from HarrieD:

Where did you order these? Here in Europe they seem to be impossible to find for a decent price.

#4161 6 days ago
Quoted from cldgin2:

http://mezelmods.com/ Ordered a couple times from them. Prices very reasonable

Yeah, but I guess you don't have to worry about shipping and customs because you live in the US judging your account info. Once ordered some stuff for a customer, ended up paying double due to shipping and customs.

#4162 5 days ago

Can someone from the Premium /Le users show me how the arms from Groot are mounted ? I have the arms on order and like to see how I can add them to my pro

Thanks in advance

Greetings

#4163 4 days ago

Does anyone have this topper. Curious how it looks in person lit up.

Screenshot_20190911-081957_Chrome (resized).jpg
#4164 4 days ago

Has anyone had an issue with a clean left ramp shot wanting to moon walk all the way to the left outlane? If so, what solution worked? Seems like it is happening on my GOTG one out of ten times. Not often, but enough to be miffed at when it happens. I am a new owner, but the previous owner said he never encountered this issue. Thanks.

#4165 3 days ago
Quoted from rickyray:

Has anyone had an issue with a clean left ramp shot wanting to moon walk all the way to the left outlane? If so, what solution worked? Seems like it is happening on my GOTG one out of ten times. Not often, but enough to be miffed at when it happens. I am a new owner, but the previous owner said he never encountered this issue. Thanks.

What kind of sling rubber do you have installed? Some of them are thicker than others and can cause this but you should be able to make minor adjustments to the position of the end of the ramp to help resolve this.

#4166 3 days ago

Hey guys,

Does anyone ever have a problem with the right orbit having the ball seemingly hit something on it's way through and never making it all the way through? This is a recent problem for me and I can't for the life of me figure out what's happening. The ball will get about 3/4 of the way in, just to about where the first pop bumper is and then it's like it hits something. It rattles and goes off into the bumpers. It doesn't do it all the time, maybe 1 out of 10 shots or so, but it's enough to be annoying as it's a new problem.

The only thing that's "changed" is a week ago I took the glass off and cleaned and waxed it for the first time. But I was exceptionally careful all around and nothing looks out of place. I have noticed the balls are going really fast now that it's all waxed up, so could it be something to do with the speed and having not-perfect shots to the orbit just not making it through because of that? That seems like it would be odd but it's the only thing I know of that changed. It could also be, obviously, coincidence that it happened after I cleaned it but I really don't see anything that it could be catching on.

I've tried to catch it when it happens but for the life of me I can't figure it out.

Thoughts?

#4167 3 days ago
Quoted from Rake:

Hey guys,
Does anyone ever have a problem with the right orbit having the ball seemingly hit something on it's way through and never making it all the way through? This is a recent problem for me and I can't for the life of me figure out what's happening. The ball will get about 3/4 of the way in, just to about where the first pop bumper is and then it's like it hits something. It rattles and goes off into the bumpers. It doesn't do it all the time, maybe 1 out of 10 shots or so, but it's enough to be annoying as it's a new problem.
The only thing that's "changed" is a week ago I took the glass off and cleaned and waxed it for the first time. But I was exceptionally careful all around and nothing looks out of place. I have noticed the balls are going really fast now that it's all waxed up, so could it be something to do with the speed and having not-perfect shots to the orbit just not making it through because of that? That seems like it would be odd but it's the only thing I know of that changed. It could also be, obviously, coincidence that it happened after I cleaned it but I really don't see anything that it could be catching on.
I've tried to catch it when it happens but for the life of me I can't figure it out.
Thoughts?

I have noticed the same thing, except mine doesn't drop in the bumpers but instead gets rejected back out about halfway in the orbit. It doesn't even make it to the bumpers. I would say this occurs about 50% of the time. Its a shame too, because the right orbit is the easier one to hit for drax.

I have cleaned and waxed mine once, nothing out of place and I am not sure why it started.

Maybe someone else will chime in because it has started becoming an issue.

#4168 3 days ago
Quoted from Rake:

Hey guys,
Does anyone ever have a problem with the right orbit having the ball seemingly hit something on it's way through and never making it all the way through? This is a recent problem for me and I can't for the life of me figure out what's happening. The ball will get about 3/4 of the way in, just to about where the first pop bumper is and then it's like it hits something. It rattles and goes off into the bumpers. It doesn't do it all the time, maybe 1 out of 10 shots or so, but it's enough to be annoying as it's a new problem.
The only thing that's "changed" is a week ago I took the glass off and cleaned and waxed it for the first time. But I was exceptionally careful all around and nothing looks out of place. I have noticed the balls are going really fast now that it's all waxed up, so could it be something to do with the speed and having not-perfect shots to the orbit just not making it through because of that? That seems like it would be odd but it's the only thing I know of that changed. It could also be, obviously, coincidence that it happened after I cleaned it but I really don't see anything that it could be catching on.
I've tried to catch it when it happens but for the life of me I can't figure it out.
Thoughts?

I just realized your issue may be different than mine. Inside that orbit by the bumpers are two gates. They do close so that the ball will drop into the bumpers. The only time that I know they are fully open is on Gamora and the sibling rivalry events. I believe the gate is down all the other times.

My issue seems to not even make it to the bumpers.

#4169 3 days ago
Quoted from smcclain65:

I just realized your issue may be different than mine. Inside that orbit by the bumpers are two gates. They do close so that the ball will drop into the bumpers. The only time that I know they are fully open is on Gamora and the sibling rivalry events. I believe the gate is down all the other times.
My issue seems to not even make it to the bumpers.

Yeah no you're having the same problem as me. Most the time for me it'll come back down the orbit, and every once in a while the momentum will take it to the left into the bumpers (or even more rarely if the ball is really flying it will make it to the top lanes). So it won't make it to the trigger thing in the orbit to register Drax but will get deflected kind of in the gap between the bottom right most bumper.

Was just trying to give that description because best I can tell that's where the issue starts is around that bumper. This isn't where the orbit stops the ball by design to drop it into the top lanes.

#4170 3 days ago

Mine does this as well. If the shot is not clean the ball rattles around near the pop bumper. I was thinking the stainless guide was bent but doesn't appear to be.

#4171 2 days ago
Quoted from rwmech5:

Mine does this as well. If the shot is not clean the ball rattles around near the pop bumper. I was thinking the stainless guide was bent but doesn't appear to be.

I thought this same thing as well but the metal looks good to me too.

It looks like at least us three are having this issues. I wonder if waxing that metal guide will help as well as the inside guide that is plastic so if it hits the orbit it won't bounce around. I think I am due for a waxing I may try this. I generally will only wax the playfield and clean things like the metal guide.

#4172 2 days ago

This has also happened to me since I stripped, cleaned and waxed mine too.
Can't see what is causing the issue, just assumed I wasn't hitting the shot clean enough.

#4173 2 days ago
Quoted from Bilbo1161:

This has also happened to me since I stripped, cleaned and waxed mine too.
Can't see what is causing the issue, just assumed I wasn't hitting the shot clean enough.

I have the same issue, but have always chalked it up to not being a clean shot.

#4174 2 days ago
Quoted from Rake:

Hey guys,
Does anyone ever have a problem with the right orbit having the ball seemingly hit something on it's way through and never making it all the way through? This is a recent problem for me and I can't for the life of me figure out what's happening. The ball will get about 3/4 of the way in, just to about where the first pop bumper is and then it's like it hits something. It rattles and goes off into the bumpers. It doesn't do it all the time, maybe 1 out of 10 shots or so, but it's enough to be annoying as it's a new problem.
The only thing that's "changed" is a week ago I took the glass off and cleaned and waxed it for the first time. But I was exceptionally careful all around and nothing looks out of place. I have noticed the balls are going really fast now that it's all waxed up, so could it be something to do with the speed and having not-perfect shots to the orbit just not making it through because of that? That seems like it would be odd but it's the only thing I know of that changed. It could also be, obviously, coincidence that it happened after I cleaned it but I really don't see anything that it could be catching on.
I've tried to catch it when it happens but for the life of me I can't figure it out.
Thoughts?

+1

#4175 1 day ago

Add Groot arms today

76AB6888-DB54-42A4-8935-5ADD9A30CA40 (resized).jpeg
#4176 1 day ago
Quoted from Bilbo1161:

This has also happened to me since I stripped, cleaned and waxed mine too.
Can't see what is causing the issue, just assumed I wasn't hitting the shot clean enough.

After my first waxing I have the same issue. The slippery surface must be allowing a not so clean shot to bounce around more than an unwaxed playfield

#4177 20 hours ago

Uooooooolo!!!!!!

#4178 14 hours ago
AA3006F7-6DED-401E-817B-7C44E25AFE53 (resized).jpeg
Promoted items from the Pinside Marketplace
4,950
Machine - For Sale
Middletown, OH
$ 89.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 399.95
$ 16.50
Lighting - Led
Lermods
There are 4178 posts in this topic. You are on page 84 of 84.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside