(Topic ID: 201799)

Guardians of the Galaxy owner's thread

By Blacksun

3 years ago


Topic Heartbeat

Topic Stats

  • 6,188 posts
  • 568 Pinsiders participating
  • Latest reply 1 day ago by Aflacjack
  • Topic is favorited by 219 Pinsiders

You

Topic Gallery

View topic image gallery

B7C37922-8231-4860-B334-2199D34BD52B (resized).jpeg
0CDFD366-CE37-42FE-BD8D-2A1ED6332EB5 (resized).jpeg
IMG_20210929_211018630_HDR (resized).jpg
920D1D05-400B-4D55-8BA2-3FC7B07FB165 (resized).jpeg
20211003_101945 (resized).jpg
Stern - Guardians AJ 2 (resized).jpg
D63B8EE8-C470-4FDA-A8EA-0BF5D48D6442 (resized).jpeg
78BD5BEF-24FF-4210-92CB-AB3E56CE8E9B (resized).jpeg
4DF1831B-4F13-452C-A7DF-C8861468EE60 (resized).jpeg
3796BD34-B88A-4C2B-9F44-2B31A058C713 (resized).jpeg
A113B22C-CD23-4559-AC26-75B0184221C1 (resized).jpeg
CC493B02-84E6-4E3B-84E7-1CF75C357E8E (resized).jpeg
IMG_1655 (resized).jpg
0D21B462-3197-421B-B3CA-F11664F8AB23 (resized).jpeg
29AF4292-868A-4AA2-9F08-80F3E76D0172 (resized).jpeg
0CEC5B12-8D32-4646-9491-CB87F2B2C8BD (resized).jpeg

Topic index (key posts)

5 key posts have been marked in this topic (Show topic index)

There are 6188 posts in this topic. You are on page 119 of 124.
#5901 63 days ago
Quoted from ExSquid:

Haha got that right I actually put my email on Marcos list for if and when the stern topper hopefully gets back in stock.
I was in the same years! Probably was in Great Mistakes same time as you.

Get the Mezel mods one. Stern one will never be in stock again unfortunately.

https://mezelmods.com/products/guardians-of-the-galaxy-silhouette-topper

#5902 62 days ago
Quoted from BallyKISS1978:

Get the Mezel mods one. Stern one will never be in stock again unfortunately.
https://mezelmods.com/products/guardians-of-the-galaxy-silhouette-topper

How tall is that thing?. I only have an 8 inch clearance to the ceiling .

956334BD-F169-422C-81C9-839A94481AA5 (resized).jpeg

#5903 62 days ago
Quoted from ExSquid:

How tall is that thing?. I only have an 8 inch clearance to the ceiling .
[quoted image]

#5904 62 days ago

Just joined the club with a used pro, loving the game with the cleland mod. Now to find out how to stop airballs off the nebula ramp 50% of the time

#5905 62 days ago

I asked this awhile ago, and never really did get an answer. My pros playfield has a slight raise in it just above the magnet. You can feel it, but can't see it. Does anyone else have this on their machine?

#5906 62 days ago
Quoted from smoothbore19:

I asked this awhile ago, and never really did get an answer. My pros playfield has a slight raise in it just above the magnet. You can feel it, but can't see it. Does anyone else have this on their machine?

I noticed that as well.

#5907 62 days ago
Quoted from ExSquid:

How tall is that thing?. I only have an 8 inch clearance to the ceiling .
[quoted image]

Oh dang, definitely won’t fit buddy. It’s taller than 8”

#5908 62 days ago
Quoted from smoothbore19:

I asked this awhile ago, and never really did get an answer. My pros playfield has a slight raise in it just above the magnet. You can feel it, but can't see it. Does anyone else have this on their machine?

I am not going to check mine. Ignorance is bliss. My magnet is working but doesn’t kick the ball out quick though, just let’s it go pretty much. I am 6.5 degrees I believe.

#5909 62 days ago

My magnet works good after some tweaks but that bump on the playfield has me a bit concerned.

#5910 62 days ago

So, I'm thinking I have an intermittent short somewhere. At seemingly random times all or most of the lights go off for about a half second. When I first got the machine this always happened when I hit the orb, but now it happens more often when it didn't before and doesn't seem to correlate to hitting anything specific. Sometimes it happens on the plunge, including the Nova Core lights so I don't know which is lit for the skill shot. Sometimes it's just during normal play, shooting a ramp or whatever.

I've gotten an overcurrent error on Node board 9 on startup I think 4 times, twice it's stayed on the error and didn't finish booting, and twice it paused on the error then continued to boot.

I've disconnected most of my mods one at a time, tried turning off the shaker and tested and haven't stopped the problem yet. I found a bad GI socket, the rivet is super loose and the whole socket flops around so I disconnected that for the time being. I'm not sure how to best troubleshoot since if it's a short it seems to not be happening most of the time so checking stuff with a multimeter doesn't seem likely to see the issue since I can't reproduce it on demand. Sometimes it happens a lot in a single game and sometimes I can go a few games without noticing it.

I'm really skittish about damaging node 9 or 8, since replacements for those likely have the new chips and require new code that I want to avoid. I appreciate any ideas for how to troubleshoot this safely.

For a sanity check, I think the original "lights out" when hitting the orb is normal, am I wrong about that? When is it normal for the entire playfield to go dark for just an instant during play?

#5911 62 days ago
Quoted from BallyKISS1978:

I am not going to check mine. Ignorance is bliss. My magnet is working but doesn’t kick the ball out quick though, just let’s it go pretty much. I am 6.5 degrees I believe.

That’s a good point, I haven’t taken the time to level the game out properly yet…

#5912 62 days ago
Quoted from OhmEye:

So, I'm thinking I have an intermittent short somewhere. At seemingly random times all or most of the lights go off for about a half second. When I first got the machine this always happened when I hit the orb, but now it happens more often when it didn't before and doesn't seem to correlate to hitting anything specific. Sometimes it happens on the plunge, including the Nova Core lights so I don't know which is lit for the skill shot. Sometimes it's just during normal play, shooting a ramp or whatever.
I've gotten an overcurrent error on Node board 9 on startup I think 4 times, twice it's stayed on the error and didn't finish booting, and twice it paused on the error then continued to boot.
I've disconnected most of my mods one at a time, tried turning off the shaker and tested and haven't stopped the problem yet. I found a bad GI socket, the rivet is super loose and the whole socket flops around so I disconnected that for the time being. I'm not sure how to best troubleshoot since if it's a short it seems to not be happening most of the time so checking stuff with a multimeter doesn't seem likely to see the issue since I can't reproduce it on demand. Sometimes it happens a lot in a single game and sometimes I can go a few games without noticing it.
I'm really skittish about damaging node 9 or 8, since replacements for those likely have the new chips and require new code that I want to avoid. I appreciate any ideas for how to troubleshoot this safely.
For a sanity check, I think the original "lights out" when hitting the orb is normal, am I wrong about that? When is it normal for the entire playfield to go dark for just an instant during play?

Is this insert lights, GI or both?

#5913 62 days ago
Quoted from bobukcat:

Is this insert lights, GI or both?

It happens so fast, it's GI for sure, not sure if it's all inserts also. Sometimes it's only the upper playfield, sometimes it seems like all of it. I need to take some video so I can play it back slowly and see exactly what's happening.

I found a loose (almost disconnected) serial connector and reseated all node board connectors, and just watched it in attract mode for 10 minutes and saw it happen a few times without anything moving.

update: ok yes it's inserts also,not all of them always. I just stared at the nebula insert until it happened and the inserts in that area flickered off for a moment when the GI went off.

#5914 61 days ago
Quoted from OhmEye:

It happens so fast, it's GI for sure, not sure if it's all inserts also. Sometimes it's only the upper playfield, sometimes it seems like all of it. I need to take some video so I can play it back slowly and see exactly what's happening.
I found a loose (almost disconnected) serial connector and reseated all node board connectors, and just watched it in attract mode for 10 minutes and saw it happen a few times without anything moving.
update: ok yes it's inserts also,not all of them always. I just stared at the nebula insert until it happened and the inserts in that area flickered off for a moment when the GI went off.

You are aware that there is a mode when it’s completed the GI flickers when making points. This ends when ball drains however.

#5915 61 days ago
Quoted from Rensh:

You are aware that there is a mode when it’s completed the GI flickers when making points. This ends when ball drains however.

Yes, but mine is having all lights go off for a moment at random times during play or even during attract mode doing nothing. Sometimes it's the entire playfield and sometimes just the upper halfish. Inserts and GI go off for less than a second then come back on. I've had it even happen several times on the plunge right at the moment I need to see which lane insert is lit for the skill shot. I can't make it happen at any particular time, and it didn't happen when I first got the machine.

I'm backing out all my mods on the theory one of them has an intermittent short.

#5916 61 days ago
Quoted from OhmEye:

Yes, but mine is having all lights go off for a moment at random times during play or even during attract mode doing nothing. Sometimes it's the entire playfield and sometimes just the upper halfish. Inserts and GI go off for less than a second then come back on. I've had it even happen several times on the plunge right at the moment I need to see which lane insert is lit for the skill shot. I can't make it happen at any particular time, and it didn't happen when I first got the machine.
I'm backing out all my mods on the theory one of them has an intermittent short.

Good idea!

#5917 61 days ago

Hey guys! Looking for a few mods for my GOTG pin, i see mezelmods does a few, sent them an email because they dont ship to the UK and they pointed me in the direction of pinballbazaar.co.uk where i could place my order and they would get the items from mezelmods for me. I sent an email to James from pinball bazaar and he verified exactly that, i placed the order, but its been 2 months, ive sent emails asking if the items have been sent and have had no reply.

So anyone know any reliable other websites with mods that ship to the UK?

Looking for these:

Pinball Trough Lighting Kit- Guardians of the Galaxy, Green
GameBlades 1 Guardians of the Galaxy GameBlades, Hexagon
Star-Lord Flasher Dome
Guardians of the Galaxy Pinball Target Illumination
Guardians of the Galaxy Pinball Ramp Illumination - Green
Guardians of the Galaxy Pinball Rocket Kickback Cover
Guardians of the Galaxy Pinball Pro Infinity Stone
Guardians of the Galaxy Pinball Scoop Illumination
Guardians of the Galaxy Pinball Groot Illumination

thanks for the help

#5918 61 days ago

Got my brand new Guardians Pro unpacked today. Build date of July 30. Unfortunately, I'm in the version 1.08 club. I was really looking forward to using the Cleland sound mode, and now obviously that is not possible. I really hope there is a way to get that changed in the near future!

#5919 61 days ago
Quoted from jstarner79:

Got my brand new Guardians Pro unpacked today. Build date of July 30. Unfortunately, I'm in the version 1.08 club. I was really looking forward to using the Cleland sound mode, and now obviously that is not possible. I really hope there is a way to get that changed in the near future!

Don't despair, its still a great game !!

#5920 61 days ago

Mine comes tomorrow and i believe is a new build as well. Oh well still cant wait.

#5921 61 days ago

So I found the mod causing my lighting issue, the last thing I expected, of course! It's the PinStadiums. I'm leaving them disconnected for now, the clips were not shorting or loose, and had a lot of clearance with the wires ziptied so it seems there's something the system doesn't like when connecting to those sockets. I'll try some other sockets tomorrow starting with only the GI connected and see how it goes. The game seems so dark now without the PinStadiums, heh. At least now I found what it is so I can work it out.

#5922 60 days ago
Quoted from OhmEye:

So I found the mod causing my lighting issue, the last thing I expected, of course! It's the PinStadiums. I'm leaving them disconnected for now, the clips were not shorting or loose, and had a lot of clearance with the wires ziptied so it seems there's something the system doesn't like when connecting to those sockets. I'll try some other sockets tomorrow starting with only the GI connected and see how it goes. The game seems so dark now without the PinStadiums, heh. At least now I found what it is so I can work it out.

So glad you found the problem,I have no experience with pinstatiums but I know once you get use to lighted playfields it’s hard to go back,I make my own that are just basic but still love them!

#5923 60 days ago
Quoted from OhmEye:

So I found the mod causing my lighting issue, the last thing I expected, of course! It's the PinStadiums. I'm leaving them disconnected for now, the clips were not shorting or loose, and had a lot of clearance with the wires ziptied so it seems there's something the system doesn't like when connecting to those sockets. I'll try some other sockets tomorrow starting with only the GI connected and see how it goes. The game seems so dark now without the PinStadiums, heh. At least now I found what it is so I can work it out.

Don't hesitate to contact Scott at Pinstadium, he's known for excellent customer service.

#5924 60 days ago
Quoted from jstarner79:

Got my brand new Guardians Pro unpacked today. Build date of July 30. Unfortunately, I'm in the version 1.08 club. I was really looking forward to using the Cleland sound mode, and now obviously that is not possible. I really hope there is a way to get that changed in the near future!

Wow I'm actually wondering if my JULY 28th build date was the cut off now.

#5925 60 days ago

So I found the mod causing my lighting issue, the last thing I expected, of course! It's the PinStadiums. I'm leaving them disconnected for now, the clips were not shorting or loose, and had a lot of clearance with the wires ziptied so it seems there's something the system doesn't like when connecting to those sockets. I'll try some other sockets tomorrow starting with only the GI connected and see how it goes. The game seems so dark now without the PinStadiums, heh. At least now I found what it is so I can work it out.

Quoted from bobukcat:

Don't hesitate to contact Scott at Pinstadium, he's known for excellent customer service.

I definitely will if I can't resolve it. I don't want to waste his time if it turns out to be a simple fix just using a different socket or something.

#5926 60 days ago

Well, I've had my machine going for only a few days and I noticed my right flipper is resting at a different angle than my right flipper. This being my first pinball machine, I'm not even sure where to start in trying to fix this and make them even. Any tips or advice I should try? Thank you very much!

20210826_191607 (resized).jpg
#5927 60 days ago

The hex bolt that tightens the flipper to the coil is a bit too loose and the angle is slipping. The flipper needs to be realigned and tightened more. Here is a pretty good doc on it.

https://www.gameroomguys.com/grg-site/how-to-docs/How-to-Pinball-Adjusting-Stern-Crank-Arm.pdf

Not hard but can be intimidating for new owners.

The flipper needs to have a gap about the thickness of a credit card. I found an old one and cut a notch in it so I can slide it between the flipper and playfield bushing while I tighten the flipper down. The gap is really important.

#5928 59 days ago
Quoted from C0untDeM0net:

The hex bolt that tightens the flipper to the coil is a bit too loose and the angle is slipping. The flipper needs to be realigned and tightened more. Here is a pretty good doc on it.
https://www.gameroomguys.com/grg-site/how-to-docs/How-to-Pinball-Adjusting-Stern-Crank-Arm.pdf
Not hard but can be intimidating for new owners.
The flipper needs to have a gap about the thickness of a credit card. I found an old one and cut a notch in it so I can slide it between the flipper and playfield bushing while I tighten the flipper down. The gap is really important.

Thank you very much! I'll give that a shot this weekend. I hope it's as simple as you make it sound!

#5929 58 days ago

What do you guys have your voice and music settings at? Also My magnet catches the ball 100% of the time, only issue I have is the release of the pinball is very slow. Just releases it but doesn’t really shoot it out.

Do you think adding the washer to the magnet will help or is their anything else I can do or check?

Just got it NIB this month with March 17th 2021 build and 1.06 code. Thank God it has 1.06, the game is so much better with clelands code. Could never go back to stock code.

#5930 58 days ago

Got my pro yesterday and just got it all setup. Holy crap this game is fast. Feels fast like tmnt so i guess thats just borg for you. That kickback is insane.

This was my first pro. Didnt know pros have a plastic apron. Is it still ok to lift the game by it? Feels a little breakable.

#5931 58 days ago
Quoted from mbrave77:

Got my pro yesterday and just got it all setup. Holy crap this game is fast. Feels fast like tmnt so i guess thats just borg for you. That kickback is insane.
This was my first pro. Didn't know pros have a plastic apron. Is it still ok to lift the game by it? Feels a little breakable.

While I haven't gotten my PRO yet, I am already considering converting the arch to metal to match my JP Premium look. Here's what I have researched which might help you:
- The GOTG manuals are wrong in the arch part numbers they call out. You'll find ALL three versions of the GOTG manuals show the same plastic apron being used. That is incorrect. I checked this with Stern support (Patrick Powers) and he agrees the manuals are wrong. Only the PRO uses plastic, and the Prem/LE machines use metal.
- Stern gave me the part number for the 'correct' metal apron used in the PRE/LE machines, but after checking with three different distributors, they are unable to find or order that part in their Stern ordering system. (Patrick says it is a purple metal arch, part #535-1191-19)
- Margaret at Pinball Life suggested parts to install in a GOTG PRO, which consist of the metal apron (in black), two metal brackets and 6 hex head screws. It totals to $91 all-in with shipping. (Part numbers: 535-8392-01, 535-8394-00, 234-5001-02)
- Stern makes a dozen different versions of their metal aprons, in a bunch of different colors, some with light cutouts and others without, so my confidence that the kit from PBL will be a perfect 'factory GOTO Prem' install is less than 100%.

#5932 58 days ago

Definitely think Im going to move the lane knobs to the easier position on this game. Outlanes seem hungry. But i hate it when games make you removed ramps and laneguides whatnot to make that little change. Seems this game is like that a bit.

#5933 58 days ago

I just installed the deluxe 12 speaker lights kit in my pro. The speaker lights turn on and work great, but the machine says "48v disabled. Close coin door or pull intertock switch to restore power." I've tried opening and closing the coin door, but nothing happens. Any tips or advice on this? I've only had my machine running for a few days, so it should be working just fine. It was working before I installed the speaker lights kit, and now it's not.

#5934 58 days ago
Quoted from jstarner79:

I just installed the deluxe 12 speaker lights kit in my pro. The speaker lights turn on and work great, but the machine says "48v disabled. Close coin door or pull intertock switch to restore power." I've tried opening and closing the coin door, but nothing happens. Any tips or advice on this? I've only had my machine running for a few days, so it should be working just fine. It was working before I installed the speaker lights kit, and now it's not.

Remove the speaker light kit (disconnect it) and see if the problem goes away to see if that is causing the issue first.

#5935 58 days ago

first day with the game I really like it but I suck. I can get just over 300m so far but dont really know how. Orb shot tried from the left always seems to borg bounce to left outlane. Can be backhanded but still pretty tough. And man those inlanes always seem to bounce to the left outlane.

#5936 58 days ago
Quoted from mbrave77:

first day with the game I really like it but I suck. I can get just over 300m so far but dont really know how. Orb shot tried from the left always seems to borg bounce to left outlane. Can be backhanded but still pretty tough. And man those inlanes always seem to bounce to the left outlane.

sounds like you don't have pitch and level correct. I have mine at 6.5 degrees and level left/right and the magnet grabs the ball out of the orb every time. The direction it flings is random and I control it with a nudge, the left outlane isn't an issue at all for mine. My ramp return to the left flipper never bounces to the outlane, and nudging to keep the ball away from the lane area keeps the outlanes from being too greedy for me. My main left outlane enemy is the HE target next to the Gamora ramp, when I forehand that from a cradle it likes to return straight to the left outlane.

Overall I love the layout and shots and don't have much to complain about, I think my poor skills are to blame for almost everything! This game is definitely improving my accuracy.

#5937 58 days ago
Quoted from OhmEye:

sounds like you don't have pitch and level correct. I have mine at 6.5 degrees and level left/right and the magnet grabs the ball out of the orb every time. The direction it flings is random and I control it with a nudge, the left outlane isn't an issue at all for mine. My ramp return to the left flipper never bounces to the outlane, and nudging to keep the ball away from the lane area keeps the outlanes from being too greedy for me. My main left outlane enemy is the HE target next to the Gamora ramp, when I forehand that from a cradle it likes to return straight to the left outlane.
Overall I love the layout and shots and don't have much to complain about, I think my poor skills are to blame for almost everything! This game is definitely improving my accuracy.

I dont think theres a pitch problem. Im at 6.6 perfectly level. Im just having issues hitting orb shot from left side which seems Borgish like tmnt. Backhand easier but still hardish. Magnet catches stuff. fun magnet kinda like houdini

#5938 57 days ago
Quoted from BallyKISS1978:

Remove the speaker light kit (disconnect it) and see if the problem goes away to see if that is causing the issue first.

Disconnected the speaker lights kit, and now the machine works fine again. So I can get the speaker lights to work or the machine to work, but not both at the same time.

#5939 57 days ago

Magnet issue is back again. The washers worked for a week. Now back to just slightly flinging the ball towards the left outlane.....smh.

#5940 57 days ago
Quoted from ExSquid:

Magnet issue is back again. The washers worked for a week. Now back to just slightly flinging the ball towards the left outlane.....smh.

Yes did the washer fix too but the true fix for the magnet is to clean and wax the PF...did this for awhile but no longer really care about the magnet. LOL.
Still love the game after 2 years especially because of theme and cleland code.

#5941 57 days ago
Quoted from DaddyManD:

Yes did the washer fix too but the true fix for the magnet is to clean and wax the PF...did this for awhile but no longer really care about the magnet. LOL.
Still love the game after 2 years especially because of theme and cleland code.

Yeah great game but being NIB I'm still pissed this is a thing. And want it fixed.

#5942 57 days ago
Quoted from DaddyManD:

Yes did the washer fix too but the true fix for the magnet is to clean and wax the PF...did this for awhile but no longer really care about the magnet. LOL.
Still love the game after 2 years especially because of theme and cleland code.

Cleaning the playfield after installing the washers solved mine. I just used a bit of Novus 2 on the magnet area. Took like 2 minutes.

Good luck!

#5943 57 days ago

Anyone happen to have a Dropbox / Box link to the 1.06 update for the game? Wanted to give it a whirl since the version of the game I purchased is at 1.04 and then give the Cleland update a shot. I'd rather do it gracefully than just image a card with the Cleland mod and throw it in.

Thanks in advance.

#5944 57 days ago
Quoted from Wolfanoz:

Anyone happen to have a Dropbox / Box link to the 1.06 update for the game? Wanted to give it a whirl since the version of the game I purchased is at 1.04 and then give the Cleland update a shot. I'd rather do it gracefully than just image a card with the Cleland mod and throw it in.
Thanks in advance.

Imagining a card is the most straight-forward approach. You do not need to install 1.06 stock, and then cleland. It's really all on the card. Just get Cleland's image and burn to a card and install. Doing so is the cleanest "graceful" install process.

#5945 57 days ago
Quoted from RDReynolds:

Cleaning the playfield after installing the washers solved mine. I just used a bit of Novus 2 on the magnet area. Took like 2 minutes.
Good luck!

How many washers did you install? I did one and it helped send the ball in different directions now versus just dropping it

#5946 56 days ago

Well, I think I discovered the problem with my flipper. My right flipper seems to have a piece broken or missing in the middle of the assembly, either some kind of screw or pin. I'm assuming I just need a brand new part now and there is no easy/quick fix for this. Just sucks as I've only had this machine up and playing for less than a week.

flip2 (resized).jpg
#5947 56 days ago
Quoted from jstarner79:

Well, I think I discovered the problem with my flipper. My right flipper seems to have a piece broken or missing in the middle of the assembly, either some kind of screw or pin. I'm assuming I just need a brand new part now and there is no easy/quick fix for this. Just sucks as I've only had this machine up and playing for less than a week.
[quoted image]

It is really hard to tell for sure from your picture but it looks like the clamp is loose on the flipper shaft and it has slide off / up, is the flipper bat sticking way up away from the playfield? Can you just loosen it up some more, push it back together and re-tighten the clamp?

#5948 56 days ago

So is GotG kind of like Star Trek in that each quest has a level 1, 2, 3? If so Im assuming I should try to finish all level 1s first? Are there bonuses for doing certain ones in order?

#5949 56 days ago
Quoted from mbrave77:

So is GotG kind of like Star Trek in that each quest has a level 1, 2, 3? If so Im assuming I should try to finish all level 1s first? Are there bonuses for doing certain ones in order?

You have the 8 timed main modes which must be completed to get to the wizard mode. Your progress is saved for all but one mode and you pick up where you left off when you restart the mode. Once you complete the mode there is a bonus level 2 which can stack with other modes. Each mode has a different bonus level. Quill for instance is a hurryup shot to the scoop for 10% of your score. Can be huge later on in the game so it's good to save completion of quill for later.

There are 2 mini wizard modes. Cherry bomb is earned for completion of 4 modes. Immolation, I believe, is earned for completing at least half of all of the modes including starting groot and orb multiball. Save Zandar main wizard mode requires completion of everything including the supers for groot and orb to qualify.

#5950 56 days ago
Quoted from mbrave77:

So is GotG kind of like Star Trek in that each quest has a level 1, 2, 3? If so Im assuming I should try to finish all level 1s first? Are there bonuses for doing certain ones in order?

No. It is not like Star Trek. When you complete a mission, the second part begins and runs in the background. Think of it like the 3-in-a-row (super ramps/targets/spinner) on Star Trek. The rectangular character insert will flash showing the related shot(s).

Knowhere 2 = left and right orbits (10 shots worth the highest value collected during the mission)
Escape Kyln 2 = Nova Corp rollovers (10 shots worth the highest value collected during the mission)
Sanctuary 2 = Hadron Enforcer targets
Pod Chase 2 = Ramps (10 shots worth the highest value collected during mission)
Sibling Rivalry 2 = Gamora ramp 1 shot for the same value collected during the mission - multiply it for huge points
Yaka Arrow 2 = Pop bumpers for 50 hits or shoot Yondu
Antiquities Shop 2 = increased scoring for 100 switch hits
Quill's Quest 2 = Upon completion of QQ, Star Lord shot (scoop) will be lit for a hurry up starting at 10% of your score

Bonus for each mission is higher when you complete it without draining or running out of time. Mission bonuses carry over from ball to ball.

Complete 50% of each mission and start Groot Multiball and Orb Multiball to light Immolation Initiative at the scoop.
Complete four missions to light Cherry Bomb Mulitball at the scoop.
Complete 100% of each mission plus Double Super Jackpot during Groot Multiball (Groot's mouth opens/closes) plus Super Jackpot during Orb multiball (all mission inserts will be lit solid) to light Save Xandar at the scoop.

There are 6188 posts in this topic. You are on page 119 of 124.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside