GTB Raven Help Needed

(Topic ID: 217130)

GTB Raven Help Needed


By Cherga

5 months ago



Topic Stats

  • 6 posts
  • 2 Pinsiders participating
  • Latest reply 4 months ago by Cherga
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

2018-05-18_12h55_01 (resized).png

#1 5 months ago

Hi all, I have an issue with my Raven machine. When starting a game the drop targets all drop as they should however the upper and lower target bulbs go out and never activate during a game. The upper and lower right drop targets work fine. Any ideas on what this can be? Thanks!

#2 5 months ago

Hi,

On the Raven, the targets banks are a bit special : indeed there is no traditional "banks" implemented like walls, but four individuals targets acting more like gates (rollover targets). So, there is four "single target" banks. As usual, a target bank can be reset (target raised), but also trip (target downed). The reset function is made using a "big" coil (A-18102) and the drop function is made using a small "flat" coil (A-19508, located inside the bank).

As usual , as there is not enough outputs on the driver board, the main coils (A-18102) are driven by SOLENOID outputs (#1, #2, #5 and #6). While the little coils (A-19508) are driven by lamps outputs (L12, L13, L14 and L15).

This is the schematic :
2018-05-18_12h55_01 (resized).png

As the drop function works on all banks, this means that the L12...L15 outputs works fine, but also that the fuses F10 and F11 are OK.
As the issue is only on the left side, the culprit should be SOLENOID #1 and #5, that are not working.

But first : check if your Raven wiring is original (because, sometimes people add extra-fuses on coils lines).

May be, this is only a bad contact problem. Check the A3J4 (on the driver board), try to plug/unplug it (of course, with power off !).
The worst case, the driver board is defective (and no more drive SOL #1 and SOL #5). In this case, probably the 2N3055 (Q58 & Q62) are burned.
If you have a spare driver board, try a swap.

#3 5 months ago

noflip95 thank you very much for the very detailed help! The first things I checked were connections and found a shorted wire. Now all targets fire randomly however I want to confirm operation since I just got the machine.

At game start all targets drop and lights go out. Randomly during play they’ll pop up and the light turns on for the activated target. After hitting the target and dropping it, the light stays on.

Does that sound like proper operation? Thanks!

#4 5 months ago
Quoted from Cherga:

...
Does that sound like proper operation? Thanks!

Yes

◾At the game start, the four "snippers" goes down.
◾During game, when the snipper sequence is activated, the "snippers" appears and disappears randomly.
◾At the end of the game, the four "snippers" goes up (and thus are all visible while the attract mode).

→ During the snipper sequence, only one "snipper" target is raised at a time, and remain active for some seconds, then it is retracted. When the "snipper" is up, the orange triangle light in front will flash. Hitting a "snipper" award 50.000 points, and the orange light remain lighted (to indicate that this snipper has already been hit).

→ To activate the snipper sequence, this depend of the selection of the DIP switch 31 (easy/difficult), either :
↠ complete the bottom left or right, 3 targets bank (in easy mode)
↠ complete the bottom 6 targets bank (in difficult mode)
The hit targets have their white triangle light off (otherwise, it is flashing)

→ For the SPECIAL, this depend of the selection of the DIP switch 32 (easy/difficult), either :
↠ shoot 3 "snippers" (in easy mode)
↠ shoot 4 "snippers" (in difficult mode)

Note also, that the TEST mode on SYS80B is "intelligent" :
- as the lamps L12...L15 are used for coils, they are not tested during the lamp test.
- but, during the solenoids test, they are activated and also the SOL #1, #2, #5, #6.
This allows to see the all 4 snipper targets to move up/down.

#5 5 months ago

Thanks again for the help. I have a new issue I’m chasing... I can’t get up the ramp. A-20095 coils are good but the ball only makes it half way up the ramp. It doesn’t look like the field upgrade to reduce stress on the Eos switches was done on this machine. Could that be the issue? Thanks.

2 weeks later
#6 4 months ago

I am able to get up the ramp now after adjusting the EOS Switch on the right flipper. Also, the ramp itself appears to have been bent by a previous owner in an attempt to achieve the same thing I was. I do however have an issue with the coil on the ramp. When activated its humming pretty loud and the coil gets hot, not to the point of melting the sleeve or anything like that it doesn’t seem right to me. The EOS Switch makes contact at rest as does the leaf switch. When activated, both switches break contact. Another issue I’m having a themachine is randomly locking up/resetting and this has only started happening since adjusting the right flipper coil switches. The switches are functioning properly... when activated EOS Switch breaks contact first followed by the secondary switch making contact. Any ideas or insight is appreciated.

Promoted items from the Pinside Marketplace
From: $ 16.95
€ 50.00
Boards
FLIPPROJETS
€ 8.40
€ 40.00
Boards
FLIPPROJETS
1,000 (OBO)
Machine - For Sale
Meriden, CT
€ 15.00
Boards
FLIPPROJETS
$ 48.00
Cabinet - Other
ModFather Pinball Mods
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 18.99
Eproms
Matt's Basement Arcade
$ 229.99
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 1,099.00
Flipper Parts
Mircoplayfields
$ 175.00
Lighting - Interactive
Professor Pinball
$ 305.00
Lighting - Interactive
...redshiftLED
$ 495.00
Cabinet - Armor And Blades
MI Pinball Refinery

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside