(Topic ID: 254350)

Ground short row 1 STTNG

By arakissun

1 year ago



Topic Stats

  • 8 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by arakissun
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

ST-TNG-Switch-matrix (resized).jpg

#1 1 year ago

Have this tonight.
Have and missing +12v.But I think I found the problem and will fix it later.

My question is:
Is it possible "Ground short row 1" to be from the missing +12v?
If not what is row1-who switches must look to check if there have some short or bad diode on them?

When I remove all connectors from MPU board,there is no error just Check Fuse F114/F115,but this thing is from the missing +12v.

#2 1 year ago
Quoted from arakissun:

Check Fuse F114/F115,

If fuses good, U20 on CPU took a hit.

LTG : )

#3 1 year ago
Quoted from arakissun:

Have this tonight.
Have and missing +12v.But I think I found the problem and will fix it later.
My question is:
Is it possible "Ground short row 1" to be from the missing +12v?
If not what is row1-who switches must look to check if there have some short or bad diode on them?
When I remove all connectors from MPU board,there is no error just Check Fuse F114/F115,but this thing is from the missing +12v.

Saw that (ground short row 1) on a friend’s TZ. He had a flipped a ribbon cable to the aux board.

#4 1 year ago

Fuses are fine but no +12v.So I think first to fix this problem.
AUX board is dissconect when message is show up.
Who are the switches of this ROW 1 and may be some of them to be shored or stucked?
It's not problem to replace u20,but it can be something simple.

#5 1 year ago
Quoted from arakissun:

Fuses are fine but no +12v.So I think first to fix this problem.
AUX board is dissconect when message is show up.
Who are the switches of this ROW 1 and may be some of them to be shored or stucked?
It's not problem to replace u20,but it can be something simple.

ST-TNG-Switch-matrix (resized).jpg
#6 1 year ago

Will fix first 12v problem and after that will check what is going on with the short.
I can put STTNG MPU in Demolition Man machine,so I will see if the problem is from MPU or something else.
I think this is the fastest and sure action.

#7 1 year ago

Or to change directly U18,U19,but first will begin with U20.It's easy job for me.
Sometimes is better to not touch/swap these old things like extract ROM ICs and etc.

#8 1 year ago

Fixed.
The cause for the message for the short was the missing +12V.
After getting now +12v everything is fine.
And the cause for these missing +12v was missing connection between C2+ and 7812+.
And the cause for this is I think because I reflow cap's legs before and looks like this reflow ate the connection between downside and upside of the board's hole.
Patched the trace.
So sometime reflow is not recommend.

P.S. But this fault was for good I think.I don't know but at F115 was put 3.15A SB fuse.May be at some fix previously I rushed some things and put very wrong fuse.And played it like this around 7 years.
Now put the right fuse 3/4A SB.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside