(Topic ID: 91515)

Grand Lizard intermittent problem starting game and ejecting ball.

By OpFlash

6 years ago

Topic Stats

  • 24 posts
  • 5 Pinsiders participating
  • Latest reply 2 years ago by Ralphman
  • Topic is favorited by 1 Pinsider


Linked Games

You're currently viewing posts by Pinsider opflash.
Click here to go back to viewing the entire thread.

#1 6 years ago

Newly purchased grand lizard. Problem started after bringing game home. Problem intermittent. Ok typically what happens when I press the start button game will not start. What happens is two coils fire, the one that ejects the locked ball for multiball and the other is the center where the ball goes when it is lost. So typically what is happening is that I can press the start button many many times but all I get is the two coils that fire and nothing. Game will not start. If I reach underneath the playfield and hold down the micro switch lever that activates that center coil (the one that kicks the ball up into the trough after the ball is lost) I can get the game to start and the first ball is ejected into the shooter lane. OK so I can play the first ball and 9 times out of ten when the first ball is lost and drops down into the bottom the ball gets kicked up into the trough and then nothing happens. Its as if the game hasn't recognized that the ball was lost and obviously ball two does not get ejected into the shooter lane. I did recently change the batteries and I did unplug and re connect all the plugs to the power supply. My game also has only 3 balls. Don't know if a GL requires more. Im not sure if this is an issue with the micro switches that make up the whole bottom ball trough assembly or the board. I did run the diagnostics before I gave up for the night and nothing seemed to come up. Any help would seriously be appreciated.

#3 6 years ago

I ran the game through the several diagnostic tests and first time through I didn't see anything amiss. I didn't run the test where it indicates if a switch is working when manually engaged. I will try this in the morning.

My game currently has 3 balls in it is this the correct amount?

#5 6 years ago

Ok I'll do this and report back with the data of the switch test.

#6 6 years ago

Ok took a look at the game and also think I have more of the proper terminology correct,

So ran the switch test it seems that while dropping the balls in that the out hole , 3 ball trough, 2 ball trough, were working however it seems that the 1 ball trough switch would work intermittently. weird most of the time when I pressed it manually it worked and then sometimes I could be pressing it and it wouldn't register. with or with out the ball didn't really make much of a difference.

However what surprised me is that when I had the playfield slightly lifted up the ball 1 trough was registering every time it seemed. Id lower the playfield down and then it wouldn't register. lift it back up and it would work again.

I attempted to start the game with the playfield back into position and same thing as before the out hole coil and the multi ball eject coil would fire and that's it the game would not start. No ball ejected into the shooter lane.

So I tried lifting the playfield up again slightly less than half way and pressed the button the game started like it should and ejected the first ball. I manually pressed the outhole switch to signal a lost ball and the game recognized the lost ball and ejected the 2nd ball.

So im thinking that this is something to do with the 1 ball trough microswitch? and or a combination of the other trough switches however the switch test is showing that the other ones are working 100% of the time.

#7 6 years ago


#9 6 years ago

I was wondering why some switches have diodes on them?

#10 6 years ago

I will try and get some pics going tonight.

#13 6 years ago

Dothedoo, I hear you 100% I actually ordered the outhole , left and center trough switches.

I cant seem to find the right trough switch anywhere here in the states. Can someone help out with this...

Part number from my manual is 5647-09633-00 Ive tried google searches and manual searches at quite a few pinball websites that sell parts. maybe there is an updated part number or cross reference that someone knows about.

I found this part on a parts website that was in the UK and the total for the one microswitch with shipping maybe well over 25 dollars ouch!

have some other things that ive gone over today and also some video etc that ill try to get posted.

1 week later
#14 6 years ago

Ok, So I ordered the outhole switch and all of the trough switches including the ball 1 trough switch. Today I replaced the outhole and the ball 1 trough switch. Again after working on the machine I feel that the issue is with the ball 1 trough switch. However the real issue seems to be that when the play field is down ball 1 trough is not recognized. when the play field is lifted up say maybe like 40% upward the switch works and it seems the game does as well.

What I did to test this was I put the machine into the switch test mode. I manually tried to activate the switch with the play field down and nothing comes up on the switch test. When I lift the playfield up the switch is activated as I can see it on the display and also hear the chime when I toggle the switch. I even adjusted the switch so that it remained activated. when I did this the machine continuously displays that the switch was activated and also looped the sound.

I then raised and lowered the playfield and when raised the switch test displayed that ball 1 trough was working.
when lowered the display goes blank and no chime. So something is happening to the wiring when the playfield is down.

Im not sure where to go from here......

#15 6 years ago

Also to note I did have the micro switch adjusted so that it wasn't stuck closed or open.

#16 5 years ago

Any Ideas? Also if there is a pinsider in the Chicago area that would be willing to maybe come over and help that would be awesome too. I could use someone's help really bad. Would help with brews or $$

#18 5 years ago

Yeah I'm thinking the back of the platforms also. However the issue is that it's not working when it's down, and when it's down I cat I can't get to the wires in the back! Im going to do my best to trace that wire all the way back And see if I can find the plug it goes into. I did unplug and replug all the harnesses in the back there with no luck.

2 months later
#19 5 years ago

I have been doing a lot of research on pins lately trying to get up to speed more with how they work etc. I am actually going to test the diodes with my DMM and see if this could be the issue then Ill move from there and report.

2 months later
#20 5 years ago

OKAY well after leaving things alone for a while I finally broke down and got in touch with someone locally that repairs pins. Im happy to report that for being totally new to pins I was in the right direction. The issue was Ball 1 Trough and the wiring. In the end some minor adjustments to the switch but more importantly the wiring harness was routed to a more proper position to the back box plus reseating the harness that leads the the Ball 1 tough and its respective plug on the CPU. Anyway the Grand Lizard lives! I can now finally start the cleaning refurb process. Ill try and take a bunch of pictures of the process.

6 months later
#21 5 years ago

UPDATE: The "fix" was very short lived. The machine worked for a short while and then after a handful of games. The same problem started right up again. The machine is set to free play. You press the start button and the game will not start. The only real way to start a game is if I literally hold down the center out hole microswitch while pressing the start button. The game does not play properly doing this because it will not recognize when the ball is lost and or kick the next ball out once the first one drains.

I can tell you though that the problem is somewhere with the wiring in the playfield.

I know this because (yes) I purchased another grand lizard a while back because it has a great playfield and is in much better shape and the game plays 100% Today I took the entire backbox from my 100% working GL and swapped it out to my GL which is having the trough / starting issues.

This helped me at least narrow down and determine that the problem was NOT coming from the boards or back box.

I am wondering what does a pinball need to start a game? I know that this is a very generalized question. But id really like to fix this one up. Recently read that the coin door could give a host of problems is some wires or switches aren't working properly. The game doesn't appear to be hacked in anyway. I know though that its something in the playfield. So that being said what would be the proper steps in troubleshooting the problem properly. I do have a DMM but yes im new. But can follow directions

#22 5 years ago

I also should note that I have both machines side by side and I had both playfields lifted up and just checked the 100% working GL to the one with the issues and the wiring to the micro switches for the trough looked equal to each other.

#23 5 years ago

Hope someone had a chance to revisit this one.

Promoted items from the Pinside Marketplace
$ 27.99
Matt's Basement Arcade
$ 17.00
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
Machine - For Sale
Morrisville, PA
$ 18.99
Matt's Basement Arcade
$ 9.00
Yorktown Arcade Supply
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
Machine - Wanted
Lincoln, NE
$ 139.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 155.00

You're currently viewing posts by Pinsider opflash.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside