(Topic ID: 149569)

Gottlieb System 80 QT Relay issue

By pinmaven

6 years ago



Topic Stats

  • 3 posts
  • 3 Pinsiders participating
  • Latest reply 4 years ago by Yeastlord
  • No one calls this topic a favorite

You

Linked Games

#1 6 years ago

So I am having an interesting issue with my Gottlieb Pink Panther game. The game will start but the Q (game over) relay will not engage, meaning no power to the solenoids to actually play the game. When I perform a relay and lamp test the Q relay works, but the T relay does not. Both work fine when the test is conducted with the playfield open. The machine has brand new Rottendog boards. I have replaced the solenoids with new ones. Wondering if it might be a grounding issue? Any advice would be appreciated.

2 months later
#2 5 years ago

I'm having a very similar issue with my Force II. This is my first system 80 game and I'm having trouble finding info on this one as well.

1 year later
#3 4 years ago
Quoted from pinmaven:

So I am having an interesting issue with my Gottlieb Pink Panther game. The game will start but the Q (game over) relay will not engage, meaning no power to the solenoids to actually play the game. When I perform a relay and lamp test the Q relay works, but the T relay does not. Both work fine when the test is conducted with the playfield open. The machine has brand new Rottendog boards. I have replaced the solenoids with new ones. Wondering if it might be a grounding issue? Any advice would be appreciated.

I'm having an identical issue with my PP. Did you ever find a solution to this?

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside