Gottlieb System 3 Flipper issues

(Topic ID: 231020)

Gottlieb System 3 Flipper issues


By JReedie

12 days ago



Topic Stats

  • 6 posts
  • 2 Pinsiders participating
  • Latest reply 4 days ago by JReedie
  • Topic is favorited by 1 Pinsider

You

Linked Games

No games have been linked to this topic.

    #1 12 days ago

    Please ignore my ignorance as I’m no System 3 expert but I’m working on a SF2 at the moment and it was having heaps of issues. Most of which I have now fixed however, currently all 3 flippers are dead, the flipper buttons are registering as I'm able to progress through the systems menu but when starting a game nothing happens. I’ve checked all fuses and they're fine, I’ve also checked all of the transistors on the driver board and they are fine too. The trough release coil is also refusing to fire so no balls are being put into play.

    The customer reported that last time the machine worked he could smell something burning so switched it off and thats when the flipper coils and also the trough release coil stopped working. The left upkicker coil was burnt out and I have ordered a replacement so I’m presuming thats what the burning smell was as theres no evidence anywhere else of anything thats toasted. Any ideas what else to look at regarding the flippers? I've read that the Q relay could potentially be the culprit but I want to gather as much information on as many possible causes as i can before turning up at the location to try and get the machine running again.

    #2 12 days ago

    Transistors won't effect the flippers (well, besides from the transistors that control the relays that enable the flippers...)

    Do you have voltage at the coils? F18,29,20,22 all have voltage on both sides? Tried grounding them?

    Do the slingshots work? Those are also enabled by the Q relay.

    #3 10 days ago

    zacaj i didnt actually have my multimeter on me, it was initially a call out for a simple fix, little did i know the horrors under the playfield. I asked the customer to test the slingshots for me and he has said they are not working either. Is it right to just assume the Q relay is the cause of the problems?

    #4 10 days ago

    Flippers, slingshots, and pop bumper only have one common point that I'm seeing on the schematic, and it's the Q relay+its connectors. I'd guess either the Q relay itself isn't working or the contacts are bad

    #5 9 days ago

    zacaj thanks for that, i’ll check out the Q relay on my next visit and hopefully thats the problem!

    #6 4 days ago

    Quick update, issue was the Q relay not firing. I've started a new thread as the problem has developed further

    https://pinside.com/pinball/forum/topic/gottlieb-system-3-troubles-1#post-4735683

    Promoted items from the Pinside Marketplace
    $ 229.99
    Lighting - Led
    PinballBulbs
    € 40.00
    Boards
    FLIPPROJETS
    From: $ 11.95
    Playfield - Toys/Add-ons
    ULEKstore
    $ 29.00
    $ 29.99
    Cabinet - Sound/Speakers
    Lighted Pinball Mods
    $ 48.00
    Cabinet - Other
    ModFather Pinball Mods
    From: $ 99.99
    Cabinet - Other
    Lighted Pinball Mods
    From: $ 19.95
    Apparel - Unisex
    Pinball Wheezer
    $ 229.99
    $ 48.00
    Playfield - Toys/Add-ons
    ModFather Pinball Mods
    $ 49.99
    Playfield - Toys/Add-ons
    Lighted Pinball Mods
    $ 5,799.00
    Pinball Machine
    Little Shop Of Games
    $ 14.95
    Playfield - Other
    Hookedonpinball.com
    $ 90.00
    Lighting - Under Cabinet
    Rock Custom Pinball
    From: $ 180.00
    € 278.00
    € 18.95
    $ 5.00
    Cabinet - Decals
    Siegecraft Electronics
    $ 99.99
    Lighting - Other
    Lighted Pinball Mods
    $ 137.00
    From: $ 50.00
    Gameroom - Decorations
    Pinball Art Prints
    $ 29.99
    Cabinet - Sound/Speakers
    Lighted Pinball Mods
    $ 9.95

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside