(Topic ID: 92226)

Gottlieb System 3 Fan Club: Haters need not apply ;)

By Gov

8 years ago


Topic Heartbeat

Topic Stats

  • 1,041 posts
  • 249 Pinsiders participating
  • Latest reply 1 day ago by Robotworkshop
  • Topic is favorited by 84 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

blue center flasher (resized).JPG
F538E1D0-E6F9-45BF-86E3-20A12A898BBC (resized).jpeg
MA-1770 (resized).png
2022-09-06_13-29-50 (resized).png
9DD7CCBA-D860-43C0-857F-DA245EB91D98 (resized).jpeg
80D53D86-1DA9-4DC7-902A-877B402C7565 (resized).jpeg
95DAD9F2-6F5D-46CA-B9D3-E156813E9421 (resized).jpeg
58729782-F182-4C69-9E29-90A594970D17 (resized).jpeg
Gottlieb_CueBallWizard_734-4 (resized).png
20220804_184753 (resized).jpg
20220804_174503 (resized).jpg
20220804_174500 (resized).jpg
image (resized).jpg
IMG_3102 (resized).JPG
IMG_3100 (resized).JPG
867537E3-D43A-43DC-9539-0D9E847E0F76 (resized).jpeg

There are 1,041 posts in this topic. You are on page 21 of 21.
#1001 3 months ago
Quoted from Scrimmbo:

Never thought I would, but I guess I'm joining the club. Bought a car hop on an online auction, not a game I'm looking for but the price was right and I need a project. The boards and the playfield seem to be in decent shape, but the cabinet is ROUGH. Bottom of the cabinet is very moldy, so I'm going to have some work to do there.
Never been a huge fan of Gottlieb, some of their games are fun but I don't much care for their mechs and stuff like that. Who knows maybe I'll learn to love it!
[quoted image][quoted image][quoted image]

This is a really good game, you’ll enjoy it!
Neat that it comes with the operator stickers so you know where it’s been!

Does anyone know how to add SERVICE CREDITS to sys3 games? There is an audit function, yet the manual doesn’t explain how to add them. Same with Sys80s

1 week later
#1002 87 days ago

Anyone have any experience with dialing in a vari-target on a System 3? I just got an Operation Thunder a little while ago, and while it's a fun game I'm having trouble getting the vari on the right side to work completely properly. I was playing with the spring tension and I could make it one of either two ways: loose enough that the coil/mech that releases the 'teeth' can do so but not tight enough to return the target to it's resting position, or vice versa - there was enough tension to return the target to rest, but it was too much for the coil/mech to release it's grip on the tooth, so the target just stays stuck. This is super annoying since hitting that target is necessary to progress through the modes. What am I doing wrong?

#1003 87 days ago
Quoted from Rolpa:

Anyone have any experience with dialing in a vari-target on a System 3? I just got an Operation Thunder a little while ago, and while it's a fun game I'm having trouble getting the vari on the right side to work completely properly. I was playing with the spring tension and I could make it one of either two ways: loose enough that the coil/mech that releases the 'teeth' but not tight enough to return the target to it's resting position, or vice versa - there was enough tension to return the target to rest, but it was too much for the coil/mech to release it's grip on the tooth, so the target just stays stuck. This is super annoying since hitting that target is necessary to progress through the modes. What am I doing wrong?

You have to consider the position you’re working in.
Steve at PBR was telling me that while the playfield is lifted, the vari-target should NOT be able to return to it’s home position, that would make it too tight. You have to keep lowering the playfield to see if you have it dialed in right. It is A LOT weaker than you’d expect! Loosen it so that when it’s tripped, it barely moves while the playfield is up. Then set it down, and see how it works.

#1004 83 days ago

Two LCA questions.

The sound seems unbalanced. The glass crash is very loud for example, while the background music and some other sounds are very quiet. Is that normal? There are times the music does get louder.

The second question has to do with the GI. I have none. Any ideas on where to start looking? If one light socket is bad, will they all go out?

Thanks

#1005 83 days ago
Quoted from MattW123456:

Two LCA questions.
The sound seems unbalanced. The glass crash is very loud for example, while the background music and some other sounds are very quiet. Is that normal? There are times the music does get louder.
The second question has to do with the GI. I have none. Any ideas on where to start looking? If one light socket is bad, will they all go out?
Thanks

For the Playfield G.I., check fuse F9 on the transformer panel.

2022-09-06_13-29-50 (resized).png
#1006 81 days ago
Quoted from MattW123456:

The sound seems unbalanced. The glass crash is very loud for example, while the background music and some other sounds are very quiet. Is that normal? There are times the music does get louder.

Yea, this is pretty normal. The glass crashing sound is kinda harsh and loud compared to other sounds and music.

The audio also changes volume occasionally, specifically, at the start of each ball, the volume will be low, then when you plunge, the volume gets loud and remains loud until you lock a ball or drain.

#1007 76 days ago

I've got a Nightmare on Elm Street that has some sound issues. It seems to play fine at startup, but after a few minutes I will start hearing a random screetching noise sometimes and then at end of game it cycles through all the callouts over and over again (which also sound a little distorted).

Anyone else ever ran into this issue with their System 3? This is my first System 3 so this is going to be a learning process I'm sure.

#1008 74 days ago

So far I’ve re-seated all connections in the backbox and even went as far as re-seating all removable chips on the boards. It seemed to help a little bit because now when the sound issues happen, the game seems to fix itself after a few seconds rather than needing a power cycle.

My voltage on the power supply is 5.03v.

Any ideas where to go from here? I’m starting to think maybe the game ROMs need to be replaced?

#1009 71 days ago

Hello, got a boot sound problem on my cue ball , extremly loud bong... coming from the subwoofer. anyone know how to fix it ? i searched a lot on net but only found solutions for system 80. Thanks

#1010 70 days ago
Quoted from Babysha:

Hello, got a boot sound problem on my cue ball , extremly loud bong... coming from the subwoofer. anyone know how to fix it ? i searched a lot on net but only found solutions for system 80. Thanks

Both my system 3's Rescue 911 and Waterworld do this when you power them on. And I don't have a subwoofer, so I can only imagine...

#1011 70 days ago

All my system 3s make a high pitched screech on boot

#1012 70 days ago
Quoted from Jakers:

So far I’ve re-seated all connections in the backbox and even went as far as re-seating all removable chips on the boards. It seemed to help a little bit because now when the sound issues happen, the game seems to fix itself after a few seconds rather than needing a power cycle.
My voltage on the power supply is 5.03v.
Any ideas where to go from here? I’m starting to think maybe the game ROMs need to be replaced?

Ideas? Anyone? I can’t find anyone else that has had this issue.

#1013 70 days ago
Quoted from Jakers:

Ideas? Anyone? I can’t find anyone else that has had this issue.

I am not familiar with the sound boards in Nightmare on Elm Street but I had something very similar on a Cactus Jack's. It ended up being the U1 chip on the aux sound board. I figured it out by pressing down on the chip while the game was having audio issues. This is not a typical through hole part, so I had to heat the area with some hot air to reflow the solder joints.

MA-1770 (resized).png
#1014 70 days ago
Quoted from Jakers:

I've got a Nightmare on Elm Street that has some sound issues. It seems to play fine at startup, but after a few minutes I will start hearing a random screetching noise sometimes and then at end of game it cycles through all the callouts over and over again (which also sound a little distorted).
Anyone else ever ran into this issue with their System 3? This is my first System 3 so this is going to be a learning process I'm sure.

I had a similar issue that I ran into and that one ended up being a flaky sound ROM. Can try reseating that first and also reseating the ribbon cable.

#1015 70 days ago
Quoted from Scrimmbo:

haha, yeah I wasn't expecting to win it, only ended up costing a few hundred, plus gas to go pick it up. I started pulling everything out this morning, to mitigate the mold situation on the bottom of the cabinet. Once I got everything out it wasn't bad to deal with at all. Before I did that I turned it on to see what it would do, the game powered up, I got GI, the game beeped once and I got garbage on the displays. My guess without going deeper is maybe bad eeproms or bad connection on the sockets? IDK, I'm going to dig into that a little later.
edit: I'd like to add that while my overall experience with Gottlieb has not been very positive, I will give them credit, it was very easy to remove the playfield and wiring harness. So much more so than any time I've done that on a Williams or Stern.

I've worked on a lot of the Williams, Bally, and Stern but Gottlieb definitely has some advantages. They fused just about everything on these System 3 games. Also the bottom of the playfield is usually well marked and at least on Stargate they added extra connectors so the drop target assembly can easily be removed to service it. Having the lamp boards which easily remove by pulling a couple clips make replacing those bulbs easy.

On these and the System 80 games I've beeb replacing the 500 ohm pot on the power board with the sealed multiturn precision version which seems a lot better than the originals.

#1016 70 days ago
Quoted from Robotworkshop:

I've worked on a lot of the Williams, Bally, and Stern but Gottlieb definitely has some advantages. They fused just about everything on these System 3 games. Also the bottom of the playfield is usually well marked and at least on Stargate they added extra connectors so the drop target assembly can easily be removed to service it. Having the lamp boards which easily remove by pulling a couple clips make replacing those bulbs easy.
On these and the System 80 games I've beeb replacing the 500 ohm pot on the power board with the sealed multiturn precision version which seems a lot better than the originals.

Which are you using? I hope someone buys GPE, lotta stuff I need to get!

#1017 70 days ago
Quoted from zacaj:

All my system 3s make a high pitched screech on boot

I don't think there is a way to remove the audio power up noise on these systems. If you are using speaker level to your sub you could put a power on delay between the audio output and the sub.

amazon.com link »

#1018 70 days ago
Quoted from Isochronic_Frost:

Which are you using? I hope someone buys GPE, lotta stuff I need to get!

I don't know if GPE carried the 500ohm precision multiturn pots. I just order those from Digikey or Mouser

1 week later
#1019 60 days ago

Have any of you used the optional communications adapter?

#1020 59 days ago
Quoted from La4s:

For the Playfield G.I., check fuse F9 on the transformer panel.[quoted image]

I was finally able to track down and label the fuses. F9 is blowing on startup. Seems to have an issue with strobe return 65 and maybe solenoid 1.

The display segment F does not light, and there seems to be voltage at segment G.

I’ve been using a manual download to my phone, but might need to break down and get a paper copy.

F538E1D0-E6F9-45BF-86E3-20A12A898BBC (resized).jpeg
#1021 59 days ago
Quoted from MattW123456:

I was finally able to track down and label the fuses. F9 is blowing on startup. Seems to have an issue with strobe return 65 and maybe solenoid 1.
The display segment F does not light, and there seems to be voltage at segment G.
I’ve been using a manual download to my phone, but might need to break down and get a paper copy.
[quoted image]

Just trying to follow along.

For the GI, I would first start with looking at a possible shorted bulb/socket, as you stated in a previous post. From there make sure that GI wiring is not exposed somehwere or shorted to another connection.

For your post, you think the display issue is also caused by the GI issue? (sorry just trying to follow along)

#1022 58 days ago

Hey everyone! Got my first system 3 lights camera action.

Anyone know of any custom roms to help normalize the mystery awards?

#1023 57 days ago

Picked up Mario Andretti
Pretty stoked about it goes great with SF2,everything works except the pop up ball save is always up was wondering if anyone has seen this before

#1024 54 days ago
Quoted from chuckwurt:

Anyone know of any custom roms to help normalize the mystery awards?

Unfortunately, none exist, and I’ve done a lot of searching. What ROM revision/checksum are you using? I did a lot of digging several years ago when I owned the game and came up with this:

The order of revisions along with checksums are as follows:
$D880 --> Revision 1
$D169 --> Revision 2
$E1F5 --> Revision 3 (the most recent revision of software for this title).
The 3rd revision of the software changes a few topographical things: the "Gun Fight" and "Mystery" award animations are MUCH faster. Mystery awards seem more balanced as well; awards like extra balls and million points are now pretty rare compared to previous software revisions. It also changes the speed at which certain callouts are made, notably the ones pertaining to the "draw card" sequence, and a more proper delay was added to the amount of time the "status report" would show after trapping a ball.

As far as normalizing the awards further, I ended up putting the game into novelty mode, which causes the extra ball award on mystery to award 1 million. Also, disable catch-up. Beyond that, there’s not much you can do.

#1025 54 days ago

I’ll check on my roms and report back. I haven’t played it a lot yet, but I’m inclined to just use it in my tournaments. If it’s good enough for pinburgh, it’s good enough for me. Haha

#1026 54 days ago

Just got me a Silver Slugger last month and I'm loving it. Teaching my boy the roots of pinball. I made a little video of him playing it with his cousins. If you want to check it out let me know what you think.

3 weeks later
#1027 32 days ago
Quoted from La4s:

Just trying to follow along.
For the GI, I would first start with looking at a possible shorted bulb/socket, as you stated in a previous post. From there make sure that GI wiring is not exposed somehwere or shorted to another connection.
For your post, you think the display issue is also caused by the GI issue? (sorry just trying to follow along)

No, I’m sure the display is its own issue.

The sockets in the game show continuity across the connections with no bulbs in them. The two I removed and tested on the bench are open when no bulb is installed, so I’m guessing the others should be the same.

There is continuity across the fuse holder. (Measured with no fuse installed.)

The F9 fuse blows immediately upon power up.

#1028 30 days ago

Mario Andretti Owners - help needed. I just bought a MA to restore and need help with the center blue flasher (the one on the spinning car mech). Previous owners had removed the flasher and apparently the wiring also. I cannot find where the flasher would plug in nor can I find any wiring that would have gone from under the playfield, thru the mech shaft hole to the flasher. Send pics or explanation please - thanks! Also - any ideas where I can find the one peice bumper cap plastic? The standard plastic sets do not come with it. The incadescent bulbs have melted it.
blue center flasher (resized).JPG

#1029 29 days ago

yesterday bought a deadly weapon. and i must say.. it is very well programmed, enough to do .. just like the video of AgtFlash, silver slugger. (also street level game) you see the glass is just on top of the playfield.. did 6 7 games now.. hit the glass 3 times now..

if i got the chance.. i buy more of these 7+ rating games of gottlieb.. (hope my girlfriend does not look at this forum, she has not seen the deadly weapon yet LOL)

1 week later
#1030 20 days ago

Does anyone know what the voltage should be coming from the main power supply? I’m measuring from c19 on the CPU.

My Freddy is having strange issues that I can only think are coming from low DC volts or flaky game ROMs.

I’ve been having strange sound issues and now the boiler door seems to have a mind of its own all of the sudden.

#1031 16 days ago

Anyone know if someone sells kits with new caps and stuff for refreshing the boards in System 3 games? I'm thinking it would be a good idea for me to do that on my Stargate.

Quoted from Jakers:

Does anyone know what the voltage should be coming from the main power supply? I’m measuring from c19 on the CPU.
My Freddy is having strange issues that I can only think are coming from low DC volts or flaky game ROMs.
I’ve been having strange sound issues and now the boiler door seems to have a mind of its own all of the sudden.

Have you done the ground mods yet? People claim doing so can reduce grounding issues with the plugs and prevent weird issues. Here's a good guide on how to do it: https://www.flippers.com/gottlieb_ground_cures.html#System3

#1032 16 days ago

Anyone know where I could get a working main and aux sound board for my Silver Slugger?

#1033 16 days ago
Quoted from heyitsjoebob:

Anyone know where I could get a working main and aux sound board for my Silver Slugger?

Time constraints cause of Pincinnati? If not, I suggest sending them out to be rebuilt.

#1034 16 days ago

Im having a troublesome issue with my Stargate.

My game:

The good:

Tournament mode works well, and the game is set on free play.

Mostly all LED lights.
New shooter lane switch, sarcophagus switch, outhole switch, trough switch.
A "light" spring was added to the trough gate to keep balls from bouncing back and triggering false ball counts.

New outhole coil and ball release coil.

New cabinet flipper switches.

Flippers completely rebuilt with complete kits from PBR.

Optos checked and cleaned

Drop target assemblies cleaned and inspected.

Kicker targets cleaned and rebuilt.

All connectors in the game have been reseated, all chips reseated, V4 game ROM and V3 DISPROM installed.

ColorDMD installed with German repro "clear" speaker panel plastic.

Sound is crisp and minimal hum from the cab speaker.

The game plays fast and powerfully and is a "joy" to play!

All switch test and lamp tests are perfect.

The bad:

Problem #1:

During extended gameplay, during multiball, the game loses track of the ball count.

The multiball modes end early, with as many as 3 balls still in play.

The flippers die and the balls drain out.

The it sets up ready for the next ball.

This doesnt happen in all games, and it happens on random mutliballs, sometimes twice in the same game.

It is mostly apparent in a Ra's bracelet mode when all 4 balls are in play, drain one ball and the mode ends draining the other 3.

Again its random and can happen in the glidercraft multiball but only have 2 balls during the mode but when 1 drains the flippers die and the mode ends.

This never happens in a short game, but always happens in a long "great" game.

This happens with the original trough switch as well as the new one recently installed.

It does not seem to be a TILT or a SLAM as there is no indication on the screen.

Problem #2 (could be related to problem #1)

If I take out all 4 balls and replace them "one by one", the outhole solenoid hesitates for up to 3 seconds to fire on the first ball but seems fairly instant on the last 3.

The outhole coil is plenty strong (and its the correct coil and resistance is perfect on it). but it isnt strong enough to clear 2 balls in the lower side of the trough.

It seems that the outhole kicker might also die when the flippers die?

This is somewhat of a problem as, when the mode ends early and flippers die, sometimes 2 balls can get trapped in the lower part of the trough and then the game is unplayable until I remove the glass and manually help one of the balls over the top to the higher side.

Wall voltage is a fairly continuous 117v to 121v.

I havent done any "ground" mods.

I have gad the game for a few months and this behavior is recent.

Any insight to this would be helpful

I started a thread here"

https://pinside.com/pinball/forum/topic/stargate-woes

#1035 16 days ago
Quoted from mystman12:

Have you done the ground mods yet? People claim doing so can reduce grounding issues with the plugs and prevent weird issues. Here's a good guide on how to do it: https://www.flippers.com/gottlieb_ground_cures.html#System3

I could have sworn this game already had the ground mods done but I just looked and sure enough, it’s the original connectors. I guess I have a project for tomorrow.

Thanks for the suggestion.

#1036 11 days ago
Quoted from heyitsjoebob:

Anyone know where I could get a working main and aux sound board for my Silver Slugger?

Which sound board does Silver Slugger use? I've got a working MA-1629 I'd consider selling. I don't know where you get aux boards, I don't think they go bad often.

#1037 11 days ago
Quoted from latenite04:

I don't know where you get aux boards

Ebay most likely.

Lots of brand new boards are on sale there.

1 week later
#1038 1 day ago

Can anyone shed some light on this.......

After moving my machine from the basement (which requires back box removal), I hooked up the everything back up and powered up the game. Well at least I thought I had everything reconnected. Turns out I overlooked the P1 plug on the CPU board. I have playfield lighting but that is about it. The DMD is out and the game will not boot. I didn't smell anything burning, etc. and turned the game off rather quickly when I realized there was an issue. Any ideas on what may be wrong?

#1039 1 day ago
Quoted from goofy1994:

Can anyone shed some light on this.......
After moving my machine from the basement (which requires back box removal), I hooked up the everything back up and powered up the game. Well at least I thought I had everything reconnected. Turns out I overlooked the P1 plug on the CPU board. I have playfield lighting but that is about it. The DMD is out and the game will not boot. I didn't smell anything burning, etc. and turned the game off rather quickly when I realized there was an issue. Any ideas on what may be wrong?

Just double check all the connectors are plugged in. Can you post pictures? Maybe someone can help spot something out of place.

#1040 1 day ago

Robotworkshop - I'll go through it again tomorrow to double check everything. I'll get some pictures then too.

#1041 1 day ago

How many of you have the optional communication adapter installed in your System 3 machine? They seem to be more popular in machines that were re-imports since I think the accounting was more strict overseas.

I pulled one out of a re-import that had a rusty DB-9 connector. Instead of fixing that I removed that connector and reworked the board to add a Bluetooth module. Now if I want to see the audits I can just connect my phone to the game. It works surprisingly well. I can leave it paired but as soon as I connect if the game isn't in a game it will generate the basic audits and send them to my phone then I disconnect. All without opening the coin door. If I want the full audits then I need to open the coin door and navigate to the audits and tell it to print the full audit when I connect the phone. I always disconnect after otherwise the game complains about removing the printer.

When I get a chance I plan on writing up the mod. I only have the one System 3 game but if I had others I would rename each Bluetooth adapter then it would be easy to connect to one at a time to pull audits.

Promoted items from the Pinside Marketplace
From: $ 14.00
Playfield - Toys/Add-ons
Twisted Tokens
Toys/Add-ons
From: $ 7.99
Playfield - Toys/Add-ons
The Pinball Scientist
Toys/Add-ons
$ 11.95
Playfield - Toys/Add-ons
ULEKstore
Toys/Add-ons
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
Sound/Speakers
$ 56.95
Cabinet - Shooter Rods
Super Skill Shot Shop
Shooter rods
From: $ 5.00
Playfield - Other
Rocket City Pinball
Other
From: $ 1.25
Playfield - Other
Rocket City Pinball
Other
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
Armor and blades
There are 1,041 posts in this topic. You are on page 21 of 21.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!