(Topic ID: 93142)

Gottlieb System 1 Cleopatra repair question


By markronz

4 years ago



Topic Stats

  • 31 posts
  • 10 Pinsiders participating
  • Latest reply 4 years ago by wayner
  • Topic is favorited by 4 Pinsiders

You

Linked Games

Topic Gallery

There have been 9 images uploaded to this topic. (View topic image gallery).

IMG_4533.JPG
IMG_4531.JPG
IMG_4532.JPG
IMG_4530.JPG
03256-696.png
003.JPG
002.JPG
001.JPG
A1J6_A1J7.jpg

#1 4 years ago

Hello everyone. I am attempting to fix up my first pin. It's a Gottlieb Cleopatra, which is a System 1 pin. I bought a new CPU and power supply for it. Then I rewired all of the pin connectors. The driver board is original and was left alone before it appeared to be in very good condition. Well I hooked everything up today and powered it up for the first time. Everything looked great. All the backbox and playfield lights were lit up and dancing. The 4 score displays all light up. They alternate from all single zero's in each position to displaying the default high score of 320,000. So as far as I can see, the machine does boot up normally. However none of the buttons on the coin door work. I can't add credits. The start game and test buttons do nothing. I've checked the molex in the bottom box and it's connected and seems fine. Then I checked the A1-J6 connector attached to my new Ni-Wumpf Cpu board. Being that I just rewired the connector, all the pins look pristine and seem just fine to me. So I can't figure out what the problem is. One time I removed the A1-J6 connector while the machine was still on. Then I connected it again and the game came to life for some reason. It started a new game, and it worked for one single ball The flippers worked. The pop bumpers worked and a few of the other targets worked. As soon as I drained the ball, the ball just stayed there in the bottom. It didn't kick over to the launch area at all. So I was back to square 1, nothing on the front panel was working.

So does anyone have any ideas what might be wrong here? Doesn't make any sense to me, but I'm new to pinball repair, so very little does.

#2 4 years ago

You need to double check all the work you did especially the crimping and new contacts you added to the connectors. You may have a flaky or intermittent connection. You may also want to ohm out all the connections.
Are you getting the relay double click on boot up?

#4 4 years ago

This is what it looks like when it boots up:


I'm new to pinball machines in general, not sure exactly what the relay double click is, or if you can maybe hear it in my video above?

I thought maybe slam switch too, but the displays look normal and have 0 or the high score on them, so that looks ok to me. Also, on a visual inspection both the slam switch and the rollover switch appear to be closed.

I can redo the crimping wiring on A1-J6, but it's weird to me that none of it would work. I mean, I would expect if I messed up a single wire that that one thing wouldn't work. Is that correct? Or would nothing work if one single contact was jacked up? My point is, I can see if I screwed up a single one or something, but I surely did not screw up crimping every single pin on that connector.

#5 4 years ago

Does that boot up look like it should? From what I can tell it seems to start normally. I tried to boot it up with A1-J6 entirely disconnected and the bootup still looks exactly the same. Is there a way I can test the continuity of the lines from the buttons to the molex connector? How about what you said early to "ohm out all the connections", I'm new, what exactly does that mean? I have a multimeter, just not sure how to test the wires like that. Can anyone give me some tips on all this?

#6 4 years ago

Ohming out your connecting is testin the continuity of the circuit. There should be a setting on your digital multimeter that will beep when you touch the two leads together. This will help you "ohm" or " ring" a circuit.

What you are describing sounds like a problem with the return line in the switch matrix for that group. All of the switches you described share the same return. Like you said, you would think at least one of the switches is working but if your return is missing you will not get any of the coin door switches to work. I beleive the rerun line for that set is A6J6-6. Check wire six on J6. I think its a black with two blue stripes. Code 066??? Not exactly sure on that though.

Either way I would suspect a problem with that return.

#7 4 years ago

I'm assuming you meant A1J6-6 not A6J6-6. I looked at my molex connector again. It looked totally fine to me. But just in case I severed all the wires and re-pinned them and put them back into the molex all over again. No change. So I am fairly certain my new molex isn't to blame. I also double checked the slam switch and the tilt ball rolling mechanism. Both appear to be closed as I'm told they should be. (Not to mention that it's not really showing symptoms of being tilted.)

I am truthfully not sure how to use my multimeter to test the continuity of the circuit. Seems like to do so you'd have to touch one wire to the molex connector and one to the other side by the coin door. I hope my wires on my multimeter are long enough to do that.

Anyway, I am just about to leave for vacation for about a week. I will check back in once I return and I've had the chance to look at this some more. So close to getting this pin up and running finally. Frustrating!

#8 4 years ago

Did Cleo ever work?
I have a Cleo as well as many other System 1s. I'll look at the schematics Thursday and write some stuff up to check. In the mean time, enjoy your Vacation!

#9 4 years ago

Also. where are you located?

#10 4 years ago

A1-J6 wiring (from Cleopatra Manual)

A1J6_A1J7.jpg

#11 4 years ago

Cleo has not worked since I bought it. Its in good condition but had the typical battery damage. I had to replace the CPU and power boards. And I'm in Green Bay, WI.

Thanks for everyone's help! Will check back in about a week!

#12 4 years ago
Quoted from woz:

A1-J6 wiring (from Cleopatra Manual)

Woz, a lot of times the wire colors in the System 1 harnesses don't match up with what the manual says. I see this a lot on the System 1 Pins. Will have to wait for OP to get back and verify colors. Still a good aid for troubleshooting.

#13 4 years ago
Quoted from pdman:

Woz, a lot of times the wire colors in the System 1 harnesses don't match up with what the manual says.

Some games (like my Genie) don't have the correct colors listed initially, but do have a correct code for each wire. Like they changed colors mid-way thru a run. More info at the link below.

http://www.pinrepair.com/sys1/index.htm#flippers
(scroll down to Gottlieb wire colors)

This obviously doesn't account for colors fading, which makes things tough. When in doubt, check the colors of the wires on either side of the wire in question.

#14 4 years ago

Explaining how to use a multimeter can be challenging. My best advice would be to head over to YouTube and watch a couple of short videos. It's a great resource and seeing it done is much easier to understand than trying to interpret posted instructions.

You'll be fine. You will figure out the problem. Take your time. Don't rush and try to enjoy fixing the machine no mater how frustrating it can be. Enjoy your vacation!

#15 4 years ago
Quoted from pdman:

Woz, a lot of times the wire colors in the System 1 harnesses don't match up with what the manual says. I see this a lot on the System 1 Pins. Will have to wait for OP to get back and verify colors. Still a good aid for troubleshooting.

I know..but at least he's got something to work with

#16 4 years ago

Ok, I am back from vacation! St Louis was pretty fun. Now I'm back and ready to start looking at the pinball machine again. I bought a nice multimeter and I've started to look more closely at my A1-J6 connector. The multimeter I bought has that audio mode for testing connectivity, so that makes things pretty easy. If it beeps, I'm gravy. So anyway, I started to test the individual parts. There are 9 total wires. The colors to appear to match the chart that woz listed above. But I had all the original wiring there to go off of, so I didn't really think that mixing up a wire was the problem. Anyway, four of the wires have a resistor in the middle. Those ones were a little difficult to test. Here's a picture of what I tested
001.JPG
The four wires that don't have resistors, I was able to check all the way from #1 on my pic, directly to #4. The other five wires, I had to test in parts. So I tested from #1 in my pic to #2. Then from #3 in my pic to #4. All 9 wires did check out when tested in parts like that.

Then in this picture, I just tested the other end of the molex connector there. I tested from #5 to all #6(all the various connectors on coin door, tilt switches,etc. These tested fine as well.
002.JPG

The molex connector itself seemed ok and seemed to fit together snugly and seems just fine as well.

Now, as I mentioned earlier the five wires with resistors I could NOT test from section 1 to 4 directly. Should I be able to? Or do the resistors restrict such testing? The reason I ask is that there does appear to be some corrosion around some of those resistors. See this pic:
003.JPG
But the resistors themselves appear ok, as far as I can tell with my naked eye. And as I said, either ends of the wiring tested fine, and all these appear to be connected to the resistors with solder solidly.

I appreciate any help you all can give me.

#17 4 years ago

Those are diodes not resistors.

#18 4 years ago

Those are diodes not resistors

#19 4 years ago

check the diodes in circuit with the coin door unplugged. .4-.6 volt reading with meter on diode setting one way and open the other way (swapping red and black lead from meter)

Then check from diode bank all the way up to the boards. I'd say a bad ground.

#20 4 years ago

Ok, sorry, diodes, not resistors. My bad. Either way, should I be able to test the continuity with those diodes in place? I can't, so does that mean they're bad? If I'm understanding you correctly you want me to not do continuity testing any more, and you want me to measure the voltage instead. Will that work and measure correctly but the the continuity test wouldn't work?

As for the specific testing you're telling me I should do, could you be more specific? Talk to me like I'm an idiot, please. I'm very new to this.

#21 4 years ago

Some digital multimeter manufacturers equip their meters with a special “diode check” function which displays the actual forward voltage drop of the diode in volts, rather than a “resistance” figure in ohms. These meters work by forcing a small current through the diode and measuring the voltage dropped between the two test leads. (Figure below)
03256-696.png

Meter with a “Diode check” function displays the forward voltage drop of 0.548 volts instead of a low resistance.

The forward voltage reading obtained with such a meter will typically be less than the “normal” drop of 0.7 volts for silicon and 0.3 volts for germanium, because the current provided by the meter is of trivial proportions. If a multimeter with diode-check function isn't available, or you would like to measure a diode's forward voltage drop at some non-trivial current, the circuit of Figure below may be constructed using a battery, resistor, and voltmeter

#22 4 years ago

Do not have the game powered up while doing this check.

// Error: Image 244678 not found //
#23 4 years ago

I suggest some reading material to help get you going:

pinwiki.com
General info including basic testing: http://www.pinwiki.com/wiki/index.php?title=General
System 1 specific: http://www.pinwiki.com/wiki/index.php?title=Gottlieb_System_1

pinrepair.com
General info including basic testing: http://www.pinrepair.com/begin/index.htm
System 1 specific: http://www.pinrepair.com/sys1/index.htm

#24 4 years ago

Thanks for your replies. And thanks for the links btw75. i had read through the pinrepair guides already, but not the pinwiki ones, which I have now read as well.

To recap a bit of what I've done so far:
- I replaced the power supply with a new Rotten Dog power supply replacement. Since this is new, I obviously did not perform any ground modifications to it or other capacitor repairs mentioned in the guides
- I replaced the CPU with a Ni-Wumpf System 1 replacement. As noted in their manual that came with it, ground modifications are not needed for this new board, so I did not do them.
- The only thing that I didn't replace was the driver board. That appeared to be in good shape. However, since the game isn't working properly yet, and replacements are relatively cheap, I did just order a Rotten Dog System 1 Driver board replacement last night. I should get it in 2-3 days. I don't know that this will fix my current issues, but at least I will have the piece of mind that I've replaced all the boards with brand new ones that should be more reliable. In the mean time, I did add a ground wire from the driver board's negative lead of capacitor C1 to the backbox ground plane, as recommended in the guide.
- I bought a brand new replacement power supply to CPU board harness.
- I bought a brand new system 1 MPU to driver board harness.
- I re-pinned all of the rest of my molex connectors with new pins and new connectors. For the A1-J6 connector, I've re-pinned that twice now.
- I double and triple checked all of my molex connectors against the stock ones and verified that I have all my wires in their correct places.
- I verified that my score displays all light up ok, and do not appear to be blown or otherwise damaged via the instructions in the guide.
- I verified that the roll tilt switch and the slam tilt switches are both Closed.
- I tested all of my fuses with my multimeter for continuity and all passed.
- I checked the resistance of all my coils, all were above 2 ohms.
- I checked the bridge rectifiers in the bottom board. These were a little more difficult to test because the colors did not match up to all green wires as noted in the guide. But I believe that I did check them properly anyway.
- I did do the diode check on the coin door switch diodes, as eavedesian notes above.
- I did do a continuity check, as I noted in my previous post, for all the wires on the A1J6 connector, which all seemed to pass as I mentioned earlier.
- So then I started to focus on the ground wire. I put one pin from my DMM on the ground (pin 1) on A1J6, then I used the other pin from my multi meter to touch all the grounds around the entire game. I touched the ones on each button, slam switch, rollover tilt, each point on the ground plan, etc, everywhere I could find that was ground and each one tested fine for continuity.

So at this point, that's really all the tips I could find in the guides on what to check. My machine does start up, like shown in my previous video, and it goes into attract mode. But still, none of the buttons on the coin door work. So I can't add coins, go into diagnostic/service mode, or start a game. It's just a beautiful, flashy, useless pin once turned on. I am going to wait for my new driver board to arrive and put that in there. But to be honest, and I know I don't know a lot about this stuff, I don't really have a lot of faith that its going to correct this problem I'm having. I feel like I went through all the steps, tested everything I was supposed to, and replaced just about everything as well. So I really don't get what I'm missing.

If anyone has any tips for me, please let me know. I must be missing something obvious or just missing something due to my lack of experience here. So I'd appreciate any help anyone can offer me.

#25 4 years ago

OK, a few updates and more questions.

I did notice that the coin door was "humming" when the machine was on. I noticed that this coil was permanently triggered on. At least I believe that's called a coil, correct me if I'm wrong. Again, still learning all this terminology.
IMG_4531.JPG

There is a bar that seems to connect into this coil, shown here:
IMG_4530.JPG
When I jiggled that bar it connects to back and forward, the game started to do really weird stuff. The humming would start and stop, so I thought that was progress. I don't think this coil is supposed to be permanently on like that. Now by "weird stuff" I mean that the game entered into the settings mode and then began to cycle through all the settings for the Ni-Wumpf board. If I jiggled that rod, it would move to the next setting, but it was automatically toggling that setting too. Like for example I got to the number of balls setting, and the setting would automatically increment from 1 to 2, to 3, etc, and then just keep circling back around like that. Through jiggling this board, I think I finally got to the setting to reset the whole board, which is what I actually wanted to do because I wasn't sure if Cleopatra was correctly selected. So anyway, I reset it and then shut off the machine.

Next, I replaced my test switch. I was told those can sometimes go bad. This did not help anything, but at least I know it's a working switch now.
IMG_4533.JPG
Then I inspected the coin switches. This one appeared to have it's wiring a bit off compared to the other switch. So I wrapped it around the switch as shown in the picture, because that's what the other one looked like.
IMG_4532.JPG
If someone could let me know if that looks correct that'd be great.

Now anyway, that wire that I moved above is connected to the rod, which is connected to the coil. I don't get what any of those pieces are for. Can someone help clue me in on what it should look like and how it should perform? Does this make any sense to anyone?

For whatever reason when I turn the game on now, there's no humming any more. If I intentionally move that bar, it does hum when the coil connects, but thats it. But now it no longer cycles through the game settings at all. So I'm just sitting here at the game select screen. It says Cleopatra on the screen (because that's the first option) but I can't get it to select no matter what button I hit or what bar/coil I jiggle... help!

#26 4 years ago

That wire bar you have circled shouldn't be touching the switch - bend it out of the way. Check the other coin switch as well and hopefully you'll be able to add credits!

That coil is the coin lockout coil. The idea being that when the game is not powered on and unable to accept credits the coil is de-energised and any coins inserted are rejected by the coin mech due to to wires diverting the coin. When the game is powered up the coil is activated, the reject wires do not divert any coins and are they accepted.

For home use you can safely remove the wire from the coil if the humming sound bothers you (just make sure you insulate the wire ends).

#27 4 years ago

YESSSSSSSSS! Not sure if that's enough S's to appropriately capture what I'm feeling! I moved those wire bars off of the coin switches and now everything started to work!!! Booyah! I knew it had to be something simple! When I got the machine, one wire bar was wrapped around the coin switch, and the other was not. So I copied it and did the same with the other, wrapping them both around like in the pic. Looks like I chose the wrong one to copy. If I would have just took both of them OFF of the coin switch, then I would have saved myself a whole lot of headaches! Not to mention $60 for the driver board I bought last night but apparently don't really need! Oh well, just super excited that its working! I won't get to play with it for a day or two more, but I hope that will be the last of my problems.

#28 4 years ago

Glad to hear you got it working! I've got a Cleopatra project game that I really need to get going. Last time I played a working Cleo was 1979!

#29 4 years ago

That's one of the contacts I was telling you to make sure it wasn't closed. The coin lockout wire was bridging the coin switch closed which wasn't letting you register another switch. That's why I said to pull the coin mechs out.

Remember when I was telling you "The boot up chiming didn't sound right? It almost sounds like you're adding a credit." That's exactly what was happening.

Check the bootup sequence now. Is there still writing in score displays 1 and 3? If not, then that quick blurb was probably showing a stuck switch. Check the manual it will probably give you a heads up about a stuck switch.

Glad its working. Fun game. Rebuild the flippers and it will play great!

#30 4 years ago

I did take out the coin mechs, but that wire was still wrapped around the coin switches. And yeah, you were spot on with that sound. Must have been putting in a credit at that same time or something. Starting to clean it up now. Just replaced all 5 drop targets, man that was a pain in the butt!

4 months later
#31 4 years ago

"Alls well that ends well" markronz. A good result and as a result you have learned things about the machine you would otherwise not have known-that is one of the +s of owning a pin!

Promoted items from the Pinside Marketplace
€ 8.40
$ 49.00
$ 200.00
Lighting - Interactive
Professor Pinball
$ 129.00
Displays
Pappy's Pinball Palace
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 269.99
From: $ 50.00
Gameroom - Decorations
Gameroom Mods
$ 4.95
$ 21.00
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
£ 39.00
Lighting - Led
PinballToys
$ 9.95
Playfield - Toys/Add-ons
pinballmod
$ 24.99
Lighting - Led
Lee's Parts
From: $ 12.99
Eproms
Matt's Basement Arcade
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 30.00
From: $ 7,500.00
$ 175.00
Lighting - Interactive
Professor Pinball
$ 20.00
Electronics
Yorktown Parts and Equip

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside