(Topic ID: 253225)

Gottlieb SEA-BELLES PLAYER STEPPER PROBLEM


By jbhjukebox

32 days ago



Topic Stats

  • 7 posts
  • 2 Pinsiders participating
  • Latest reply 27 days ago by jbhjukebox
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 4 images uploaded to this topic. (View topic image gallery).

Scan_0003 (resized).jpg
Scan_0002 (resized).jpg
Scan_0001 (resized).jpg
seabelles2 (resized).jpg

#1 32 days ago

I have a 1956 Gottlieb SEA-BELLES I'm having a problem with. Game has set for years and am getting it up and going. Having a problem with the player and ball in play stepper. It's a two player game and if you play one player it all works fine until ball four drains and it goes to ball 5 player two. The stepper pulses twice between each ball but on the 5th ball the stepper pulses 3 times and sends it to player two ball 5. Looking at the schematic you have several score motor switches involved. Not sure where to start to find why it's stepping an extra position. I am experienced at EM games but there is always more to learn. Any help would be appreciated.

#2 32 days ago
Quoted from jbhjukebox:

The stepper pulses twice between each ball but on the 5th ball the stepper pulses 3 times and sends it to player two ball 5. Looking at the schematic you have several score motor switches involved.

Can you post the relevant part of the schematic?

#3 32 days ago

Here is the schematic showing the add balls coil. Not sure why ball 5 goes to 2nd player. Thanks for looking at this.

seabelles2 (resized).jpg
#4 32 days ago

Can you scan farther down on the Balls Played Unit and also include the legend, ie-what relay each letter corresponds to. Thanks

#5 31 days ago

More schematic. Thanks for looking.

Scan_0002 (resized).jpgScan_0001 (resized).jpgScan_0003 (resized).jpg
#6 31 days ago

I would check the Balls Played Unit (BPU) for correct alignment and solid contact by stepping it by hand. I had a similar thing happen on my Mayfair and that's where it was.

#7 27 days ago

Checked and readjusted ball count unit many times, no change. It to work correctly a few times (don't know why) then back to ball 5 goes to second player. Something is out of adjustment. Still not sure where to go look for the problem. Trying lots of things. Thanks for looking and any advise.

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
$ 13.00
$ 25.00
Apparel - Unisex
Project Pinball Charity
From: $ 125.00
Playfield - Toys/Add-ons
Pinball Mod Co.
$ 24.99
Lighting - Led
Lee's Parts
$ 225.00
Playfield - Toys/Add-ons
Pinball Mod Co.
$ 7,899.00
Pinball Machine
Classic Game Rooms
$ 69.50
Playfield - Toys/Add-ons
Lermods
$ 159.00
Playfield - Toys/Add-ons
Sparky Pinball
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 24.99
Lighting - Interactive
Lee's Parts
$ 7.00
Electronics
APB Enterprises
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 180.00
Playfield - Toys/Add-ons
Pinball Customs
$ 9.99
Eproms
Matt's Basement Arcade
$ 24.95
Playfield - Toys/Add-ons
ULEKstore
$ 142.00
Boards
nvram.weebly.com
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 30.00
Playfield - Other
Filament Printing
$ 2.50
Playfield - Decals
Doc's Pinball Shop
$ 5,599.00
Pinball Machine
Operation Pinball
€ 8.40
From: $ 6,499.00
Pinball Machine
Great American Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside