(Topic ID: 189649)

Gottlieb Jet Spin not scoring

By Sodacrack

4 years ago



Topic Stats

  • 9 posts
  • 4 Pinsiders participating
  • Latest reply 2 years ago by PhillyArcade
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

IMG_2794 (resized).JPG
IMG_2798 (resized).JPG

You're currently viewing posts by Pinsider Sodacrack.
Click here to go back to viewing the entire thread.

#1 4 years ago

I have a Jet Spin that I have been working on recently and could use a little advice. The game starts and plays, but the score reels do not activate. However, the score motor does work and turn when I hit targets on the playfield. My first guess is to clean the jones plugs, but it there anything else I should be looking for.

Also, When the playfield activates a chime coil for the first time in a game the coil stays locked on until I start a new game.

I currently do not have a manual, but it is on order.

Any help is appreciated.

#3 4 years ago
Quoted from zacaj:

Do the score relays in the backbox activate? Since the chime is locking on I'd assume the score relay is as well. The score relays stay on until the score reel pulls all the way in (there's an eos switch). Clean all the contacts on the score relays and check for voltage at the reels.

Well, here is what I found out. I cleaned the jones plugs and manually advanced some of the score reels off of zero. I started a one player game and the score reels reset to zero, but the score reels are still not scoring during game play.

If I start a one player game and just drain the ball without hitting any targets, it just stays on player one and ejects the ball without advancing the ball count or player.

If I start a one player game and hit a target the chime coil locks on and score reels do not come on. Then when I drain the ball it advances to the next player and ejects the next ball. It then continues to advance through players as the ball is drained.

#4 4 years ago

I was reading the start-up sequence for the coin unit and if players 1 & 4 are lit on the backglass, the coin unit is not stepping up from the zero to one player position. I will check tonight, but I think 1 and 4 are lit on my Jet Spin when I start a game.

#7 4 years ago
Quoted from zacaj:

It sounds like whatever contact on the score relay sends power to the reel either isn't making good contact or isn't getting voltage itself. When resetting the reels are energized by different relays, but that does tell us the reels are at least getting voltage.

I found a couple of problems with the coin unit. One of the problems was that it was binding up at the screw that I circled in the photo. The threads broke off the screw as I was removing it. Do you know where I can find another one?

IMG_2798 (resized).JPG

IMG_2794 (resized).JPG

You're currently viewing posts by Pinsider Sodacrack.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside