(Topic ID: 117709)

Gottlieb Genesis problem with reveal


By ngoett

4 years ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 7 months ago by guard
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 4 years ago

Have a strange problem that we cannot seem to figure out. When the playfield is up the reveal relay will click on and reveal the robot woman thing perfectly fine. But as soon as I put the playfield down into the game the relay will turn on but will not hold to keep the motor running on the reveal (it just barely moves and stops) so messed with the switch stack and is now very sensitive but still doesnt work correctly... Tried it with the playfield sitting on the brackets somewhat out of the game and it works fine again. Just do not know why it does not work once the playfield is dropped down into the game? Any ideas? Thanks for the help!

#2 4 years ago

bump for help

#3 4 years ago

Sounds like something gets moved each time you lower the playfield. Check connectors to make sure they're not loosely connected and do continuity tests on all the wires connected to the motor and switch all the way to the backbox. You will probably need to break out the manual to trace to which pins they eventually lead to in the backbox. Obviously, you'll need to check this while the playfield is down and throwing a fault, so maybe use a lead wire with an alligator clip on the contact points under the playfield, then connect that to the multimeter (then use the other lead to connect to the appropriate wires in the backbox).

Also, check the left and right sides of the playfield to make sure none of the wires are getting squashed when the playfield goes down. If a frayed wire is making contact with grounded metal, things could be going haywire there.

#4 4 years ago

Thanks for your reply. Ill get into that a report back!

#5 4 years ago

problem solved. was what i figured all along. relay bracket needed bent slightly so that the coil was closer to the plate to trigger the switches. seriously spent hours messing with it yesterday and got it just right today!

4 years later
#6 7 months ago

Still puttering on mine.....about 5 hours in and it works about 3 out of every 4 times. Unless, just like you, the playfield is up, and then it works every time.
[I know it's an old thread but the info helped so.....]

Promoted items from the Pinside Marketplace
From: $ 49.95
€ 8.40
$ 14.99
Electronics
PinballElectronics.com
$ 299.00
Displays
Boston Pinball Company
From: $ 19.95
From: $ 18.00
Apparel - Men
Pinside Shop
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 28.50
Playfield - Toys/Add-ons
ULEKstore
$ 5,799.00
Pinball Machine
Little Shop Of Games
$ 14.00
Electronics
Yorktown Parts and Equip
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside