(Topic ID: 262309)

gottlieb buck rodgers drop target issue

By willie0912

2 years ago



Topic Stats

  • 7 posts
  • 4 Pinsiders participating
  • Latest reply 2 years ago by willie0912
  • No one calls this topic a favorite

You

Linked Games

#1 2 years ago

Got a Buck Rodgers, it had a lot of problems which most are now solved. I put a new Ni-Wump cpu in it, changed the power supply and tried several different driver boards. My main problem is the red drop target reset coil stays energized. I changed the coil and diode and checked all the switches on that bank with no luck. Any ideas would help, Thanks Bill

#2 2 years ago

There should be a fuse that blows in that circuit when a solenoid locks on.

The switches have no bearing on the drop reset locking on. They only come into play in gameplay when you get all of them down, the mpu senses this and runs a routine to reset them at that point.

You're either got a short in the wiring or the driver board is still bad - also system 1's should all have their grounds linked together see pinwiki, pinrepair.com, or flippers.com for details on that.

#3 2 years ago

Is Buck Rogers one of those games that has an under the playfield transistor? If so perhaps it is bad or perhaps the lamp Drive transistor that fires the under the playfield transistor. I don’t have a schematic for that game or I would check.

#4 2 years ago

I didn't think the switches had anything to do with it so I am glad you clarified that for me. I am leaning towards a problem with the driver board also, The strange thing is it fried the coil without blowing a fuse. And to the second person who replied to me no it does not have the under the playfied transistor boards, but thanks anyway.

#5 2 years ago

Are you sure the coil is staying energized and it's not just a magnetized coil stop. Did it fry the second coil?

#6 2 years ago

No it did not fry the second coil but I also shut it off as soon as I see it engage, I never thought about the coil stop but I will check it out next week when I go back to where the game is located, Thanks again

1 week later
#7 2 years ago

Well I found the problem with the drop target issue. I pulled out the pin on the connector for that driver and even though it was a new terminal it had to be bent out a little more and it now works fine. Thanks everyone for your input.

Promoted items from the Pinside Marketplace
From: $ 2.99
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 1.25
Playfield - Other
Rocket City Pinball
From: $ 1.00
Playfield - Other
Rocket City Pinball
$ 20.00
Various Novelties
GC Pinball
From: $ 55.00
Gameroom - Decorations
Pinball Photos LLC
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!