(Topic ID: 291876)

Gottlieb 6-digit display flicker

By DickHamill

6 months ago



Topic Stats

  • 8 posts
  • 4 Pinsiders participating
  • Latest reply 6 months ago by G-P-E
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

displaylayout6 (resized).jpeg
IMG_2712 (resized).jpg
IMG_2714 (resized).jpg
IMG_2713 (resized).jpg
IMG_2711 (resized).jpg

You're currently viewing posts by Pinsider G-P-E.
Click here to go back to viewing the entire thread.

#4 6 months ago

It is an induced pulse from another signal. Hanging a scope probe puts a very tiny but just enough capacitive load to eliminate the narrow pulse.
Probably caused by a poor connection on that signal somewhere on the board. If you can't find it - get a 15-20pF capacitor (similar value to your scope lead which fixes the issue) with a 100V rating, attach between pin 3 and ground. Yes, a kluge but for a one-off fix...

1 week later
#8 6 months ago

Replacing the three caps wouldn't have been a bad idea. I imagine a bad bypass capacitor (especially C1) could have caused similar issues. These don't fail often but are sometimes physically broken.

You're currently viewing posts by Pinsider G-P-E.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside