(Topic ID: 138394)

Got my Haunted House! Need help!

By Camvr2013

8 years ago


Topic Heartbeat

Topic Stats

  • 20 posts
  • 7 Pinsiders participating
  • Latest reply 8 years ago by Fortytwo
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

20150909_222647.jpg
20150909_222641.jpg
#1 8 years ago

So I brought home my first pin today, yay! I decided to take the plunge and jump right in with a Sys 80. So it's home and now I'm trying to diagnose the issues causing it not to fire up a game. I'm not finding many troubleshooting guides. Here's a video of what it's doing. Does anyone have any insight as to what the issue may be?

Thanks in advance!

#2 8 years ago

Did you add credits? Does it have a ball in it? Did you push start?

#3 8 years ago

The game doesnt have free play, so if you start a game without credits (my BH) acted funny too. I did the alligator clamp mod to add freeplay quick. or drop some coins in

#4 8 years ago
Quoted from northvibe:

The game doesnt have free play, so if you start a game without credits (my BH) acted funny too. I did the alligator clamp mod to add freeplay quick. or drop some coins in

Can you expand on the alligator clip mod? Is it documented somewhere? Sorry, I'm new to all of this!

#5 8 years ago
Quoted from Camvr2013:

Can you expand on the alligator clip mod? Is it documented somewhere? Sorry, I'm new to all of this!

I had a HH that had a installed credit button on it. You just wire it with your coin switches so when press the button it adds a credit. There also a speech mod mine had too.

#6 8 years ago
Quoted from 2Kaulitz:

I had a HH that had a installed credit button on it. You just wire it with your coin switches so when press the button it adds a credit. There also a speech mod mine had too.

Did you add multiball too ?

#7 8 years ago
Quoted from labnip:

Did you add multiball too ?

Never got around to it but the guy that has it now is going to at some point.

#8 8 years ago

Hello,
I am currently working on my second system 80 game. I would suggest before getting too hung up doing the basic updates and checks. It takes a couple evenings and cost less than $50 if done right. If they have been done great!
Slam switch mod
Power supply update
Board ground mod
Rewire CPU to interconnect (doecent electronics 18$)
Re pin powersupply to CPU wires.
What you get a chance pop bumper boards updates.

Currently my black hole randomly half doesn't work and all I have to do is reseat the interconnect plugs, I have the rewire kit in the mail.
There is a good write up on system 80 in the pinwiki
Fortytwo

#9 8 years ago
Quoted from Camvr2013:

Can you expand on the alligator clip mod? Is it documented somewhere? Sorry, I'm new to all of this!

Yeah! Let me get on my laptop

#10 8 years ago

ok..odd. I can't find mine, forgot where they went. This shall help though! Oh....see it now, i'll go snap a pic.

Your holy grail of info:
http://pinwiki.com/wiki/index.php?title=Gottlieb_System_80

Free play:
http://pinwiki.com/wiki/index.php?title=Gottlieb_System_80#Enabling_Free_Play

I JUST ordered and received the pascal sys 80 board. For you that board can enable new features, like MB and speach.
http://www.flippp.fr/pi80.php

incase you need new boards. Nice thing about that one, it is 3 boards in 1. And new...so less crap to deal with.

#11 8 years ago

There ya go. My black hole

20150909_222641.jpg20150909_222641.jpg

20150909_222647.jpg20150909_222647.jpg

#12 8 years ago

So tonight, first night into it and boy what a great feeling! Someone did some really half ass repairs on this machine which will require some retro-action on my part. Here's what I've discovered tonight.

Ran Self-Test and Switch 67 is open according to the report. Is this a common problem?

Additionally, I attempted to test the Sound Board, as no sound is one of the major issues I faced with this machine. Welp, running the sound test that's built into the board yielded no results. No sound or test or anything. Is it possible the board is bad? How should I proceed? Even a little sound would be promising. But nothing, even messed with the volume control just to be sure.

Thanks for everyones' help so far!

#13 8 years ago

Would recommend to get it to play first and then address the sound board. Concerning your switch 67, did u look at the switch and see if it's actually open?

#14 8 years ago

Switch 67 is the outhole on the main playfield (upper left side). I didn't look at my playfield to look at it, but it should be very easy to tell if it's a normally closed or normally open switch. Would also,check to make sure it hasn't had the wires come loose.

#15 8 years ago

Here is a link to a great reference on System 80 machines. The hypertext in the html no longer works due to the original pages no longer existing.

http://level42.ca/files/PinRepair/Gottlieb%20Sys80/index1.htm
http://level42.ca/files/PinRepair/Gottlieb%20Sys80/index2.htm
http://level42.ca/files/PinRepair/Gottlieb%20Sys80/index3.htm

#16 8 years ago

Another unusual thing about Gottlieb is their coin door "slam" switch. This normally closed switch MUST be closed or a game won't start Unlike the other pinball manufacturers where their slam switch was normally open, Gottlieb (foolishly) choose to have their slam switch normally closed (like on the prior System1 games). This means if this switch is open, or the connectors/wiring from the CPU board to this switch are broken/corroded/failed (common problem, due to CPU board battery corrosion), the game will NOT work!

Might want to check this. I have an aftermarket niwumph CPU board so this isn't a problem for my machine now.

#17 8 years ago

Yup.
Haunted house is known for wires breaking off. Had to solder several of mine after it got delivered. They're just hanging there...

#18 8 years ago

Welp got it up and running! Fuse F4 was blown and apparently this was an issue before I purchased the machine. I thought I had gone over every fuse but I had not. Game plays just fine now, but I still plan to go through and do all of the mods/upgrades. Fuse F4 didn't just blow magically and now I intend to figure out why it did. Thanks again for everyones' help so far!

#19 8 years ago

Awesome!

#20 8 years ago

Awesome, glad to hear. If you have general dead sound board I had the same issue on my Devils dare. I ended up,using the clock diagnostic procedure described in the CPU section and found I had a bad clock ic. Same clock circuit as the CPU.
Fortytwo

Promoted items from Pinside Marketplace and Pinside Shops!
$ 35.00
Cleaner
PFX PinMods
 
$ 1,159.00
Flipper Parts
Mircoplayfields
 
$ 1.49
Playfield - Toys/Add-ons
Daddio's 3D Printed Mods
 
From: $ 10.00
Playfield - Toys/Add-ons
Toast-Mach1 Mods Shop
 
From: $ 1.00
Playfield - Other
Rocket City Pinball
 
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.