(Topic ID: 243026)

GoT auto plunger super weak (video)


By Ranhorton

9 days ago



Topic Stats

  • 9 posts
  • 4 Pinsiders participating
  • Latest reply 5 days ago by Ranhorton
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

775A4ED1-A8D1-4CFF-9BDD-0B58C5697557 (resized).jpeg
Connector (resized).png

#1 9 days ago

My Got Prem auto plunger is on the fritz. Can barely fire the ball more than 6 inches 90% of the time.
Been reading through different posts about this problem and tried many different suggestions but still not working.
Thoughts?

#2 8 days ago

I’d start by making sure everything in that mech is tightly secured (check all mounting screws, etc) and moving freely

#3 8 days ago
Quoted from jitneystand1:

I’d start by making sure everything in that mech is tightly secured (check all mounting screws, etc) and moving freely

I agree - had something like this happen, and I compared it to another Stern game I had, and the launcher had just come loose. Tightened it up, and it was all good.

#4 8 days ago

Everything is tight. Took it all apart and cleaned/reassembled. It all started when I added the cliffy shooter lane protectors. Gonna check the solder welds next. Maybe I cracked one during my reassembly.
Totally open to other thoughts on what it could be.

#5 8 days ago

For shits and giggles I added a drop of silicone lubricant to the metal arm parts. The mechanism moves very smoothly. It’s like it’s not getting enough power to the coil. I also added a padding where the arm bangs into the underside of the playfield to make sure the coil plunger isn’t too high in the coil sleeve.
Feel like I’ve tried all the tricks which means it will probably be something stupid that I missed which is causing the issue.

#6 8 days ago
Quoted from Ranhorton:

It all started when I added the cliffy shooter lane protectors.

Maybe this is just me, but I think I'm 100% lifetime on the thing I did immediately preceding a malfunction being the cause of the malfunction. So after eliminating the weld joints as the cause, I'd take the shooter lane protectors off one by one and see if anything changes. If the mech itself is fine I'd have to assume it's hitting something when it fires. If not the shooter lane protectors then something underneath.

#7 8 days ago

I had a very similar issue (not quite as weak as yours). No other coils on the node board had exhibited any weak behavior either.

I tried all kinds of stuff with the mech (lube, replaced bushings, polished all the friction surfaces, slight bending of the 'fork', felt spacers to take the slop out), replaced the coil, flashing software (quick and full), and tried swapping node boards 9 and 10. None of that resolved it for me.

Ensure that the connections are SOLID in the power harness connector (at both the PS and the playfield harness). I ended up playing with the pins in the playfield harness (stretched the pins out a bit as they seemed a bit compressed) and that seemed to do the trick for me. You can even play around with a jumper wire if you want to bypass the harness connector entirely.

Connector (resized).png

#8 8 days ago

Great suggestions guys.
Gonna try both of these tomorrow and will report back.
Thanks again!

#9 5 days ago

Took everyone’s advice and I think I have it working properly again!
Adjusted the cliffy on the right of the shooter lane by a little and the ball seems to sit just a little more snug in the shooter lane.
Reseated/tightened all the molex connectors. Also made sure all wires were snug in the node boards’ molex connectors as well.
In test mode it was getting the ball up each time and 85% of the balls had enough power to get up to the elevator/upper playfield (and not too much ricocheting!).
Even out on my best score ever by far!
Thanks for all the suggestions everyone. They were a big help.

775A4ED1-A8D1-4CFF-9BDD-0B58C5697557 (resized).jpeg
Promoted items from the Pinside Marketplace
7,200
Sale Pending!
Templeton, CA
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 399.95
$ 22.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 22.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 15.00
Cabinet - Decals
ModFather Pinball Mods
7,999 (OBO)
Machine - For Sale
Kansas City, MO
$ 22.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
$ 70.00
Playfield - Toys/Add-ons
PinWorlds
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 39.95
Playfield - Toys/Add-ons
Hookedonpinball.com
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 16.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
$ 20.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
6,250
Machine - For Sale
Rocklin, CA
$ 10.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 10.00
Playfield - Decals
Mods for your pinballs
$ 10.00
Playfield - Decals
Mods for your pinballs
$ 11.95
$ 45.00
Gameroom - Decorations
Pinball Photos
$ 11.95
$ 20.00
Cabinet - Other
Pin Monk
Hey modders!
Your shop name here

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside