(Topic ID: 301767)

gold wings suddenly stopped booting up

By quantumjosh

57 days ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 45 days ago by quantumjosh
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

FCBA8041-7AED-4B0A-95EC-221333C751C4 (resized).jpeg
A29483F6-21B8-46EC-81E0-58B6DC8D8455 (resized).jpeg

#1 57 days ago

i bought a gold wings about a month ago and played it a lot. tonight i went to turn it on and the playfield lights up but the display doesnt. the backlight then lit up seemed delayed and finally the display lit up but the scroll text was moving very slowly and when i pushed play it just said 140 and the game wasnt working (pics below)
i took off the translite to check if it might have been battery damage but no batteries. the upper left board wasnt fully mounted the two bottom screw were off and there was a flashing red light not sure if its supposed to flash like that or not.
no idea where to start on this one. any advice? please help!

A29483F6-21B8-46EC-81E0-58B6DC8D8455 (resized).jpegFCBA8041-7AED-4B0A-95EC-221333C751C4 (resized).jpeg
#2 57 days ago

Try removing and reconnecting all of the connectors on the boards. Its been a while since ive worked on one, but i remember those were a known issue with these. Especially that interconnect on the bottom between the two boards.

1 week later
#3 45 days ago

it was a blown fuse seems like. changed 2 that looked suspect under the playfield and it worked again

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside