(Topic ID: 97719)

GnR not consistently launching ball up ramp


By adalogue

5 years ago



Topic Stats

  • 13 posts
  • 7 Pinsiders participating
  • Latest reply 4 years ago by PinballNZ
  • No one calls this topic a favorite

You

Linked Games

#1 5 years ago

This one has me a bit baffled. Replaced PPB relay, disassembled/cleaned ball launch assembly, and replaced BR1 and C1 on the PPB, but ball is not getting up launch ramp about 50% of the time.

50V line is 71VDC normally, and gets as low as 41VDC when firing launch coil.

I even tried firing the coil directly (grounding drive line) and no improvement.

Also noticed some issues with the 6 ball assy lockout in the trough. Took it apart, cleaned, and lubed metal pivot points but it sometimes doesn't completely actuate the assembly. Much less often than the launch issue, but maybe they are related?

1 week later
#2 4 years ago

Bumpity

#3 4 years ago

There's lots of "issues" with the ball launch on GnR.

Check which revision of ramp you have. Go look at the service bulletin for mods to the ramp angle (if applicable). It's also feasible to take 50 or so turns off the stock rated coil for a bit more zip.

#4 4 years ago

Cool, will do, thanks!

#5 4 years ago

I didn't see mention that you replaced the coil sleeve? It's always the first thing I try.

#6 4 years ago

Make sure the ball launch assy (coil and plunger) is lined up correctly so that when it strikes the ball it isn't pushing the ball into the side of the launch lane or ramp.

Reduce the height of the metal ramp as much as possible to reduce the steepness of the ramp. There is some adjustment normally where the ramp mounts onto the backboard of the playfield. Drop it as low as possible.

Even take a video of the ball being shot up the ramp a few times and then try to watch back in slow motion and see if the ball is hitting the launch lane or ramp anywhere and slowing the ball down.

#7 4 years ago

Yes, I put in a new coil sleeve and cleaned the plunger. I'll check the ramp, connection, and last resort unwind the coil.

Thanks again!

#8 4 years ago

Worked on it more last night, new symptom - other coils weak also. Some HV coils (flipper, auto launch) and LV coils (upper left saucer kick out, shooter lane feeder) are weak. I've already rebuilt the HV solenoid supply on the PPB (BR and filter cap), haven't touched the LV solenoid supply.

I found a 2.5 ohm resistance on the 0.25A SB fuse for F7 (mains fuse) on the PSU, replaced it, no changes.

Bad connector? Rebuild LV solenoid supply?

#9 4 years ago

Might be a silly question:

What is the coil strength set to? In the game options, there's 3 settings for coil power.

#10 4 years ago

I'm sure no pro.. other coils being weak, lower than expected voltages, is there a bridge rectifier breaking down or a storage capacitor going soft (re-read and youve been there)? it could be transformer gone soft feeding low voltage into rectifier and cap idk, what you'd described seems more global than local, so maybe give a good look upstream.

#11 4 years ago

Coil strength set to High. Will check xfmr connections and other connections upstream of PPB.

#12 4 years ago
Quoted from adalogue:

Yes, I put in a new coil sleeve and cleaned the plunger. I'll check the ramp, connection, and last resort unwind the coil.
Thanks again!

Just a side note , I did all the things you did and replaced my coil bracket. It was banged up and coil was not sitting in it square.I found a replacement bracket at planetary pinball.Part # 535-6385-00 . Leg levelers totally down at all four corners. No problems since making all these adjustments. Hope you figure it out. Sucks in multiball when two or three balls stuck in shooter lane.

3 weeks later
#13 4 years ago

Hi, I am having a similar problem, it will launch the balls up the ramp but if you have multiballs close together the 3 or 4th ball won't make it up the ramp. I was going to replace the bridge as when I have the magnets going and multiball after 20 or so secs the F5 fuse blows and kills the flippers.
When I first got it going I had a mate look at it and he bent the bracket and that enabled the the balls to make it up the ramp consistently but now I have the F5fuse issue on multiball.!

I have also been told to move the magnet board as close to the MPU as well as it can affect the magnets and lock them on.

If you find a solution please post it as it may fix my problem as well.

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
6,500
Machine - For Sale
Albuquerque, NM
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 30.00
Electronics
Yorktown Parts and Equip
From: $ 16.95
$ 49.00
Playfield - Toys/Add-ons
Lermods
$ 279.95

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside