New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 246981)

Globe Trotters help


By remyjd

1 year ago



Topic Stats

  • 24 posts
  • 9 Pinsiders participating
  • Latest reply 1 year ago by remyjd
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 13 images uploaded to this topic. (View topic image gallery).

15628785494567149295836227389114 (resized).jpg
15628669925926396123824507060153 (resized).jpg
20190711_114248 (resized).jpg
20190711_114308 (resized).jpg
20190710_152929 (resized).jpg
20190711_114319 (resized).jpg
20190711_114338 (resized).jpg
20190711_114355 (resized).jpg
20190711_114408 (resized).jpg
20190711_114408 (resized).jpg
20190711_114418 (resized).jpg
20190710_152929 (resized).jpg
20190710_152915 (resized).jpg

#1 1 year ago

Hello all.
Recently picked up a globe trotters world tour. Guy swears it worked but by time I got there his dad had already taken off the top and moved it to garage. I decided to take a chance. I've plugged everything back in but when I turn it on powers up and nothing else. No sound..no numbers on any high scores. Based on that vague description does anyone have a clue what it might be? Also anyone here in Amarillo texas area that could help out the new guy?

#2 1 year ago

SO when you tuen it on and look at the boards is there no sound and/or no beeps?

Have you check the fuses on the bridge rectifier board?

#3 1 year ago

Correct no sounds no beeps. When I first turned it on it powered up but blew a bulb from back glass

20190710_152915 (resized).jpg20190710_152929 (resized).jpg
#4 1 year ago

A bulb? Or a fuse

Get in there and test them fuses

#5 1 year ago

Double check everything is plugged in correctly. Double check all the fuses for any blown. The MPU should have a LED that flickers on then flashes 7 times. Does the game get that far?

#6 1 year ago

I did not notice the flashing led. I will investigate fuses and look for lights. Additionally I got from same guy a buck Roger's pin. Again back off when I got there. I haven't tried putting it back together yet. Supposedly it was working as well. I paused to get them since I couldn't see work but guy swore they did and marked the price down to $50 each. So I thought worth the gamble.

#7 1 year ago
Quoted from remyjd:

I did not notice the flashing led. I will investigate fuses and look for lights. Additionally I got from same guy a buck Roger's pin. Again back off when I got there. I haven't tried putting it back together yet. Supposedly it was working as well. I paused to get them since I couldn't see work but guy swore they did and marked the price down to $50 each. So I thought worth the gamble.

Wait the games were $50 each? Yeah right they worked before you got there. But hey, can't complain at that price.

#8 1 year ago

He had them listed higher. But took posting down before he finally answered me because his dad took em to garage and he couldn't prove they worked anymore. Hoping it's all true. Lol I've spent money on stupider stuff than that before...

#9 1 year ago

Not much of a gamble. Many of us here would give you a lot more for those games.

#10 1 year ago

Good news. A plug wasn't in good. She plays. Thanks. What do I clean field with?

#11 1 year ago

wow $50 globetrotters, steal of the year for sure!
congrats!

depends on how dirty it is but I typically just use Novus 1 for cleaning the playfield then wax it with some 100% carnauba wax. plenty of threads on here about that kinda stuff for you to check out as well.

#12 1 year ago
Quoted from remyjd:

What do I clean field with?

Novus 2
EDIT: Unless the paint is flaking off.

#13 1 year ago

Cool thx. Maybe I can hook up the buck Roger's today as well. Hopefully it works as told

#14 1 year ago

Do yourself a favor and clean the inside of the cabinet to get rid of the black mold. Rubber gloves and mild bleach solution to get rid of it. Stock up on some rags and magic erasers.

You stole that game for 50.

Find the Bally person near your home to get you started. Some food and beer go a long way.

You might want to post a picture of the rectifier board. My guess is it’s probably fried.
Since you did so well you might want to start with a new one. You also might consider having all the boards tested by a professional to make sure they are all performing properly. You are so far ahead that a few bucks now will preserve the hair on your head.

#15 1 year ago

She's working. Needs cleaned. As u can see inside is dirty? Mold? Thx I'll clean in there. She's had better days but maybe this is typical type wear. Pretty rusty coin.

15628669925926396123824507060153 (resized).jpg20190710_152929 (resized).jpg20190711_114248 (resized).jpg20190711_114308 (resized).jpg20190711_114319 (resized).jpg20190711_114338 (resized).jpg20190711_114355 (resized).jpg20190711_114408 (resized).jpg20190711_114408 (resized).jpg20190711_114418 (resized).jpg
#16 1 year ago

Ok the buck Roger's powers and feeds ball. Sound is haywire with buzzing and whistling.
fuses look ok. . Ball launches but no bunkers bounce it back. Flippers work. Doesn't score. Player one score flickers zero
15628785494567149295836227389114 (resized).jpg

#17 1 year ago

First rule - Fuses "looking OK" doesn't mean anything

#18 1 year ago

Wow! That’s a sweet deal.

#19 1 year ago

Sorry duh found plug for buck Roger's. Sound screams when start button is pushed. Lots of loud buzzing and whistling. Once it actually sounded like laser. Middle bunkers are kicking back but only one of the side ones all the others do not. Sorry I don't know term names of top of my head.

#20 1 year ago

Yikes, First things first! Remove the battery before you need to buy a Ni-Wumph. Get something else to run the memory. Go to http://www.pinwiki.com/wiki/index.php?title=Gottlieb_System_1 and read up. Also, reach down in the depths of the game and find J6, plug that into the CPU.

#21 1 year ago

So now sometimes the button doesn't start the game. There is a button on bottom left front you can push that will reset sometimes so button will start game. Sometimes nothing does anything and finally it will let button start game. Game doesn't require quarters. Ideas whats going on? Is there like a short perhaps?

1 week later
#22 1 year ago

Anyone?

#23 1 year ago

Hard to telll, but I would make sure the contacts for the switch you close when pushing the button are clean and making contact. Use a multimeter to make sure.

#24 1 year ago

It flashes between 00 and scores when waiting for the game to be started. Is that normal?

Promoted items from the Pinside Marketplace
$ 11.00
Electronics
Third Coast Pinball
$ 30.00
Electronics
Third Coast Pinball
$ 9.00
Electronics
Yorktown Arcade Supply
$ 49.99
Electronics
PinballElectronics.com
$ 22.50
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 155.00
From: $ 15.00
$ 119.95
Boards
Allteksystems
From: $ 45.00
Displays
PinballSolutions.eu
From: $ 25.00
Boards
nvram.weebly.com
$ 149.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside