(Topic ID: 188258)

Glitch with Scoring/CPU function on X Files machine


By Integrated

2 years ago



Topic Stats

  • 12 posts
  • 5 Pinsiders participating
  • Latest reply 8 months ago by scottholdren
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 11 images uploaded to this topic. (View topic image gallery).

2017 June 20th (11) (resized).jpg
2017 June 20th (10) (resized).jpg
Sega X-Files pinball Switch Matrix Grid (resized).jpg
2017 June 2nd (5)  (resized).jpg
20170505_180243 (resized).jpg
20170413_094819 (resized).jpg
20170413_093446 (resized).jpg
20170413_093828 (resized).jpg
20170413_095938 (resized).jpg
20170413_100820 (resized).jpg
20170413_095900 (resized).jpg

#1 2 years ago

Just a question to anyone who may be able to help, there is an issue I can't work out at the moment. It's some kind of malfunction/glitch with the CPU that affects the digital scoring function, i.e. every time I get a bonus after losing a ball, or when scoring a jackpot during gameplay it is something crazy like 999 999 920 989 (or similar), so its impossible to know what true score I'm getting. Its been doing this since I bought it a few weeks ago. This glitch even effects the service menu function as when I try to choose the various functions it malfunctions (regardless of whether or not I use the flipper buttons/start button or the actual buttons inside the coin box). I did manage to eventually do a Factory Reset and Audits reset etc but it didn't help. The numbers of most of the settings come up as 999 999 989 (or similar).
I was hoping (to the point of praying) that by replacing the Game ROM A3.O3 and Display ROM0 A3.00 that this would fix it, but to my dismay it didn't make any difference.
The original battery area looks clean and it had previously been relocated to a better position and I have changed to new batteries. The CPU boards look like they are in quite good condition.
I am really hoping that someone can help me sort out this problem as its really disheartening.
With appreciation,
~ Michael

20170413_095900 (resized).jpg

20170413_100820 (resized).jpg

20170413_095938 (resized).jpg

20170413_093828 (resized).jpg

20170413_093446 (resized).jpg

20170413_094819 (resized).jpg

#2 2 years ago

Very strange that swapping the cpu and display ROMs did not fix it... mind boggling actually. What Im left with then, is that somethings wrong with the display itself, but that does not really sound logical. But some other tech wizards here surely must have an idea.

#3 2 years ago

I put the new display ROM & cpu ROM in and felt quietly confident that it would fix the problem but no luck at this stage. I'm hoping someone may have been able to solve a similar problem at some stage and can help me out. I will post a pic of the section with the new cpu ROM.

20170505_180243 (resized).jpg

#4 2 years ago

Maybe some other chip is screwing stuff up, but no idea what it could be.

#5 2 years ago

Try pulling the batteries for 5 minutes then do a factory reset

#6 2 years ago

I tried the battery idea and unfortunately it didn't fix the problem.
Last night I ordered a NV RAM DMD+
I am hoping that this could actually solve the problem with the glitch. I had previously replaced the cpu & display ROM's but it didn't fix the problem and there has been a couple of people on the Aussie Arcade forum that have said that the problem may be a defective RAM chip. So I wonder if by putting in the NV RAM device that it will also fix any existing faulty RAM situation that my machine may have?

2 weeks later
#7 2 years ago

Hi again guys. Sorry for my lack of experience with all of this, as this is my very first pinball machine I appreciate your patience and understanding. I am definitely willing to learn. I ended up sending away for the Anypin DMD RAM device and received it a few days ago, I snipped the battery wires off and then replaced the previous RAM chip with the Anypin DMD and then turned it on and found that the whitestar board didn't boot up? I tried replugging the RAM a couple of times to no avail so I thought I must have accidentally put the chip in upside down or something so I turned the machine off and reversed the chip but it still didn't boot. I then took the AnyPin out and replaced it with the original RAM and now it still won't boot up at all?

My electrician friend came over tonight and helped me check all of the fuses and we discovered that the F23 fuse has been blown which he said was actually a good thing because it is designed to do that to safeguard against more serious damage. Due to my inexperience I am learning the hard way from my mistakes. I think I must have damaged something on my machine because when I put the replacement fuse in of the exact same amps and then turned the machine on the same fuse blew again.
It is a 4 Amp fuse on the Power Driver Board (5 Volt DC Logic).
If possible can you give me some guidance as to what potentially could be the problem as I am very keen to find a solution and get my machine booting up again.

(From unplugging the Anypin DMD so many times I accidentally bent one of the little pin legs and when I went to straighten it I snapped it off, very annoyed at myself for doing that. Fortunately, Rob from LockWhenLit has generously offered to send me a replacement AnyPin device but due to me living in Australia it may take some time before I receive it).

With gratitude for any help or guidance anybody can give

Kind regards,

~ Mick

3 weeks later
#8 2 years ago

Hey guys just an update on tech problem. I realised I had made the silly mistake of putting the anypin NV RAM chip in the wrong way which damaged it so I put the original RAM chip back in and I also found a loose earth strap that was connected above the DMD onto the speaker surround. I went and picked up a new 4 Amp fuse from my local electronics outlet and put it in, took a deep breath, turned in the toggle switch and fortunately it booted up again !!
Rob was kind enough to offer to send me a replacement anypin NV RAM which I just receiving today and made sure I installed it properly this time It's a great device and I was glad to get rid of the battery pack. I was quietly hoping that the new anypin NV RAM chip may fix up the problem my X Files pin is having with the corrupt input which affects the digital scoring and settings etc but the prob is obviously something else.
One thing that may give a clue to anyone who may be able to help is when I go into the Service Menu it seems to malfunction and jump to the wrong function and all the factory settings are scrambled (this is regardless of whether i use the flipper buttons and start button instead of the portals switches). If I persevere enough in the service menu I can eventually do a Factory Reset & Audits reset etc but when the machine boots up the glitch is still in the system. I'm wondering if it due to a corruption in one of the other RAM chip's or if there is some kind of wiring problem/short in the Portals assembly or something else. I noticed the data ribbon cable and plugs that goes from the CPU board to the DMD boards was quite twisted and old looking, I wonder if this could cause these kinds of problems?
The game still pays well (apart from the glitch and some of the flashers not working even though I put new bulbs in them).
I have enjoyed adding all the new mods and have also cleaned all the playfield and ramps and install the entire LED light kit and new rubbers throughout.
I just need to sort out to the weird data glitch problem. Can anyone give me some ideas of how to potentially fix it?
With appreciation,
~ Mick

2017 June 2nd (5) (resized).jpg

#9 2 years ago

Bumping for visibility and hopefully someone with a solution finds the thread and chimes in.

#10 2 years ago

Even though it is a struggle trying to use the service menu function when the glitch is making the options jump around I was able to persevere enough to enter more deeply into the Diagnostics section of the Service Menu function and did a thorough testing procedure including lamp test, coil test and switch test. I will write the results here in the hope that someone with tech experience can see what's going on and point me in the right direction. Thank you in advance for any assistance.

SINGLE LAMP TEST:
* when initiating some of the single lamps, one of the pop bumper lights comes on at half power?
e.g.
#13 'Bonus Times 2' (Yel-Grn : Red-Blk) also lights the Bottom Pop Bumper
#14 'Bonus Times 4' (Yel-Blu : Red-Blk) also light the Right Pop Bumper
#29 'Double Jackpot' (Yel-Grn : Red-Yel) also lights the Bottom Pop Bumper
#30 'Extra Ball' (Yel-Blu : Red-Yel) also light the Right Pop Bumper
* in total I identified 12 cases of this and it is always a pattern of a consecutive two
* another thing to note is that the #52 Top Pop Bumper light (Yel-Blk : Red-Vio) has never worked since I purchased the machine (even after I installed the new bulb)

SINGLE COIL TEST:
* the Right Ramp Top Flasher Light does not work (even after bulb replacement)
* when the #F6 Flash Rt Ramp Top is tested, the Rt Ramp Bottom Flasher goes on instead
* when the #F7 Flash Rt Ramp Bottom is tested, nothing lights
* another thing to note is that even though both of the Left Ramp Flasher Lights do not work during gameplay but they do work in test mode.

SWITCH TEST:
* when going into this testing mode it is nearly impossible to see whats going on as it goes crazy with the options cycling through fast (maybe due to one of the switches being stuck on or some other kind of glitch or cross-wiring situation?)
* After a while of watching the various switch matrix diagrams cycling across the display there is one that keeps showing up as the culprit but it says #95 (Grn-Gry : Wht-Vio) NOT USED

* I was also able to enter into another diagnostics section of the service menu titled Dr Pinball TECHNICIAN ALERTS:
An alert comes up as 'CHECK SWITCHES'
#46 Magnet Opto
#34 NOT USED
#36 NOT USED
And the other alert comes up as 'SWITCH STUCK OPEN'
#34 NOT USED

#11 2 years ago

* Update at this stage is that I have fixed the Right Ramp Top Flasher Light (discovered a wire had been dislodged from the plastic plug)
* And I may have discovered a possible clue relating to the 'CHECK SWITCHES' alert for #34 and #35. I cross referenced with the Switch Matrix Grid Chart in the game manual and it has those two 'Not Used' switches associated with the [B]Grn-Blk[/B] wires (on the Drive column).
Sega X-Files pinball Switch Matrix Grid (resized).jpg
I then searched through the wiring under the playfield and discovered some of that associated wiring may have been tampered with by the previous owner.
2017 June 20th (10) (resized).jpg
i.e. as can be seen in the attached pic, there are three Grn-Blk wires soldered together (with no insulation) plus also another single Grn-Blk wire looks like it has previously been slotted into a plug but now isn't (some tape had been put over the area where it had previously been attached).
I have also included a pic from further away so any X Files owners can see the location of the wiring in question, and can maybe have a look under their playfields for me to double-check how it should be?
2017 June 20th (11) (resized).jpg
Many thanks for anyone who can assist.
Best regards,
~ Mick

1 year later
#12 8 months ago

I'm having the same problem - tried a new DMD controller, new ribbon cable, and reflowed ribbon connectors. Then I found this:

http://pinwiki.com/wiki/index.php?title=Sega/Stern_White_Star_Repair#Failed_74HCT273_buffer_IC_on_the_MPU_board

"The 74HCT273 at U201 on the CPU board buffers the output to the display controller via the ribbon cable. Should this IC fail, incorrect or no data will reach the display controller. Most of the time, this results in only the "splash screen" appearing which is displayed by the DMD controller on it's own, or in rare instances, the odd displays shown at left. First an over-scaled "Location ID:" image is displayed then "Bad Schematic Table Index!". This particular failure was caused by a corroded trace between U201 pin 2 and the via just northwest of pin 2. However, the same message may be displayed any time that the data path between U201 and the DMD Controller fails (i.e. poor header connections, failed ribbon cable)."

I am waiting for a new chip to see if this fixes it for me.

Update: totally fixed the problem. the old chip had a little burn spot which may or may not be related. Used a 74LS273 just because it was on hand, seems to work fine.

Promoted items from the Pinside Marketplace
From: $ 220.00
Playfield - Toys/Add-ons
CzTV Mods
$ 14.50
Electronics
PinballElectronics.com
$ 50.00
From: $ 16.95
2,300
Sale Pending!
Oakville, MO
2,700 (OBO)
Machine - For Sale
Deerfield Beach, FL
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
Wanted
Machine - Wanted
Commack, NY
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 12.99
Eproms
Matt's Basement Arcade
$ 125.00
Cabinet - Armor And Blades
Id Rather Play Pinball
$ 9.99
Eproms
Matt's Basement Arcade
$ 35.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside