New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 227025)

Ghostbusters Help - River of Slime


By HeadNZ

1 year ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by HeadNZ
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

F0A531D7-5395-449E-AAE5-401A6503A6D6 (resized).jpeg
DC3018B8-9283-4FB1-8901-65EAB106EA73 (resized).jpeg
F037C262-FCCF-4E7A-A7F3-22226C45114B (resized).jpeg

#1 1 year ago

Hi

Done some miles on my Premium Ghosterbusters since I got it a couple of weeks ago. I have something not right in the River Of Slime under the city. In between the three poppers is a big led flasher and mine isnt working. Actually I cannot remember if its ever gone. Anyway, I lifted the playfield and swapped the led bulb with another led bulb from the playfield that I new was working and still no joy. My question is this, in the service menu where do I need to be to test just this flasher?

F037C262-FCCF-4E7A-A7F3-22226C45114B (resized).jpeg
#2 1 year ago

Go to Service Menu - Diagnostics - Lamps - Flashers, and find the Pop Bumpers Flasher. That should be it.

I might have changed the names of the steps a little because I do not see any game to check if 100% correct at the moment.

#3 1 year ago
Quoted from Invi00:

Go to Service Menu - Diagnostics - Lamps - Flashers, and find the Pop Bumpers Flasher. That should be it.
I might have changed the names of the steps a little because I do not see any game to check if 100% correct at the moment.

Hmmm... this is getting a bit strange as on the service menu where you check the flashers I go to item 130 and the river of slime flasher is doing nothing but this little ghost is flashing.

And then I go to the single led test menu and I can get the same ghost to flash. Hmmm???

DC3018B8-9283-4FB1-8901-65EAB106EA73 (resized).jpegF0A531D7-5395-449E-AAE5-401A6503A6D6 (resized).jpeg
#4 1 year ago

I do not have any ghostbusters at the moment to check how it should work but I think you should check how it looks under the playfield, maybe some wiring is not as it should be.

#5 1 year ago

Make sure a 5V Flasher is in there in case a 12V (the more common variety) got put in there.

#6 1 year ago

FIXED! Turms out one of the connector plugs had been put on and snagged two pins into one hole from the factory. Bent pin back to position... refitted connector plug and BOOM... all good!

Thanks to those who responded.

Promoted items from the Pinside Marketplace
$ 259.95
Lighting - Led
Pin Stadium Pinball Mods
Trade
Machine - For Trade
Carthage, MO
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
From: $ 14.95
Playfield - Toys/Add-ons
ULEKstore
From: $ 99.00
Lighting - Under Cabinet
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside