(Topic ID: 235048)

Ghostbusters - error can't locate pinballs


By dmj1977

8 months ago



Topic Stats

  • 26 posts
  • 5 Pinsiders participating
  • Latest reply 7 months ago by dmj1977
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

IMG-6236 (resized).JPG
DAA76322-BFB4-4086-8A59-971FD0D8693F (resized).jpeg
12FCD2DD-C3F2-4AA6-B03B-7B3409BE4D2C (resized).jpeg
CEE99494-5744-414E-8DE0-354D74DB3FAB (resized).jpeg
5CD43C37-71D5-4CBC-AD89-290E4B4B7486 (resized).jpeg

#1 8 months ago

Seem to have created a problem with my GB LE. When i turn the game on it gives an error that it can't locate pinballs (with 6 balls loaded). Removing and re-adding the balls makes no difference to the switch tests - trough 1 through 6 are active whether the balls are in or note. Have checked all connections on the trough board and other boards (can't find any lose connections anywhere). Power cycled the game at one point and got an error that said something about a node board update but haven't been able to get that error again. Suspect I may have a dead node board (/) but not sure how to troubleshoot further from here. Any advice gratefully received,

Thanks

#2 8 months ago

Following

#3 8 months ago

I'll have to look at my premium to see where the trough wires go. If it is a node board, curious if there is another node board in the game it could be swapped with to verify. Stern's help line may be of help as well, or your local distributor.

have you traced the wires from the trough back to make sure one wasn't broke?

#4 8 months ago

Thanks northvibe - board swapping could be the go - not sure how to tell which are interchangeable?
Can’t see/find any broken wires or contact points....

#5 8 months ago

Ha! Ya there are two of those boards. The other is near the magna sling magnets.

You could swap those out, or even check it for solder breaks or bad competent on the board. I swear there was a thread about fixing the node boards....

12FCD2DD-C3F2-4AA6-B03B-7B3409BE4D2C (resized).jpeg5CD43C37-71D5-4CBC-AD89-290E4B4B7486 (resized).jpegCEE99494-5744-414E-8DE0-354D74DB3FAB (resized).jpegDAA76322-BFB4-4086-8A59-971FD0D8693F (resized).jpeg
#6 8 months ago

thanks mate - the distributor offered to send some replacement ball trough balls as a first troubleshooting test. So i'll try that and move onto nodes from there if i have to (based on a couple of things i did while i was on the phone he thought the trough boards the more likely culprit). But more than that I'm not convinced i won't create new problems moving the boards around. I'll update back in case the info ends up being useful to anyone in the future....
thanks for the photos - will be very useful if/when i have to go to the next step....

#7 8 months ago

Cheapest and easiest is
Balls
Trough boards
Node board
And you know they want to try cheapest first, which makes sense if they are sending you parts. Just sucks to have a game down for a long time.

Please post up when you find the solution or try something!

#8 8 months ago

the plot thickens (or i'm too thick to work it out?)

replaced the trough boards and that problem went away. Game recognises balls and puts them into play as normal. Most everything seems to be working normally, except
- the VUK on the subway (on the right) doesn't fire. This holds true in test mode and in game play. error comes up on screen during game play saying "operator alert! subway eject device malfunction"
- a bunch of the lights are always on (never turn off) lower and mid-left side of the playfield (as per the attached pic)
(can't find any lose connections anywhere)

any ideas? in the meantime i'm gonna report back to the distributor as well....

IMG-6236 (resized).JPG

#9 8 months ago

I remember some of the Ethernet cables being pulled too tight. Try reseating the ethernets under the pf. Maybe some are too tight or pinched.

Also node boards daisy chain off each other, so an issue up front could lead to an issue in back.

Did you try swapping node boards yet?

#10 8 months ago

didn't think it was possible but i'm more confused

replacement node board arrived today. Before i installed it was looking through the menu, found the node board test function and noticed that there was an error on the node board i was about to replace (number 8). Seemed encouraging.

Replaced the node board and at first the lights that were previously stuck on weren't on anymore. Tested the subway eject thinking it might be all fixed but no luck - subway eject still not working. Power cycled and now the problem lights are flickering a bit. This time get a node updating message and then an error saying node update failed. Tried power cycling 5 or 6 more times with the same result (node update failed).

Leave it off for a couple of hours. Turn it back on and no more node board update error. First time though i get the original locating pinballs error. Power cycle again. This time no locating pinballs error but back to the same lights being stuck on and the subway eject not working. So basically back to where i started.... (with new node board and new trough boards installed...)

so very confused....

#11 8 months ago

(also yep, checked all connections with particular focus on the ethernet - seems all good)

#12 8 months ago

Try going back to an earlier code, or downloading the code from sterns site. May even be a corrupt file at this point. A buddy’s METLE did some crazy shit (worse than you’re describing here), and just needed to be reloaded. Give it a shot. If that doesn’t help, maybe a new memory card as the next step in diag

#13 8 months ago

Ohh good point. What code version are you running? Wonder if there is a firmware from stern to update the spike as well...

#14 8 months ago

i'm runnining 1.13. Trying to reinstall 1.13 leads to update failed. So far no luck finding earlier versions of the code...

#15 8 months ago

OK got a clean install of 1.13 loaded but no change...

#16 8 months ago

tried putting a blank sd card in (with a view to installed code onto a new sd card) but the machine hangs on the stern logo with the blank sd card inserted. Not sure if that is related... might by trying a 3rd SD card just in case...

#17 8 months ago

A blank SD card has no game on it.

If you copied one to the other, the file system format will matter. Stern is promising info but has not done so yet.

https://sternpinball.com/2019/02/05/stern-of-the-union-address-february-2019/

Engineering Updates:

We will be releasing instructions on how to create a complete SD card for a SPIKE system Stern pinball machine. We will also be releasing a manual and schematics of the SPIKE system by the end of the month.

#18 8 months ago

so if i understand correctly, if i want to try a new SD card i have to clone the old SD card onto it? (if the SD card is the problem this might just replicate the issue i'm thinking?)

I was hoping if i had a blank SD card inserted and a usb stick with the code on it ready for install it would just install the code from the usb onto the sd card (sounds like there is no base operating system to allow this with a blank SD card?)

#19 8 months ago

That’s my understanding.

SD card holds the OS.
USB gets mounted by the OS for updates.

#20 8 months ago

Also per spike version there were different sd card versions.

#21 8 months ago

Tried replacing the Ethernet that runs to node 8 with a new cable. Back to the node update failed problem. NFI what’s going on...

#22 8 months ago

Bit more info, just in case... with old cable it sometimes boots up (lights stuck on / subway vuk doesn’t work) and sometimes goes to node update and fails. With new cable it always goes to node update and fails. Make me think maybe 2 problems? The old cable has an intermittent fault but also the board won’t take an update for some reason....

#23 8 months ago

I’ll ask the dumb question. You try calling 800-KICKERS yet? When I’ve had to call I found them to be pretty good.

#24 8 months ago

I haven’t - maybe I should - even from Australia...

#25 8 months ago

Hi

I had a similar problem where when the ball went into the Subway sometimes the game would sit there and hunt for the ball. After alot of messing around, it turned out that there is a little micro-switch that sits at the lock point in the Subway that is fixed by two very small bolts. In my case the game had left the factory with only one bolt. Meaning, the micro-switch would move randomly and sometimes not trigger when a ball went there. I put the missing little bolt in to secure it and all fixed. Have a good look at that micro-switch.

1 month later
#26 7 months ago

believe it or not this issue is ongoing. Been working with the distributor and a local tech but no luck yet. Figure i'll post here in case anyone can see something we are missing.

Have solved some associated problems with lights not working and coil that had burnt out. Remaining issue us the ball search / trough problem. Distributor has (kindly) provided 2 additional trough node boards and replacement trough boards.

No matter which node board i install at node 8 (of the 3 i have) the same thing happens:
- with one set of trough boards, in the ball trough test, it sees all balls as present and can't tell when a ball is not in the trough
- with the other set of trough boards, it sees all balls as absent and can't tell when a ball is present.

any ideas.....

Promoted items from the Pinside Marketplace
$ 29.95
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 12.99
From: $ 22.00
Playfield - Toys/Add-ons
ModFather Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside