New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 158288)

Ghostbuster Issue Thread


By exflexer

4 years ago



Topic Stats

  • 4,465 posts
  • 526 Pinsiders participating
  • Latest reply 20 days ago by cpr9999
  • Topic is favorited by 148 Pinsiders

You

Linked Games

Topic Gallery

There have been 713 images uploaded to this topic. (View topic image gallery).

SwitchStatus (resized).jpg
TroughSwStatus (resized).JPG
screen-capture-1 (resized).png
0255267F-B344-4A63-AF52-98DC3187BF9D (resized).jpeg
1331CF7A-01AE-4406-9820-04400DCCBD5F (resized).jpeg
4108cb973a95ea7af25aed4b17fca9ebd79e350b.png (resized).png
15FB2563-1183-47AE-9CAD-29E28F48CE76 (resized).png
3E7F33D8-B885-40E3-9F8B-D3DEB2864FFA (resized).png
A4C49F70-C0D9-4E25-BF1A-2B738D764708 (resized).png
360A39C8-0C7C-413F-A84E-F2F5E058E086 (resized).png
IMG_4482 (resized).JPG
Ramp Postr (resized).jpg
Ramp Post (resized).jpg
IMG_20200225_234132 (resized).jpg
IMG_20200127_105230 (resized).jpg
Node 8 (resized).png

Topic index (key posts)

55 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 4465 posts in this topic. You are on page 90 of 90.
#4451 51 days ago
Quoted from izboy:

I’ve got a long post, and I hope there’s somebody out there who can help me. I just bought a Ghostbusters machine that has a lot of mods. It was working fine but I think something got jostled during transport. When I turn it on I get a tech alert saying overcurrent protection and then you go into the menu and it says it’s occurring through note board eight and then talks about the right sling.I have attached photos showing the tech alert and included a list of mods that the game came with. It does have every stern manufacture upgrade that has come out. I’m not super tech savvy I just am looking for some guidance. I have talked with Stern, I have replaced all the lights associated with the slingshots and I have borrowed a different note board eight and replaced it to make sure that the node board eight is not bad.
‪Mods include:‬
‪Color DMD‬
‪Full cliffy protector set‬
‪NO GHOST ACRYLICS Speaker Grill Insert‬
‪Custom Book stacking mod‬
‪Stern Lasercut plasma gun side rails‬
‪Custom Ghostbuster logo Backbox Hinge set‬
‪Speaker Light Kit 10‬
‪GHOSTBUSTERS 3D GHOST TRAP‬
‪ECTO GOGGLES SHIELD‬
‪River of slime plastic pop bumper mod‬
‪ECTO 1 Lighted Car MOD‬
‪Stern TOPPER‬
‪Arcade Keepup Dimming Backbox Kit‬
‪TILT Graphics Sideblades‬
‪Ghostbusters Scolari Brothers Drop Target Spring Fix Kit‬
‪Shaker Motor Kit‬
‪Custom Coin door magnets‬
‪GB Keychain‬
‪PerfectPlay Silicone Rubbers‬
‪Flipper Fidelity Complete Stern Speaker System With 10" Woofer‬
‪PinGuard Cabinet, Felt and nylon Leg and bolt Protectors‬
‪Leg Leveler Rubber Castors - Set Of 4‬
‪PinGuard SPIKE Shooter Lane Protector‬
‪8-Way Power Splitter Board‬
‪Metal Hex Spacer (Ramp Fix)‬
‪BriteButtons Illuminated Flipper Button (Purple)‬
‪Gozer Action Figure‬
‪Pinmonk Full color LED Gels + I added my own for the center lights‬
‪Die Cut Ball-Drop Protective Playfield Mylar‬
‪Ghost Trap Flipper Bat covers‬
‪Ghostbusters Pinball Backboard Illumination‬
‪Ghostbusters Pinball Slimer Pinballs - Green with Pink‬
‪Ghostbusters Pinball Scoop LED‬
‪Swapped out to lower pressure plunger and auto launcher spring‬
‪Extended Sling Protector with Center Post‬
‪cp3r's Airball Protector‬
‪Ghostbusters Mirror Replacement Mod‬
‪Replaced with Williams/Bally heavy-duty inner Leg Bracket‬
‪Stern Yellow flippers‬
‪TerrorDog figures‬
‪Ball Baron Ninja balls‬
‪Added Stern service bulletin for the node boards‬
‪Fixed the left flasher issue that can short out‬
‪Custom Instruction cards‬
‪Stern Tournament Button and Switch Assembly‬
‪Ghostbusters Upgrade Kit - center post‬
‪Replaced with Stern Lockdown Bar and Receiver Assembly‬
‪Pinstadium lights kit‬
‪Ghostbuster logo Plunger Plate‬
‪Swinks Target Wedge - 4 Degree mod‬
‪Stern Firehouse and sign‬
‪Handpainted custom slimer covers‬
‪Custom Subway car mod‬
‪Yoyokopter pink outlane guards‬
‪Yoyokopter ghost trap mod‬
Any help and insight would be greatly appreciated
[quoted image][quoted image][quoted image][quoted image]

As mentioned, that node board is prone to failure. Was the service bulletin stuff done to the node boards? If not, you most likely need a new board.

https://sternpinball.com/wp-content/uploads/2018/10/Stern-SB189.pdf

https://sternpinball.com/wp-content/uploads/2018/10/Stern-SB190revB.pdf

#4452 51 days ago

Hey,

I need help trying to identify this part. It's the metal plate that covers the captive ball area in the center of the playfield. I've included a picture. I cannot find this part or part number listed anywhere in the manual. It appears to be a standard part across the Pro, Premium, and LE models. Does anyone know the part number and where I can find one?

Thanks

4108cb973a95ea7af25aed4b17fca9ebd79e350b.png (resized).png
#4453 51 days ago
Quoted from nlrobert:

Hey,
I need help trying to identify this part. It's the metal plate that covers the captive ball area in the center of the playfield. I've included a picture. I cannot find this part or part number listed anywhere in the manual. It appears to be a standard part across the Pro, Premium, and LE models. Does anyone know the part number and where I can find one?
Thanks
[quoted image]

Id give Stern a call.

#4454 47 days ago

I have a quick question that I wanted to see if somebody could help me out with. My Nunzios glory brother pops up and then seems to pop right back down. Is there a quick way to adjust this?

#4455 47 days ago

Try checking the spring tension underneath the targets. It also could be a broken “ledge” plastic that catches on the lip to keep the target up. Unfortunately, this piece breaks more than it should. Good to keep a couple on hand just in case.

#4456 46 days ago
Quoted from izboy:

I have a quick question that I wanted to see if somebody could help me out with. My Nunzios glory brother pops up and then seems to pop right back down. Is there a quick way to adjust this?

I also had this issue and my problem was the spring that pushed the target onto the ledge. It just needed some stretching then it was working again.

#4457 43 days ago

I was adding speaker lights and lifted up the play field. When I went to play the first game I found this on the play field. Anyone know where it came from? I can’t find anywhere that has a grey post , they are all clear or stainless. Thanks for any help.
Dana

0255267F-B344-4A63-AF52-98DC3187BF9D (resized).jpeg1331CF7A-01AE-4406-9820-04400DCCBD5F (resized).jpeg
#4458 43 days ago

that post to the underside of the ramp on the rhs next to the rhs up ramp piece - stops balls getting ontop of the plastic under the ramp

mine has been off for 2 years and waiting for a break to remove the ramp

see the upside mounted post behind the hex post

screen-capture-1 (resized).png
#4459 37 days ago

Hey,

I have a GB that I purchased a few weeks ago. It needed a few new parts, so it took me a few weeks to get all the parts and get everything installed (new slimer, new wire form ramp, new rubbers, etc). I finally got it finished and it's launching two balls whenever you start a new game. I replaced both trough opto boards with new ones and that did not fix the issue. I removed the trough assembly, cleaned it and made sure there were no blockages in any of the sensor holes. That did not fix the issue either. The assembly itself is fine and there are no broken welds or bent pieces.

When I hit the start button to begin a game, it launches the first ball and then a second ball immediately after. There's no delay and it's not a situation where the first ball is falling back into the trough. Also, these are brand new balls and it did this on the first game, so it's not an issue where the balls are magnetized.

I went into the switch test matrix and here is what the switch status looks like when all 6 balls are in the trough. I'm not sure if this is supposed to be like this or not, but trough switches 6, 5, 4, 3, and 2 are all closed, but trough switch 1 shows open. The Trough jam switch shows closed. If I take another ball and put it into the trough eject opening (so that it's stacked on top of the ball in first position in the trough), the trough switch 1 closes. The trough jam switch status never changes.

I included a second picture of the switch status with no balls in the trough.

I guess my first question is whether this supposed to be how it works and what is expected for normal operation or is something out of whack?

TroughSwStatus (resized).JPGSwitchStatus (resized).jpg
#4460 37 days ago
Quoted from nlrobert:

Hey,
I have a GB that I purchased a few weeks ago. It needed a few new parts, so it took me a few weeks to get all the parts and get everything installed (new slimer, new wire form ramp, new rubbers, etc). I finally got it finished and it's launching two balls whenever you start a new game. I replaced both trough opto boards with new ones and that did not fix the issue. I removed the trough assembly, cleaned it and made sure there were no blockages in any of the sensor holes. That did not fix the issue either. The assembly itself is fine and there are no broken welds or bent pieces.
When I hit the start button to begin a game, it launches the first ball and then a second ball immediately after. There's no delay and it's not a situation where the first ball is falling back into the trough. Also, these are brand new balls and it did this on the first game, so it's not an issue where the balls are magnetized.
I went into the switch test matrix and here is what the switch status looks like when all 6 balls are in the trough. I'm not sure if this is supposed to be like this or not, but trough switches 6, 5, 4, 3, and 2 are all closed, but trough switch 1 shows open. The Trough jam switch shows closed. If I take another ball and put it into the trough eject opening (so that it's stacked on top of the ball in first position in the trough), the trough switch 1 closes. The trough jam switch status never changes.
I included a second picture of the switch status with no balls in the trough.
I guess my first question is whether this supposed to be how it works and what is expected for normal operation or is something out of whack?[quoted image][quoted image]

Something basic to try if you haven't already...I had an issue where I was getting two balls intermittently and it was due to the ball eject power being set too high when popping out of the trough. With the excessive force the ball was popping out of the trough into the shooter lane so hard that the ball was being pushed up the shooter lane so much that the sensor thought there was no ball and sent another one. Upon lowering the eject power, the issue subsided immediately.

#4461 37 days ago
Quoted from orlandu81:

Something basic to try if you haven't already...I had an issue where I was getting two balls intermittently and it was due to the ball eject power being set too high when popping out of the trough. With the excessive force the ball was popping out of the trough into the shooter lane so hard that the ball was being pushed up the shooter lane so much that the sensor thought there was no ball and sent another one. Upon lowering the eject power, the issue subsided immediately.

Thanks! That did the trick. I can't believe I didn't think of doing that to start with. I lowered it to the lowest level and it fixed the issue!

Game is playing 100% now!

#4462 37 days ago
Quoted from nlrobert:

Thanks! That did the trick. I can't believe I didn't think of doing that to start with. I lowered it to the lowest level and it fixed the issue!
Game is playing 100% now!

Awesome! Glad it worked. Crazy how the default setting is to launch the ball from the trough so dam hard. I also lowered the power of the auto launch...it was so hard it was bashing into the plastics at the top of the shooter lane.

#4463 36 days ago

I spoke to soon. I started playing a few games and the games would start fine with only 1 ball being ejected as expected. However, when the game ended and I attempted to start a new game, I would get "Locating Pinballs" error and the game would go into a ball search mode. If I waited 15 seconds or so, I could then start a new game and it played fine. Then the same locating pinballs error occurred when you go to start a new game. I then realized that I had mistakenly only installed 5 balls when I put them back into the game. I found one sitting on the counter that I missed. I installed the 6th ball into the game and now it's ejecting 2 balls when I start a new game (every time).

So, I guess back to my original post with the pictures of the switch matrix. It seemed off to me with trough 1 showing open when balls were installed. Can someone confirm if what I posted is correct behavior or does it look wrong? It would be great if someone else could look at their game and post the same picture to see if there are any differences.

#4464 36 days ago

Problem solved!!!!....I reseated all of the connectors and that didn't fix the issue. However, while I was doing so I noticed that the connector for the LED light board in the center of the playfield (the one that indicates completed modes) was plugged in and off by 1 pin. It's connection is located right next to the where the trough connector plugs in. I was so focused on trying to troubleshoot the trough issue that I didn't notice those lights not working. I reconnected that plug correctly and that resolved all the issues. Odd that it exhibited the behavior I was experiencing, but that definitely was causing the problem and fixed the issue.

Thanks for the input and assistance.

2 weeks later
#4465 20 days ago

FYI

Mod - For Sale
New “One for $20 (sale - both for $30)! Supplies limited. PET-G plastic. 1. Airball protector, Left ramp - see below. 2. Right Orbit protector - see below. (see instructions below). ...”
11 days ago
Saukville, WI
20

Promoted items from the Pinside Marketplace
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 18.00
Apparel - Men
Pinside Shop
$ 49.95
$ 17.50
Cabinet - Other
Pin Monk
From: $ 218.00
$ 27.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
There are 4465 posts in this topic. You are on page 90 of 90.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside