(Topic ID: 158288)

Ghostbuster Issue Thread


By exflexer

4 years ago



Topic Stats

  • 4,485 posts
  • 529 Pinsiders participating
  • Latest reply 4 days ago by orlandu81
  • Topic is favorited by 149 Pinsiders

You

Linked Games

Topic Gallery

There have been 717 images uploaded to this topic. (View topic image gallery).

main-qimg-70f0cc5a9d7263efec90c4b221738a5b (resized).jpg
IMG_4729 (resized).jpg
IMG_4732 (resized).JPG
IMG_4731 (resized).JPG
SwitchStatus (resized).jpg
TroughSwStatus (resized).JPG
screen-capture-1 (resized).png
0255267F-B344-4A63-AF52-98DC3187BF9D (resized).jpeg
1331CF7A-01AE-4406-9820-04400DCCBD5F (resized).jpeg
4108cb973a95ea7af25aed4b17fca9ebd79e350b.png (resized).png
15FB2563-1183-47AE-9CAD-29E28F48CE76 (resized).png
3E7F33D8-B885-40E3-9F8B-D3DEB2864FFA (resized).png
A4C49F70-C0D9-4E25-BF1A-2B738D764708 (resized).png
360A39C8-0C7C-413F-A84E-F2F5E058E086 (resized).png
IMG_4482 (resized).JPG
Ramp Postr (resized).jpg

Topic index (key posts)

55 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 4485 posts in this topic. You are on page 76 of 90.
#3751 2 years ago

<Do you guys recommend installing all the cliffy protectors? do I really need the drain protector? Last, I was wondering whether it is a good idea to install the Scolari Bros protectors>

I would highly recommend the shooter lane AND the drain protector cliffys. After doing the shooter lane, the ball drain is a piece of cake.

I would not install the Scolari Bros protectors as they have been known to cause air balls. If your drop targets are properly aligned, there isn't too much wear.

#3752 2 years ago

pindenoo7,I had to remove the Scolari Cliffys!! The one on the left causes massive airballs before you hit the left ramp!!Now,smooth as glass !!

#3753 2 years ago
Quoted from pinden007:

<Do you guys recommend installing all the cliffy protectors? do I really need the drain protector? Last, I was wondering whether it is a good idea to install the Scolari Bros protectors>
I would highly recommend the shooter lane AND the drain protector cliffys. After doing the shooter lane, the ball drain is a piece of cake.
I would not install the Scolari Bros protectors as they have been known to cause air balls. If your drop targets are properly aligned, there isn't too much wear.

Double check if your game has the newer metal side rails. If so, you cannot use the shooter lane cliffy that sits under it. Which of course, is where you need the protection the most.

#3754 2 years ago
Quoted from RobF:

Double check if your game has the newer metal side rails. If so, you cannot use the shooter lane cliffy that sits under it. Which of course, is where you need the protection the most.

Yes, metal side rails. Ouch...

#3755 2 years ago
Quoted from RobF:

Double check if your game has the newer metal side rails. If so, you cannot use the shooter lane cliffy that sits under it. Which of course, is where you need the protection the most.

Not true. Talk to Cliff, he has a version for the metal rails that he sent me (I have metal rails). Just let him know before you order - they work great!

#3756 2 years ago
Quoted from jyeakley:

Not true. Talk to Cliff, he has a version for the metal rails that he sent me (I have metal rails). Just let him know before you order - they work great!

+1 - I have a cliffy on that side with metal side rails.

#3757 2 years ago
Quoted from jyeakley:

Not true. Talk to Cliff, he has a version for the metal rails that he sent me (I have metal rails). Just let him know before you order - they work great!

Quoted from Schwaggs:

+1 - I have a cliffy on that side with metal side rails.

Great! He must have just added them after I reported my issue last July. Thanks for the info.

#3758 2 years ago
Quoted from hawkmoon:

pindenoo7,I had to remove the Scolari Cliffys!! The one on the left causes massive airballs before you hit the left ramp!!Now,smooth as glass !!

I have Cliffy's on my Scoleri Bros targets and I don't get airballs. My drop targets are properly aligned underneath the playfield though. It's weird that so many people are having issues with air balls. I don't get them on my machine. I don't even have an airball deflector on my game as I have never needed one.
Mine is a Pro, maybe it is is a Premium or LE thing I guess?

I also have all the Cliffys installed on my Pro. The improved Librarian one since the Stern cheapy broke in two, the ball drain, Containment unit and the metal shooter lane ones. I too have the metal shooter rail one and have the metal installed in the shooter lane like others do, so it certainly is possible as others have said now.

#3759 2 years ago

Weird issue this morning, be right scoleri brother Pops up then goes right back down immediately. I have the pinball life spring on it since day one, I tried the stock springs and I get the same result. Any ideas? Thanks guys.

#3760 2 years ago

There is a small piece of plastic that forms a ledge for the drop target to catch on. It's undersized and way too thin to hold up the beating it takes. I've replaced two broken pieces in about 1.5 years on mine.

If you have some piece of plastic laying around, a few hand tools and maybe a dremel... you can make your own. Or you can find them at Marco. I didn't see them listed on Pinball Life, but you're so close I would give them a call.

pasted_image (resized).png

#3761 2 years ago
Quoted from MadPole:

There is a small piece of plastic that forms a ledge for the drop target to catch on. It's undersized and way too thin to hold up the beating it takes. I've replaced two broken pieces in about 1.5 years on mine.
If you have some piece of plastic laying around, a few hand tools and maybe a dremel... you can make your own. Or you can find them at Marco. I didn't see them listed on Pinball Life, but you're so close I would give them a call.

Thanks!!! Pinball Life appears to have them instock. Do you have to take anything else apart or is it a simple fix? Thanks so much!!!!

#3762 2 years ago
Quoted from Marcdaddy:

Thanks!!! Pinball Life appears to have them instock. Do you have to take anything else apart or is it a simple fix? Thanks so much!!!!

If you make your own, they'll last a lot longer. Just a little piece of plastic and you drill two holes in it to mount it.

#3763 2 years ago

I can design a metal version if people want it?

#3764 2 years ago
Quoted from swinks:

I can design a metal version if people want it?

Thant would be great, Id take 2 for sure!

#3765 2 years ago
Quoted from swinks:

I can design a metal version if people want it?

I would take a couple!

#3766 2 years ago
Quoted from HookedonPinonics:

Hocus, I would agree that your machine produces a lot of air balls. When I play it at Einsteins I noticed I was getting a ton. I have a premium as well and have the plastic deflector for the left ramp and never have any. I never thought of the scoleri bros protectors causing more airballs but it makes sense.

yeah I'll go ahead and pop those out next time I get a chance. They seem kinda overkill anyway with how I got the playfield protected.
When I was setting it up at my house I don't remember there being that many air balls either, but that seemed like forever ago.

#3767 2 years ago

Just picked up a pro and the auto launch can’t shoot the ball all the way to the top. Any ideas?

#3768 2 years ago
Quoted from Its_me_aj:

Just picked up a pro and the auto launch can’t shoot the ball all the way to the top. Any ideas?

Can you adjust the coil power in the audits?

#3770 2 years ago
Quoted from Its_me_aj:

Just picked up a pro and the auto launch can’t shoot the ball all the way to the top. Any ideas?

Shoot a launch with your iphone in slo-mo mode to see if it's a power issue (ball shoots straight) or an alignment issue (ball zigs between the sides of the ball launch chute). You can really only see it with slow motion. If it's a power issue, see if the coil power is set to Normal or Low in the settings. If it's an alignment issue, adjust the auto-launch forks.

#3771 2 years ago
Quoted from Schwaggs:

+1 - I have a cliffy on that side with metal side rails.

Ok, but if you have the metal rails, it's still a three piece solution, right? Or is the rail protected as it's made of metal?

#3772 2 years ago
Quoted from philsublime:

Ok, but if you have the metal rails, it's still a three piece solution, right? Or is the rail protected as it's made of metal?

I believe he has a side rail protector for the metal rails if you would like to install one.

#3773 2 years ago
Quoted from hocuslocus:

yeah I'll go ahead and pop those out next time I get a chance. They seem kinda overkill anyway with how I got the playfield protected.
When I was setting it up at my house I don't remember there being that many air balls either, but that seemed like forever ago.

If you do before this Sunday I will be up there for a tournament and let you know how it plays.

#3774 2 years ago
Quoted from philsublime:

Ok, but if you have the metal rails, it's still a three piece solution, right? Or is the rail protected as it's made of metal?

3 piece solution. 1 for each side of the shooter lane and 1 for the shooter lane wall.

#3775 2 years ago

My GB Prem delivered today and it is airball heaven (insert sarcastic shocked face here)..... I looked thru a lot of threads and a couple pages back on this one, an operator said that the Modfather protectors were cracking from straight hits. This is HUO so play wouldn't be as high.

Has anyone else tried the Modfather protectors (both left ramp and inlane/outlane)? I like the creative cut of those, but the coloring is a bit much for me. I like the clear that they offer. I looked at PinGrafix and LittleShopofGames as well. They all seem to be a variation on the same design. Are all the versions pretty comparable at stopping the problem?

#3776 2 years ago
Quoted from sethi_i:

My GB Prem delivered today and it is airball heaven (insert sarcastic shocked face here)..... I looked thru a lot of threads and a couple pages back on this one, an operator said that the Modfather protectors were cracking from straight hits. This is HUO so play wouldn't be as high.

Try this one: watch video.

https://pinside.com/pinball/market/classifieds/ad/56778

69913EA0-526E-4CB7-91F7-204165596D24 (resized).jpeg

#3777 2 years ago
Quoted from HookedonPinonics:

If you do before this Sunday I will be up there for a tournament and let you know how it plays.

Actually did it this last sunday. I think it helped, at least I'm pretty sure anyway.
I only had a chance to play a couple games, though they were pretty short since I suck at ghostbusters.
That flipper gap gets me every time.

#3778 2 years ago
Quoted from sethi_i:

My GB Prem delivered today and it is airball heaven (insert sarcastic shocked face here)..... I looked thru a lot of threads and a couple pages back on this one, an operator said that the Modfather protectors were cracking from straight hits. This is HUO so play wouldn't be as high.

This is the only person who has had any breaking issues as far as I know.

#3779 2 years ago
Quoted from sethi_i:

My GB Prem delivered today and it is airball heaven (insert sarcastic shocked face here)..... I looked thru a lot of threads and a couple pages back on this one, an operator said that the Modfather protectors were cracking from straight hits. This is HUO so play wouldn't be as high.
Has anyone else tried the Modfather protectors (both left ramp and inlane/outlane)? I like the creative cut of those, but the coloring is a bit much for me. I like the clear that they offer. I looked at PinGrafix and LittleShopofGames as well. They all seem to be a variation on the same design. Are all the versions pretty comparable at stopping the problem?

I have the Pingrafix version on my pro and it works fine.

#3780 2 years ago

Hey all,

Possibly a common prob...but an issue I am seeing with my recently acquired GB Prem...has to do with the initial plunge of the ball, and the Orbit lock that allows it to go down the lane and get the target shot (i.e. to start 'ok who brought the dog'?)

I'm noticing a about 30% of the time the ball appears to hit the orbit switch despite a full plunge...and ends up going down the P/K/E area...keeping me from starting a scene quickly (game counts as a miss the ball going down the P/K/E - bumper area)

Here's a video of what's happening.

Check out the :19-21 second mark...and again around :27 mark

Was watching this is slow motion, the first hit and it does look like the ball bouncing off the corner below the beginning of the latch/Orbit latch...with the clearance on this latch, I wonder if this is normal? The second hit seems to suggest the latch is hanging low, or wasn't triggered to rise up.

Any information appreciated. Thanks for taking a look!!

cheers

#3781 2 years ago
Quoted from brandonx76:

Hey all,
Possibly a common prob...but an issue I am seeing with my recently acquired GB Prem...has to do with the initial plunge of the ball, and the Orbit lock that allows it to go down the lane and get the target shot (i.e. to start 'ok who brought the dog'?)
I'm noticing a about 30% of the time the ball appears to hit the orbit switch despite a full plunge...and ends up going down the P/K/E area...keeping me from starting a scene quickly (game counts as a miss the ball going down the P/K/E - bumper area)
Here's a video of what's happening.
Check out the :19-21 second mark
Was watching this is slow motion, and it does look like the ball bouncing off the corner below the beginning of the latch/Orbit latch...with the clearance on this latch, I wonder if this is normal?
Any information appreciated. Thanks for taking a look!!
cheers

Looks like maybe the gate isn't raising *quite* high enough and is stopping the ball dead. Slo-mo filming mode and better lighting would be more helpful for diagnosis.

#3782 2 years ago
Quoted from vireland:

Looks like maybe the gate isn't raising *quite* high enough and is stopping the ball dead. Slo-mo filming mode and better lighting would be more helpful for diagnosis.

Hey - Thanks for taking a look. Hmm, same video but made some video tweaks and shortened/slowed down

I can try another video with better lighting tomorrow.

If the gate isn't raising quite high enough, any suggestions?

#3783 2 years ago
Quoted from brandonx76:

Hey - Thanks for taking a look. Hmm, same video but made some video tweaks and shortened/slowed down

I can try another video with better lighting tomorrow.
If the gate isn't raising quite high enough, any suggestions?

Better lighting and a little more slow-mo should help see if the ball is catching the WHOLE gate bottom, or just one edge. Just one edge is easier than the whole thing, but the solution will be a combination of bending and/or shimming the gate bracket to bring it up just 2mm or so.

#3784 2 years ago

just a quick question on your problem. Is there any mylar near the top of the right orbit before entering the PKE's. I found I had mylar that would stop the ball from activating the switch to raise the gate. I'm thinking maybe yours is making the switch but possibly a little airbourne when travelling towards the gate

#3785 2 years ago
Quoted from brandonx76:

Hey all,

Possibly a common prob...but an issue I am seeing with my recently acquired GB Prem...has to do with the initial plunge of the ball, and the Orbit lock that allows it to go down the lane and get the target shot (i.e. to start 'ok who brought the dog'?)

I'm noticing a about 30% of the time the ball appears to hit the orbit switch despite a full plunge...and ends up going down the P/K/E area...keeping me from starting a scene quickly (game counts as a miss the ball going down the P/K/E - bumper area)

Does the problem occur on a manual plunge, auto plunge, or both? I had something similar happening with my game on a full manual plunge. The issue was greatly mitigated by switching to a lower tension spring.

#3786 2 years ago
Quoted from gweempose:

Does the problem occur on a manual plunge, auto plunge, or both? I had something similar happening with my game on a full manual plunge. The issue was greatly mitigated by switching to a lower tension spring.

Happens both... think it happens more on auto plunge...current approach is that I have to do a full plunge to get any success to make the orbit...and it is at least mostly slowed if anything around the plunge orbit because it hits the latch to some degree.

It is interesting however, I haven't had a scenario that I can recall where hitting the right ramp (to start who brought the dogs for example) that it doesn't successfully make the orbit)...seems to be that it's a problem that occurs on the plunge exclusively.

#3787 2 years ago
Quoted from embryon:

just a quick question on your problem. Is there any mylar near the top of the right orbit before entering the PKE's. I found I had mylar that would stop the ball from activating the switch to raise the gate. I'm thinking maybe yours is making the switch but possibly a little airbourne when travelling towards the gate

Hi Thanks - hmm, no mylar..I have noticed sometimes the ball doesn't hit the trigger at full plunge, and so the latch doesn't open (the last ball in my video is an example of this)...and if that was the only prob, I could live with it because if I don't pull the plunge so hard it would make the switch to trigger the orbit latch...problem is, then the odds of the orbit completing are diminished because of the ball then won't clear the latch. So I have to hit it hard...auto plunge, sometimes it clear and sometimes it doensn't (the latch). Seems like I may need to mod the orbit latch

#3788 2 years ago

My GB Prem isn't registering left ramp hits on a clean-fast shot from the right flipper. If I backhand it from the left, or if a right shot rattles a little but still makes it up the ramp it registers. If the ball rolls quickly and cleanly up the ramp from the right flipper, nothing...if I get into a looping rhythm from the right...none of them register.

Has anyone had this? I've been advised to bend the switch shown. Should I bend the "horseshoe" end more open, bend the entire arm out, or bend the arm closer...making the arm travel less to activate the switch. Or is it simply trial and error until it registers?!?

IMG_3379 (resized).jpg

#3789 2 years ago
Quoted from vireland:

Better lighting and a little more slow-mo should help see if the ball is catching the WHOLE gate bottom, or just one edge. Just one edge is easier than the whole thing, but the solution will be a combination of bending and/or shimming the gate bracket to bring it up just 2mm or so.

Hey Vireland, per request...here's a better perspective...the last shot I zoom in and show extra slo motion

Appreciate the additional opinion. Also I reached out to Stern for their input but haven't heard back yet...left a vm too

#3790 2 years ago
Quoted from sethi_i:

My GB Prem isn't registering left ramp hits on a clean-fast shot from the right flipper. If I backhand it from the left, or if a right shot rattles a little but still makes it up the ramp it registers. If the ball rolls quickly and cleanly up the ramp from the right flipper, nothing...if I get into a looping rhythm from the right...none of them register.
Has anyone had this? I've been advised to bend the switch shown. Should I bend the "horseshoe" end more open, bend the entire arm out, or bend the arm closer...making the arm travel less to activate the switch. Or is it simply trial and error until it registers?!?

SUPER COMMON problem on that ramp. Bend the leaf out more. You should be able to feel the click when the switch registers. You want that to happen at about the 3/4 point of the stroke.

#3791 2 years ago
Quoted from brandonx76:

Hey Vireland, per request...here's a better perspective...the last shot I zoom in and show extra slo motion
» YouTube video
Appreciate the additional opinion. Also I reached out to Stern for their input but haven't heard back yet...left a vm too

Looks a lot like the GoT Premium rattle on the left orbits. Stern engineering is really not that great these days.

You're probably going to have to remove stay-puft and light up the area very well and slo-mo record various speed ball plunges to see how the ball is landing from the shooter lane onto the left corner (point 1) and if it's rattling before it leaves the corner at point 2. Something on the right needs to be adjusted so it smoothly hugs the stainless guide instead of rattling as it's clearly doing by the time it hits the left side in your video.

ghostbusters-pf-rattle (resized).jpg

#3792 2 years ago
Quoted from brandonx76:

Hey Vireland, per request...here's a better perspective...the last shot I zoom in and show extra slo motion
» YouTube video
Appreciate the additional opinion. Also I reached out to Stern for their input but haven't heard back yet...left a vm too

Make sure that your machine is level left to right. Make sure that you have the proper angle front to back. For example if the machine is set to steep the ball could be falling forward and hitting the front rail instead of hugging the back rail.

#3793 2 years ago

ya know, I gotta laugh, and I appreciate everyone's thoughts so far...but I am finding if I don't pull the plunger its hardest, say about 70 %, I make the orbit just fine...

so pretty much problem solved..The thing I am noticing is the auto plunger, still seems to struggle and the ball can get stuck in the orbit occasionally. Again I can get around this by plunging before the auto plunger shoots, but if I was able to adjust the auto plunger velocity, that would probably fix my problem there...don't suppose this is something Stern would enable/enhance in the software

The game is perfectly level'd , but it was also suggested I possibly change the pitch a bit so it's steeper, to possibly assist with this. Hadn't tried that yet

#3794 2 years ago
Quoted from brandonx76:

ya know, I gotta laugh, and I appreciate everyone's thoughts so far...but I am finding if I don't pull the plunger its hardest, say about 70 %, I make the orbit just fine...
so pretty much problem solved..The thing I am noticing is the auto plunger, still seems to struggle and the ball can get stuck in the orbit occasionally. Again I can get around this by plunging before the auto plunger shoots, but if I was able to adjust the auto plunger velocity, that would probably fix my problem there...don't suppose this is something Stern would enable/enhance in the software
The game is perfectly level'd , but it was also suggested I possibly change the pitch a bit so it's steeper, to possibly assist with this. Hadn't tried that yet

You can also solve it by either short plunging and backhanding the mode start (extra points for not validating the playfield this way), going for 6x or using the start mode exploit. No reason to long plunge in this game

#3795 2 years ago
Quoted from brandonx76:

so pretty much problem solved..The thing I am noticing is the auto plunger, still seems to struggle and the ball can get stuck in the orbit occasionally. Again I can get around this by plunging before the auto plunger shoots, but if I was able to adjust the auto plunger velocity, that would probably fix my problem there...don't suppose this is something Stern would enable/enhance in the software

Not going to happen in software, but you can put a slightly more powerful coil in there to make it kick stronger.

#3796 2 years ago
Quoted from vireland:

Not going to happen in software, but you can put a slightly more powerful coil in there to make it kick stronger.

Ok wishful thinking...and actually, I was hoping to bring it down a notch...since over plunging seems to be when I have the prob. hmm

#3797 2 years ago
Quoted from brandonx76:

Ok wishful thinking...and actually, I was hoping to bring it down a notch...since over plunging seems to be when I have the prob. hmm

Weaker coil, then. That's IF you already changed the coil strength for all coils from Normal to Soft in the system menu. If you haven't, that'd be a good place to shave 5-10% off the power.

#3798 2 years ago
Quoted from vireland:

Weaker coil, then. That's IF you already changed the coil strength for all coils from Normal to Soft in the system menu. If you haven't, that'd be a good place to shave 5-10% off the power.

Oh no kiddin? Hmm, I did see that in the menu, I wasn't really aware of coil settings, how they factor in. But I'm definitely a noob pinball owner..will give it a shot

#3799 2 years ago
Quoted from brandonx76:

Oh no kiddin? Hmm, I did see that in the menu, I wasn't really aware of coil settings, how they factor in. But I'm definitely a noob pinball owner..will give it a shot

I always set it to soft. Doesn't make that much of a difference to a player and keeps the machine from getting beat up.

#3800 2 years ago
Quoted from vireland:

SUPER COMMON problem on that ramp. Bend the leaf out more. You should be able to feel the click when the switch registers. You want that to happen at about the 3/4 point of the stroke.

Registering on all shots! Thanks....

Promoted items from the Pinside Marketplace
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 79.00
Lighting - Under Cabinet
Arcade Upkeep
$ 199.99
$ 349.95
Lighting - Led
Pin Stadium Pinball Mods
There are 4485 posts in this topic. You are on page 76 of 90.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside