Ghostbuster Issue Thread

(Topic ID: 158288)

Ghostbuster Issue Thread


By exflexer

2 years ago



Topic Stats

  • 4,166 posts
  • 486 Pinsiders participating
  • Latest reply 1 day ago by kidchrisso
  • Topic is favorited by 144 Pinsiders

You

Linked Games

Topic Gallery

There have been 634 images uploaded to this topic. (View topic image gallery).

IMG_0132 (resized).jpg
Screenshot_20181006-072857_Chrome (resized).jpg
Screenshot_20181006-072844_Chrome (resized).jpg
GB Switch Test (resized).jpg
IMG_20180304_174524 (resized).jpg
Print (resized).jpg
cale scolari (resized).jpg
drop target alt (resized).jpg
IMG_1703 (resized).JPG
20180804_165622 (resized).jpg
20180804_165426 (resized).jpg
13AB20DE-3A78-424E-8E2A-8309F49962DE (resized).jpeg
received_10160723852695603 (resized).jpeg
20180720_213838 (resized).jpg
20180720_213818 (resized).jpg
IMG_20180722_091709 (resized).jpg

Topic index (key posts)

55 key posts have been marked in this topic, showing the first 20 (Show topic index)

There are 4169 posts in this topic. You are on page 72 of 84.
#3551 11 months ago

No obstructions in subway, ball passes through to right flipper no issues, coil seems fine as will kick ball out of hole when manually dropped in. Most balls that enter the subway and lock have a hard time exiting. When a game is over and there is a ball remaining in the subway, it takes a while to eject, eventually giving a subway lockup error....please help

Thanks

#3552 11 months ago
Quoted from Kiwipinhead:

Howdy all.. I have a strange problem with my LE. I had a new playfield fitted 5 months ago and put 50 games on it with no issues.
So after not playing it for 2 or so months fired it up and all is well until Slimer (ghost target) is hit. The machine locks up and the sound starts cutting out then the machine resets.
Slimer does not work (swing out) in test. I have disabled Slimer and no resets.
I have checked all the wiring and plugs, all o.k
So.. is this a node board issue?
Has anyone had this happen to thier machine?
Thanks in advance. 

I had this EXACT same problem. Pull up your PF so that it is resting against the backbox. At the very bottom adjacent to the slimer moter is the "motor control board" (I forget exactly what its called, but the wires to the motor will go there). In my case, there is a molex connector that plugs in to the bottom that is part of the big wire harness going around the bottom there, mine pulled out and exhibited the exact same behavior as yours. Check and see if you have a plug loose our pulled out back there.

#3553 11 months ago

Does anyone know why the clear inserts in front of the slings sometimes stay on? This is on a premium, and I seem to notice it after playing a few modes /multi ball but I haven't figured out the pattern.

#3554 11 months ago
Quoted from arcadenerd925:

I had this EXACT same problem. Pull up your PF so that it is resting against the backbox. At the very bottom adjacent to the slimer moter is the "motor control board" (I forget exactly what its called, but the wires to the motor will go there). In my case, there is a molex connector that plugs in to the bottom that is part of the big wire harness going around the bottom there, mine pulled out and exhibited the exact same behavior as yours. Check and see if you have a plug loose our pulled out back there.

Thanks for the reply, I will recheck when I get home. I did pull the plug off the motor board to the motor,to see if the motor was shorting out or doing a voltage drop. But still resets with it unpluged

#3555 11 months ago
Quoted from wisemanbba:

Having a few minor issues with GB Premium.
- ejecting two balls quite often into plunger. First one sometimes doesn’t come out clean which then causes two to come out.
- slimer mechanism. Sometimes, he registers a hit when he isn’t hit. The shaker or a hard hit somewhere else sets it off.
- ball gets caught up too just past the PKE lights on initial plunge. Wasn’t happening before but now seems to happen more often than not.
Thanks for any help on these!
I posted this on forum but was told it might help to post here. Apologize for double post.

On the ejecting ball issue, turn down the coil power about 15 or so. Fixed issue for me.

#3556 11 months ago
Quoted from mbt:

Does anyone know why the clear inserts in front of the slings sometimes stay on? This is on a premium, and I seem to notice it after playing a few modes /multi ball but I haven't figured out the pattern.

It's an indicator the magna slings are in a more active state.

#3557 11 months ago
Quoted from mbt:

Does anyone know why the clear inserts in front of the slings sometimes stay on? This is on a premium, and I seem to notice it after playing a few modes /multi ball but I haven't figured out the pattern.

When they're charged up (to be more active and do the funny-weird things with the ball), they stay on.

#3558 11 months ago

I had an issue with Slimer dragging his butt on the metal around the center captive... I shimmed it up with two washers, which improved it, but It seems as though I could add a third, but then the allen screw won't have any more metal to screw into on the shaft.

Anyone else had this issue, and a better solution to get Slimer to stop dragging on the PF?

19249931_10159661305845061_1793762682_o (resized).jpg

#3559 11 months ago
Quoted from vireland:

When they're charged up (to be more active and do the funny-weird things with the ball), they stay on.

Thanks, That makes sense.

#3560 11 months ago
Quoted from Sirphobos:

I had an issue with Slimer dragging his butt on the metal around the center captive... I shimmed it up with two washers, which improved it, but It seems as though I could add a third, but then the allen screw won't have any more metal to screw into on the shaft.
Anyone else had this issue, and a better solution to get Slimer to stop dragging on the PF?

Some drag is normal. I shimmed mine. I talked to Chaz and said how designed.

#3561 11 months ago

Unboxed my GB pro today. Looks great. September 29 2017 build, playfield does has spelling error, but updated slimer assy, metal bracket under captive ball, right loop mylar...

But my slimer won't move. It moved once down on the first ball after hitting the ghost target but didn't move back up for the next player.
Went to slimer test but nothing and test reports as failed. Don't hear the motor running. Switches work for the up and down position when manuall turning crank

Power on both sides of the fuse on the motor pcb but not on the connector of the motor pins when running the test
reseated connectors on the slimer motor pcb
reseated all rj45 connectors
rebooted game
factory reset on game
turned crank to put slimer back up but slimer stays up in gameplay

Mailed Patrick Powers a few hours ago but waiting for an answer. Anybody experienced the same?

slimertestfailed (resized).jpg

#3562 11 months ago

Stern will provide me a new motor and motor board... fingers crossed this fixes it. To bad this happened with my NIB machine but Stern support was great in communication so thumbs up for this.

#3563 11 months ago

I'm still trying to diagnose my issues on my Ghostbusters Premium with slimer swinging fully clockwise on startup and then stopping there. Can someone confirm their wiring configuration connecting to the optical board connected to the slimer motor assembly? I've attached mine for reference and it is: Red; Pink/Yellow; Pink/Orange; Pink/Green; Black/Brown. I confirmed that the wires run to Node board 8 and are going to the correct pin, but I was unsure of the configuration in the connector to the optical board. I couldn't seem to find that in the manual.

IMG_20171110_205619 (resized).jpg

#3564 11 months ago
Quoted from jaystile:

I'm still trying to diagnose my issues on my Ghostbusters Premium with slimer swinging fully clockwise on startup and then stopping there. Can someone confirm their wiring configuration connecting to the optical board connected to the slimer motor assembly? I've attached mine for reference and it is: Red; Pink/Yellow; Pink/Orange; Pink/Green; Black/Brown. I confirmed that the wires run to Node board 8 and are going to the correct pin, but I was unsure of the configuration in the connector to the optical board. I couldn't seem to find that in the manual.

Running the latest software? At least one of the earlier revisions did this.

#3565 11 months ago

Anyone know of a thread or post that highlights what a new owner should do for an LE? Tweaks and needed mods(needed being key word)? And yes I will go through the 72 page thread here but there is a lot of fluff and pissed off people getting an LE and would rather learn from others than figure out through frustration. Advice is welcome too. Figured by now someone had to put a list together and trying to find. Everyone says this is a great game once you get it dialed in. I just don’t know what that means.

#3566 11 months ago
Quoted from vireland:

Running the latest software? At least one of the earlier revisions did this.

Yes, I am running version 1.13 from http://www.sternpinball.com/games/ghostbusters/premium

I was going to do some continuity testing of the wires and I just wanted to make sure everything was going into the opto board as expected.

#3567 11 months ago
Quoted from Jimmyapple:

Anyone know of a thread or post that highlights what a new owner should do for an LE? Tweaks and needed mods(needed being key word)? And yes I will go through the 72 page thread here but there is a lot of fluff and pissed off people getting an LE and would rather learn from others than figure out through frustration. Advice is welcome too. Figured by now someone had to put a list together and trying to find. Everyone says this is a great game once you get it dialed in. I just don’t know what that means.

Install cliffy's

Adjust height of drop targets
Adjust spring on drop targets (20-25 coils up)

Check & change balls

SLIMER butt nut - check slimer positions and butt nut

Put a washer under right ball guide (blue rubber bumper) to help playfield damage

Put mylarr down - where the ball lands when shot out. Or install Cliffy's

Get the green spring for the manual shooter rod, and the high compression spring for the auto-launcher

Align flippers

Install the plastic air ball protector and right orbit protector (GET THE ONE I MAKE

Adjust the coil power in the service menu ADJ > G.B. > Feature Adjustment #11 - Trough Eject Power. Mine is set the lowest power 176

Check 14th street subway switch to make sure ball is changing swithc state

Ball guide rod 1/4" higher - hit with hammer (behind each sling shot area - this prevents ball jumping in the drain areas)

Hex spacer 1 5/8" (or 1 3/4") - change this on the right plastic 1/2 circle ramp (this shorter hex makes it easier for ball to go up).

#3568 11 months ago

what cpr9999 says does cover it but also play the game and see what the issues are from his list of things as I would not hit the ball guides if it does not need it or alternatively go for cliffy made / TaylorVA designed ball guides. I also would not install the cliffy's on the drops as they cause airballs.

#3569 11 months ago

Not sure if this is the correct area for this question or not. I have a Ghostbusters pro and I seem to be have a small problem with the left flipper. It works, but when I hit the ball at the end of the flipper it seems to have a low power. If I hit it in the middle of the flipper, it works as normal. I did replaced the nylon sleeve because it was dirty, in the flipper coil but that didn't effect much. I also replaced the flipper buttons the other day. The gap on the flipper switch seems good. IS There something I'm missing? thanks

#3570 11 months ago
Quoted from bicyclenut:

Not sure if this is the correct area for this question or not. I have a Ghostbusters pro and I seem to be have a small problem with the left flipper. It works, but when I hit the ball at the end of the flipper it seems to have a low power. If I hit it in the middle of the flipper, it works as normal. I did replaced the nylon sleeve because it was dirty, in the flipper coil but that didn't effect much. I also replaced the flipper buttons the other day. The gap on the flipper switch seems good. IS There something I'm missing? thanks

Try cleaning flipper button switch contacts. If that doesn't clear it up, replace the left EOS switch.

#3571 11 months ago
Quoted from ExtremePinball:

ry cleaning flipper button switch contacts. If that doesn't clear it up, replace the left EOS switch.

I did that. I found that it was the break leaf switch. I bent them down a little more so it makes a good break. Fixed the problem. Thanks

#3572 11 months ago
Quoted from jaystile:

I'm still trying to diagnose my issues on my Ghostbusters Premium with slimer swinging fully clockwise on startup and then stopping there. Can someone confirm their wiring configuration connecting to the optical board connected to the slimer motor assembly? I've attached mine for reference and it is: Red; Pink/Yellow; Pink/Orange; Pink/Green; Black/Brown. I confirmed that the wires run to Node board 8 and are going to the correct pin, but I was unsure of the configuration in the connector to the optical board. I couldn't seem to find that in the manual.

Chas from Stern support verified the wiring configuration is correct. While my slimer is still not working, I feel that Stern is taking care of me and we will get the issue resolved. Chas has shipped out replace opto boards, slimer motor assembly, and is now sending out the motor control board. I'm hoping that will be the final solution.

#3573 11 months ago
Quoted from Sirphobos:

I had an issue with Slimer dragging his butt on the metal around the center captive... I shimmed it up with two washers, which improved it, but It seems as though I could add a third, but then the allen screw won't have any more metal to screw into on the shaft.
Anyone else had this issue, and a better solution to get Slimer to stop dragging on the PF?

You could probably get a longer screw and raise him more, but I wouldn't recommend it. On the Premium, as Slimer moves left and right, stopping in specific positions, he blocks or interferes with certain shots, including the left orbit. If you raise him to where his butt doesn't drag, he probably won't block or interfere with certain shots the way the designers intended (especially the left orbit). I wonder if anyone has tried bending the metal cover (over the captive balls) where he usually drags his butt.

#3574 11 months ago

I like when slimer drags his ass...... Reminds me of my aunt's old shih tzu with hemorrhoids

#3575 11 months ago

Anyone have a fix for the subway lock malfunction? Mine does this, this is not my video but it is what my machine does....

Thanks!

#3576 11 months ago

I have an interesting thing happening with the Scoleri targets. I noticed weirdness during gameplay, so I went into diagnostics menu. The left target goes up fine, but does not go down (all I hear is clicking). The right target goes down fine, but only stays up maybe once out of every 4 times.

I do have the pinball life spring fix installed.

Any ideas?

#3577 11 months ago
Quoted from jyeakley:

The left target goes up fine, but does not go down (all I hear is clicking).

This would indicate that the spring is probably too tight.

#3578 11 months ago
Quoted from gweempose:

This would indicate that the spring is probably too tight.

Fixed!

The right target not going up every time was due to the spring being too tight. I barely stretched it out and it goes up every time now.

The left target not going down (clicking) was due to the target release mechanism getting caught on a screw that the factory didn’t screw in all the way (see pic). Once I screwed it in the rest of the way, it works great!

76955886-C51B-4551-A21A-392CB94D31E1 (resized).jpeg

#3579 11 months ago
Quoted from thall17:

Anyone have a fix for the subway lock malfunction? Mine does this, this is not my video but it is what my machine does....
» YouTube video
Thanks!

Anyone?

#3580 11 months ago
Quoted from jyeakley:

I have an interesting thing happening with the Scoleri targets. I noticed weirdness during gameplay, so I went into diagnostics menu. The left target goes up fine, but does not go down (all I hear is clicking). The right target goes down fine, but only stays up maybe once out of every 4 times.
I do have the pinball life spring fix installed.
Any ideas?

Switch back to the stock springs.

#3581 11 months ago

Pic of the active switch test screen, and solenoid test.

#3582 11 months ago

Hi all. New owner for a GBLE. Got an issue that I’m not sure how to move forward on. Got the GB in trade, Aug 16 build. The playfield isn’t level- high centers with slope on both sides. Only real issue is that it causes even more outlane drains. Anyone know how to level this out? I’ve adjusted all the legs, checked the pitch but can’t seem to get flat all the way across. Put a ruler across playfield and you can see under each side when pushed down in center. Thanks for any help. Positive side is less sdtm though

#3583 11 months ago
Quoted from jyeakley:

I have an interesting thing happening with the Scoleri targets. I noticed weirdness during gameplay, so I went into diagnostics menu. The left target goes up fine, but does not go down (all I hear is clicking). The right target goes down fine, but only stays up maybe once out of every 4 times.
I do have the pinball life spring fix installed.
Any ideas?

For what it is worth - I had similar issue - and eventually my ledge plastic broke. I replaced plastic and put stock springs back. I don’t know for sure if the aftermarket springs caused the plastic to break but they didn’t make the targets drop that much better than the originals so I went back to the originals with a few links dropped down instead. The Scolari targets just suck - period. Huge flaw in this game IMO.

#3584 11 months ago

Here's a video of the wrtby bug
I'm sure had I hit the left scoop (like I was trying for) it woulda been fine. But I put 2 balls in the right scoop and the game got very confused to the point of having to restart the machine. Very sad.new code new code new code please! Pretty weak wizard mode at this point anyway.100,000 jackpots. Pshhhhh

#3585 11 months ago
Quoted from brainmegaphone:

The Scolari targets just suck - period. Huge flaw in this game IMO.

I agree. That's why I normally leave mine turned off.

#3586 11 months ago
Quoted from gweempose:

I agree. That's why I normally leave mine turned off.

When mine were broken and turned off I have to admit I kind of liked the game better. Maybe I should make it permanent.

#3587 10 months ago

Any help would be appreciated. I just got my replacement ghostbusters LE playfield. Slimer is barely recognizing any hits.

How do I adjust it?

#3588 10 months ago
Quoted from Trekkie1978:

Any help would be appreciated. I just got my replacement ghostbusters LE playfield. Slimer is barely recognizing any hits.
How do I adjust it?

Follow the diagrams to adjust slimer so his steel cable just touches the front inside edge of the metal ring.
This is a normally closed switch. when hit, the switch opens.

slimer mech2 (resized).jpg

#3589 10 months ago
Quoted from jaystile:

Chas from Stern support verified the wiring configuration is correct. While my slimer is still not working, I feel that Stern is taking care of me and we will get the issue resolved. Chas has shipped out replace opto boards, slimer motor assembly, and is now sending out the motor control board. I'm hoping that will be the final solution.

I did install the new motor control board, but it no affect on slimer rotating fully clockwise and then stopping. Chas asked if I could ground the red/white and red/grey connection on the node8 board. This did cause slimer to rotate forward and backward confirming the motor is working. Next, he had me swap node8 and node9 boards as they are the same as long as you update the dip switches. This was to see if the node board is bad. The result was the same and slimer doesn't return home. Awaiting more debug instructions.

#3590 10 months ago
Quoted from jaystile:

I did install the new motor control board, but it no affect on slimer rotating fully clockwise and then stopping. Chas asked if I could ground the red/white and red/grey connection on the node8 board. This did cause slimer to rotate forward and backward confirming the motor is working. Next, he had me swap node8 and node9 boards as they are the same as long as you update the dip switches. This was to see if the node board is bad. The result was the same and slimer doesn't return home. Awaiting more debug instructions.

That is frustrating but it sounds like they are trying hard to help at least!

#3591 10 months ago
Quoted from chucksmith:

Follow the diagrams to adjust slimer so his steel cable just touches the front inside edge of the metal ring.
This is a normally closed switch. when hit, the switch opens.

Do I adjust it by moving the top of #7?

Thanks!

#3592 10 months ago
Quoted from Trekkie1978:

Do I adjust it by moving the top of #7?
Thanks!

Parts 1,4,8 can be slid back or forward causing the cable to move. Part #8 is slotted and the most effective adjustment.

#3593 10 months ago
Quoted from jaystile:

I did install the new motor control board, but it no affect on slimer rotating fully clockwise and then stopping. Chas asked if I could ground the red/white and red/grey connection on the node8 board. This did cause slimer to rotate forward and backward confirming the motor is working. Next, he had me swap node8 and node9 boards as they are the same as long as you update the dip switches. This was to see if the node board is bad. The result was the same and slimer doesn't return home. Awaiting more debug instructions.

I'm suspecting an opto or switch that tells slimer where he is.
If the board is good and the motor is good, then the board sounds confused as to where slimer is.
There are 2 optos on the slimer motor board.
Assuming there is not crud in the slots of the encoder wheel, then there is part 29 (520-6999-03) ENCODER OPTO AMPLIFIER ASSEMBLY
gb-slimer opto-wheel (resized).png
slimer optos (resized).png

#3594 10 months ago

Hey everyone, Q: Where is the ghostbusters owners club topic /thread ? I cannot find it. Link please?

#3595 10 months ago
Quoted from chucksmith:

Hey everyone, Q: Where is the ghostbusters owners club topic /thread ? I cannot find it. Link please?

https://pinside.com/pinball/forum/topic/ghostbusters-club-we-got-one

#3596 10 months ago
Quoted from chucksmith:

I'm suspecting an opto or switch that tells slimer where he is.
If the board is good and the motor is good, then the board sounds confused as to where slimer is.
There are 2 optos on the slimer motor board.
Assuming there is not crud in the slots of the encoder wheel, then there is part 29 (520-6999-03) ENCODER OPTO AMPLIFIER ASSEMBLY

Yeah, we've already tried three opto boards, two motor control boards, two slimer motors, and swapping the node boards. It is probably something more subtle. Thanks for your thoughts, let me know if you have others!

(No, there is no crud in the encoder wheels.)

#3597 10 months ago
Quoted from jaystile:

Yeah, we've already tried three opto boards, two motor control boards, two slimer motors, and swapping the node boards. It is probably something more subtle. Thanks for your thoughts, let me know if you have others!
(No, there is no crud in the encoder wheels.)

Sounds like the only thing left is the wiring harness associated with slimer. Have you replaced those?

#3598 10 months ago
Quoted from Schwaggs:

Sounds like the only thing left is the wiring harness associated with slimer. Have you replaced those?

Good call !

#3599 10 months ago

Hi have a pro i wondering how much slimer should bob up and down. Mine does drop down but has a little bob. is the arm suppose to move up and down causing you to miss slimer?

#3600 10 months ago
Quoted from flipordie:

Hi have a pro i wondering how much slimer should bob up and down. Mine does drop down but has a little bob. is the arm suppose to move up and down causing you to miss slimer?

no, he drops down to the playfield level and then like yours bobs up and down and still being able to be hit in both limits of the bobbing.

Promoted items from the Pinside Marketplace
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 149.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
5,799
Machine - For Sale
Milford, CT
$ 199.99
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
From: € 189.00
Displays
GermanGamingSupplies.com
$ 18.95
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 12.99
Cabinet - Decals
Bent Mods
$ 22.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
$ 170.00
Cabinet - Other
Pin Mods
$ 45.00
Cabinet - Other
...redshiftLED
$ 199.99
$ 199.99
Lighting - Led
Lighted Pinball Mods
4,500
Machine - For Sale
Orlando, FL
$ 7,199.00
Pinball Machine
Operation Pinball
$ 69.99
Lighting - Led
PinballBulbs
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 35.00
Playfield - Toys/Add-ons
3D MODS
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 7,199.00
Pinball Machine
Gulf Coast Pinball, LLC
There are 4169 posts in this topic. You are on page 72 of 84.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside