Ghostbuster Issue Thread


By exflexer

1 year ago


Stats

  • 3,576 posts
  • 441 Pinsiders participating
  • Latest reply 1 day ago by thall17
  • Topic is favorited by 131 Pinsiders

Find

Search this topic for posts matching certain words or written by a specific Pinsider. Or both!




Linked Games



Topic Gallery

There have been 573 images uploaded to this topic. (View topic image gallery).

76955886-C51B-4551-A21A-392CB94D31E1 (resized).jpeg
IMG_20171110_205619 (resized).jpg
slimertestfailed (resized).jpg
19249931_10159661305845061_1793762682_o (resized).jpg
slimer mech2 (resized).jpg
IMG_3165 (resized).jpg
IMG_3160 (resized).jpg
IMG_3162 (resized).jpg
IMG_4264 (resized).JPG
IMG_4263 (resized).JPG
IMG_3956 (resized).JPG
73F216E5-68AF-4441-9F8A-7DC92527C980 (resized).jpeg
F7D4689D-98CF-4EC0-B23D-53EB1FD1B2D4 (resized).jpeg
EC3DD4ED-C68E-4D88-9A6C-57C706B5F7EF (resized).jpeg
pic7 - Copy (resized).jpg
pic5 - Copy (resized).jpg


Topic index (key posts)

53 key posts have been marked in this topic, showing the first 20 (Show topic index)

There are 3576 posts in topic. You are on page 72 of 72.
#3551 18 days ago

No obstructions in subway, ball passes through to right flipper no issues, coil seems fine as will kick ball out of hole when manually dropped in. Most balls that enter the subway and lock have a hard time exiting. When a game is over and there is a ball remaining in the subway, it takes a while to eject, eventually giving a subway lockup error....please help

Thanks

#3552 18 days ago
Quoted from Kiwipinhead:

Howdy all.. I have a strange problem with my LE. I had a new playfield fitted 5 months ago and put 50 games on it with no issues.
So after not playing it for 2 or so months fired it up and all is well until Slimer (ghost target) is hit. The machine locks up and the sound starts cutting out then the machine resets.
Slimer does not work (swing out) in test. I have disabled Slimer and no resets.
I have checked all the wiring and plugs, all o.k
So.. is this a node board issue?
Has anyone had this happen to thier machine?
Thanks in advance. 

I had this EXACT same problem. Pull up your PF so that it is resting against the backbox. At the very bottom adjacent to the slimer moter is the "motor control board" (I forget exactly what its called, but the wires to the motor will go there). In my case, there is a molex connector that plugs in to the bottom that is part of the big wire harness going around the bottom there, mine pulled out and exhibited the exact same behavior as yours. Check and see if you have a plug loose our pulled out back there.

#3553 18 days ago

Does anyone know why the clear inserts in front of the slings sometimes stay on? This is on a premium, and I seem to notice it after playing a few modes /multi ball but I haven't figured out the pattern.

#3554 18 days ago
Quoted from arcadenerd925:

I had this EXACT same problem. Pull up your PF so that it is resting against the backbox. At the very bottom adjacent to the slimer moter is the "motor control board" (I forget exactly what its called, but the wires to the motor will go there). In my case, there is a molex connector that plugs in to the bottom that is part of the big wire harness going around the bottom there, mine pulled out and exhibited the exact same behavior as yours. Check and see if you have a plug loose our pulled out back there.

Thanks for the reply, I will recheck when I get home. I did pull the plug off the motor board to the motor,to see if the motor was shorting out or doing a voltage drop. But still resets with it unpluged

#3555 18 days ago
Quoted from wisemanbba:

Having a few minor issues with GB Premium.
- ejecting two balls quite often into plunger. First one sometimes doesn’t come out clean which then causes two to come out.
- slimer mechanism. Sometimes, he registers a hit when he isn’t hit. The shaker or a hard hit somewhere else sets it off.
- ball gets caught up too just past the PKE lights on initial plunge. Wasn’t happening before but now seems to happen more often than not.
Thanks for any help on these!
I posted this on forum but was told it might help to post here. Apologize for double post.

On the ejecting ball issue, turn down the coil power about 15 or so. Fixed issue for me.

#3556 18 days ago
Quoted from mbt:

Does anyone know why the clear inserts in front of the slings sometimes stay on? This is on a premium, and I seem to notice it after playing a few modes /multi ball but I haven't figured out the pattern.

It's an indicator the magna slings are in a more active state.

#3557 18 days ago
Quoted from mbt:

Does anyone know why the clear inserts in front of the slings sometimes stay on? This is on a premium, and I seem to notice it after playing a few modes /multi ball but I haven't figured out the pattern.

When they're charged up (to be more active and do the funny-weird things with the ball), they stay on.

#3558 16 days ago

I had an issue with Slimer dragging his butt on the metal around the center captive... I shimmed it up with two washers, which improved it, but It seems as though I could add a third, but then the allen screw won't have any more metal to screw into on the shaft.

Anyone else had this issue, and a better solution to get Slimer to stop dragging on the PF?

19249931_10159661305845061_1793762682_o (resized).jpg

#3559 15 days ago
Quoted from vireland:

When they're charged up (to be more active and do the funny-weird things with the ball), they stay on.

Thanks, That makes sense.

#3560 15 days ago
Quoted from Sirphobos:

I had an issue with Slimer dragging his butt on the metal around the center captive... I shimmed it up with two washers, which improved it, but It seems as though I could add a third, but then the allen screw won't have any more metal to screw into on the shaft.
Anyone else had this issue, and a better solution to get Slimer to stop dragging on the PF?

Some drag is normal. I shimmed mine. I talked to Chaz and said how designed.

#3561 13 days ago

Unboxed my GB pro today. Looks great. September 29 2017 build, playfield does has spelling error, but updated slimer assy, metal bracket under captive ball, right loop mylar...

But my slimer won't move. It moved once down on the first ball after hitting the ghost target but didn't move back up for the next player.
Went to slimer test but nothing and test reports as failed. Don't hear the motor running. Switches work for the up and down position when manuall turning crank

Power on both sides of the fuse on the motor pcb but not on the connector of the motor pins when running the test
reseated connectors on the slimer motor pcb
reseated all rj45 connectors
rebooted game
factory reset on game
turned crank to put slimer back up but slimer stays up in gameplay

Mailed Patrick Powers a few hours ago but waiting for an answer. Anybody experienced the same?

slimertestfailed (resized).jpg

#3562 11 days ago

Stern will provide me a new motor and motor board... fingers crossed this fixes it. To bad this happened with my NIB machine but Stern support was great in communication so thumbs up for this.

#3563 9 days ago

I'm still trying to diagnose my issues on my Ghostbusters Premium with slimer swinging fully clockwise on startup and then stopping there. Can someone confirm their wiring configuration connecting to the optical board connected to the slimer motor assembly? I've attached mine for reference and it is: Red; Pink/Yellow; Pink/Orange; Pink/Green; Black/Brown. I confirmed that the wires run to Node board 8 and are going to the correct pin, but I was unsure of the configuration in the connector to the optical board. I couldn't seem to find that in the manual.

IMG_20171110_205619 (resized).jpg

#3564 9 days ago
Quoted from jaystile:

I'm still trying to diagnose my issues on my Ghostbusters Premium with slimer swinging fully clockwise on startup and then stopping there. Can someone confirm their wiring configuration connecting to the optical board connected to the slimer motor assembly? I've attached mine for reference and it is: Red; Pink/Yellow; Pink/Orange; Pink/Green; Black/Brown. I confirmed that the wires run to Node board 8 and are going to the correct pin, but I was unsure of the configuration in the connector to the optical board. I couldn't seem to find that in the manual.

Running the latest software? At least one of the earlier revisions did this.

#3565 9 days ago

Anyone know of a thread or post that highlights what a new owner should do for an LE? Tweaks and needed mods(needed being key word)? And yes I will go through the 72 page thread here but there is a lot of fluff and pissed off people getting an LE and would rather learn from others than figure out through frustration. Advice is welcome too. Figured by now someone had to put a list together and trying to find. Everyone says this is a great game once you get it dialed in. I just don’t know what that means.

#3566 9 days ago
Quoted from vireland:

Running the latest software? At least one of the earlier revisions did this.

Yes, I am running version 1.13 from http://www.sternpinball.com/games/ghostbusters/premium

I was going to do some continuity testing of the wires and I just wanted to make sure everything was going into the opto board as expected.

#3567 9 days ago
Quoted from Jimmyapple:

Anyone know of a thread or post that highlights what a new owner should do for an LE? Tweaks and needed mods(needed being key word)? And yes I will go through the 72 page thread here but there is a lot of fluff and pissed off people getting an LE and would rather learn from others than figure out through frustration. Advice is welcome too. Figured by now someone had to put a list together and trying to find. Everyone says this is a great game once you get it dialed in. I just don’t know what that means.

Install cliffy's

Adjust height of drop targets
Adjust spring on drop targets (20-25 coils up)

Check & change balls

SLIMER butt nut - check slimer positions and butt nut

Put a washer under right ball guide (blue rubber bumper) to help playfield damage

Put mylarr down - where the ball lands when shot out. Or install Cliffy's

Get the green spring for the manual shooter rod, and the high compression spring for the auto-launcher

Align flippers

Install the plastic air ball protector and right orbit protector (GET THE ONE I MAKE

Adjust the coil power in the service menu ADJ > G.B. > Feature Adjustment #11 - Trough Eject Power. Mine is set the lowest power 176

Check 14th street subway switch to make sure ball is changing swithc state

Ball guide rod 1/4" higher - hit with hammer (behind each sling shot area - this prevents ball jumping in the drain areas)

Hex spacer 1 5/8" (or 1 3/4") - change this on the right plastic 1/2 circle ramp (this shorter hex makes it easier for ball to go up).

#3568 9 days ago

what cpr9999 says does cover it but also play the game and see what the issues are from his list of things as I would not hit the ball guides if it does not need it or alternatively go for cliffy made / TaylorVA designed ball guides. I also would not install the cliffy's on the drops as they cause airballs.

#3569 8 days ago

Not sure if this is the correct area for this question or not. I have a Ghostbusters pro and I seem to be have a small problem with the left flipper. It works, but when I hit the ball at the end of the flipper it seems to have a low power. If I hit it in the middle of the flipper, it works as normal. I did replaced the nylon sleeve because it was dirty, in the flipper coil but that didn't effect much. I also replaced the flipper buttons the other day. The gap on the flipper switch seems good. IS There something I'm missing? thanks

#3570 8 days ago
Quoted from bicyclenut:

Not sure if this is the correct area for this question or not. I have a Ghostbusters pro and I seem to be have a small problem with the left flipper. It works, but when I hit the ball at the end of the flipper it seems to have a low power. If I hit it in the middle of the flipper, it works as normal. I did replaced the nylon sleeve because it was dirty, in the flipper coil but that didn't effect much. I also replaced the flipper buttons the other day. The gap on the flipper switch seems good. IS There something I'm missing? thanks

Try cleaning flipper button switch contacts. If that doesn't clear it up, replace the left EOS switch.

#3571 8 days ago
Quoted from ExtremePinball:

ry cleaning flipper button switch contacts. If that doesn't clear it up, replace the left EOS switch.

I did that. I found that it was the break leaf switch. I bent them down a little more so it makes a good break. Fixed the problem. Thanks

#3572 6 days ago
Quoted from jaystile:

I'm still trying to diagnose my issues on my Ghostbusters Premium with slimer swinging fully clockwise on startup and then stopping there. Can someone confirm their wiring configuration connecting to the optical board connected to the slimer motor assembly? I've attached mine for reference and it is: Red; Pink/Yellow; Pink/Orange; Pink/Green; Black/Brown. I confirmed that the wires run to Node board 8 and are going to the correct pin, but I was unsure of the configuration in the connector to the optical board. I couldn't seem to find that in the manual.

Chas from Stern support verified the wiring configuration is correct. While my slimer is still not working, I feel that Stern is taking care of me and we will get the issue resolved. Chas has shipped out replace opto boards, slimer motor assembly, and is now sending out the motor control board. I'm hoping that will be the final solution.

#3573 6 days ago
Quoted from Sirphobos:

I had an issue with Slimer dragging his butt on the metal around the center captive... I shimmed it up with two washers, which improved it, but It seems as though I could add a third, but then the allen screw won't have any more metal to screw into on the shaft.
Anyone else had this issue, and a better solution to get Slimer to stop dragging on the PF?

You could probably get a longer screw and raise him more, but I wouldn't recommend it. On the Premium, as Slimer moves left and right, stopping in specific positions, he blocks or interferes with certain shots, including the left orbit. If you raise him to where his butt doesn't drag, he probably won't block or interfere with certain shots the way the designers intended (especially the left orbit). I wonder if anyone has tried bending the metal cover (over the captive balls) where he usually drags his butt.

#3574 5 days ago

I like when slimer drags his ass...... Reminds me of my aunt's old shih tzu with hemorrhoids

#3575 1 day ago

Anyone have a fix for the subway lock malfunction? Mine does this, this is not my video but it is what my machine does....

» YouTube video

Thanks!

#3576 1 day ago

I have an interesting thing happening with the Scoleri targets. I noticed weirdness during gameplay, so I went into diagnostics menu. The left target goes up fine, but does not go down (all I hear is clicking). The right target goes down fine, but only stays up maybe once out of every 4 times.

I do have the pinball life spring fix installed.

Any ideas?

#3577 1 day ago
Quoted from jyeakley:

The left target goes up fine, but does not go down (all I hear is clicking).

This would indicate that the spring is probably too tight.

#3578 1 day ago
Quoted from gweempose:

This would indicate that the spring is probably too tight.

Fixed!

The right target not going up every time was due to the spring being too tight. I barely stretched it out and it goes up every time now.

The left target not going down (clicking) was due to the target release mechanism getting caught on a screw that the factory didn’t screw in all the way (see pic). Once I screwed it in the rest of the way, it works great!

76955886-C51B-4551-A21A-392CB94D31E1 (resized).jpeg

#3579 1 day ago
Quoted from thall17:

Anyone have a fix for the subway lock malfunction? Mine does this, this is not my video but it is what my machine does....
» YouTube video
Thanks!

Anyone?

Promoted items from the Pinside Marketplace
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
From: $ 119.99
Lighting - Backbox
Rock Custom Pinball
4,800 (Firm)
Machine - For Sale
Lake Charles, LA
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 15.00
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 18.99
Lighting - Led
Lermods
7,199
Machine - For Sale
Milford, CT
$ 149.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 22.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
$ 149.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 34.95
Playfield - Plastics
Hookedonpinball.com
$ 18.00
Playfield - Toys/Add-ons
Meph's Mods
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
€ 42.00
Playfield - Toys/Add-ons
YOYOKOPTER MODS
$ 170.00
Cabinet - Other
Pin Mods
From: $ 14.95
Playfield - Toys/Add-ons
ULEKstore
$ 29.95
$ 119.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
€ 45.00
Playfield - Toys/Add-ons
YOYOKOPTER MODS
$ 49.99
Lighting - Led
PinballBulbs
From: $ 35.00
Lighting - Interactive
Professor Pinball
From: $ 20.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 22.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
Hey modders!
Your shop name here
There are 3576 posts in topic. You are on page 72 of 72.

Reply

Wanna join the discussion? Sign up for a Pinside account, or log in if you already have an account.


Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside