New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 158288)

Ghostbuster Issue Thread


By exflexer

4 years ago



Topic Stats

  • 4,465 posts
  • 526 Pinsiders participating
  • Latest reply 18 days ago by cpr9999
  • Topic is favorited by 148 Pinsiders

You

Linked Games

Topic Gallery

There have been 713 images uploaded to this topic. (View topic image gallery).

SwitchStatus (resized).jpg
TroughSwStatus (resized).JPG
screen-capture-1 (resized).png
0255267F-B344-4A63-AF52-98DC3187BF9D (resized).jpeg
1331CF7A-01AE-4406-9820-04400DCCBD5F (resized).jpeg
4108cb973a95ea7af25aed4b17fca9ebd79e350b.png (resized).png
15FB2563-1183-47AE-9CAD-29E28F48CE76 (resized).png
3E7F33D8-B885-40E3-9F8B-D3DEB2864FFA (resized).png
A4C49F70-C0D9-4E25-BF1A-2B738D764708 (resized).png
360A39C8-0C7C-413F-A84E-F2F5E058E086 (resized).png
IMG_4482 (resized).JPG
Ramp Postr (resized).jpg
Ramp Post (resized).jpg
IMG_20200225_234132 (resized).jpg
IMG_20200127_105230 (resized).jpg
Node 8 (resized).png

Topic index (key posts)

55 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 4465 posts in this topic. You are on page 70 of 90.
#3451 3 years ago
Quoted from Who-Dey:

Yes about 10 or 15 coils. I did that to mine and now they drop really nice.

When I got my new GB, The Scolari Brothers bricked all the time. I adjusted them twice and now I can't recall the last time they didn't go down. Once you dial it in with the spring-adjustment (10 or 15 coils), they should work great.

#3452 3 years ago
Quoted from northvibe:

Stern doesn't do logical things..... in theory then, they should instead use a stronger spring instead of their current. However PBL had new springs...but they didn't work for me.

The perfect solution from stern is to add a course screw adjustment to loosen/tighten the spring.
Then stern will adjust at the factory. When they don't work at home, its a simple tweak and off you go.

#3453 3 years ago

Haven't seen this issue mentioned, so putting it out there for posterity. If the Ecto Goggles "hit" becomes intermittent or doesn't work, it's likely the wires going to the left opto in the lane that runs under the goggles.

Stern re-designed this so each wire has a "channel" on the bottom side of the board to hold it in place, but unfortunately, this requires 4 bends in a kind of question mark shape, which seems to lend itself to wire breaks. Stern confirmed they have seen issues with this.

I removed the Opto assembly from the underside (dead simple - only two screws), then removed the left opto board and unsoldered all three wires. Cut them back about 1/2" to get rid of whatever wire was intermittent and keep them all even, then re-soldered them directly to the back of the opto board, eliminating all the bends. Works great again.

#3454 3 years ago
Quoted from chucksmith:

The perfect solution from stern is to add a course screw adjustment to loosen/tighten the spring.
Then stern will adjust at the factory. When they don't work at home, its a simple tweak and off you go.

Also a good idea.

Dang still need to adjust mine. I had league at my house and lost the ball twice because of them not dropping!

#3455 3 years ago

Shoots 2 balls sometimes from the ball trawl. Where can the error be?
Ola

#3456 3 years ago
Quoted from Olaa:

Shoots 2 balls sometimes from the ball trawl. Where can the error be?
Ola

Does the coil fire twice, or do you have two balls that get pushed up into the shooter lane at the same time?

#3457 3 years ago
Quoted from krankin:

Does the coil fire twice, or do you have two balls that get pushed up into the shooter lane at the same time?

Yeah, good question.

Also watch, sometimes the ball comes out, then bounces back into the trough. I turned down that coil in settings as it was flying out like a bandit.

#3458 3 years ago
Quoted from northvibe:

Yeah, good question.
Also watch, sometimes the ball comes out, then bounces back into the trough. I turned down that coil in settings as it was flying out like a bandit.

Will check this tomorrow, thank you
Ola

#3459 3 years ago
Quoted from krankin:

Does the coil fire twice, or do you have two balls that get pushed up into the shooter lane at the same time?

Two balls that get pushed up at the same time.
Ola

#3460 3 years ago

hey all!
i have 2 questions or problems.

1 does anyone notice the right orbit the switch dosnt connect with ball? there is a mylar strip on pf right before it.
i took off the mylar and it worked. but i am afraid of wear there and there is a reason for the mylar so i stuck it back on and now the ball goes over switch too fast or rises or something and it dosnt go off all the time. anyone notice this problem?
also
2 as far as flippers and trying to trap ball. i find that the ball instead of slowing down on flipper and holding it will bounce off flipper right around to side drains. it drives me nuts!!!!! it one of the biggest ways i lose balls. so i guess my question is the game not at right level (which ive noticed this game is very important to have all level right) or are flipper bands a rubber that it bounces too hard and replace those?
thanks

#3461 3 years ago

on issue threads is there a way to look up issues talked about without reading whole thread?

#3462 3 years ago
Quoted from orb:

on issue threads is there a way to look up issues talked about without reading whole thread?

Go to page 1 and look at the index of "key posts" which will take you right to subjects of interest.

#3463 3 years ago
Quoted from orb:

1 does anyone notice the right orbit the switch dosnt connect with ball? there is a mylar strip on pf right before it.
i took off the mylar and it worked. but i am afraid of wear there and there is a reason for the mylar so i stuck it back on and now the ball goes over switch too fast or rises or something and it dosnt go off all the time. anyone notice this problem?

Leave the mylar off. I removed the mylar on mine and never looked back. I don't think wear will be a problem on a home use game.

#3464 3 years ago
Quoted from orb:

hey all!
i have 2 questions or problems.
1 does anyone notice the right orbit the switch dosnt connect with ball? there is a mylar strip on pf right before it.
i took off the mylar and it worked. but i am afraid of wear there and there is a reason for the mylar so i stuck it back on and now the ball goes over switch too fast or rises or something and it dosnt go off all the time. anyone notice this problem?

Common problem. I removed my Myalr, so have many others. I wouldn't sweat it.

#3465 3 years ago

Leave the Mylar off. Game will be fine.

#3466 3 years ago
Quoted from MT45:

Quick question LE owners ... I'm having an issue with auto plunge. About 75% of the time. The ball hits Stay Puft and rattles around up in the corner to finally either drop down the ecto lane or just fall back down the shooter lane. Anyone else? Fixes?

This happens on my premium too... 75-80% of time. Have you managed to fix?

#3467 3 years ago

I made a Plastic at the end of the shooter lane, don't want that my walking stay puft get damaged. Works fine

#3468 3 years ago

thanks guys. yeah will take off again. HUO game probably wont see the wear.

#3469 3 years ago
Quoted from gweempose:

Leave the mylar off. I removed the mylar on mine and never looked back. I don't think wear will be a problem on a home use game.

And even if it did it's in an area that you can't even see so it don't matter anyway. It's not going to wear in area anymore than it would anywhere else anyway I don't think.

#3470 3 years ago

Could you show a pic?

#3471 3 years ago
Quoted from sirlonzelot:

I made a Plastic at the end of the shooter lane, don't want that my walking stay puft get damaged. Works fine

Could you show a pic?

#3472 3 years ago
Quoted from mattartist:

Could you show a pic?

Sure, you need some spacers to install it.

IMG_1097 (resized).JPG

#3473 3 years ago
Quoted from sirlonzelot:

Sure, you need some spacers to install it.

Good idea (Appreciate the share), I may have to cut something like that too. Doesnt happen very often for me but when it does its really annoying.

#3474 3 years ago

If you have the walking stay puft I think it's a must have. I am not sure how long the bracket holds, when he gets hit from the ball

#3475 3 years ago
Quoted from sirlonzelot:

Sure, you need some spacers to install it.

Great idea! I'm quite new to pinball. Are they just standard spacers?

#3476 3 years ago
Quoted from sirlonzelot:

Sure, you need some spacers to install it.

Is that mech the walking stay puft man?

#3477 3 years ago

I use plastic spacers, not sure for the length.

Yes i installed Mezel mods stay puft mod

#3478 3 years ago

Does anyone know of any forthcoming code updates? I believe one is needed, correct? Just hoping for one last complete code before I trade my GB pro and move on....

#3479 3 years ago

This is how I solved it.

DSC_0046 (resized).JPG

DSC_0047 (resized).JPG

DSC_0048 (resized).JPG

DSC_0050 (resized).JPG

#3480 3 years ago
Quoted from Olaa:

This is how I solved it.

Great pics.... this is what I need to do. I do have a 3d printer so might design a mod.

1 week later
#3481 3 years ago

I'm sure its probably somewhere in this thread, but in my defense its 70 pages long, can someone tell me how to tweak Slimer (or do I need to call Stern for a part?) because it basically won't register when I hit it...and its completely useless right now.

#3482 3 years ago
Quoted from cscmtp:

I'm sure its probably somewhere in this thread, but in my defense its 70 pages long, can someone tell me how to tweak Slimer (or do I need to call Stern for a part?) because it basically won't register when I hit it...and its completely useless right now.

Can you put the game in test and get it to register? Do some shots register but not all?

If you call your distributor or stern tech they can help. Mine is original premium and it registers most hits but some don't....

#3483 3 years ago
Quoted from cscmtp:

I'm sure its probably somewhere in this thread, but in my defense its 70 pages long, can someone tell me how to tweak Slimer (or do I need to call Stern for a part?) because it basically won't register when I hit it...and its completely useless right now.

The mech kind of works like a tilt bob. Pretty sure you can adjust it.

#3484 3 years ago
Quoted from cscmtp:

I'm sure its probably somewhere in this thread, but in my defense its 70 pages long, can someone tell me how to tweak Slimer (or do I need to call Stern for a part?) because it basically won't register when I hit it...and its completely useless right now.

Manually check to see if it registers.
If it does by hand, take the top plate off, and see if you need to raise or lower slimer.
If nothing registers, I'd start with distributor support, or share more details...pro, premium, etc, and more help will come.

#3485 3 years ago
#3486 3 years ago

I ran into a small issue / fix this week that might help GB owners who are 1st time owners.
My GB-Premium is a whole year old this month.
Recently I've noticed the left scoop was waiting a while (and taking longer) to kick out the ball.

This morning the ball just sat in there as if nothing happened and then the machine went into ball-search.

I shut off the machine and found the switch in the left scoop was squashed down so it barely was being pressed by the ball.

If this happens to you....
With the glass off and the power off, put your finger in the scoop and feel for the switch.
Gently bend the tip of the switch actuator back upward toward the playfield surface.

I tested with power off listening for the click to ensure the click happened before the switch bottomed out.

Next - Test it in switch test mode with a ball.
Caution: The solenoid will fire if you use your finger to press the switch wacking your finger so turning off the machine is advised.

Now The response time is back to what it should be.
The moment the ball lands in the scoop the flasher goes off and kicks the ball back up.

#3487 3 years ago
Quoted from chucksmith:

I ran into a small issue / fix this week that might help GB owners who are 1st time owners.
My GB-Premium is a whole year old this month.
Recently I've noticed the left scoop was waiting a while (and taking longer) to kick out the ball.
This morning the ball just sat in there as if nothing happened and then the machine went into ball-search.
I shut off the machine and found the switch in the left scoop was squashed down so it barely was being pressed by the ball.
If this happens to you....
With the glass off and the power off, put your finger in the scoop and feel for the switch.
Gently bend the tip of the switch actuator back upward toward the playfield surface.
I tested with power off listening for the click to ensure the click happened before the switch bottomed out.
Next - Test it in switch test mode with a ball.
Caution: The solenoid will fire if you use your finger to press the switch wacking your finger so turning off the machine is advised.
Now The response time is back to what it should be.
The moment the ball lands in the scoop the flasher goes off and kicks the ball back up.

It's also pretty common for one of the two screws holding the switch on the left or right scoop to unwind and fall out, which leaves the switch in place, but the actuator arm drops too low to register when the ball comes in. You just have to find the tiny black screw in the black cabinet...which can take a while...to fix it.

#3488 3 years ago
Quoted from vireland:

It's also pretty common for one of the two screws holding the switch on the left or right scoop to unwind and fall out, which leaves the switch in place, but the actuator arm drops too low to register when the ball comes in. You just have to find the tiny black screw in the black cabinet...which can take a while...to fix it.

This happened to me as well shortly after I bought the game. I wonder why it's a more common occurrence on this particular game. I don't recall ever having one of the little black screws come loose on any of my other Sterns.

#3489 3 years ago
Quoted from vireland:

It's also pretty common for one of the two screws holding the switch on the left or right scoop to unwind and fall out, which leaves the switch in place, but the actuator arm drops too low to register when the ball comes in. You just have to find the tiny black screw in the black cabinet...which can take a while...to fix it.

Thanks I'll check that too just in case.

#3490 3 years ago

yup. same. the screw fell out of mine and broke switch altogether. the coolest part for me was doing my first solder job and putting new switch in. but find it weird so many had issue in this spot.

but i put lock tight on screws because the screws came out more than once.

#3491 3 years ago
Quoted from chucksmith:

Thanks I'll check that too just in case.

I checked it. The screws for that switch were tight and fine although I found 2 near by screws holding switches that had loosened up so I adjusted and tighten all of them. These screws look like they could use a lock washer or a drop of Loctite .

#3492 3 years ago

I'm in the process of being made whole. I got a box to ship back my play field for a warranty replacement. Stern was breaking my heart there for a bit when my new in box game was shedding it's clearcoat but I am glad they are taking care of me (even if it was slow in coming). My buddy came over and helped me remove the play field. Removing the play field only required disconnecting 3 connectors and lifting it out, so that was easy. I'll be sad until the new one gets here. I'll update then.

IMG_6230 (resized).png

#3493 3 years ago

I'm glad they are taking care of you on an issue that should not have happened. Waiting does suck. I have been one of the lucky ones that has had no problem with my clear coat or cabinet corners. I am sad the code is not finished and probably won't get finished. I was so excited for this theme. I think this title has been a bust for Stern given all the problems.

#3494 3 years ago
Quoted from jaystile:

I'm in the process of being made whole. I got a box to ship back my play field for a warranty replacement. Stern was breaking my heart there for a bit when my new in box game was shedding it's clearcoat but I am glad they are taking care of me (even if it was slow in coming). My buddy came over and helped me remove the play field. Removing the play field only required disconnecting 3 connectors and lifting it out, so that was easy. I'll be sad until the new one gets here. I'll update then.

Best of luck to you. I just packed up my playfield to send back as well. A bit of a pain but hopefully worth it. I have minor ghosting on three inserts and was surprised how quickly Stern agreed to replace the playfield. The game was totally dialed in and playing great, so am hoping I won’t regret it.

#3495 3 years ago

I have noticed while playing recently that my plunger is not in the middle of the lane. I re-leveled the game recently and also noticed that the playfield doesn't not drop nicely into it's slots. Has anyone run into this before and if so what did you do to get the table to drop in effortlessly?

Attached is a picture of what I'm seeing (in the view finder of the plunger, it's down the middle.

Plunger (resized).JPG

#3496 3 years ago
Quoted from Fitzhume:

Has anyone run into this before and if so what did you do to get the table to drop in effortlessly?

That is a sign that while your playfield may measure level your cabinet is likely twisted. I'd try putting a level on the bottom of the front and back of the cabinet to see if they are level.

#3497 3 years ago
Quoted from Gogojohnnyquack:

That is a sign that while your playfield may measure level your cabinet is likely twisted. I'd try putting a level on the bottom of the front and back of the cabinet to see if they are level.

I will give this a shot. Thanks for the information.

UPDATE:

WOW! I can't believe that just a couple of turns on the front left leg allows that playfield to be lifted and set to easily now. Thanks for that suggestion!

#3498 3 years ago

https://pinside.com/pinball/forum/topic/ghostbusters-airball-air-ball-right-orbit-protector

Thinking about make another run.

Go to link above and add your name. Thx. Also, watch video in the link above.

pic5 - Copy (resized).jpg
pic7 - Copy (resized).jpg

#3499 3 years ago
Quoted from Fitzhume:

WOW! I can't believe that just a couple of turns on the front left leg allows that playfield to be lifted and set to easily now. Thanks for that suggestion!

Glad to hear it, you're welcome!

1 week later
#3500 3 years ago

While installing the metal apron/arch to my GB Premium, one of the front flexible screw fasteners (attaching to nut through drilled hole in the playfield) broke off. I have not been able to find this part. Does anyone know if the apron can be repaired and what the correct part is? Thanks.

Promoted items from the Pinside Marketplace
$ 17.50
Cabinet - Other
Pin Monk
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
From: $ 23.00
Playfield - Plastics
ModFather Pinball Mods
$ 349.95
Lighting - Led
Pin Stadium Pinball Mods
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 199.00
Gameroom - Decorations
Lit Frames
There are 4465 posts in this topic. You are on page 70 of 90.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside