New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 158288)

Ghostbuster Issue Thread


By exflexer

4 years ago



Topic Stats

  • 4,465 posts
  • 526 Pinsiders participating
  • Latest reply 22 days ago by cpr9999
  • Topic is favorited by 148 Pinsiders

You

Linked Games

Topic Gallery

There have been 713 images uploaded to this topic. (View topic image gallery).

SwitchStatus (resized).jpg
TroughSwStatus (resized).JPG
screen-capture-1 (resized).png
0255267F-B344-4A63-AF52-98DC3187BF9D (resized).jpeg
1331CF7A-01AE-4406-9820-04400DCCBD5F (resized).jpeg
4108cb973a95ea7af25aed4b17fca9ebd79e350b.png (resized).png
15FB2563-1183-47AE-9CAD-29E28F48CE76 (resized).png
3E7F33D8-B885-40E3-9F8B-D3DEB2864FFA (resized).png
A4C49F70-C0D9-4E25-BF1A-2B738D764708 (resized).png
360A39C8-0C7C-413F-A84E-F2F5E058E086 (resized).png
IMG_4482 (resized).JPG
Ramp Postr (resized).jpg
Ramp Post (resized).jpg
IMG_20200225_234132 (resized).jpg
IMG_20200127_105230 (resized).jpg
Node 8 (resized).png

Topic index (key posts)

55 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 4465 posts in this topic. You are on page 51 of 90.
#2501 3 years ago
Quoted from jrio101:

I wonder why the playfield date is so much older than the build date? I just received a premium with a late December build and the playfield is from December.

My Dec 16th pro had a Mid-July playfield.

#2502 3 years ago
Quoted from RipleYYY:

+1 about inserts, same state here, not a prob
btw, i should have missed something, did they corrected (or not seeing pics) the REINFORCEMENT error on pro version !?

I noticed that too. The spelling was corrected (supposedly) on the Pro. My Premium has the right spelling (Late Sept 2016 playfield)
John's Arcade got a pro where he expected the spelling to be fixed but was not so I'm not sure if any pro's have the correct spelling.
In any event the spelling is not a big deal. No ghosting? then your good to go.

#2503 3 years ago
Quoted from chucksmith:

I noticed that too. The spelling was corrected (supposedly) on the Pro. My Premium has the right spelling (Late Sept 2016 playfield)
John's Arcade got a pro where he expected the spelling to be fixed but was not so I'm not sure if any pro's have the correct spelling.
In any event the spelling is not a big deal. No ghosting? then your good to go.

It's an Oct 19th Playfield in a Jan 12th pin.

Thanks guys for all the input!!

#2504 3 years ago

Another question:

What's everyone doing these days to fix the outer-lane issues?

Thanks

#2505 3 years ago

An affordable, well working set from me......

#2506 3 years ago
Quoted from Jonjon74:

Another question:
What's everyone doing these days to fix the outer-lane issues?
Thanks

There are no outer-lane issues. That's because they are, exactly, the way the designer wanted them. Same holds true for the right ramp. All of the purists here are replacing the ramp post with a shorter one so they can make the shot. Well they are completely "altering the geometry" of the game. Don't like slimers butt dragging on your playfield? Too bad, that's how it was designed, tested, and delivered as a final product. There are no mistakes. There are no design flaws. There are no defects. Everything is sunshine & roses.

#2507 3 years ago
Quoted from ExtremePinball:

There are no outer-lane issues. That's because they are, exactly, the way the designer wanted them. Same holds true for the right ramp. All of the purists here are replacing the ramp post with a shorter one so they can make the shot. Well they are completely "altering the geometry" of the game. Don't like slimers butt dragging on your playfield? Too bad, that's how it was designed, tested, and delivered as a final product. There are no mistakes. There are no design flaws. There are no defects. Everything is sunshine & roses.

I was reading your post thinking....this guy is insane. Then I looked up and seen it was you and was like.....wtf is he thinking, he knows better than this? Then at the end I found out you were joking lol. You had me going there for a minute!

#2508 3 years ago
Quoted from Who-Dey:

I was reading your post thinking....this guy is insane. Then I looked up and seen it was you and was like.....wtf is he thinking, he knows better than this? Then at the end I found out you were joking lol. You had me going there for a minute!

lmao.... Lets say there were some issues, what would one do to resolve said issues.

#2509 3 years ago

I added ball guide extensions. One on each side, which stand above the factory guides and extend the forward post 3/8".

It now plays like a pinball machine should. Shameless ball drains few and far-between.

#2510 3 years ago
Quoted from Jonjon74:

Another question:
What's everyone doing these days to fix the outer-lane issues?
Thanks

I just installed Art's outer-lane fix on my replacement PF.

IMG_3365 (resized).JPG

IMG_3367 (resized).JPG

IMG_3366 (resized).JPG

#2511 3 years ago
Quoted from RickAHG:

I just installed Art's outer-lane fix on my replacement PF.

Unfortunately I have a pro model and these won't work.

#2512 3 years ago
Quoted from ramegoom:

I added ball guide extensions. One on each side, which stand above the factory guides and extend the forward post 3/8".
It now plays like a pinball machine should. Shameless ball drains few and far-between.

Which ones did you add? Pro Model?

#2513 3 years ago
Quoted from Jonjon74:

Which ones did you add? Pro Model?

The Pinball Life version fits the pro perfectly ...

http://www.pinballlife.com/index.php?p=product&id=4255

GB lane heighteners (resized).JPG

#2514 3 years ago

Easy fix to the ball hopping over outlanes on Le/premuim. I use some drop dead foam from pinbits, use just a small piece on the left side insidea the wireform, and a piece about and inch x 1/2 inch in the right side under the metal piece where I have my twinkie mod. Slows the ball down just enough where it drops perfect every time.

20170210_220720 (resized).jpg

#2515 3 years ago

The pinball life version looks good and has the center post but the ball will still hop over the rail. The key is to slow and take the spin out of the ball right before it drops.

#2516 3 years ago
Quoted from mzhulk:

The pinball life version looks good and has the center post but the ball will still hop over the rail. The key is to slow and take the spin out of the ball right before it drops.

What rail are you talking about? Are you referring to the rail between the double inlanes? If so, why would you care if the ball hops over it? I assume most people are concerned about the ball hopping the outer rail and draining.

#2517 3 years ago
Quoted from Jonjon74:

Which ones did you add? Pro Model?

Premium model:
outlane_rails_modification (resized).jpg

#2518 3 years ago
Quoted from RickAHG:

I just installed Art's outer-lane fix on my replacement PF.

Replacement PF - is that program already running? Did you get a replacement due to ghosting or another issue?

1 week later
#2519 3 years ago
Quoted from JoshODBrown:

had my pro swapped on the weekend. only 55 games in or so, drain and inserts good so far (not out of the woods yet), but had some clear chip out of the right eject area yesterday.
picture here on this thread https://pinside.com/pinball/forum/topic/hey-stern-are-you-serious/page/110#post-3586411
also, my replacement playfield date is unreadable. https://pinside.com/pinball/forum/topic/changeorg-petition-gary-stern-replace-defective-playfields/page/17#post-3580766

Thanks for the report! I guess I'm glad that I have not got mine yet then.

#2520 3 years ago
Quoted from atariaction:

Thanks for the report! I guess I'm glad that I have not got mine yet then.

From what I've read, chipping in the pro's right eject saucer happens to a lot of people.
Looking at that pro-right-saucer ... it looks like a high risk site for chipping.
If I had a pro, I'd put some Mylar in and around that saucer before the 1st play.
I'd also put a cliffy drain hole protector & shooter lane protector on all machines.

#2521 3 years ago

The switch on my right orbit/Ecto lane doesn't register about 40% of the time, especially if I'm hitting it hard and fast. I've tried bending it, but I bent it so far it would close just but getting it screwed back in. I bent it back a little, but it's back to the 40% failure rate.

Any ideas?

#2522 3 years ago
Quoted from Sinestro:

The switch on my right orbit/Ecto lane doesn't register about 40% of the time, especially if I'm hitting it hard and fast. I've tried bending it, but I bent it so far it would close just but getting it screwed back in. I bent it back a little, but it's back to the 40% failure rate.
Any ideas?

I've been having issues with this same switch. I've tried tweaking the actuator. It helped a bit, but it's still not 100%. Unfortunately, that switch is just in a really bad location.

#2523 3 years ago

I attempted to adjust my switch the same as you did with little effect. Then I used micro needle nose pliers and tweezers to adjust the switch while it was still screwed onto the PF. It took some effort but I managed to bend the switch arm right by the switch contact point to where the slightest pressure would trip it but it wouldn't false. Works probably 95-98% of the time now.

#2524 3 years ago
Quoted from Sinestro:

The switch on my right orbit/Ecto lane doesn't register about 40% of the time, especially if I'm hitting it hard and fast. I've tried bending it, but I bent it so far it would close just but getting it screwed back in. I bent it back a little, but it's back to the 40% failure rate.
Any ideas?

I noticed this with my replacement playfield a few times, but never had the issue with the original. I havent looked at the switch yet, as it hasn't been happening enough to make it annoying... but yeah, a really hard shot around that right orbit and it'll sort of float over the switch sometimes. you might want to check the pitch of your game, if it's too low it might happen more often maybe?

#2525 3 years ago
Quoted from Jarbyjibbo:

I attempted to adjust my switch the same as you did with little effect. Then I used micro needle nose pliers and tweezers to adjust the switch while it was still screwed onto the PF. It took some effort but I managed to bend the switch arm right by the switch contact point to where the slightest pressure would trip it but it wouldn't false. Works probably 95-98% of the time now.

I might just have to try that!

#2526 3 years ago

Playing my GB Pro today the ball went into the left scoop (under the flashing light). The scoop dropped a 1/4 inch or so into the PF with the ball inside. I pull the ball out and raised the pf. The spot welds on the metal scoop part had broke free from the arm under the pf and the scoop is hanging loose. Any idea how to fix it?

#2527 3 years ago
Quoted from jamesdeloris:

Playing my GB Pro today the ball went into the left scoop (under the flashing light). The scoop dropped a 1/4 inch or so into the PF with the ball inside. I pull the ball out and raised the pf. The spot welds on the metal scoop part had broke free from the arm under the pf and the scoop is hanging loose. Any idea how to fix it?

Contact your distributor or Stern support directly for a replacement would be my suggestion.

#2528 3 years ago

Keep in mind that some right orbit shots will not activate unless you make it all the way around to the left side. So you try backhanding it up and only makes it to the pops, does not count, is not a switch problem. It's the way certain shots are programmed.

#2529 3 years ago
Quoted from CaptainNeo:

Keep in mind that some right orbit shots will not activate unless you make it all the way around to the left side. So you try backhanding it up and only makes it to the pops, does not count, is not a switch problem. It's the way certain shots are programmed.

What about when you're in who brought the dog and I hit a lit right orbit, it comes all the way around back to my left flipper and doesn't gimmie credit for it? Or when the mode is lit and ready to start at the right ladder and same thing, loops all the way around to the left flipper and doesn't start a mode.

Not sure why this happens on the prem only, but the 3 different ones I've played have all done this on hard direct shots around the right orbit.

#2530 3 years ago
Quoted from chuckwurt:

What about when you're in who brought the dog and I hit a lit right orbit, it comes all the way around back to my left flipper and doesn't gimmie credit for it? Or when the mode is lit and ready to start at the right ladder and same thing, loops all the way around to the left flipper and doesn't start a mode.
Not sure why this happens on the prem only, but the 3 different ones I've played have all done this on hard direct shots around the right orbit.

That's strange, because if the right orbit switch doesn't register, then the controlled gate should remain closed.

#2531 3 years ago

also what code are you running? The orbit acts differently during different revisions.

#2532 3 years ago

I have the latest code and the right orbit is for shit. Doesn't register a ton of shots. Credits the ecto shot but not switch behind. Sometimes it will get hung up on gate but sometimes it will loop all the way around.

#2533 3 years ago
Quoted from CaptainNeo:

Keep in mind that some right orbit shots will not activate unless you make it all the way around to the left side. So you try backhanding it up and only makes it to the pops, does not count, is not a switch problem. It's the way certain shots are programmed.

This is changed in the latest code. Full orbits are not required any more to even qualify scenes.

Rob

#2534 3 years ago
Quoted from CaptainNeo:

also what code are you running? The orbit acts differently during different revisions.

Latest code. Also I was mistaken about it going all the way around. It was dropping into the pops because the controlled gate remained closed.

It only happens on strong shots. 100% working on shots that barely make it back to the switch.

#2535 3 years ago

I've turned down power but more times than I'd like the ball gets hung at that orbit gate and rocks Stay Puft during auto save.
What have you guys done to minimize or eliminate it? Bend it? remove it?

#2536 3 years ago
Quoted from Rob_G:

This is changed in the latest code. Full orbits are not required any more to even qualify scenes.
Rob

i have the newest code and a couple shots are still needed to have full orbit. Like to start spook central, it has to go all the way around.

#2537 3 years ago

heu no !
it start with the right lane switch only

#2538 3 years ago
Quoted from Vino:

I've turned down power but more times than I'd like the ball gets hung at that orbit gate and rocks Stay Puft during auto save.
What have you guys done to minimize or eliminate it? Bend it? remove it?

Up the pitch of your game or 7.0. If that does not help install one of these high compression springs on the auto launch. I installed one of the high compression springs on the ball through coil to save the shooter lane as well works great.

IMG_2250 (resized).JPG

#2539 3 years ago
Quoted from Vino:

I've turned down power but more times than I'd like the ball gets hung at that orbit gate and rocks Stay Puft during auto save.
What have you guys done to minimize or eliminate it? Bend it? remove it?

I totally removed it , ball spends plenty of time in the pops as it is and it allows full left orbit shots while at the same time creating more flow to the game .
I tried everything imaginable to adjust that top right gate ,including cutting off the excess metal corners to a nice rounded edge with my dremel. Finally said screw works great with out it .

#2540 3 years ago
Quoted from golfingdad1:

I totally removed it , ball spends plenty of time in the pops as it is and it allows full left orbit shots while at the same time creating more flow to the game .
I tried everything imaginable to adjust that top right gate ,including cutting off the excess metal corners to a nice rounded edge with my dremel. Finally said screw works great with out it .

Good plan! I might consider doing this too. At least for a while to see how it works.

Rob

#2541 3 years ago

I received the Stern Ecto Goggle protector kit last week and went to install it yesterday. Of the 3 screws on the left side of the goggle assembly, only the middle one would come out, the top and bottom ones seem to be spinning freely (like the threads are stuffed?). Anyone experienced something similar? Has anyone got any tips on pulling the Ecto Goggles out and apart?

#2542 3 years ago
Quoted from Zzap:

I received the Stern Ecto Goggle protector kit last week and went to install it yesterday. Of the 3 screws on the left side of the goggle assembly, only the middle one would come out, the top and bottom ones seem to be spinning freely (like the threads are stuffed?). Anyone experienced something similar? Has anyone got any tips on pulling the Ecto Goggles out and apart?

The exact same thing happened to me with those screws. I even called Chas at Stern for tips to get them out but he was baffled. I ended up placing the Hooked on Pinball Ecto protector by just sliding it over the assembly and keeping in place with a bit of clear double stick 3M tape. It stays fine, but the issue is kind of annoying.

#2543 3 years ago

I vote to not hassle with those screws or pulling it apart and go with Hooked ecto goggle protector for 30 bucks. Easy install and blends right in and provides more peace of mind.
A "mod" perhaps, but one I believe that will more than pay for itself in time.

Btw all, Thanks all for the advice/tips on the orbit gate.

#2544 3 years ago
Quoted from Spelunk71:

The exact same thing happened to me with those screws. I even called Chas at Stern for tips to get them out but he was baffled. I ended up placing the Hooked on Pinball Ecto protector by just sliding it over the assembly and keeping in place with a bit of clear double stick 3M tape. It stays fine, but the issue is kind of annoying.

Thanks, response from the vendor was to try and pull it apart, and send it to them if I can't get it out...

I'll take a look at the Hooked On one...

#2545 3 years ago
Quoted from golfingdad1:

I totally removed it , ball spends plenty of time in the pops as it is and it allows full left orbit shots while at the same time creating more flow to the game .
I tried everything imaginable to adjust that top right gate ,including cutting off the excess metal corners to a nice rounded edge with my dremel. Finally said screw works great with out it .

I yanked out that damn gate as well. The switch might not register, but at least the ball doesn't go batsh*t crazy all over the place when it ricochets off of it.

#2546 3 years ago

For anyone who's seen the ball shoot through the right ramp only to hit the playfield with enough spin to send it up, out, over to the left drain... This was happening to me about 50% of the time.

This past weekend, I made a tiny tweak that made the world of difference.
Now the ball drops and flows down the lane intended with no spinning out.
As a side note: I used my removable mylar to protect the drop zone.
Stern has Mylar there but its a bit high and not centered well under the drop zone.
right ramp adjustment (resized).png
ball drop mylar (resized).jpg

#2547 3 years ago
Quoted from chuckwurt:

Latest code. Also I was mistaken about it going all the way around. It was dropping into the pops because the controlled gate remained closed.
It only happens on strong shots. 100% working on shots that barely make it back to the switch.

I'm having the same issue. It doesn't really happen a lot, but I'd like it to never ever happen. This game is hard enough already without having shots not register. I just started noticing this tonight so I haven't pinpointed whether is a mode thing or just a super hard clean and fast shot thing. I seen that someone mentioned bending the switch upwards a little bit, not sure if that is a good idea or not?

#2548 3 years ago
Quoted from Swainer80:

I yanked out that damn gate as well. The switch might not register, but at least the ball doesn't go batsh*t crazy all over the place when it ricochets off of it.

That particular gate has no switch attached to it, it's completely mechanical.

#2549 3 years ago

These are my pet peeves.

#1 When I shoot the ball into play, and try to catch with the left flipper, the ball usually bounces up and hits that little corner post sticking out below the library and heads for right between the flippers. Not every time, but enough to be super annoying. To me, the ball should bounce, then come to a rest on the left flipper.

#2 The gate situation is a mess in the Ecto lane. It's supposed to stop the ball from draining SDTM, but many times the ball manages to roll out around it and drain. Seems to me the gate should have been about a half and inch wider. Also, how in the WORLD does the one-way gate coming from the pops keep flying open and letting the ball get inside the pops sometimes? I'm still baffled how this is happening mechanically, but it is.

I have my game leveled around 7 degrees.

#2550 3 years ago
Quoted from Sinestro:

#2 The gate situation is a mess in the Ecto lane. It's supposed to stop the ball from draining SDTM, but many times the ball manages to roll out around it and drain.

I never get a SDTM drain from the ecto lane. The ball is always delivered to the right flipper. In fact, I can usually do a drop catch and gain control of it.

Promoted items from the Pinside Marketplace
From: $ 0.80
Playfield - Other
Rocket City Pinball
$ 86.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 14.95
Playfield - Toys/Add-ons
ULEKstore
From: $ 40.00
Lighting - Interactive
Professor Pinball
Trade
Machine - For Trade
Suamico, WI
$ 16.50
Lighting - Led
Lermods
$ 495.00
Cabinet - Armor And Blades
MI Pinball Refinery
There are 4465 posts in this topic. You are on page 51 of 90.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside