Getting King Pin up and running -- assistance needed please

(Topic ID: 218854)

Getting King Pin up and running -- assistance needed please


By goldenboy232

14 days ago



Topic Stats

  • 20 posts
  • 4 Pinsiders participating
  • Latest reply 10 days ago by goldenboy232
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

14FD63C2-FF2D-4144-B431-982E0796E42E (resized).jpeg
D2281F11-4F97-4F5E-92C3-F8F79D01ABCC (resized).jpeg
Pinball (resized).png

#1 14 days ago

Hi guys, I'm close to the finish-line with the second King Pin (the one with the weird Canadian kill-switch I posted about a few weeks ago) I bought back in May, which I'm going to sell. It starts up normally and kicks out the ball, and will go through Balls 1-5 to Game Over normally. That was a big relief, since I hadn't powered it up since bringing it home.

As far as I can tell there are 3 primary issues remaining, and we'll take them one at a time, but I list them all here together in case they're related.

1. The drop-target bank -- when it resets -- doesn't ALWAYS reset all the targets. In other words, they reset but occasionally some of them (maybe half?) fall back down under the playfield. Sometimes it resets just fine. But about half the time some of the targets don't stay "up". What are the main causes of this I need to be looking at? (Note: Not sure if relevant, but earlier yesterday they weren't working at all and I noticed that the white wire had come unsoldered from the transformer. I resoldered it and the reset began working as described above).

2. Sometimes when scoring -- and often this happens with the drop targets, but not always (sometimes it will happen with some of the playfield switches) -- I'll get hundreds and thousands scoring when only hundreds should be scoring. Seems like occasionally a random 10-point score will happen as well maybe when hundreds are scoring. So it's like a path is being opened to other scoring relays/chimes when it shouldn't be, but only occasionally.

3. This may be related to #2 above, but I think my score reels still need some adjusting because I notice that things happen such as when the hundreds reel moves the thousands might move with it. Do the score reel switches (9s?) cause not only the reel next to it to move at times, but could that also cause #2 above (and actually activate the chimes too?)?

Ok, let's start with #1 above -- drop-target bank not always resetting please. Would greatly appreciate your help.

*** NOTE: If you need a high-res scan of my schematic, I can provide one, but will need to run to Kinko's tomorrow. ***

Thanks!

#2 14 days ago

1. Sounds like your reset bar is not going high enough.
Possible issues:
a. The adjustment moved (not real likely)
b. The electrical pulse is too slow. (Check motor 2C, and the S and E relays) refer to the bottom under the transformer on your schematic.
c. The coil stop is broken off in the sleeve
d. Dirty, sluggish plunger.
e. Other mechanical issue
f. Target bank misadjusted with respect to rubber band on the field, causing interference.

#3 14 days ago

For 2. Check your carryover switch on your score reel.

#6 14 days ago

Nothing opening a path to cause chime or reels. Things are CLOSING to complete the path.

In the case of your score reels. If they are working properly, when you score a hundred, the hundreds wheel is activated by the M relay (follow along on your schematic). The M relay has 4 type "A" contacts. You see this under the relay list on the left. One of these completes the circuit to the score reel and another completes the circuit to the chime.

Additionally, when you get to 9 on the hundreds reel, one of the switches on the score reel closes (just to the right of the L (thousands) relay on your schematic). This is often called the decade switch or carry over switch or something similar. Then, the next time the M relay closes, it advances the hundreds score reel to 0 and activates the L relay. The L relay, in turn activates the 1000s reel AND the chime.

In your case, it seems like the carry over switch on the hundreds relay is misadjusted and causing the 100s to carry over to the 1000s when it shouldn't.

#7 13 days ago

Yep, makes sense. I'll go back over the reels more closely. That's likely what's causing the wrong reel(s) to move and chime.

I meant "closing" -- just had a brain lapse in terminology.

Will report back on the target bank resetting and also on this later this week. Thanks newmantjn!

#8 12 days ago

So two steps forward but a step backward too. I got all the scoring to work correctly but my 1,000s reel won’t reset.

In adjusting the reels I noticed (and maybe caused?) two wires on that reel to come unsoldered: the one attached to the “4” lug on the circuit board and the double wire that connects to one of the runout switch lugs (the middle switch in the stack—I believe that’s runout).

I’ve soldered and re-soldered both of those a couple of times but the reel still won’t reset. Is one of those the likely culprit? Or something else. The coil works because the game scores correctly if I manually reset it and start a game.

Also I can maybe get 1-2 reset pulses from the coil if I hold the reel in my hand and move it around a bit. Sound like a short? A bad solder connection?

I don’t want to lead the witnesses though. Could it be something else?

Mark

#9 12 days ago
Quoted from goldenboy232:

1,000s reel won’t reset

If the Thousands Unit Runout switch and the switch on the Reset Completed (A) relay look OK, diagnose this circuit with Alligator clip jumper wires.

Pinball (resized).png
#10 12 days ago

Will do. I think I’ll start by jumping that runout switch to see if that solves it. I’m almost positive it has to be something on the reel itself, as it was working (resetting) before I started fiddling with it to fix the scoring issues.

#11 12 days ago

Jumpered the switch and the reel spun correctly.

Spent some more time with the switch contacts and now the real resets correctly. Thank you all!

OK next problem: this game has two broken set-screws – one in each flipper. How the heck do I get these out? I tried turning them with a needle nose plyers in the plyers just slip off.
14FD63C2-FF2D-4144-B431-982E0796E42E (resized).jpegD2281F11-4F97-4F5E-92C3-F8F79D01ABCC (resized).jpeg

#12 12 days ago
Quoted from goldenboy232:

OK next problem: this game has two broken set-screws – one in each flipper. How the heck do I get these out? I tried turning them with a needle nose players in the players just slip off

Nothing certain, but a few things might work and one will work for sure
1. Penetrating oil on the remains of the screw.
2. Heat on the crank arm. Mini torch, soldering iron, lighter.
3. Then Vise Grip on the stub.

or try to cut a slot in it and see if you can screw it out. (this won't work, but somebody may suggest it.)

Sure fire solution:

Sawsall/hacksaw through the flipper shaft and buy new parts from PBR.

#13 12 days ago

Yea, the one you should be able to get vice grips on, the other, time to cut it off with a hacksaw.

#14 11 days ago

Ended up hack-sawing them and ordering all new flipper assemblies from PBR.

#15 11 days ago
Quoted from goldenboy232:

Ended up hack-sawing them and ordering all new flipper assemblies from PBR.

That's usually how that goes. Join the club.

#16 11 days ago

Slightly off-topic of this particular restoration: In my other King Pin (the one in my collection) am blowing the 25v 15a fuse — must’ve accidentally moved something I shouldn’t have. For that specific fuse to be blowing where are the likely culprits to look at?

#17 11 days ago

lots of different areas. when does it blow? right at power on or after reset? i had flipper solenoid wires rubbing on tilt hardware etc. did you fix something?

#18 11 days ago
Quoted from goldenboy232:

For that specific fuse to be blowing where are the likely culprits to look at?

First things first. Get the proper tool for the job:
http://www.pinwiki.com/wiki/index.php?title=EM_Repair#Electrical_short_troubleshooting_Fuse_helper

If you really get stuck, start chunking out the circuit.

Think about when it happens. Sometimes? All the time? Certain actuators?

Generally, right after the circuit breaker, your eyes are your best tool to find the short.

#19 11 days ago

Thanks, I have one of those fuse helpers – made one a couple of years ago. I will use that. Seems to blow right after power up.

#20 11 days ago
Quoted from goldenboy232:

Seems to blow right after power up.

You could disable the R relay and see if it makes a difference. This would cut the 25v circuit about in half.

#21 10 days ago

Spotted and fixed it. I had unsoldered the wires from the door coil to prevent it from buzzing and had not properly insulated them and wire-nutted them off. They were touching the inside of the coin door.

Promoted items from the Pinside Marketplace
1,450 (Firm)
Machine - For Sale
Alamo Heights, TX
$ 89.00
Cabinet Parts
Pappy's Pinball Palace
$ 2.00
Various Other Swag
Project Pinball Charity
$ 170.00
Cabinet - Other
Pin Mods
$ 15.00
Playfield - Decals
Metal-Mods
$ 229.99
$ 36.99
Eproms
Matt's Basement Arcade
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 44.99
Lighting - Interactive
Lee's Parts
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
From: $ 140.00
$ 15.00
Playfield - Decals
Metal-Mods
$ 18.99
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 319.00
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 99.99
Lighting - Other
Lighted Pinball Mods
$ 495.00
Cabinet - Armor And Blades
MI Pinball Refinery
$ 10.50
Playfield - Decals
The MOD Couple
$ 495.00
Cabinet - Armor And Blades
MI Pinball Refinery
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside