(Topic ID: 72768)

Getaway lock ramp issue.


By halpain24

5 years ago



Topic Stats

  • 6 posts
  • 5 Pinsiders participating
  • Latest reply 5 years ago by yonkiman
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

image.jpg

You're currently viewing posts by Pinsider LongJohns.
Click here to go back to viewing the entire thread.

#3 5 years ago

Check the assembly for any broken or bent parts. The switch could be an issue as mentioned above - check that first. It is easier to see and work on if you remove the playfield from the cabinet since it is right at the end of the playfield, but there is a fair amount of work dealing with the wiring harness and all it's connectors (I like how they did the earlier machines like the system 11, much easier to remove the playfield).

On mine the bracket for the coils was broken/bent and made to just work (since replaced), but I could the pin that fits in the slot of the ramp getting bent down and causing issues as well.

Promoted items from the Pinside Marketplace
€ 3.70
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 20.00
Cabinet - Other
Rock Custom Pinball

You're currently viewing posts by Pinsider LongJohns.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside